21:02:36 <markmcclain> #startmeeting Networking
21:02:37 <openstack> Meeting started Mon May 13 21:02:36 2013 UTC.  The chair is markmcclain. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:37 <armax> hello
21:02:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:40 <openstack> The meeting name has been set to 'networking'
21:02:58 <markmcclain> #link https://wiki.openstack.org/wiki/Network/Meetings
21:03:13 <markmcclain> #topic Annoucements
21:03:30 <markmcclain> #info Mellanox Plugin merged earlier today.
21:03:53 <markmcclain> That brings us up to 12 plugins which is cool
21:04:14 <markmcclain> #link https://launchpad.net/quantum/+milestone/havana-1
21:04:24 <rkukura> I'm hoping to take us back down to 10 plugins
21:04:47 <markmcclain> rkukura: I'm looking forward to that
21:05:29 <garyk> hi
21:05:39 <enikanorov> hi garyk
21:05:49 <markmcclain> Havana-1 is two weeks away.  We're looking ok, but do have several blueprints in review.
21:06:23 <markmcclain> Any questions or additions to the agenda before we run through the reports?
21:06:52 <markmcclain> #topic Bugs
21:07:55 <markmcclain> Right now all of our High priority bugs have fixes in for Havana.  If there are any bugs graded too low, let us know.
21:08:18 <markmcclain> We've fixed 112 bugs for H1.
21:09:06 <markmcclain> That leaves us with 108 that are open.  If the sub team leads have a some time, take a look through your topic make sure the open bugs are still relevant (we do have a few old ones).
21:09:52 <markmcclain> #topic API
21:09:57 <markmcclain> salv-orlando: hi
21:10:06 <salv-orlando> hello people
21:10:09 <salv-orlando> blueprints
21:10:34 <salv-orlando> good progress made on ext-gw-modes (https://review.openstack.org/#/c/25525/)
21:10:46 <salv-orlando> amotoki is helping with reviews
21:11:20 <salv-orlando> the focus of the blueprint was restricted to SNAT only. It did not make sense to set enable_dnat on ext gw to control floating IPs
21:11:39 <salv-orlando> authZ decoupling - https://review.openstack.org/#/c/28249/
21:12:02 <salv-orlando> good progress here too - an apparently simple advice turned into a nightmare which made the patch more extensive
21:12:22 <salv-orlando> I am confident to merge this patch before the H-1 deadline
21:12:33 <salv-orlando> but make-authz-orthogonal will complete in H-2
21:12:44 <markmcclain> Question about the gw modes…. the policy framework will now support those that do not want to enable this feature?
21:13:02 <salv-orlando> the patch for the policy framework is running tox -epy27 on my other screen
21:13:17 <salv-orlando> will be pushed soon (if the tests pass!)
21:13:35 <markmcclain> great
21:13:51 <salv-orlando> A reviewer (alex xu) noticed that we're losing bw compatibility with policy.json
21:13:56 <salv-orlando> and that's not ok.
21:14:02 <salv-orlando> we need to treat it as any other conf file.
21:14:25 <salv-orlando> So I will push in the following days a patch for ensuring the old policy work, even if in deprecated mode.
21:14:34 <salv-orlando> other blueprints:
21:14:39 <markmcclain> that's a good catch
21:15:04 <salv-orlando> markmcclain:yes, we took for granted that perhaps people never bothered to change that file
21:15:08 <salv-orlando> but we cannot know
21:15:17 <salv-orlando> other blueprints: https://blueprints.launchpad.net/quantum/+spec/l3-router-port-relationship
21:15:34 <salv-orlando> markmcclain: are we still on target for H-1?
21:16:35 <markmcclain> yes.. I've had another dev tracking down a bug that we found this mornign
21:17:11 <salv-orlando> cool
21:17:12 <salv-orlando> other blueprints: https://blueprints.launchpad.net/quantum/+spec/api-core-for-services
21:17:16 <salv-orlando> pushed out to H-2
21:17:38 <salv-orlando> however, enikanorov gave us a patch which will be shortly merged as part of this blueprint
21:18:00 <salv-orlando> this patch allows for having the same plugin running several services
21:18:04 <salv-orlando> which is the short term need
21:18:08 <markmcclain> right
21:18:11 <salv-orlando> however all the short term need was because of:
21:18:26 <salv-orlando> https://blueprints.launchpad.net/quantum/+spec/quantum-l3-routing-plugin
21:18:42 <salv-orlando> for which I haven't heard in a while, and I don't know if we should untarget
21:18:54 <enikanorov> i guess bigswitch has plans for this feature as well
21:19:12 <enikanorov> (but that's just a guess)
21:19:16 <salv-orlando> enikanorov: sure (just thinking of what should happen in H-1)
21:19:17 <markmcclain> #action markmcclain to followup on L3 plugin
21:19:29 <salv-orlando> thanks PTL
21:19:29 <SumitNaiksatam> enikanorov: we do think that work is useful/required
21:19:44 <salv-orlando> that is all from the API world. Thanks for your patience.
21:19:58 <mestery> salv-orlando: the L3 blueprint is being worked on by Bob at the moment.
21:20:09 <mestery> salv-orlando: I'll get you an update this week on that.
21:20:18 <salv-orlando> mestery: thanks.
21:20:22 <markmcclain> mestery: Thanks
21:20:34 <mestery> markmcclain salv-orlando: sure, np!
21:21:08 <markmcclain> salv-orlando: Thanks for the update
21:21:25 <markmcclain> #topic VPNaaS
21:21:30 <markmcclain> nati_ueno: hi
21:21:45 <nati_ueno> ok
21:21:45 <nati_ueno> We agreed ipsec api (still we have minor discussion) https://blueprints.launchpad.net/quantum/+spec/vpnaas-python-apis
21:22:04 <nati_ueno> One minor discussion is local_subnet o local_cidr
21:22:12 <nati_ueno> local_subnet vs local_cidr
21:22:38 <nati_ueno> We got comment that local_subnet is familiar word for VPN admins
21:22:52 <nati_ueno> markmcclain: local_subnet/peer_subnet is ok for you?
21:23:13 <markmcclain> my only concern is local_subnet is an overload term
21:23:26 <nati_ueno> markmcclain: OK we can also discuss with this in today's meeting (I'll report this later)
21:23:31 <markmcclain> salv-orlando: probably has some thoughts on this too
21:23:59 <markmcclain> usually when we name something _subnet it's the id to a subnet resource object
21:24:22 <nati_ueno> markmcclain: I have same opinion
21:24:29 <nati_ueno> let's discuss
21:24:35 <markmcclain> Ok the VPNasS meets in 2.5 hours?
21:24:38 <nati_ueno> We agreed first implementation vpn architecture
21:24:44 <nati_ueno> Discussion Note https://docs.google.com/a/ntti3.com/presentation/d/1J7k1eI13-3pQVwp5XgZDWPfzUvuSqczRdK0lEZKQOKk/edit#slide=id.p
21:24:49 <nati_ueno> Next meeting is 5/13 PST 5:00 PM on #openstack-meetings
21:24:52 <nati_ueno> markmcclain: yep
21:25:08 <nati_ueno> that's all from VPN team
21:25:14 <markmcclain> Thanks for the update
21:25:26 <markmcclain> any questions for the VPN team?
21:25:48 <markmcclain> #topic Security Groups/Firewalling
21:26:08 <arosen> Hi, nothing new to really report. There is one patch on review that fixes a security group bug
21:26:40 <nati_ueno> IMO, the patch is OK for go
21:26:52 <markmcclain> I'll take another look at it after the meeting
21:26:53 <markmcclain> https://review.openstack.org/#/c/27792/
21:27:03 <arosen> cool thanks
21:27:18 <markmcclain> SumitNaiksatam: Update on FWaaS?
21:27:19 <SumitNaiksatam> on the FWaaS front, I pushed out an "early" patch: https://review.openstack.org/#/c/29004/
21:27:36 <SumitNaiksatam> this is WIP, so don't crucify me on the unit tests :-)
21:27:41 <SumitNaiksatam> working on it
21:27:44 <markmcclain> hehe
21:28:11 <SumitNaiksatam> i am trying to do this in a way that this will satisfy our reference implementation
21:28:30 <SumitNaiksatam> with not having to create any additional objects beyond those absolutely needed
21:28:53 <SumitNaiksatam> so i don't have the dynamic/group ip objects for ip addresses in here yet
21:29:12 <SumitNaiksatam> that will come in subsequent iterations
21:29:25 <SumitNaiksatam> at least want to get an end-to-end flow going first
21:29:33 <SumitNaiksatam> with ip tables driver et al
21:29:43 <markmcclain> sounds like a good approach
21:29:51 <SumitNaiksatam> like before, Rajesh M from Dell working on the driver side of things
21:29:55 <SumitNaiksatam> Rajesh here?
21:30:03 <SumitNaiksatam> we had some meetings last week
21:30:15 <SumitNaiksatam> we will document the ref impl design as well
21:30:39 <SumitNaiksatam> maybe rajesh is not around
21:30:47 <nati_ueno> SumitNaiksatam: Do you have fw-agent ?
21:30:54 <SumitNaiksatam> ah
21:31:05 <SumitNaiksatam> was just asking if there were questions :-)
21:31:27 <SumitNaiksatam> nati_ueno: the current plan is to do something similar to what you did with security groups and l2 agent
21:31:45 <nati_ueno> SumitNaiksatam: so you are going to update l2 agent?
21:31:48 <SumitNaiksatam> we will have the l3 agent extend a base implementation
21:31:51 <nati_ueno> SumitNaiksatam: or update l3-agent?
21:31:57 <SumitNaiksatam> so no new fw_agent
21:32:01 <SumitNaiksatam> yeah thats right
21:32:25 <SumitNaiksatam> l3 agent
21:32:50 <nati_ueno> SumitNaiksatam: Interesting. so fw support is hard coded in l3-agent?
21:32:54 <SumitNaiksatam> no
21:32:58 <nati_ueno> SumitNaiksatam: or we have some driver stuff ?
21:33:15 <SumitNaiksatam> this is just for the reference implementation
21:33:29 <SumitNaiksatam> the driver model is always available
21:33:31 <nati_ueno> SumitNaiksatam: I'm wondering l3-agent will dynamically loading service drivers
21:33:58 <SumitNaiksatam> hmmm…i am not sure i have heard of that approach, but we can discuss
21:34:08 <nati_ueno> SumitNaiksatam: OK talk in offline
21:34:08 <SumitNaiksatam> in the first iteration, it would be good to keep this simple
21:34:14 <SumitNaiksatam> and see it work
21:34:19 <markmcclain> perfect.. offline will document it for everyone else
21:34:50 <nati_ueno> may be mailing list is best
21:35:14 <SumitNaiksatam> sure
21:35:16 <markmcclain> nati_ueno: for this type of discussion yes
21:35:36 <nati_ueno> ok thanks
21:35:42 <markmcclain> SumitNaiksatam: Thanks for the update.  The progress is looking good.
21:35:51 <SumitNaiksatam> ok, thanks
21:35:59 <markmcclain> I skipped over Nova by accident
21:36:05 <markmcclain> #topic Nova Integration
21:36:05 <garyk> heh
21:36:27 <garyk> onmigration path not much progress has ben made
21:36:33 <garyk> there is a bug though - https://bugs.launchpad.net/nova/+bug/1160442
21:36:35 <uvirtbot`> Launchpad bug 1160442 in quantum "when boot many vms with quantum, nova sometimes allocates two quantum ports rather than one" [Undecided,Incomplete]
21:36:58 <garyk> i have managed to reproduce on a few occaisions. trying to debug but with debug info the problem does not reproduce :(
21:37:35 <garyk> plan to invest more time next week on migration path. sorry
21:38:16 <markmcclain> Yeah the Nova bug is interesting
21:39:02 <garyk> i think it happens when one host fails and it is resceduled on another
21:39:04 <markmcclain> danwent: think you could help narrow down the steps to reproduce?
21:39:26 <danwent> markmcclain: i have never actually seen this
21:39:33 <danwent> SumitNaiksatam said he has seen it.
21:39:38 <markmcclain> you filed the bug :p
21:39:41 <danwent> i just triaged a bug coming from someone else
21:39:42 <salv-orlando> I tried for a few days to reproduce it with no luck
21:39:48 <SumitNaiksatam> yeah, several times
21:40:08 <danwent> i think this is what launchpad does when someone converts a question to a bug
21:40:21 <SumitNaiksatam> but unfortunately I did not get any insight from debugging
21:40:30 <danwent> see: https://answers.launchpad.net/quantum/+question/225158
21:40:39 <markmcclain> danwent: ah.. didn't realize it started on Answers
21:40:57 <danwent> yeah, LP does a shitty job of making that easy to find out
21:41:38 <markmcclain> Ok any other Nova Integration related questions?
21:41:44 <amotoki> we need to resume https://bugs.launchpad.net/nova/+bug/1112912 to handle Hybrid mode with generic VIF driver.
21:41:46 <uvirtbot`> Launchpad bug 1112912 in quantum "get_firewall_required should use VIF parameter from quantum" [High,In progress]
21:42:14 <amotoki> nati_ueno and I were working on it, but the work is stopped now.
21:42:15 <nati_ueno> ah that's mine
21:42:29 <nati_ueno> sorry, and thank for your pointing it
21:42:33 <markmcclain> Do you all have time to resume the work?
21:42:35 <nati_ueno> I'll work on it on this week
21:42:46 <nati_ueno> markmcclain: yes
21:42:59 <amotoki> nati_ueno: sounds nice.
21:43:30 <markmcclain> nati_ueno: thanks
21:43:36 <nati_ueno> restored https://review.openstack.org/#/c/21946/
21:43:40 <nati_ueno> danwent: could you remove -2?
21:43:56 <danwent> nati_ueno: sure
21:43:59 <markmcclain> #topic LBaaS
21:44:12 <enikanorov> hi
21:44:13 <markmcclain> The LBaaS sub-team will meeting May 16th at 1400 UTC
21:44:15 <danwent> nati_ueno: done
21:44:21 <avishayb> hi
21:44:21 <nati_ueno> danwent: thanks!
21:44:37 <enikanorov> we have 3 patches for lbaas on review
21:45:04 <enikanorov> one is moving files, i planned to do this in two patches
21:45:31 <enikanorov> the first one is on review now, the second show rename agent_loadbalancer to loadbalancer and move services one level up
21:46:07 <enikanorov> these are wishlist features that are not critical
21:46:25 <enikanorov> we have other two patches implementing "multivendor support"
21:46:40 <enikanorov> i think we'll discuss them in detail on lbaas meeting
21:47:10 <markmcclain> yeah.. that's on the agenda
21:47:20 <enikanorov> seems to be all from lbaas
21:48:11 <markmcclain> is the core comfortable with moving db files into the same directory with the service that needs it?
21:48:23 <markmcclain> https://review.openstack.org/#/c/28257/
21:48:48 <markmcclain> This is review enikanorov mentioned about moving files around
21:48:56 <salv-orlando> My opinion was that db is the db regardless of the service, but I found myself to be a minority. So I won't complain anymore,
21:49:25 <salv-orlando> counter argument is that lb people will be able to find all stuff in one place
21:49:41 <marun> ?
21:49:47 <enikanorov> db stuff is not in one place even now
21:50:03 <enikanorov> db logic resides in lots of files actually
21:50:11 <marun> so centralize it
21:50:31 <marun> I vote with salv-orlando
21:50:40 <salv-orlando> I think this is a discussion for gerrit
21:50:41 <garyk> salv-orlando: i also vote with you on this one
21:50:42 <markmcclain> enikanorov: all of the vendor neutral db code is in the same directory
21:50:53 <enikanorov> marun: take a look at the proposal https://wiki.openstack.org/wiki/Quantum/ServiceDirectoryStructure
21:51:03 <garyk> salv-orlando: i think that we should also try and work to abstract the db layer
21:51:04 <markmcclain> salv-orlando: agreed.. I just wanted to make sure everyone was aware of the review
21:51:45 <markmcclain> Ok.. running low on time
21:51:50 <markmcclain> #topic Stable
21:52:08 <markmcclain> 2013.1.1 was release last Thursday correct?
21:52:21 <lifeless> 8
21:52:26 <garyk> yes, that is correct
21:52:44 <garyk> there are a few additional stable reviews. but moving nicely
21:53:07 <markmcclain> yeah.. we've been getting a good number of reviews on the changes which is good
21:53:38 <garyk> yup.
21:53:42 <markmcclain> #topic Testing
21:53:51 <garyk> i am tested every day
21:53:56 <markmcclain> haha
21:54:03 <nati_ueno> ha ha
21:54:30 <markmcclain> mlavalle: any news from the Tempest changes that the Networking team needs to know?
21:54:39 <markmcclain> marun: any updates on your work?
21:54:40 <marun> I made progress last week on the api test refactor.
21:55:16 <marun> I have 10 network tests that can be run against a plugin api or the rest api.
21:55:19 <markmcclain> marun: cool
21:55:21 <mlavalle> markmcclain: working through the issues in the quantum full jenkins gate
21:55:57 <mlavalle> the issues are on test cases written for Nova that test network
21:56:25 <mlavalle> will clean them one by one
21:56:40 <markmcclain> mlavalle: Thanks for updating us
21:56:58 <markmcclain> #topic Horizon
21:57:11 <markmcclain> amotoki: Looks like there is only 1 Networking related blueprint
21:57:33 <amotoki> one registered one is secgroup.
21:57:52 <amotoki> I planned to register BP about quota support and extension-aware feature enabling.
21:58:14 <amotoki> I just started to study how to implement for H-2 this week.
21:58:28 <SumitNaiksatam> have also registered for FWaaS
21:58:31 <markmcclain> ok
21:58:36 <SumitNaiksatam> but thats not targeted for H1
21:58:57 <markmcclain> SumitNaiksatam: cool… I only looked at H1 since that is around the corner
21:59:02 <amotoki> SumitNaiksatam: thanks. H-2 is best but early H-3 is np.
21:59:13 <SumitNaiksatam> sure
21:59:28 <markmcclain> Any other Horizon related items?
21:59:46 <markmcclain> #topic ML2
22:00:01 <rkukura> need to move this up from the end of the agenda!
22:00:02 <markmcclain> rkukura: https://review.openstack.org/#/c/20105/
22:00:14 <markmcclain> I place it higher next week
22:00:23 <rkukura> still expecting to make H-1
22:00:35 <markmcclain> When do you expect to remove the WIP status?
22:00:39 <rkukura> comments so far on WIP patch have been incorporated/answered
22:01:01 <rkukura> main thing needed now is updating linuxbridge RPC to match openvswitch and hyperv
22:01:18 <rkukura> this is addressed in VXLAN implementation for linuxbrudge
22:01:43 <markmcclain> right and updating in way that compatible
22:01:48 <rkukura> but RPC version numbers also need to match between the agents, so looking at how to maintain compability
22:05:57 <safchain__> I just wanted to introduce myself; my name is Sylvain Afchain, I recently joined the Openstack team at eNovance
22:06:15 <markmcclain> safchain__: welcome!
22:06:26 <safchain__> I'm going to start get more involved on Openstack/Quantum
22:06:40 <emagana> safchain__: welcome to the team!!!
22:06:40 <safchain__> markmcclain: thx :)
22:07:01 <sc68cal> Figure I'll do the same - Sean Collins here -thanks everyone for their patients on my QoS API DB review. Still getting the hang of Gerrit/ git review switches :)
22:07:06 <sc68cal> *patience
22:08:38 <markmcclain> sc68cal: Welcome!  Yeah gerrit does take a bit of getting used to at first.
22:08:55 <markmcclain> Ok.. The VPNaaS SubTeam meets in 2 hours and the LBaaS Sub tesm meetings Thursday at 1400 UTC
22:09:15 <sc68cal> mostly I keep clearing the WIP bit when I do an amend :)
22:10:01 <markmcclain> sc68cal: yeah that bit it not sticky
22:10:22 <markmcclain> Talk to everyone on the mailing list/IRC
22:10:24 <markmcclain> #endmeeting