17:00:33 <igordcard> #startmeeting network_common_flow_classifier
17:00:34 <openstack> Meeting started Tue Oct 11 17:00:33 2016 UTC and is due to finish in 60 minutes.  The chair is igordcard. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:38 <openstack> The meeting name has been set to 'network_common_flow_classifier'
17:00:43 <igordcard> hi all
17:00:46 <igordcard> let's wait 2 minutes to improve the chances of everyone being around
17:00:49 <ralonsoh> hi
17:00:57 <igordcard> hi ralonsoh
17:01:01 <davidsha> Hi
17:01:05 <igordcard> hi davidsha
17:01:43 <dkushwaha> hi
17:02:36 <igordcard> is ajo around?
17:04:07 <davidsha> igordcard: He was on this morning, but haven't seen him online since 12:00 UTC I think.
17:04:07 * njohnston watches from the sidelines
17:04:24 <igordcard> giving 2 more minutes so key stakeholders like ajo and cathy can arrive
17:04:40 <igordcard> hi njohnston
17:05:36 <davidsha> njohnston: hey
17:06:00 <igordcard> I won't go through the agenda again this time
17:06:02 <igordcard> #link https://wiki.openstack.org/wiki/Neutron/CommonFlowClassifier#Discussion_Topic_11_October_2016
17:06:26 <igordcard> but I have created an Etherpad so we can add the major points to be discussed at the summit: https://etherpad.openstack.org/p/neutron-common-classification-framework-barcelona
17:07:37 <igordcard> I'll send an email to the ML regarding a summit meet-up
17:07:56 <igordcard> regarding the OVS flow management, the spec is still up:
17:08:02 <igordcard> #link https://review.openstack.org/#/c/320439
17:09:42 <igordcard> anything to discuss before I end the meeting?
17:11:12 <njohnston> The OVS flow management, when it is adopted... will the existing OVS firewall implementation of security groups in neutron change to accomodate that?
17:11:48 <ralonsoh> must change
17:11:50 <igordcard> #action igordcard: Send email about common classification framework summit meet-up
17:12:10 <ralonsoh> because firewall modifies the flows
17:12:32 <davidsha> njohnston: That is the plan, if it doesn't the pipeline simply won't work.
17:12:32 <ralonsoh> and the only one now modifying those flows is the flow manager
17:12:59 <njohnston> I thought so; I've been out of the loop on this, but since I am going to be trying to implement similar functionality (OVS flow-based firewalling - https://bugs.launchpad.net/neutron/+bug/1627785) in FWaaS, but that makes sense.
17:12:59 <openstack> Launchpad bug 1627785 in neutron "[RFE] Create FWaaS driver for OVS firewalls" [Wishlist,Confirmed] - Assigned to Nate Johnston (nate-johnston)
17:13:40 <ralonsoh> I think this firewall is out of scope
17:14:38 <igordcard> ralonsoh: in what sense?
17:14:46 <davidsha> I'll be pushing to get an up to date patch for the flow manager up before the summit, if we can get another core reviewer to look at the spec and approve it we should be good.
17:15:40 <ralonsoh> well, actually fwaas is a L2 extension
17:15:41 <ralonsoh> yes
17:15:46 <ralonsoh> you are right
17:16:00 <ralonsoh> all extensions using OVS must be adapted
17:16:10 <ralonsoh> that means: flow manager should be aware of them
17:16:31 <njohnston> very good - I'll be at the meet-up in Barcelona!
17:16:41 <davidsha> Same!
17:17:03 <igordcard> okay, so there is the need for a flow management meet-up and a classification meet-up
17:17:12 <igordcard> as such, here's a new etherpad:
17:17:55 <igordcard> #link https://etherpad.openstack.org/p/neutron-ovs-flow-management-barcelona
17:18:22 <davidsha> Thanks
17:18:52 <njohnston> thanks!
17:19:03 <igordcard> davidsha mentioned his OVS flow management code, you can check it here:
17:19:12 <igordcard> #link https://review.openstack.org/#/c/323963
17:19:20 <davidsha> igordcard: I've added it to the etherpad also
17:20:16 <igordcard> any other discussion points?
17:22:19 <njohnston> None here
17:22:19 <igordcard> alright! thank you all!
17:22:28 <njohnston> Thanks!
17:22:30 <davidsha> Thanks
17:22:47 <igordcard> we won't have an IRC meeting next time (in 2 weeks) since we'll be at the summit
17:23:01 <igordcard> thanks!
17:23:01 <igordcard> bye
17:23:07 <igordcard> #endmeeting