17:00:37 <kzaitsev_mb> #startmeeting murano
17:00:37 <openstack> Meeting started Tue May 24 17:00:37 2016 UTC and is due to finish in 60 minutes.  The chair is kzaitsev_mb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:40 <openstack> The meeting name has been set to 'murano'
17:00:57 <kzaitsev_mb> #topic rollcall
17:01:03 <kzaitsev_mb> o/
17:01:06 <lexplua> o/
17:01:14 <freerunner> \o/
17:01:16 <tlashchova_> o/
17:01:20 <kzaitsev_mb> let's see who's here today for the meeting =)
17:01:25 <sergmelikyan> o/
17:01:27 <StanLagun> o/
17:01:35 <zhurong> 0/
17:02:04 <oshykhkerimov> o/
17:03:10 <vakovalchuk> o/
17:04:05 <kzaitsev_mb> #topic Action Item Review
17:04:20 <kzaitsev_mb> we had a couple of AI related to convergence
17:04:58 <kzaitsev_mb> 1) I was to register a BP for any future work related to convergence
17:05:01 <kzaitsev_mb> #link https://blueprints.launchpad.net/murano/+spec/murano-heat-convergence
17:05:29 <kzaitsev_mb> and Nikolay_St was to check current status
17:05:52 <kzaitsev_mb> hm, seems that he's not here today. Well, I'll fill in on the topic then for the record.
17:07:15 <kzaitsev_mb> Murano does work ok with heat-convergence enabled, all the apps are deployed/deleted just fine. However heat folks warned us from enabling it by default on our CI as the feature is not yet stable on the heat side
17:07:58 <kzaitsev_mb> therefore we decided to get back to it at n-1 and then n-2 milestones and see if it's ready and enable it then
17:08:16 <kzaitsev_mb> Nikolay_St: I've just filled everybody in on the convergence stuff )
17:08:52 <Nikolay_St> kzaitsev_mb: thx. has problem with my internet connection :(
17:09:04 <kzaitsev_mb> no problem =)
17:09:58 <kzaitsev_mb> 3d AI was on me — to create a backport review session, like we agreed to have one every 2 weeks, but the summit disrupted the schedule =) We have 1 for today.
17:10:15 <kzaitsev_mb> so on to our agenda for today
17:10:17 <kzaitsev_mb> #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:10:58 <kzaitsev_mb> We've already given status update on heat convergence, so I'll skip that part =)
17:11:06 <kzaitsev_mb> #topic Newton CPL volunteers
17:11:37 <kzaitsev_mb> if anyone is not familiar with the concept — here's a link
17:11:40 <kzaitsev_mb> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
17:12:37 <kzaitsev_mb> So I've been working through the emails and one of them suggested that it's time to update the CPL page.
17:14:58 <kzaitsev_mb> Some of the CPL positions right now are assigned to me (I've also replaced katyafervent's position and Serg's with myself) but I obviously won't have time to tend all those cross-project activities
17:15:56 <kzaitsev_mb> So if anyone is interested in volounteering — the list is: i18n, oslo, cross-project specs, documentation
17:16:14 <Nikolay_St> kzaitsev_mb: I can try cross-project specs
17:17:00 <kzaitsev_mb> Nikolay_St: great (I actually think I've removed that from you and wanted to ask you if you're still interested in being that sort of a CPL)
17:17:07 <kzaitsev_mb> Nikolay_St: so obviously you are =)
17:17:45 <Nikolay_St> kzaitsev_mb: so, also I'm not sure that log working group is still alive
17:17:52 <Nikolay_St> will check it tomorrow
17:17:59 <kzaitsev_mb> Could you please update the wiki respectively? =)
17:18:49 <Nikolay_St> sure
17:18:56 <Nikolay_St> give me a minute =)
17:19:13 <kzaitsev_mb> we still have oslo, i18n and docs. =) There's no real hurry in that, but I would be happy to share some of the cross-project communications.
17:21:05 <kzaitsev_mb> oshykhkerimov, vakovalchuk, tlashchova_, zhurong: If anyone of you is interested — those are actually pretty interesting and rewarding activities.
17:21:14 <oshykhkerimov> I can try with oslo f.e. if smb helps me to start
17:22:02 <HoloIRCUser> I'll think about it for sure
17:22:44 <vakovalchuk> sorry)
17:23:05 <kzaitsev_mb> like I said — there's no real hurry, feel free to ping me if you'll make you mind — I'll be able to help you around/introduce to some meetings/etc =)
17:23:58 <kzaitsev_mb> oshykhkerimov: cool — feel free to edit the wiki and add yourself as an oslo CPL. Ping me sometime afterwards if anything is uncertain to you =)
17:24:01 <kzaitsev_mb> Also
17:24:30 <tlashchova_> i18n looks interesting but the liason for this project should be a core reviewer
17:25:00 <vakovalchuk> I think I can try something of these after becoming comfortable with bug supervision
17:25:20 <kzaitsev_mb> tlashchova_: well, I think we can make an exception =)
17:26:09 <freerunner> kzaitsev_mb: We also have VMT CPL role vacant..
17:27:22 <kzaitsev_mb> tlashchova_: I'm +1 on delegating i18n CPL to you, so unless there are any objections — let's put you into that position and see how it works out
17:28:14 <kzaitsev_mb> freerunner: vulnerability management — true.
17:28:31 <kzaitsev_mb> well, I think I'll reseve that one for myself for now
17:29:13 <kzaitsev_mb> unless there is a volounteer — whereas I suggest we would put both of us there and work together on that
17:29:54 <kzaitsev_mb> Also. We've put freerunner as a Infra and QA CPL — he has been fulfilling those roles anyways =)
17:30:38 <kzaitsev_mb> tlashchova_: seems like no objections — so could you please update the wiki and but your name in the i18n liaison? =)
17:31:00 <tlashchova_> kzaitsev_mb: sure
17:32:05 <freerunner> kzaitsev_mb: So, we also should create murano-coresec team (if we still not have it) in launchpad
17:32:36 <kzaitsev_mb> #info New CPLs for newton cycle: Nikolay_St: cross-project specs; freerunner: QA & Infra; oshykhkerimov: oslo; tlashchova_:i18n;
17:32:56 <kzaitsev_mb> #action update the wiki to mention new CPLs
17:33:33 <kzaitsev_mb> freerunner: well, I think you're right, but that seems to be a bit outside the discussion and I have to admit — I'm not entirelly confident in the topic
17:34:04 <kzaitsev_mb> Let's mone this discussion to the next IRC meeting and go all the preps needed?
17:35:10 <kzaitsev_mb> ok, went better than expected. =)
17:35:32 <kzaitsev_mb> #topic Review bugs to backport to stable/mitaka
17:35:56 <kzaitsev_mb> I've put together an etherpad with potential bugs, that can be backported to s/mitaka
17:36:03 <Nikolay_St> oh, the best part
17:36:08 <kzaitsev_mb> #link https://etherpad.openstack.org/p/murano-stable-backports
17:36:27 <kzaitsev_mb> it's a bit big, since we hadn't backported much since 2.0.0 =)
17:37:40 <kzaitsev_mb> I'll give you guys some time to read/look through it =)
17:39:57 <kzaitsev_mb> Most of the bugs marked as unapplicable are docs/unit-tests/new-features(wishlist-bugs)
17:42:33 <kzaitsev_mb> to put this list together I've used awesome tools by ihrachys, available on release-tools repository
17:42:42 <kzaitsev_mb> worked like a charm )
17:43:26 <kzaitsev_mb> Smth like './bugs-fixed-since.py --repo ../../murano/murano --start 2.0.0 | ./lp-filter-bugs-by-importance.py murano | ./lp-filter-bugs-by-tag.py murano in-stable-mitaka | ./annotate-lp-bugs.py murano'
17:43:39 <Nikolay_St> kzaitsev_mb: looks good for me
17:44:08 <vakovalchuk> great job finding it
17:45:21 <zhurong> this is a great tools
17:46:07 <kzaitsev_mb> Nikolay_St: I think I'll wait a day or two for any feedback about the bugs in the etherpad. If there would be none — I'm going to backport all of those to stable/mitaka, maybe would ask vakovalchuk to help me a bit =)
17:46:42 <vakovalchuk> of course
17:48:07 <kzaitsev_mb> ok, done with this topic then. =)
17:48:13 <kzaitsev_mb> #topic Open Discussion
17:49:02 <kzaitsev_mb> does anyone have anything to share =)
17:49:42 <Nikolay_St> hm
17:50:21 <Nikolay_St> I want to put this up to everyoune: https://etherpad.openstack.org/p/yaql-sphinx-extension
17:50:46 <kzaitsev_mb> #link https://etherpad.openstack.org/p/yaql-sphinx-extension
17:51:54 <Nikolay_St> any thoughts? StanLagun ativelkov ^^
17:52:59 <StanLagun> I'm okay with the first part of the etherpad but have several issues with the second one
17:58:04 <kzaitsev_mb> I think you would be able to ping Stan on his opinion after this meeting.
17:58:48 <kzaitsev_mb> We're almost out of time, so if anyone has anything else — feel free to come to #murano
17:58:57 <kzaitsev_mb> #endmeeting