17:00:44 <sergmelikyan> #startmeeting murano
17:00:44 <openstack> Meeting started Tue Feb  9 17:00:44 2016 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:46 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:50 <openstack> The meeting name has been set to 'murano'
17:01:02 <kzaitsev_ip_> o/
17:01:11 <sergmelikyan> o/
17:01:42 <freerunner> \o/
17:01:49 <ativelkov> o/
17:01:50 <tlashchova> o/
17:01:52 <sergmelikyan> it's always confusing how to great folks properly on meetings like this  :)
17:03:04 <slagun> \0/
17:05:16 <kzaitsev_mb> o/
17:05:22 <ksnihyr> o/
17:05:59 <sergmelikyan> #topic Action Items
17:06:28 <slagun> \_(%)_/
17:06:38 <sergmelikyan> #1 sergmelikyan ask community about the potential interest for having a midcycle meetup?
17:07:08 <sergmelikyan> Still in progress because I need to confirm first if Mirantis will be able to host this midcycle meetup
17:07:23 <sergmelikyan> #action sergmelikyan ask community about the potential interest for having a midcycle meetup?
17:07:31 <sergmelikyan> #2 ask kolla folks about murano-glare situation
17:07:34 <sergmelikyan> kzaitsev_mb: ^
17:07:49 <kzaitsev_mb> oh boy =)
17:07:58 <kzaitsev_mb> I forgot about kolla thing completely
17:08:11 <kzaitsev_mb> thought I only had an AI about GSOC )
17:08:33 <kzaitsev_mb> let's please keep it on the list?
17:09:18 <sergmelikyan> sure
17:09:30 <kzaitsev_mb> #action kzaitsev_mb ask kolla folks about murano-glare plugin situation
17:09:31 <sergmelikyan> #action kzaitsev_mb ask kolla folks about murano-glare situation
17:09:36 <kzaitsev_mb> hah )
17:09:44 <sergmelikyan> #undo
17:09:45 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x98381d0>
17:09:57 <sergmelikyan> #3 check with GSOC folks if murano need some official registration for GSOC
17:09:57 <kzaitsev_mb> I won'd undo mine )
17:10:05 <sergmelikyan> hopefully )
17:10:06 <kzaitsev_mb> yep, we need to put something
17:10:11 <sergmelikyan> or cycle will go on and on :)
17:10:31 <kzaitsev_mb> on https://wiki.openstack.org/wiki/GSoC2016
17:10:35 <kzaitsev_mb> #link https://wiki.openstack.org/wiki/GSoC2016
17:11:03 <kzaitsev_mb> #link https://wiki.openstack.org/wiki/Internship_ideas
17:11:08 <kzaitsev_mb> and probably here =)
17:11:31 <sergmelikyan> nice!
17:11:38 <sergmelikyan> kzaitsev_mb: way to go :)
17:11:55 <kzaitsev_mb> Those pages are going to be used as a place Google folks would look at
17:12:15 <kzaitsev_mb> when determining whether to accept OpenStack to GSOC this year
17:12:37 <kzaitsev_mb> I've pinged vkmc — we'll cleanup the Internship Ideas page later this week )
17:12:51 <kzaitsev_mb> I've had a couple of ideas  of what we can put there
17:13:12 <kzaitsev_mb> #link https://etherpad.openstack.org/p/murano-2016-gsoc-ideas
17:13:42 <kzaitsev_mb> I'm liking 'Murano package validation tool' and 'Searchlight Integration' the most to be honest =)
17:13:50 <sergmelikyan> Nice, slagun I guess this is where you can put all your beautiful ideas about improvements )
17:13:59 <kzaitsev_mb> although yaql.js also looks nice )
17:14:12 <kzaitsev_mb> I'll keep you folks updated on the situation around GSOC )
17:14:20 <sergmelikyan> kzaitsev_mb: I like idea of having validation during package import more that package validation tool by itself :)
17:14:33 <slagun> +many for yaql.js
17:15:27 <sergmelikyan> implementing yaql.js is too complex I guess for Google Summer of Code event kind of stuff
17:15:30 <kzaitsev_mb> slagun: I'll ping you personally for more ideas to put there =)
17:16:58 <sergmelikyan> let's move on :)
17:17:13 <sergmelikyan> #topic Bashate/shellcheck job for murano-apps(freerunner)
17:17:21 <freerunner> Hey :)
17:17:35 <freerunner> So, I would like explain for a little.
17:17:54 <freerunner> In our murano-apps repo we have a lot of bash scripts.
17:18:26 <freerunner> In ever app we have at least one *sh file
17:18:44 <kzaitsev_mb> I generally like the idea of having shellcheck jobs there. We would brobably need to disable a couple of rules along the way, but generally — I think it's good
17:19:13 <kzaitsev_mb> I've seen my share of bad shell code there, that shellcheck would weed out
17:19:23 <sergmelikyan> kzaitsev_mb: I don't think this is worse it, given that we actually don't really have complex scripts
17:19:40 <sergmelikyan> kzaitsev_mb: tho agree about bad code
17:19:43 <kzaitsev_mb> #link https://blueprints.launchpad.net/murano/+spec/add-shellcheck-jobs
17:19:56 <kzaitsev_mb> I've filed it a while ago =))
17:20:07 <freerunner> Wow
17:20:47 <freerunner> Sooo, maybe it's a good time to implement a job for murano-apps?)
17:21:14 <kzaitsev_mb> freerunner: when I filed the bp — I didn't know how to add a new job =)
17:21:33 <kzaitsev_mb> and it turned out — there were no ready templates for shellcheck
17:21:41 <kzaitsev_mb> have the situation changed? =)
17:21:53 <kzaitsev_mb> I think I even recieved some positive support on the ML =)
17:22:29 <kzaitsev_mb> from infra folks.
17:22:35 <freerunner> kzaitsev_mb: Khm. Doesn't know about situation with templates..
17:22:52 <kzaitsev_mb> so. are there any objections to this idea? =)
17:23:16 <sergmelikyan> My point is that it may be too complex to be worth spending time on that
17:23:59 <sergmelikyan> I like the idea, maybe let's check how complex would be to implement it now?
17:24:11 <sergmelikyan> freerunner: what do you think?
17:24:43 <freerunner> sergmelikyan: Ok, I will research it ;)
17:25:12 <sergmelikyan> #action freerunner will check how complex is to add bashate job on murano-apps
17:25:33 <sergmelikyan> #topic Should we declare a Spec Freeze for Mitaka?
17:26:20 <kzaitsev_mb> that one is...
17:26:24 <kzaitsev_mb> complex =)
17:26:41 <sergmelikyan> yep :)
17:27:13 <Nikolay_St> well, we want to follow major guideliness - so we must declare Spec Freeze
17:27:31 <freerunner> A lot of projects have spec freeze date..
17:27:39 <Nikolay_St> in other hand we don't have much spec in this cycle
17:27:59 <sergmelikyan> Nikolay_St: depending on why - I am not a big fun for following guidelines for guidelines
17:28:45 <kzaitsev_mb> I'd say that I'm ok with not declaring it
17:28:50 <Nikolay_St> sergmelikyan: me neither
17:28:57 <kzaitsev_mb> since we 1) didn't declare it in advance
17:29:14 <kzaitsev_mb> 2) as long as we're following the FF after m-3
17:29:25 <kzaitsev_mb> I do not really feel the need to do it
17:29:57 <sergmelikyan> kzaitsev_mb: +100500
17:32:13 <sergmelikyan> no objections?
17:32:17 <kzaitsev_mb> Since there are no strong points in favor of declaring — I'd say we should not declate Spec Freeze
17:32:20 <Nikolay_St> nope
17:32:22 <sergmelikyan> #topic Open Discussion
17:32:30 <Nikolay_St> Oh
17:32:34 <slagun> We can declare spec freeze and immediately open specs for Newton. It is also okay to implement Newton specs in Mitaka
17:32:51 <kzaitsev_mb> slagun: we can already open specs for newton =)
17:33:25 <kzaitsev_mb> I've thought of doing so last week
17:33:41 <kzaitsev_mb> (when I was tinkering with glance's spec repo)
17:33:54 <Nikolay_St> I have something to discuss
17:34:00 <Nikolay_St> this patch: https://review.openstack.org/#/c/272308/
17:34:56 <Nikolay_St> I forgot to reach Alexey and ask him why didn't he upload this app to master branch
17:35:38 <freerunner> Nikolay_St: This patch should be a cherry-pick..
17:35:44 <slagun> We shouldn't put apps into murano-apps that aren't going to be supported
17:37:05 <Nikolay_St> well, I can easily imagine situation in which app developer will upload app for specific release
17:37:27 <Nikolay_St> slagun: so, it's better not to have an app at all than have it in stable branch?
17:38:15 <slagun> Nikolay_St: yes, because anything in that repo is on us
17:38:33 <sergmelikyan> Nikolay_St: I don't have a problem with backporting new apps to previous releases, but I don't really like idea of having app per specific release
17:40:16 <sergmelikyan> Nikolay_St: Alexey don't want to propose this app to master?
17:40:21 <Nikolay_St> slagun: ok, really don't have enough might to argue about specific case
17:40:46 <Nikolay_St> sergmelikyan: as I write above I forgot to contact him about it today
17:41:05 <slagun> I don't like the idea to have apps that nobody is going to support. And if the author do want to support it then have up to data version is master is a first requirement
17:42:57 <sergmelikyan> Today we are really negative ;0
17:44:16 <kzaitsev_mb> It has to be something with weather =)
17:44:34 <Nikolay_St> :D
17:44:51 <Nikolay_St> slagun: I heard you
17:45:03 <Nikolay_St> I guess we should place this argument somewhere
17:45:55 <kzaitsev_mb> Nikolay_St: into the review ;)
17:46:10 <kzaitsev_mb> you'll have a link to logs after the meeting ;)
17:47:00 <kzaitsev_mb> so you can officially -1 it and give link to this conversation as reason =)
17:47:31 <Nikolay_St> kzaitsev_mb: I mean 'for future use'
17:48:13 <Nikolay_St> so, that's all from my side
17:49:59 <kzaitsev_mb> I'm planning on working on some sort of document(wiki or docs), that would summarise how we work with backports in murano and in murano-apps =) would remember to include this one there.
17:50:31 <freerunner> kzaitsev_mb: Maybe we can include it into contributing guide?
17:50:50 <kzaitsev_mb> freerunner: probably =)
17:51:25 <freerunner> Nice  :)
17:51:26 <kzaitsev_mb> won't happen this/next week. but hope to have it before Mitaka anyway.
17:53:06 <Nikolay_St> :D
17:59:35 <sergmelikyan> #endmeeting