17:01:20 <sergmelikyan> #startmeeting murano
17:01:20 <openstack> Meeting started Tue Nov 10 17:01:20 2015 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:24 <openstack> The meeting name has been set to 'murano'
17:01:25 <sergmelikyan> Hi folks :/
17:01:28 <sergmelikyan> o/
17:01:33 <daneyon_> o/
17:01:34 <katyafervent> hi
17:02:09 <kzaitsev_mb> o/
17:02:35 <Nikolay_St> hi
17:03:19 <kzaitsev_mb> I've left this channel at some point =) the number of #openstack-meeting channels is getting out of hand =)
17:03:33 <kzaitsev_mb> I've heard the're planning to add -4 sometime soon )
17:03:47 <sergmelikyan> omg :)
17:05:50 <sergmelikyan> Let's get started :)
17:06:01 <sergmelikyan> #topic Image and package visibility concerns
17:06:29 <sergmelikyan> http://lists.openstack.org/pipermail/openstack-dev/2015-November/079041.html
17:06:37 <kzaitsev_mb> ok, so there was a letter from Oliver
17:06:44 <kzaitsev_mb> yep #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/079041.html
17:06:57 <kzaitsev_mb> oh, no, that's my response =)
17:07:09 <mfalatic> o/
17:07:14 <kzaitsev_mb> anyway. the situation is the following:
17:07:53 <kzaitsev_mb> we've already merged commits to CLI and dashboard(earlier toady), that attempt to set visibility of the images
17:08:04 <kzaitsev_mb> to the same value as the one of the packages at upload time
17:08:12 <kzaitsev_mb> so basically the bug is solved.
17:08:47 <kzaitsev_mb> one other question Oliver raised was that after the packages is uploaded — visibility of an image might be changed.
17:09:00 <kzaitsev_mb> which basically breaks murano package, that depends on it.
17:09:36 <kzaitsev_mb> (meaning you can't use the public package from other project, after that)
17:10:02 <kzaitsev_mb> So the first half of the bug is solved and merged, while the 2d one...
17:10:45 <kzaitsev_mb> Currently it seems to be very difficult to implement that, but we might be able to do so, as part of our migration towards glare.
17:11:56 <kzaitsev_mb> I believe we should file a BP for that, and probably consult with ativelkov and other glare guys whether it would be possible at some point to maintin dependecny graph (with respect to visibility and probably other properties)
17:12:03 <kzaitsev_mb> Am I typing too much? =)
17:12:07 <katyafervent> This situation looks good to me.
17:12:22 * sergmelikyan still reading :)
17:12:42 <kzaitsev_mb> #link https://review.openstack.org/#/c/236830/
17:12:48 <kzaitsev_mb> CLI commit
17:12:52 <katyafervent> That's good, that we fixed some issues and we should make should everything works as expected in glare
17:12:58 <kzaitsev_mb> dashboard commit: #link https://review.openstack.org/#/c/236834/
17:13:16 <katyafervent> And now we can concentrate on other issues
17:13:17 <kzaitsev_mb> do not be alarmed by -1 from ativelkov, if you read the comment — he's actually ok with the patch
17:13:32 <sergmelikyan> I agree with creating BP for the future
17:13:56 <kzaitsev_mb> I'll try to ping Oliver (shame he's not here today =/)
17:14:02 <kzaitsev_mb> if he doesn't — I'll file it
17:14:23 <sergmelikyan> regarding changing visibility - it's hard to guard against actions like that - user can delete VM for deployed applications at any point of time
17:14:27 <kzaitsev_mb> #action kzaitsev_mb file a BP for maintaining visiblity of dependencies (or have Oliver do it)
17:14:30 <sergmelikyan> or even complete stack
17:14:57 <kzaitsev_mb> sergmelikyan: well, it's not about VM, but about glance image, that murano package depends on
17:15:22 <kzaitsev_mb> i.e: can we forbid deleting an image that public packages depend upon?
17:15:28 <kzaitsev_mb> I believe currently not
17:15:42 <sergmelikyan> kzaitsev_mb: I understand, but I am saying that user who has access to the cloud - can basically break working application at any point of time - or even remove dependencies
17:15:52 <sergmelikyan> including images and packages
17:15:54 <kzaitsev_mb> but can we do something, with that, when we move to glare, not sure =)
17:16:23 <kzaitsev_mb> well, it might turn out, that the task is impossible in the end =)
17:16:41 <sergmelikyan> I guess GLARE can help us here, not prevent, but at least warn about things like that BEFORE deployment
17:16:55 <kzaitsev_mb> at best we might warn somehow, that the user is breaking stuff
17:17:02 <sergmelikyan> yep
17:17:20 <kzaitsev_mb> oh, you're right, glare might help perform a pre-flight check
17:17:44 <kzaitsev_mb> so that the user would get an early meaningfull error in case dependencies are missing
17:19:41 <sergmelikyan> yep - that's what I am thinking about - will you reflect that?
17:20:07 <kzaitsev_mb> yep, in a BP (I've already added action )
17:20:15 <sergmelikyan> #topic Juno EOL (kzaitsev)
17:20:29 <sergmelikyan> kzaitsev_mb: today you are men of the meeting :)
17:20:35 <kzaitsev_mb> So this is another thing I wanted to highlight
17:21:12 <kzaitsev_mb> #link https://wiki.openstack.org/wiki/StableBranchRelease#Planned_stable.2Fjuno_releases_.2812_months.29
17:21:43 <kzaitsev_mb> I've pinged apevec today, and he is planning to release last juno release this week
17:21:47 <kzaitsev_mb> unless something happens
17:22:33 <kzaitsev_mb> and that something is happening in this #link http://lists.openstack.org/pipermail/openstack-dev/2015-November/078630.html ML thread =)
17:23:07 <kzaitsev_mb> So what I wanted to say is that most likely We'll release the last release of juno this week.
17:23:12 <kzaitsev_mb> marking its EOL
17:23:36 <sergmelikyan> kzaitsev_mb: agree :)
17:23:54 <sergmelikyan> we need to verify that everything is merged there first
17:23:55 <kzaitsev_mb> oh yeah, if someone doesn't know it yet — I'm the one who's going to carry out release duties during M cycle =)
17:24:16 <sergmelikyan> Yep - sorry forgot to announce that :)
17:24:28 <sergmelikyan> kzaitsev_mb: thank you so much for agreeing to help me with that :)
17:26:58 <Nikolay_St> kzaitsev_mb: congrats with the new duties)
17:27:44 <kzaitsev_mb> well, I actually do not have anything to add on the topic =)
17:28:08 <kzaitsev_mb> Nikolay_St: as if new duties is something we all want =))))
17:28:54 <sergmelikyan> #topic Open Discussion
17:30:04 <katyafervent> I want to discuss our docs
17:30:33 <freerunner> sergmelikyan: Open Discussion? :) So, we have at least one more item in agenda, or I'm wrong?
17:30:39 <katyafervent> We still have no automatic build on RTD. And I agreed, that duplicating docs are confusing
17:30:51 <kzaitsev_mb> katyafervent: know what you did there ;)
17:30:59 <katyafervent> We can add link to murano docs from the official openstack page
17:31:31 <katyafervent> well, it should be done anyway :)
17:31:58 <sergmelikyan> katyafervent: looks like you added that item after I've checked the page, sorry
17:31:58 <katyafervent> I will talk to the documentation team about it. but building on rtd is still actual question
17:32:09 <kzaitsev_mb> katyafervent: on good idea fungi did mentions — is that we can ask folks from the doc-team. ML or attend their meeting
17:32:17 <katyafervent> It was not me :)
17:32:21 <sergmelikyan> katyafervent: true, I thought that would happen automatically once a day - but this is not working
17:32:38 <fungi> right, check with the docs team about getting the main index updated
17:32:53 <kzaitsev_mb> well, one thing that is bad right now: you can't google official documentation =(
17:32:54 <fungi> that's where official projects' documentation resides
17:33:16 <kzaitsev_mb> I can't google it anyway. google points me to readthedocs =(
17:33:29 <sergmelikyan> fungi: http://docs.openstack.org/developer/openstack-projects.html - you are talking about this?
17:33:32 <katyafervent> also, there is a way to get different versions of the docs in a better way that we don't know about :)
17:34:03 <katyafervent> sergmelikyan, http://www.openstack.org/software/project-navigator/
17:34:19 <katyafervent> I'd like to see murano here ^^^
17:34:28 <fungi> katyafervent: oh, that'
17:34:33 <fungi> s handled by the foundation staff
17:34:37 <fungi> not the community
17:34:49 <fungi> www.openstack.org is not a community maintained site
17:35:02 <fungi> it's the foundation's marketing portal, basically
17:35:04 <sergmelikyan> katyafervent: there was mailing thread about project navigator
17:36:23 <kzaitsev_mb> sergmelikyan: katyafervent: Am I understanding this correctly, that we've agreed to deprecated readthedocs?
17:37:07 <katyafervent> I think we should start working on that. At least update links everywhere to openstack docs
17:37:09 <sergmelikyan> kzaitsev_mb: no, we still want them to be available and up to date, but we can't use OpenStack Infra for that like before
17:38:12 <kzaitsev_mb> sergmelikyan: hm. so how would we update the docs then?
17:39:08 <katyafervent> I don't find the way of automatic update, may be somebody else should look up
17:39:42 <freerunner> Folks, we missed one important topic... kzaitsev_mb sergmelikyan
17:40:08 <kzaitsev_mb> I wonder if Sahara guys are having the same issue..
17:40:20 <katyafervent> kzaitsev_mb, they do
17:40:36 <katyafervent> but it doesn't bother them :)
17:41:13 <kzaitsev_mb> lol =)
17:41:28 <kzaitsev_mb> then probably it shouldn't bother us too?
17:42:05 <sergmelikyan> kzaitsev_mb: I would still prefer to have them in two places :) Doesn't hurt
17:42:31 <kzaitsev_mb> I wonder what was the issue in the first place..
17:43:03 <katyafervent> sergmelikyan, it's extra headache to manage
17:43:16 <kzaitsev_mb> well I'm ok with it as long as everyone is ok with it. Seems like doc-team and infra team are not that ok with it )
17:43:40 <kzaitsev_mb> gotta investigate more
17:44:08 <katyafervent> I'm also voting for rtd deprecation
17:45:43 <kzaitsev_mb> well, unless there would be an easy way to sync rtd
17:46:03 <kzaitsev_mb> let's check what other projects use rtd?
17:47:21 <katyafervent> #action: Investigate and find out way of managing RTD
17:48:06 <katyafervent> let's discuss docs on ML or in murano later
17:49:48 <Nikolay_St> freerunner: has something to talk about
17:52:44 <freerunner> Nikolay_St: Thanks for notification ;)
17:53:37 <freerunner> So, I would like to inform you guys, that today or tomorrow I will make a commit, which will enable py34 jobs for muranoclient.
17:53:46 <andreykurilin__> (great)
17:53:48 <freerunner> ofc, it will non-voting
17:54:06 <kzaitsev_mb> awesome =)
17:54:18 <freerunner> So, we have a bp for py34 support, and me and kzaitsev_mb will work on it ;)
17:54:30 <StanLagun> isn't it py35 already?
17:54:56 <andreykurilin__> When muranoclient will start support py34, rally team will move muranoclient from optional-requirements to main
17:54:57 <kzaitsev_mb> I've done some preliminary work to see if our client is py3 ready. it isn't, but doesn't seem that bad
17:55:33 <kzaitsev_mb> StanLagun: the jobs as of now use py34 AFAIK
17:55:44 <freerunner> StanLagun: I think, we should make py34 support first.
17:55:53 <andreykurilin__> StanLagun: I suppose that OpenStack infrastructure is ready only for py33 and py34
17:56:22 <andreykurilin__> py33 jobs alredy deprecated, so currently only py34 job is available
17:56:41 <StanLagun> since we cannot use any of py3 features I guess it is not important anyway
17:57:06 <kzaitsev_mb> sergmelikyan: #link https://review.openstack.org/#/c/234336/
17:57:08 <kzaitsev_mb> So
17:57:13 <katyafervent> FYI https://review.openstack.org/#/c/243748/ murano link is added
17:57:24 <kzaitsev_mb> I believe we should deprecate rtfd
17:57:45 <freerunner> StanLagun: It is important in case, that most of OpenStack clients have py34 support.
17:57:58 <andreykurilin__> StanLagun: if muranoclient will not support py3, some project can remove support for murano or something else
17:58:45 <StanLagun> freerunner: I meen the difference between 3.4 and 3.5 is not important for us as we can't make use of 3.5 features anyway
17:58:55 <andreykurilin__> :)
17:59:38 <freerunner> StanLagun: AFAIK, infra heve no py35 jobs yet.
18:00:14 <sergmelikyan> thank you folks for the meeting!
18:00:18 <sergmelikyan> #endmeeting