17:00:42 <sergmelikyan> #startmeeting murano
17:00:42 <openstack> Meeting started Tue Nov  3 17:00:42 2015 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:46 <openstack> The meeting name has been set to 'murano'
17:01:05 <sergmelikyan> Welcome to the first after summit meeting :)
17:01:08 <sergmelikyan> o/
17:01:18 <kzaitsev_ip> o/
17:01:31 <sergmelikyan> I hope here would be few folks joining us today :)
17:01:41 <sergmelikyan> kzaitsev_ip: o/
17:02:00 <freerunner> o/
17:02:05 <aderyugin> 0/
17:02:38 <kzaitsev_ip> I'm still lagging from a flight :) it's 2am in Tokyo now :))
17:03:16 <sergmelikyan> yeah... hope it will be short jet-lag
17:04:00 <sergmelikyan> it's easier in east -> west direction usually
17:05:09 <sergmelikyan> Today I had no time to prepare agenda, so I guess I will go through hot topics
17:05:20 <sergmelikyan> #topic CI/CD
17:05:31 <sergmelikyan> How our gates are feeling?
17:05:40 <freerunner> sergmelikyan: Feel good ;)
17:05:54 <sergmelikyan> kzaitsev_ip: I saw that we landed all needed patches, but did we resolve all issues?
17:05:54 <kzaitsev_ip> stables are back stable :)
17:06:01 <sergmelikyan> kzaitsev_ip: thank you!
17:06:33 <kzaitsev_ip> I mean there was no error from stable-maintenance jobs today
17:06:58 <sergmelikyan> kzaitsev_ip: noticed that, probably by next week we will also fix tagging...
17:07:10 <sergmelikyan> #topic Tagging Liberty
17:07:32 <sergmelikyan> kzaitsev_ip: had you chance to verify how we should proceed?
17:07:34 <kzaitsev_ip> k. so we still haven't solved our 1.0.0 situation
17:08:22 <kzaitsev_ip> well. yes. I've tried just tagging stable branch and everything seems to be fine with it
17:09:05 <kzaitsev_ip> this goes well with the release guys planning to abandon preversioing during mitaka
17:09:50 <sergmelikyan> kzaitsev_ip: like completely?
17:09:58 <kzaitsev_ip> so I believe I'll tag 1.0.1 tomorrow or the day after(since tomorrow is a holiday here )
17:10:18 <kzaitsev_ip> Serg, yes.
17:11:22 <kzaitsev_ip> I'm on the phone currently, but I'll share the etherpad from summit design session
17:11:43 <kzaitsev_ip> the plan was to tag just use tags and postversonng for everything
17:12:20 <sergmelikyan> seems quite good, if that would be also nicely automated - will solve a lot of issues and save time
17:14:03 <sergmelikyan> #topic Open Discussion
17:14:53 <sergmelikyan> I was not able to process all the notes after the summit, I guess we need to work on the follow-ups especcialy for the community app-catalog, we had great discussion with Kevin and Chris on the summit
17:15:04 <sergmelikyan> last day was especially good
17:16:03 <kzaitsev_ip> sry. was trying to find an etherpad in summit app
17:16:16 <freerunner> sergmelikyan: Looks like you skip one item in agenda.. =(
17:16:17 <kzaitsev_ip> have I missed much?
17:16:34 <sergmelikyan> freerunner: which one?
17:16:58 <freerunner> sergmelikyan: So, I would like to disable one gate in our client repo.
17:17:27 <kzaitsev_ip> well the etherpad isn't there. I'll post it to murano channel as soon as I get to my laptop.
17:18:16 <freerunner> sergmelikyan: The gate-murano-devstack-dsvm is useless now for muranoclient patches verification, and should be disabled.
17:18:19 <sergmelikyan> kzaitsev_ip: you are talking about this one https://etherpad.openstack.org/p/murano-mitaka-contributors-meetup
17:18:38 <sergmelikyan> kzaitsev_ip: or this https://etherpad.openstack.org/p/TYO-app-catalog
17:19:18 <kzaitsev_ip> serelikyan, no, about the one that says somethings about abandoning pre-versioning
17:19:50 <kzaitsev_ip> from release session.
17:20:10 <kzaitsev_ip> about the gate: makes total sense to me.
17:20:34 <kzaitsev_ip> none of the projects seem to have such jobs anyway.
17:20:44 <sergmelikyan> freerunner: +1
17:21:18 <freerunner> sergmelikyan: Nice, then I'll do the patch. ;)
17:21:31 <kzaitsev_ip> freerunner feel free to execute what you wanted to :)
17:21:46 <freerunner> ^_^
17:22:44 <kzaitsev_ip> about the release session — funny thing is I hardly understood half the things they were saying up until now :)
17:23:49 <kzaitsev_ip> I've reviewed my note from summit yesterday and it was so clear — what they were talking about:))
17:25:09 <freerunner> FYI, while you were on summit, we setted up a new gate on murano. It's about out cfapi :) It's red now, but after landing https://review.openstack.org/#/c/241267/1 and https://review.openstack.org/#/c/240074/ it will become green =)
17:25:17 <freerunner> sergmelikyan, kzaitsev_ip ^^
17:30:41 <kzaitsev_ip_> I think I lost a couple of messages, sry. gotta setup some more reliable mobile client
17:31:08 <freerunner> kzaitsev_ip_: You just need a bouncer
17:33:17 <kzaitsev_ip_> well, a i have a couple of solutions almost set up :) just need to do the final bits
17:43:07 <Nikolay_St> hoe
17:43:15 <Nikolay_St> is it still murano-time?
17:43:31 <freerunner> Nikolay_St: Whew ;) Yep
17:43:45 <freerunner> Nikolay_St: You're late a little bit =)
17:43:56 <sergmelikyan> yep, but not so much happening... probably we should cut this meeting short today :)
17:44:13 <Nikolay_St> freerunner: unfortunately I catch a traffic jam
17:44:19 <Nikolay_St> sergmelikyan: 1 minute please
17:45:29 <Nikolay_St> sergmelikyan: kzaitsev_ws freerunner I registered a new bp today
17:45:34 <Nikolay_St> #link: https://blueprints.launchpad.net/murano/+spec/external-request-middleware
17:45:50 <Nikolay_St> it's about a new middleware for non-OpenStack requests
17:45:51 <kzaitsev_ws> freerunner: also about gates — we've reached an agreement with congress to add murano gate to their jobs
17:46:38 <freerunner> kzaitsev_ws: I promise, I will think about it ;)
17:47:03 <kzaitsev_ws> #link https://etherpad.openstack.org/p/congress-mitaka-integrations
17:47:30 <kzaitsev_ws> freerunner: so probably you and I should crash at one of theirs irc meetings
17:47:37 <freerunner> kzaitsev_ws: Our job-template merged now, so, we need only rewrite our congress-integration tests on tempest instead murano and congress clients.
17:47:41 <sergmelikyan> Nikolay_St: I don't really get the idea - any spec about that?
17:47:44 <kzaitsev_ws> and I believe, that we can help them set up the jov
17:48:04 <kzaitsev_ws> cause otherwise this might stay just in the etherpad ))
17:48:42 <Nikolay_St> sergmelikyan: I can create one :) For me idea is clear so I forget that it's needed.
17:48:55 <Nikolay_St> will do it on Thursday
17:49:23 <kzaitsev_ws> #link https://etherpad.openstack.org/p/mitaka-relmgt-process-changes
17:49:36 <kzaitsev_ws> the etherpad for relmgt changes for mitaka
17:49:41 <sergmelikyan> Nikolay_St: I meant where the original idea is comming from?
17:49:45 <kzaitsev_ws> and here is a link for pre versioning
17:49:51 <kzaitsev_ws> #link https://etherpad.openstack.org/p/mitaka-release-drop-pre-versioning
17:50:06 <freerunner> Nikolay_St: Nice bp, looks cool.
17:50:19 <Nikolay_St> sergmelikyan: well, we have 'problems' with service broker requests auth
17:50:25 <kzaitsev_ws> so, coming back to 1.0.1 — it would probably be just fine to tag it without altering setup.cfg at all
17:51:12 <Nikolay_St> not it works through Basic Auth, which is not good, because we can't use different middlewares such as context, keystone and ssl
17:51:52 <kzaitsev_ws> Nikolay_St: the whole thing is going to only be enabled in the cfapi pipeline in paste, right?
17:53:14 <Nikolay_St> kzaitsev_ws: it's right for now, because cf is the only one service which send requests to murano outside OpenStack
17:53:33 <kzaitsev_mb> .
17:53:41 <kzaitsev_ws> Nikolay_St: k. makes sense
17:55:09 <Nikolay_St> sergmelikyan: so, should I create a spec or idea look quite simple?
17:55:48 <sergmelikyan> Nikolay_St: I would say we definetely need spec :)
17:56:32 <Nikolay_St> #action Nikolay_St create a spec for bp: external-request-middleware
17:59:54 <sergmelikyan> #endmeeting