17:02:27 <kzaitsev_mb> #startmeeting murano
17:02:28 <openstack> Meeting started Tue Oct  6 17:02:27 2015 UTC and is due to finish in 60 minutes.  The chair is kzaitsev_mb. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:31 <openstack> The meeting name has been set to 'murano'
17:02:35 <Nikolay_St> HI
17:02:46 <kzaitsev_mb> #topic rollcall
17:02:48 <kzaitsev_mb> 0/
17:03:00 <ddovbii> hi
17:03:22 <freerunner> Hey! You're late =)
17:03:27 <katyafervent2> hi
17:04:25 <kzaitsev_mb> not much for agenda today =) serg and stan won't be able to attend.
17:05:17 <kzaitsev_mb> #topic Action Items Review
17:05:54 <kzaitsev_mb> 1) release new version of the client and propose change to global-requirements
17:06:45 <kzaitsev_mb> I believe we did, but it's not possible to add clients to global requirements
17:08:13 <kzaitsev_mb> and 2d) we're still working on app-catalog integration. ativelkov & I are working on that one.
17:09:08 <kzaitsev_mb> #topic Liberty release
17:10:08 <ativelkov> o/
17:10:16 <Nikolay_St> kzaitsev_mb: good to know
17:10:29 <kzaitsev_mb> global openstack releses on Oct 15.
17:10:53 <kzaitsev_mb> Let's review any bugs we still have for L release, shall we
17:11:45 <kzaitsev_mb> #link https://launchpad.net/murano/+milestone/liberty-rc2
17:12:36 <kzaitsev_mb> I seee 2 bugs, still up for l2 and L in general
17:12:48 <ativelkov> bug 1502589	is clear and I have a solution for it
17:12:48 <openstack> bug 1502589 in murano mitaka "Deadlock in DB on package deletion" [High,Confirmed] https://launchpad.net/bugs/1502589 - Assigned to Alexander Tivelkov (ativelkov)
17:12:52 <ativelkov> will try to commit tomorrow
17:13:01 <kzaitsev_mb> k, great!
17:13:32 <kzaitsev_mb> #link https://launchpad.net/bugs/1502589
17:13:46 <kzaitsev_mb> #info ativelkov is about to fix 1502589
17:13:53 <ativelkov> however, bug 1502437 is trickier: I still cannot understand why it happens. If the reason is the amount of environments, then it is actually not a bug
17:13:53 <openstack> bug 1502437 in murano mitaka "Murano picks cidr for subnet which is already used" [Critical,New] https://launchpad.net/bugs/1502437
17:14:25 <ativelkov> we have a limit on number of environments which may co-exist in a tenant (i.e. share the same murano router)
17:14:35 <ativelkov> by default that limit is 20
17:14:39 <freerunner> ativelkov: AFAIK, this bug reproduced under heavy load...
17:14:50 <ativelkov> freerunner: yup, that was a rally test
17:15:22 <ativelkov> however, the test was supposed to be run in several tenants, so it is unclear how many environments it creates per tenant
17:17:18 <ativelkov> I have detailed logs, will need to analyze it
17:17:24 <kzaitsev_mb> Should it be critical then?
17:17:39 <ativelkov> kzaitsev_mb: I don't think so
17:17:48 <kzaitsev_mb> cause, looks like you need specific conditions to reproduce it.
17:18:12 <ativelkov> yup: it's actually a race condition for a cidr
17:18:51 <kzaitsev_mb> wonder what Serg would say, but looks like we can downgrade Importance
17:20:00 <freerunner> kzaitsev_mb: Agreed.
17:20:49 <kzaitsev_mb> And looks like there is no easy way to eliminate that race condition, cause murano puts cidr to heat, so there is a chance that 2 murano envs would request heat to create networks with same cidrs
17:21:21 <kzaitsev_mb> and the error would not come up, untill both of the stacks are launched
17:22:42 <kzaitsev_mb> so looks like there is no easy way for an env to know, that someone requested the same cidr =/
17:25:34 <kzaitsev_mb> ok, the bug is definitelly there. I believe, that we should downgrade it to High, and it would not hurt us to fix it after the release. And probably backport it to j/k/l if we find a suitable solution.
17:25:38 <kzaitsev_mb> huh
17:25:49 <kzaitsev_mb> Serg was the one, who marked it as Critical
17:25:50 <kzaitsev_mb> =)
17:26:18 <kzaitsev_mb> so we'll need to convince him tomorrow anyway, that the bug is not that Critical =)
17:27:04 <kzaitsev_mb> #action discuss https://bugs.launchpad.net/murano/+bug/1502437 severity with Serg, continue considering fixes.
17:27:05 <openstack> Launchpad bug 1502437 in murano mitaka "Murano picks cidr for subnet which is already used" [Critical,New]
17:27:40 <kzaitsev_mb> #link https://launchpad.net/murano-apps/+milestone/liberty-rc2
17:28:42 <kzaitsev_mb> in the apps we have a couple of k8s bugs, assigned to Stan, I believe I even saw a couple of fixes on review, so hopefully they'll be through.
17:29:13 <kzaitsev_mb> so yep, looks like nothing to discuss there =)
17:30:47 <kzaitsev_mb> #link https://launchpad.net/python-muranoclient/+milestone/0.8.0
17:32:20 <kzaitsev_mb> a couple of bugs in progress and a medium bug about CLI.
17:33:32 <kzaitsev_mb> doesn't look like there are any blockers anywhere across our repositories =)
17:35:46 <katyafervent2> thats cool
17:36:30 <kzaitsev_mb> #topic Open Discussion
17:38:53 <kzaitsev_mb> Looks like we've done nice job fixing bugs =)
17:43:43 <kzaitsev_mb> k, so if no one comes up with any topics — I'll end the meeting early =)
17:43:55 <kzaitsev_mb> in a couple of minutes )
17:50:01 <kzaitsev_mb> k, thanks everyone! =) see you in #murano and next week.
17:50:12 <kzaitsev_mb> #endmeeting