17:00:24 <sergmelikyan> #startmeeting murano
17:00:25 <openstack> Meeting started Tue Sep 22 17:00:24 2015 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:28 <openstack> The meeting name has been set to 'murano'
17:00:29 <katyafervent> 0/
17:00:37 <freerunner> Hi folks! ;)
17:01:03 <tlashchova> o/
17:01:35 <kzaitsev_mb> o/
17:01:48 <kzaitsev_mb> \o
17:03:30 <_ddovbii> Hi!
17:03:54 <sergmelikyan> https://wiki.openstack.org/wiki/Meetings/MuranoAgenda <- our agenda for today
17:04:51 <sergmelikyan> First of all, I would like to apologize for missing deadline for sending my candidacy as PTL for the next cycle :(
17:05:04 <sergmelikyan> Sorry guys, I miscalculated timezones :(
17:05:42 <sergmelikyan> According to http://git.openstack.org/cgit/openstack/governance/tree/resolutions/20141128-elections-process-for-leaderless-programs.rst now it's up to TC to assign PTL for Murano
17:06:13 <sergmelikyan> but I hope that I will be assigned given that I sent e-mail, but was not able to send commit with my candidacy to Gerrit
17:07:17 <sergmelikyan> It's going to be decided tonight in 3 hours on the TC meeting
17:08:13 <katyafervent> don't worry, you'll be selected :)
17:08:50 <sergmelikyan> next topic that I would like to discuss is readiness to the Liberty RC1
17:08:59 <sergmelikyan> katyafervent: thx for support :)
17:09:52 <sergmelikyan> according to the https://launchpad.net/murano/+milestone/liberty-rc1 we have only 1 high bug left
17:10:59 <sergmelikyan> StanLagun: https://bugs.launchpad.net/bugs/1476687
17:11:00 <openstack> Launchpad bug 1476687 in murano "murano-agent hangs after processing the first request on RHEL6-based distro" [High,Confirmed] - Assigned to Stan Lagun (slagun)
17:11:08 <sergmelikyan> it's assigned to you, any ETA?
17:11:44 <StanLagun> sergmelikyan, haven't had a change to debug it yet
17:12:02 <sergmelikyan> we need to finish it before end of tomorrow :(
17:13:03 <sergmelikyan> StanLagun: how we can help you with this task?
17:13:19 <katyafervent> we also have couple of high bugs in murano-apps
17:13:58 <StanLagun> someone need to try run agent on RHEL and see if it hangs. And if it does you need to debug it
17:14:21 <StanLagun> and don't know how it can be distributed between several developers
17:14:46 <sergmelikyan> so essentially no...
17:15:11 <StanLagun> I even don't know if it really hangs
17:15:42 <kzaitsev_mb> so we're going to release tommorrow, right?
17:15:49 <sergmelikyan> StanLagun: please take a look at this ASAP - according to the bug description it prevents using agent on any rhel6 based OS which many people do
17:15:57 <sergmelikyan> kzaitsev_mb: thursday
17:16:03 <StanLagun> And if it is it may take a long time to discover why because it will mean something wrong with kombu/eventlet
17:16:04 <kzaitsev_mb> I see
17:16:18 <StanLagun> sergmelikyan, is it of a higher priority than k8s?
17:16:37 <sergmelikyan> StanLagun: I would say yes for the next week
17:16:48 <sergmelikyan> *for this and the next week
17:18:04 <katyafervent> https://bugs.launchpad.net/murano-apps/+bug/1490586
17:18:05 <openstack> Launchpad bug 1490586 in murano-apps mitaka "unable to deploy Rally application" [High,In progress]
17:18:42 <katyafervent> bug in murano-apps. regarding comments from assigner it will not be fixed in liberty :(
17:19:00 <katyafervent> but we need to track it to backport later
17:19:01 <sergmelikyan> #action StanLagun is going to switch working to https://bugs.launchpad.net/bugs/1476687
17:19:02 <openstack> Launchpad bug 1476687 in murano "murano-agent hangs after processing the first request on RHEL6-based distro" [High,Confirmed] - Assigned to Stan Lagun (slagun)
17:21:17 <sergmelikyan> katyafervent: any individual bug in individual applications is not going to prevent releasing murano-apps, though we need to have this in release nots
17:21:25 <sergmelikyan> https://launchpad.net/murano-apps/+milestone/liberty-rc1 - we have 5 bugs here
17:22:13 <sergmelikyan> I propose to go through them and see what we can safely move to the next milestone
17:22:24 <katyafervent> https://bugs.launchpad.net/murano-apps/+bug/1466068
17:22:25 <openstack> Launchpad bug 1466068 in murano-apps "Deployment failed, but the status is 'Ready'" [High,Confirmed] - Assigned to Dmytro Dovbii (ddovbii)
17:23:09 <katyafervent> This one is important, Dmitro will try to fix it together with Stan
17:23:40 <sergmelikyan> _ddovbii: ^
17:23:44 <sergmelikyan> ?
17:23:51 <sergmelikyan> How it is going with this bug?
17:24:28 <_ddovbii> I've already tried to investigate it, but looks like I dont have any ideas. Maybe I need Stan's help
17:25:25 <katyafervent> So we hoped this bug will be fixed in rc1, please let us know if you need help
17:25:31 <katyafervent> Another bug is https://bugs.launchpad.net/murano-apps/+bug/1495548
17:25:32 <openstack> Launchpad bug 1495548 in murano-apps "Update UI definitions to the latest supported version" [High,In progress] - Assigned to Ekaterina Chernova (efedorova)
17:25:39 <_ddovbii> will try to fix it before tomorrow evening
17:26:02 <sergmelikyan> StanLagun: ^ can you also get together with _ddovbii?
17:26:10 <StanLagun> sure
17:27:23 <katyafervent> ok, so regarding application update - the patch is waiting for a review
17:27:57 <sergmelikyan> katyafervent: link?
17:28:29 <katyafervent> 1495548 5 messages above
17:29:35 <katyafervent> https://review.openstack.org/#/c/223555/
17:29:40 <katyafervent> here is a patch
17:30:13 <sergmelikyan> katyafervent: I see two open questions in this patch
17:30:22 <sergmelikyan> katyafervent: can you address them?
17:30:55 <katyafervent> where?
17:31:10 <sergmelikyan> in this patch
17:31:54 <katyafervent> I answered xiangxinyong	in the bug like he asked
17:32:12 <kzaitsev_mb> I'm ok with releasing 2.2 in s/liberty FYI
17:32:28 <katyafervent> StanLagun, should change his opinion after we discussed app versioning
17:32:40 <katyafervent> So anybody welcome to review
17:34:04 <sergmelikyan> I am +1 for that
17:36:23 <katyafervent> Next one is https://bugs.launchpad.net/murano-apps/+bug/1491383
17:36:25 <openstack> Launchpad bug 1491383 in murano-apps "Deployment of few ADs in one env in some configuration fails with error" [High,Confirmed] - Assigned to Alexey Khivin (akhivin)
17:36:46 <katyafervent> StanLagun, can you comment on that?
17:36:51 <katyafervent> is it high at all?
17:38:37 <StanLagun> why do you ask me?
17:39:22 <katyafervent> I'm asking your opinion
17:40:16 <StanLagun> Probably it is high if AD is important for us
17:40:40 <StanLagun> But  know nothing about why it happens
17:40:55 <sergmelikyan> I would say that it's more Medium
17:41:07 <katyafervent> ok, so we hoped akhivin is working on it
17:41:17 <katyafervent> Thats all for murano-apps bugs
17:43:00 <sergmelikyan> thx... we don't have critical bugs preventing release of RC, but it would be nice to not have high bugs too :)
17:44:55 <sergmelikyan> #topic Open Discussion
17:45:43 <enthurohini> hello sergmelikyan, katyafervent and kzaitsev_mb: as you provided me the blueprints, i am interested in https://blueprints.launchpad.net/murano/+spec/tag-murano-heat-stacks and https://blueprints.launchpad.net/python-muranoclient/+spec/openstack-client-plugin-support
17:46:02 <enthurohini> I have some doubts so should i clear them here?
17:47:21 <sergmelikyan> sure, and we can discuss it anytime in #murano too
17:48:27 <enthurohini> sergmelkiyan, Thanks for the freedom. Can you provide mentor for this both BP?
17:49:27 <kzaitsev_mb> enthurohini: what kind of mentorship do you want? =)
17:49:35 <katyafervent> I can help you
17:49:45 <katyafervent> You can send messages directly to me ^)
17:50:07 <kzaitsev_mb> we're usually pretty open and you can easily find katyafervent or me or someone else in #murano =)
17:50:32 <enthurohini> kzitsev_mb, as i am new to this, i will need guidance of mentor who will guide me in right direction
17:50:38 <kzaitsev_mb> ok katyafervent volunteered, so feel free to ping her =P
17:51:20 <enthurohini> katyafervet thanks
17:52:00 <katyafervent> welcome
17:52:06 <enthurohini> katyafervent, https://blueprints.launchpad.net/murano/+spec/tag-murano-heat-stacks in this bp it is mentioned that some tags will be hidde bydefault. so there will be a list of tags in advance?
17:52:21 <enthurohini> _hiiden
17:53:00 <enthurohini> or operator will provide tags to stacks?
17:53:08 <katyafervent> no, stacks should not be hidden
17:53:45 <enthurohini> then?
17:54:43 <katyafervent> you will mark stacks created by murano with tags
17:54:48 <enthurohini> katyafervent, see when stack will generate, it will not have any tag. right?
17:55:16 <kzaitsev_mb> enthurohini: stack-tagging was added in L
17:55:18 <katyafervent> it should be regarding to the parameter of config
17:55:26 <kzaitsev_mb> so currently we do not tag heat stack
17:55:36 <kzaitsev_mb> created during deployment
17:55:41 <katyafervent> that what this blueprint should do
17:56:02 <katyafervent> How this tags will be used is out of scope of this BP
17:56:28 <kzaitsev_mb> yep, if cloud operator decides to hide some tags — that's up to him
17:56:37 <kzaitsev_mb> moreover, that's not connected to murano anyway
17:56:41 <enthurohini> First clear me, tagging will be done on what heat created stacks or murano ceated?
17:56:42 <kzaitsev_mb> it would be a heat setting
17:57:23 <kzaitsev_mb> murano creates heat stacks. murano should tag them during creation. does that answer your question?
17:59:00 <enthurohini> tagging will be done according to config parameter?
17:59:23 <enthurohini> kzaitsev_mb, yes.
18:00:01 <sergmelikyan> folks, let's continue in #murano
18:00:04 <sergmelikyan> #endmeeting