16:59:35 <sergmelikyan> #startmeeting Murano
16:59:36 <openstack> Meeting started Tue Aug 11 16:59:35 2015 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:59:41 <openstack> The meeting name has been set to 'murano'
16:59:47 <aderyugin> 0/
17:00:00 <sergmelikyan> o/
17:00:07 <ativelkov> o/ :)
17:00:13 <FilipBlaha> o/
17:00:15 <ddovbii> hi
17:00:21 <freerunner> hey!
17:00:31 <mgershen> o/
17:02:11 <sergmelikyan> Agenda for todays meeting: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:02:21 <sergmelikyan> #topic Action Items Review
17:02:49 <sergmelikyan> #1 kzaitsev_mb write an email to encourage murano team and murano users to test new yaql
17:03:21 <kzaitsev_mb> hi
17:03:34 <kzaitsev_mb> sry, thought that we're in meeting-3 for some reason.
17:04:13 <kzaitsev_mb> I remember I had to write 2 emails. I thin I only wrote one.
17:04:25 <kzaitsev_mb> Was really waiting for yaql commits to be merged
17:05:04 <ativelkov> kzaitsev_mb: they are
17:05:18 <kzaitsev_mb> so I wrote an email about periodic jobs, yes =)
17:05:29 <kzaitsev_mb> and didn't write one about testing yaql
17:05:33 <sergmelikyan> kzaitsev_mb: most of them are merged, I believe we can release RC2 already
17:05:49 <sergmelikyan> ativelkov: do you have plans to do that in near future?
17:06:11 <ativelkov> sergmelikyan: sure. In an hour or so.
17:06:12 <kzaitsev_mb> Will write to ML, right after RC2 hits pypi =)
17:06:18 <sergmelikyan> awesome!
17:06:31 <sergmelikyan> #action kzaitsev_mb write an email to encourage murano team and murano users to test new yaql
17:06:43 <sergmelikyan> #2 kzaitsev_mb write e-mail about stable jobs
17:06:45 <sergmelikyan> done :)
17:06:52 <sergmelikyan> right? :)
17:06:56 <kzaitsev_mb> yep that one is done.
17:07:06 <kzaitsev_mb> no failures from murano jobs there btw
17:07:14 <sergmelikyan> #topic YAQL 1.0 Status
17:07:26 <kzaitsev_mb> hope it'll stay that way =)
17:07:36 <sergmelikyan> I think this also covers status for yaql 1.0 - RC2 + testing => release
17:07:55 <sergmelikyan> kzaitsev_mb: yep :)
17:08:53 <kzaitsev_mb> citing Stan: RC2 would most likely become 1.0 and commit is ready to be tested. And is in fact being tested already.
17:09:20 <sergmelikyan> kzaitsev_mb: we thought same thing about RC1 ;)
17:10:05 <slagun> The difference between RC1 and RC2 is that Murano already works on RC2
17:10:15 <kzaitsev_mb> so just for the record #link https://review.openstack.org/#/c/204099/
17:10:28 <kzaitsev_mb> and the spec
17:10:32 <kzaitsev_mb> https://review.openstack.org/#/c/209908/
17:11:05 <slagun> Thre will be second spec as soon as I fix one more bug in this commit and then I'll update commit message
17:12:55 <sergmelikyan> We plan to update commits to Murano with new requirement to RC2
17:13:05 <sergmelikyan> slagun:
17:14:32 <sergmelikyan> sorry :) It was question :)
17:15:04 <slagun> the question is should we update requirements.txt for rc2?
17:15:12 <sergmelikyan> yep
17:16:18 <slagun> Maybe it will be better to set it to >=1.0.0<2.0.0 right from the start, test with RC2 and if everything work fine make rc2 to be the release and merge new engine there?
17:16:41 <slagun> I'm not sure
17:17:26 <sergmelikyan> slagun: I am not sure that it will work
17:17:39 <slagun> why?
17:18:18 <sergmelikyan> I think pip will skip beta packages when you set this kind of requirements
17:18:22 <ativelkov> I like the idea of having final rquirements from the beginning
17:18:31 <ativelkov> but yeah, rc will be ignored
17:18:45 <kzaitsev_mb> we'll have to ignore openstack-proposal bot for some time I guess, but that's fine by me
17:20:24 <slagun> we will release 1.0.0 final before new engine so no problem here. At least if you okay with installing requirements manually for tests
17:20:32 <ativelkov> I've added one more commit to yaql (https://review.openstack.org/#/c/211678): very simple one. Please review, and I'll release rc2 as soon as this one is merged
17:21:37 <sergmelikyan> ativelkov: +2
17:21:44 <ativelkov> thanks
17:21:46 <sergmelikyan> slagun: let's pin to RC2 for now
17:21:55 <sergmelikyan> slagun: ok?
17:22:15 <slagun> okay
17:22:42 <slagun> ativelkov: +2/+1
17:22:48 <ativelkov> thanks :)
17:22:55 <sergmelikyan> #info pin yaql requirements to RC2
17:23:04 <sergmelikyan> #undo
17:23:05 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0xa50c850>
17:23:11 <sergmelikyan> #action pin yaql requirements to RC2
17:23:42 <slagun> >=1.0.0rc2<2.0.0 is ok?
17:23:51 <ativelkov> nope
17:24:00 <ativelkov> let's pin with == for now
17:24:16 <sergmelikyan> #topic Artifact (glance v3) transition status update
17:24:18 <sergmelikyan> ativelkov: +1
17:24:57 <ativelkov> OK. So, there is a bunch of bugs in glance reported related to artifact filtering by version
17:25:28 <katyafervent2> hi, sorry I'm late
17:25:38 <ativelkov> #link https://bugs.launchpad.net/glance/+bug/1479700
17:25:38 <openstack> Launchpad bug 1479700 in Glance "Artifacts: filtering by dictionary key is not working" [Undecided,In progress] - Assigned to Alexander Tivelkov (ativelkov)
17:25:38 <ativelkov> #link https://bugs.launchpad.net/glance/+bug/1480392
17:25:39 <ativelkov> #link https://bugs.launchpad.net/glance/+bug/1480393
17:25:39 <openstack> Launchpad bug 1480392 in Glance "Artifacts: filtering by range is not working as expected" [Undecided,New] - Assigned to Alexander Tivelkov (ativelkov)
17:25:40 <openstack> Launchpad bug 1480393 in Glance "Artifacts: filtering by version ignores operators other than equality" [Undecided,New] - Assigned to Alexander Tivelkov (ativelkov)
17:25:42 <uvirtbot> Launchpad bug 1479700 in glance "Artifacts: filtering by dictionary key is not working" [Undecided,In progress]
17:25:43 <uvirtbot> Launchpad bug 1479700 in glance "Artifacts: filtering by dictionary key is not working" [Undecided,In progress] https://launchpad.net/bugs/1479700
17:25:45 <uvirtbot> Launchpad bug 1480392 in glance "Artifacts: filtering by range is not working as expected" [Undecided,New]
17:25:46 <uvirtbot> Launchpad bug 1480392 in glance "Artifacts: filtering by range is not working as expected" [Undecided,New] https://launchpad.net/bugs/1480392
17:25:47 <uvirtbot> Launchpad bug 1480393 in glance "Artifacts: filtering by version ignores operators other than equality" [Undecided,New]
17:25:48 <uvirtbot> Launchpad bug 1480393 in glance "Artifacts: filtering by version ignores operators other than equality" [Undecided,New] https://launchpad.net/bugs/1480393
17:26:02 <ativelkov> oops ) lots of bot spam, sorry
17:26:09 <katyafervent2> ativelkov, do you plan to fux them by yourself?
17:26:27 <katyafervent2> *fix
17:26:32 <ativelkov> Yes. The first one is fixed already. It just awaits for some tests to be landed
17:26:58 <ativelkov> The initial commit of the murano artifact itself is in gerrit
17:27:08 <ativelkov> #link https://review.openstack.org/#/c/211635/
17:27:52 <kzaitsev_mb> ohmygosh. I almost thought that we already ended the meetint with 3 messages from @openstack %)
17:27:53 <katyafervent2> that's cool, so are we just waiting for bugs to be fixed, right?
17:28:52 <ativelkov> katyafervent2: not just them. We'll have to add artifacts support to python-muranoclient afterwards
17:30:32 <sergmelikyan> ativelkov: nice, what about support of them in Murano? I believe I did see something pushed recently
17:30:56 <ativelkov> sergmelikyan: just the plugin itself (see the link above)
17:31:40 <ativelkov> The code in python-muranoclient has to wait till the fixes are in place (and till we release an experimatal version of python-glanceclient with v3 support)
17:31:57 <katyafervent2> can we start working on the client? or bugs block that activity?
17:32:17 <katyafervent2> got the answer)
17:34:40 <ativelkov> so, the plan is to close the glance bugs later this week, so we may proceed
17:34:47 <sergmelikyan> #info ativelkov is working on bugs in GLARE, plugin for Murano is published
17:35:05 <slagun> what is GLARE?
17:35:18 <slagun> artifact repository?
17:35:18 <ativelkov> GLance Artifact REpository )
17:35:34 <ativelkov> mfedosin coined the name while in Vancouver :)
17:36:15 <ativelkov> funny it's got known wider
17:37:02 <ativelkov> next item? :)
17:37:44 <sergmelikyan> #topic Open Discussion
17:38:14 <sergmelikyan> I would like to bring to attention feedback in this commit: https://review.openstack.org/#/c/211157/3/murano/engine/system/heat_stack.py
17:38:23 <sergmelikyan> while mgershen and slagun are both here :)
17:38:40 <sergmelikyan> should we address it or merge as it is?
17:38:48 <sergmelikyan> I am for addressing :)
17:39:21 <slagun> sergmelikyan: what exactly do you want to address there?
17:39:31 <mgershen> Kirill Zaitsev also has a comment.
17:40:01 <mgershen> I am fine with whatever slagun thinks
17:40:39 <sergmelikyan> What about comment from kzaitsev_mb?
17:41:01 <sergmelikyan> mgershen: I got correctly that your second comment is about formmating of the same code?
17:41:32 <mgershen> yes, I just read the style guide ^^"
17:42:10 <sergmelikyan> I would prefer to have fix for this bug ASAP, but I don't see how kzaitsev_mb concern is addressed, but I see +1 from him :)
17:42:21 <slagun> there cannot be infinite loop in this case. Though the waiting code in theory can wait forever but it could do so before and it is not related to this commit
17:43:11 <slagun> I thought we agreed on that with kzaitsev_mb
17:43:23 <kzaitsev_mb> true
17:43:39 <kzaitsev_mb> I wonder if we should continue the loop if we got 404 from heat, though
17:43:56 <kzaitsev_mb> is there any valid situation where we should do so?
17:44:16 <slagun> we will not continue in that case
17:44:55 <slagun> self._last_stack_timestamps will be reseted to (None, None) in that case
17:45:54 <kzaitsev_mb> yep, but initial values are (None, None). I meant we could just ignore this code if got 404
17:46:05 <sergmelikyan> slagun: I would happy to see that you agreed in comments to review :) It was somewhat silent agreement :)
17:46:16 <kzaitsev_mb> that would eliminate even theoretical possibility of us waiting forever
17:48:30 <slagun> kzaitsev_mb: I don't see theoretical possibility even as for now. And this change will make this code even more cryptic. In what case there can be infinite loop?
17:48:37 <slagun> Even in theory
17:49:09 <kzaitsev_mb> In current code — there can't be. I've updated my review btw )
17:49:54 <sergmelikyan> Than let's finish discussing this bug :)
17:50:00 <sergmelikyan> Thank you folks
17:50:13 <sergmelikyan> Please leave comments in review in the future
17:50:34 <mgershen> ok
17:50:39 <sergmelikyan> It's was confusing :(
17:50:58 <mgershen> sorry :(
17:51:37 <ativelkov> folks, I've updated https://review.openstack.org/#/c/211678/ (there was some pep issue). Could you please re-approve?
17:52:05 <kzaitsev_mb> just for the record todays agenda is available at #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda/Archive/2015-08-11/
17:56:27 <sergmelikyan> #endmeeting