17:00:25 <sergmelikyan> #startmeeting murano
17:00:26 <openstack> Meeting started Tue Apr 28 17:00:25 2015 UTC and is due to finish in 60 minutes.  The chair is sergmelikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:30 <openstack> The meeting name has been set to 'murano'
17:00:42 <sergmelikyan> Hi Team o/
17:00:46 <aderyugin> hi!
17:00:55 <ddovbii_> Hi
17:01:26 <ativelkov> o/
17:01:36 <kzaitsev> I suggest we deside on a secret murano greeting
17:01:47 <sergmelikyan> kzaitsev, like? :)
17:01:52 <freerunner> yo!
17:01:56 <kzaitsev> dunno
17:01:58 <sergmelikyan> ativelkov, was proposing usage of muranoers
17:02:02 <katyafervent> 0/
17:02:20 <slagun> o%//
17:02:32 <FilipBlaha> hi
17:03:28 <kzaitsev> do OS-users have a secret greeting?
17:03:36 <sergmelikyan> (⌐■_■)
17:03:46 <sergmelikyan> kzaitsev, dunno :)
17:03:54 <sergmelikyan> #topic Agenda
17:04:16 <sergmelikyan> As usual today's agenda is available here: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:04:42 <sergmelikyan> I would like to go through few bugs today that are considered critical, but we are so close to release...
17:04:57 <sergmelikyan> #topic Action Items
17:05:38 <sergmelikyan> #1 meeting about blueprint/abstract-env-template is scheduled for ...
17:06:07 <sergmelikyan> henar was not able to attend that meeting and we didn't agreed on a new time :(
17:06:48 <sergmelikyan> In scope of this topic, let's discuss for a minute what is better way to have discussions around new features given that we are not able to dicuss them on summit?
17:07:09 <ativelkov> I'd prefer hangout
17:07:41 <ativelkov> I mean, if we need some way other then spec review
17:08:22 <sergmelikyan> ativelkov, yeah I am talking about pre-spec discussions that usually held during summit
17:09:09 <ativelkov> yup, the hangout should work then
17:09:21 <sergmelikyan> ativelkov, I also like hangout
17:09:34 <sergmelikyan> slagun, katyafervent any thoughts?
17:11:29 <slagun> +1
17:11:42 * sergmelikyan has issues with eyesight not ears, but he is wandering if he missed response from katyafervent
17:11:43 <katyafervent> I agreed with hangout
17:12:26 <sergmelikyan> Then our workflow is: announcement -> discussion (hangout) -> meeting minutes
17:12:31 <slagun> but even better to have rich chat + hangout
17:12:38 <sergmelikyan> rich chat?
17:12:50 <ativelkov> I propose to have some etherpad to gather discussion proposals
17:13:29 <slagun> something like slack. Something better than IRC
17:13:40 <sergmelikyan> ativelkov, agree
17:13:42 <ativelkov> slack is internal only
17:13:55 <slagun> there are a lot of similar projects
17:13:56 <ativelkov> you cannot use for intercompany communications
17:14:02 <ativelkov> ah, got it
17:14:06 <sergmelikyan> slagun, can't understand why you consider slack is better option than IRC, but let's skip this
17:14:16 <ativelkov> well, we used to have "virtual summits" in Glance
17:14:28 <sergmelikyan> ativelkov, using?
17:14:33 <ruhe> IRC should be the default choice. it's the only open channel of real-time communication
17:14:48 <sergmelikyan> ruhe, for chat - sure, +1
17:14:55 <ruhe> yeah, for chatting
17:15:16 <ativelkov> it was called vidyo
17:15:30 <katyafervent> I also prefer IRC
17:15:45 <ativelkov> www.vidyo.com
17:15:48 <slagun> the problem with IRC is its single-line message. You cannot paste code samples etc
17:15:59 <sergmelikyan> Last question before moving on...
17:16:05 <sergmelikyan> ativelkov, how did you like it?
17:16:24 <ativelkov> well, nothing special. ± the same as webex
17:16:40 <sergmelikyan> huh...
17:16:46 <sergmelikyan> #topic Release Status
17:16:59 <sergmelikyan> https://launchpad.net/murano/+milestone/kilo-rc2
17:17:25 <sergmelikyan> We still have several open issues, three of them I would like to discuss specifically
17:17:43 <sergmelikyan> I think aderyugin fixed issue with our devstack, and that is a relief
17:18:03 <sergmelikyan> kzaitsev is working on his issue, but I would consider it also fixed
17:18:11 <ruhe> link to patch to devstack: https://review.openstack.org/#/c/178290/
17:18:23 <katyafervent> Finally!
17:18:36 <sergmelikyan> Yeah... it's so sad that issue was so simple :(
17:19:37 <sergmelikyan> https://review.openstack.org/177796 & https://review.openstack.org/177869 for catalog issues fixed by kzaitsev
17:19:57 <sergmelikyan> freerunner, can you help us verify this issues?
17:20:37 <freerunner> sergmelikyan: sure
17:20:43 <sergmelikyan> We are really close to release, like 2 days left, and it's big risk to include fixes right now, but from other point of view this bug is a major flaw in core Murano functionality
17:20:45 <kzaitsev> We're currently doing that =)
17:20:53 <katyafervent> There are no more new bugs in rc2, right?
17:20:56 <sergmelikyan> kzaitsev, awesome!
17:21:24 <sergmelikyan> katyafervent, not exactly :( Today we found three more critical bugs that I would like to discuss today.
17:21:34 <sergmelikyan> Main question - should we have them fixed in kilo or not
17:21:58 <sergmelikyan> #1 https://bugs.launchpad.net/murano/+bug/1449500
17:21:58 <openstack> Launchpad bug 1449500 in murano "AgentListener doesn't stop after GC cleanup" [Critical,Confirmed] - Assigned to Stan Lagun (slagun)
17:22:45 <slagun> sergmelikyan: I already know why it happens. Will fix today
17:23:04 <sergmelikyan> This bug essentially breaks application deployment and it is really critical... I personally think that we need to  focus  and fix this in Kilo
17:23:06 <katyafervent> we can always back port them later, as we did for some bugs found in stable/juno
17:23:06 <ruhe> what are the chances to introduce a regression with your fix?
17:23:31 <sergmelikyan> katyafervent, not exactly - many people use released version not a stable branches
17:23:45 <slagun> ruhe: very unlikely
17:24:04 <katyafervent> so you will be use latest version of juno not 2014.2
17:24:57 <katyafervent> now it's 2014.2.2 and it has fixes for some critical bugs
17:25:05 <sergmelikyan> opposite - people usually use and include in the distribution 2014.2, 2014.2.1 and so on and rarely pull code from stable/juno
17:25:34 <ativelkov> katyafervent: we don't want to wait for 2015.1.1 for such a critical fix
17:25:41 <sergmelikyan> if we would not fix this bug in kilo right now it means that fix would be available at least 1-2 month later
17:25:46 <sergmelikyan> ativelkov, +1
17:26:10 <ativelkov> so, I'd prefer to risk and include it in RC3
17:26:24 <sergmelikyan> ativelkov, we still may release in RC2 :)
17:26:37 <ativelkov> s/RC3/RC2 :)
17:26:45 <sergmelikyan> slagun, so any hints how you plan to fix this issue?
17:27:31 <ativelkov> But that's a lesson lerned: we definetly have to many critical issues at RC stage. Probably because we had too many freeze exceptions
17:28:01 <sergmelikyan> or very late QA cycle & not so many tests :(
17:28:11 <slagun> sergmelikyan: we are using environment.start()/stop() to execute pre/post deploy hooks. The fix is to have GC as an explicit step with pre/post-GC hooks similar to deployment
17:28:25 <ativelkov> sergmelikyan: that's the reason of that: we were still doing feature development when the schedule assumes QA
17:28:34 <slagun> currently GC happens implicitly upon model load
17:28:45 <ativelkov> let's remember this and try to avoid such a pattern at L
17:29:16 <katyafervent> ruhe, is it a common practice to fix such kind of bugs in rc releases? do all the projects have a lot of bugs in rc releases?
17:29:18 <sergmelikyan> ativelkov, yeah...
17:29:37 <sergmelikyan> katyafervent, it depends... horizon goes for RC3 AFAIK
17:31:08 <ruhe> in what scenarios will this issue be reproduced? would it affect *all* users?
17:31:59 <slagun> it affects any application that have destruction logic
17:32:15 <sergmelikyan> slagun, ruhe Kubernetes?
17:32:53 <slagun> I've encountered this issue when I started to implement Docker applications removal
17:33:25 <slagun> we don't have distruction in any other applications in murano-apps but users may have it in their own apps
17:33:50 <ruhe> then, imho, fix should be merged now in kilo
17:34:24 <sergmelikyan> #startvote Fix #1449500 in RC2? Yes, No
17:34:24 <openstack> Begin voting on: Fix #1449500 in RC2? Valid vote options are Yes, No.
17:34:25 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:34:32 <sergmelikyan> #vote Yes
17:34:40 <slagun> #vote yes
17:34:42 <katyafervent> #vote Yes
17:34:49 <ruhe> #vote Yes
17:35:16 <ativelkov> #vote yes
17:35:19 <sergmelikyan> #endvote
17:35:19 <openstack> Voted on "Fix #1449500 in RC2?" Results are
17:35:21 <openstack> Yes (5): katyafervent, ruhe, ativelkov, slagun, sergmelikyan
17:35:21 <freerunner> #vote yes
17:35:36 <sergmelikyan> I think we had majority here :)
17:35:40 <sergmelikyan> freerunner, sorry :)
17:35:51 <freerunner> sergmelikyan: Oops =)
17:36:08 <sergmelikyan> #2 https://bugs.launchpad.net/murano/+bug/1449497
17:36:08 <openstack> Launchpad bug 1449497 in murano "[MuranoPL] pselect exits on first exception" [Critical,Confirmed] - Assigned to Stan Lagun (slagun)
17:36:37 <slagun> this is even more important than the previous one
17:36:56 <katyafervent> This bug is nasty, we should definitely fix it
17:37:18 <katyafervent> We can't get real exception because of this bug
17:37:29 <sergmelikyan> Yeah, this affects almost every deployment
17:37:35 <ativelkov> Well, there is another option: replace pselect with select in core library. This will not introduce any regressions, we'll just decrease performance
17:37:47 <slagun> we had this bug since day 1 of MuranoPL :)
17:37:53 <ativelkov> I mean, in the Environment.deploy()
17:37:55 <katyafervent> Moreover, this bug shows misleading exception
17:38:05 <sergmelikyan> slagun, you are proud of that? :)
17:38:30 <slagun> sergmelikyan: :-))
17:38:37 <sergmelikyan> slagun, if you tell me that you know about this issue long time ago I will not buy a beer for you on Summit
17:38:42 <ruhe> slagun: may i ask you to update bug description and include steps to repro, symptoms, etc. so that users of murano might understand it and figure out they're hitting exactly this issue?
17:39:33 <sergmelikyan> :)
17:39:36 <freerunner> ruhe: one second, please ;)
17:39:49 <slagun> I told about it several times but until know it didn't caused any real harm
17:40:27 <slagun> ruhe: there is a slightly better description here: https://bugs.launchpad.net/mos/+bug/1449635
17:40:27 <openstack> Launchpad bug 1449635 in Mirantis OpenStack "[MuranoPL] pselect exits on first exception" [Critical,Confirmed] - Assigned to Stan Lagun (slagun)
17:41:09 <slagun> symptom is when you [OS Errno 2]: No such file in dashboard. Sometimes this is the only error you see
17:41:22 <sergmelikyan> I agree that we need to update description for #1449497... nasty :(
17:41:47 <ruhe> it seems that there's general agreement that this one should be fixed now
17:42:26 <sergmelikyan> #agree #1449635 need to be fixed in RC2
17:42:50 <sergmelikyan> #3 https://bugs.launchpad.net/murano/+bug/1449510
17:42:50 <openstack> Launchpad bug 1449510 in murano "[Docker] Sometimes Docker doesn't start" [High,Confirmed] - Assigned to Stan Lagun (slagun)
17:43:16 <sergmelikyan> I have doubts about that one... it's just one of the application that we developed, and does not affect core functionality
17:43:34 * sergmelikyan remembered that we need to move tracking apps bugs to separate launchpad
17:44:02 <ruhe> sergmelikyan: +1 and in long term we'll need to reconsider the approach to track applicaitons as part of release of murano. they're different entity
17:44:04 <slagun> This is additional step in DockerStandaloneHost to start docker service. Just a workaround. I think this is some docker startup bug
17:44:29 <sergmelikyan> But from the other point of view it affects K8s & Docker apps and they are most powerful apps that we have AND they enable whole different level of applications
17:44:30 <freerunner> sergmelikyan: ruhe: https://bugs.launchpad.net/murano/+bug/1449497 done.
17:44:30 <openstack> Launchpad bug 1449497 in murano "[MuranoPL] pselect exits on first exception" [Critical,Confirmed] - Assigned to Stan Lagun (slagun)
17:44:48 <sergmelikyan> slagun, so you have workaround for that bug?
17:45:16 * sergmelikyan changing his mind about buying a beer for slagun
17:46:01 <ruhe> freerunner: one minor suggestion - include logs into the bug description. it'll help users to google for this error
17:46:03 <slagun> sergmelikyan: yes, I have. It is very simple. I will commit it with application removal
17:46:10 <slagun> (but not in the same coommit)
17:46:53 <sergmelikyan> slagun, ok, then beer is on me and maybe a wine :) kzaitsev says that Vancouver should have great wine
17:47:07 <kzaitsev> icewines
17:47:34 <sergmelikyan> #startvote Fix #1449510 in RC2? Yes, No
17:47:34 <openstack> Begin voting on: Fix #1449510 in RC2? Valid vote options are Yes, No.
17:47:35 <openstack> Vote using '#vote OPTION'. Only your last vote counts.
17:47:43 <ativelkov> #vote Yes
17:47:47 <freerunner> #vote yes
17:47:53 <slagun> #vote Yes
17:48:00 <aderyugin> #vote yes
17:48:02 <ddovbii_> #vote Yes
17:48:04 <sergmelikyan> ruhe ? :)
17:48:14 <ruhe> #vote Yes
17:48:21 <katyafervent2> # No
17:48:22 <ativelkov> sergmelikyan: don't we have any restrictions on our RCs from Openstack's release manager?
17:48:22 <sergmelikyan> #endvote
17:48:22 <openstack> Voted on "Fix #1449510 in RC2?" Results are
17:48:23 <openstack> Yes (6): ruhe, ativelkov, slagun, freerunner, ddovbii_, aderyugin
17:48:49 <ruhe> katyafervent2: why no?
17:48:54 <sergmelikyan> ativelkov, no, Murano is not managed by OpenStack Release Manager
17:49:24 <sergmelikyan> as well as other projects joined to Big Tent recently
17:49:32 <katyafervent2> do we have time for so many bugs?
17:49:49 <freerunner> katyafervent2: This bug should be fixed. Sometimes it blocks deployment.
17:50:07 <slagun> katyafervent: there is also https://bugs.launchpad.net/murano/+bug/1446582
17:50:07 <openstack> Launchpad bug 1446582 in murano "Invalid workflow of application replacement" [Medium,Confirmed] - Assigned to Stan Lagun (slagun)
17:50:24 <sergmelikyan> Looks like we have solutions for all of them, and I  believe freerunner some tests that are not yet commited for last bug
17:50:26 <katyafervent2> if you are 100% sure we wikk fux it and TEST in 3 days - i dont minf
17:50:26 <slagun> and I'm going to close close 4 bugs today
17:50:58 <ruhe> slagun: and not introduce any regressions as you promised before ;)
17:50:58 <sergmelikyan> slagun, ok, Jack is also on me :)
17:51:29 <slagun> ruhe: I do a lot of manual testing on k8s and Docker. So at lest those 2 wont break
17:51:44 <slagun> sergmelikyan: :)
17:52:35 <sergmelikyan> Let's make a deal then: if we will have fix this issues by tomorrow, and freerunner will give his +1 to reviews (obviously +1 from other reviewers as well), we agree to merge them to RC2 and release it
17:52:46 <sergmelikyan> *for all of the mentioned issues
17:53:16 <slagun> I'm going to commit them to master first and then we decide if we are going ti cherry-pick them to stable/kilo if you don't mind
17:53:50 <ruhe> deal
17:54:07 <katyafervent2> ok
17:54:32 <sergmelikyan> slagun, better to propose them to stable/kilo first
17:54:50 <sergmelikyan> will save time, testing phase will be same regardless of the branch
17:56:36 <slagun> ok
17:57:30 <sergmelikyan> #topic Summit Etherpads
17:57:52 <sergmelikyan> #action sergmelikyan create etherpad for summit topics
17:58:03 <sergmelikyan> We are little bit late on this task, mea culpa
17:58:07 <sergmelikyan> I will do that ASAP
17:58:15 <sergmelikyan> #topic Open Discussion
17:58:38 * sergmelikyan changed topic in rush to avoid throwing eggs phase :)
17:58:59 <sergmelikyan> Few minutes to bring topics that we will discuss in #murano
18:00:19 <ruhe> time's up
18:00:50 <sergmelikyan> #endmeeting