17:00:01 <serg_melikyan> #startmeeting murano
17:00:02 <openstack> Meeting started Tue Jul 29 17:00:01 2014 UTC and is due to finish in 60 minutes.  The chair is serg_melikyan. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:05 <openstack> The meeting name has been set to 'murano'
17:00:16 <serg_melikyan> o/
17:00:25 <serg_melikyan> Hi :)
17:00:37 <IgorYozhikov> hi
17:01:19 <serg_melikyan> Agenda for today's meeting is available here: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:01:42 <dteselkin_> Hi
17:01:51 <gokrokve> Hi
17:02:07 <serg_melikyan> Let's start as usual with AI review :)
17:02:15 <serg_melikyan> #topic Action Items Review
17:02:25 <tsufiev> hi
17:02:34 <smurashov_> hi
17:02:42 <serg_melikyan> katyafervent, tsufiev first action item is on you :)
17:02:49 <tsufiev> oops
17:02:56 <serg_melikyan> "update etherpad with results of our investigations about unit and integration tests in Horizon/Muranodashboard"
17:03:04 <serg_melikyan> Any news since last week?
17:03:20 <katyafervent> hi
17:03:32 * tsufiev is ashamed
17:04:02 <serg_melikyan> I assume that there are no news about this AI?
17:04:11 <serg_melikyan> :)
17:04:33 <tsufiev> serg_melikyan, I think there should be one person responsible :)
17:05:03 <serg_melikyan> katyafervent: had you time to update etherpad with results of investigations?
17:06:28 <katyafervent> No, I don't know what else to investigate
17:06:48 <serg_melikyan> katyafervent: so all results are already published?
17:06:48 <ruhe_> i think its alrwady in progress
17:07:21 <ruhe_> katyafervent is moving dashboard tests to work inside devstack
17:07:26 <katyafervent> I'm searching for etherpad
17:07:39 <serg_melikyan> katyafervent: thx!
17:07:53 <serg_melikyan> Then let's to move to another AI
17:08:19 <serg_melikyan> sjmc7: "Get more details on Apps Licencing from HP side"
17:08:34 <sjmc7> what ryan already did is fine for this for now
17:08:46 <serg_melikyan> I think patch from drupalmonkey is already merged :)
17:08:49 <sjmc7> yeah
17:08:52 <drupalmonkey> yep
17:08:55 <serg_melikyan> :)
17:08:56 <sjmc7> we'll revisit if and when proper licensing comes up
17:09:05 <serg_melikyan> sjmc7: ok, thx
17:09:32 <serg_melikyan> Looks like this is all on AI Review topic
17:09:44 <serg_melikyan> Did I miss somethings?
17:10:25 <serg_melikyan> #topic Announcements
17:10:47 <serg_melikyan> #info murano-apps project is created
17:11:02 <katyafervent> https://etherpad.openstack.org/p/horizon_unit_tests_analysis here it is, but there is no any update
17:11:09 <gokrokve> Cool. Does it have gerrit?
17:11:15 <serg_melikyan> gokrokve: sure
17:11:44 <serg_melikyan> This repository is intended as storage for applications that may serve as example for community
17:12:56 <ruhe_> yes, i wouldnt like to see our complex examples. theyre too scary for newcomers
17:13:23 <serg_melikyan> I agree with ruhe that we need to start filling-in this repo with examples based on SoftwareConfiguration, with Hot Packages and so on.
17:13:32 <gokrokve> https://github.com/murano-project/murano-app-incubator/tree/master/io.murano.apps.java.HelloWorldCluster
17:13:36 <gokrokve> How about that?
17:13:43 <gokrokve> Just added this night.
17:14:01 <gokrokve> Can use both single instance Tomcat and Tomcat Cluster with LB
17:14:49 <gokrokve> New Tomcats are added too
17:14:52 <serg_melikyan> gokrokve: cool! I think this one will eventually end-up in murano-apps :) But you need to make change to Gerrit
17:15:02 <ruhe_> gokrokve  thats an example of a complex package
17:15:10 <stan_lagun> SoftwareCongiguration doesn't make applications simpler by itself. It just a replacement for MuranoAgent which is rarely a reason for complexity
17:15:36 <serg_melikyan> stan_lagun: agree, but SoftwareConfiguration has much more demand for now
17:15:49 <stan_lagun> I don't say not to use it
17:16:23 <serg_melikyan> I will write-up a little email to mailing-list tomorrow about this repository and our plans
17:16:27 <gokrokve> As I heard there is an issue with SoftwareConfigs
17:16:36 <gokrokve> they are executed on each stack update
17:16:48 <serg_melikyan> #action sergmelikyan need to write-up a little email to mailing-list tomorrow about this repository and our plans
17:16:55 <stan_lagun> But having lots of simple applications won't help anyone as most real life applications are complex and the person who tries to write such application will have no proper example
17:17:27 <gokrokve> Agree. That is why we have examples with inheritance and multiple selections
17:17:30 <sjmc7> then we can add a proper, well documented example
17:17:34 <btully> i agree that a mix of simple to complex would be ideal
17:17:38 <sjmc7> but we need short introduction ones
17:17:52 <gokrokve> +1
17:17:54 <sjmc7> that teach concepts
17:17:56 <stan_lagun> lets rate them
17:18:04 <gokrokve> I think the best candidates are databases
17:18:13 <stan_lagun> as for books. Intended reader level
17:18:18 <gokrokve> MariaDB, MySQL, PostreSQL, Mongo
17:18:18 <serg_melikyan> eventually this repository will be filled with all sorts of applications, but we need to always mind that application in murano-apps are public examples about how to create application in particular case. Starting from apps focused on SoftwareConfig is logical
17:18:48 <ruhe_> sergmelikyan, +1
17:18:49 <gokrokve> Sure. DBs are godd candidates as they usually require less steps for installation
17:19:16 <btully> agreed, teaching concepts is crucial. i think that should be the primary focus vs # of steps
17:19:28 <stan_lagun> if gokrokve is right about configs being reaplied on each update this would mean they are still useless in Heat
17:19:28 <serg_melikyan> Looks like we are on the same wave here :)
17:19:47 <serg_melikyan> Let's move to the next topic
17:19:59 <serg_melikyan> #topic Plans for Juno
17:20:22 * serg_melikyan meen juno-3
17:21:14 <serg_melikyan> part of blueprints that were approved for J2 but not finished were moved to j3
17:21:46 <serg_melikyan> let's go through blueprints mentioned in agenda
17:21:59 <serg_melikyan> 1)https://blueprints.launchpad.net/murano/+spec/disable-murano-agent
17:22:13 <sjmc7> there's a patch in review
17:22:26 <serg_melikyan> sjmc7: thank you!
17:23:07 <serg_melikyan> And since we agreed on implementation this BP may be approved, right?
17:23:19 <sjmc7> i think it got agreed upon previously
17:23:19 <ruhe_> i guess we can mark this as approved
17:23:21 <serg_melikyan> any objections?
17:23:43 <serg_melikyan> sjmc7: yeah, but BP in LP was not marked so, I don't know why
17:23:52 <serg_melikyan> done
17:24:15 <serg_melikyan> 2)  https://blueprints.launchpad.net/murano/+spec/engine-test-based-on-murano-pythonclient
17:25:16 <stan_lagun> Why need to disable Agent? You can just use images without Agent
17:25:28 <serg_melikyan> I think this is really useful thing, but which implementation scenarios we are going to choose?
17:25:54 <serg_melikyan> stan_lagun: where you have been when we discussed this BP? :)
17:26:13 <sjmc7> yes, you can, and then it fails to deploy without any message
17:26:15 <stan_lagun> for 1 minute?
17:26:27 <serg_melikyan> stan_lagun: nope, this this was discussed for weeks
17:26:38 <sjmc7> this isn't the first discussion of it. it's optional, doesn't require any action to leave it enabled
17:26:39 <stan_lagun> If you disable agent you are not supposed to use agent-based apps anyway
17:27:18 <serg_melikyan> stan_lagun: this is idea
17:27:25 <sjmc7> let's re-discuss this later if need be
17:27:33 <serg_melikyan> sjmc7: +100
17:27:38 <ruhe_> its a feature request for deployments where agent is not usable at all
17:27:42 <serg_melikyan> what about second one?
17:27:57 <serg_melikyan> I mean second link that I have shared: https://blueprints.launchpad.net/murano/+spec/engine-test-based-on-murano-pythonclient
17:28:01 <smurashov_> if we make murano engine tests inhereted from tempest scenarios, we complicate murano-ci
17:28:47 <smurashov_> we will need to clone tempest, and configure it
17:29:12 <serg_melikyan> But eventually we can run some set of tests on OpenStack CI?
17:29:33 <serg_melikyan> (for example without deployment)
17:29:41 <serg_melikyan> or with faked one
17:30:14 <smurashov_> all engine tests with deployment
17:30:18 <smurashov_> isn't it?
17:30:52 <serg_melikyan> I think I like the idea, but we need to discuss implementation more.
17:30:57 <serg_melikyan> any objections?
17:31:18 <ruhe_> i expect our tests to run in a limited devstack env, where murano, dashboard and tempest are installed via devstack and the rest is used from a stable cloud installation
17:31:43 <ruhe_> but that's future
17:31:43 <smurashov_> +
17:32:24 <serg_melikyan> ruhe_: I think we definitely need this feature, and I have already marked Direction as Approved. But let's discuss this thing a little bit more
17:32:54 <serg_melikyan> 3) https://blueprints.launchpad.net/murano/+spec/muano-api-exception-handling
17:33:12 <serg_melikyan> First of all, we need to fix URI for this BP :)
17:33:19 <serg_melikyan> katyafervent: :)
17:33:55 <serg_melikyan> https://blueprints.launchpad.net/murano/+spec/murano-api-exception-handling
17:34:05 <serg_melikyan> sjmc7: I think you had some BP/Bug related to this?
17:34:23 <sjmc7> i think it's been gradually improving
17:34:27 <katyafervent> https://bugs.launchpad.net/murano/+bug/1328662
17:34:28 <uvirtbot> Launchpad bug 1328662 in murano "[api] Should return JSON/XML error response bodies" [High,Confirmed]
17:34:31 <sjmc7> there are a number of bugs/blueprints, will keep working on it
17:34:38 <sjmc7> stan's improvements have helped too
17:34:38 <katyafervent> Here it is
17:35:16 <katyafervent> But murano-api still have no special exception handing
17:36:11 <katyafervent> or similar blueprint is already exist?
17:36:16 <ruhe_> i've stated my -1 on teh whiteboard
17:36:33 <serg_melikyan> "[ruhe] +1 for idea, -1 for spec. needs more details - you need to be more explicit, you can even list exceptions you'd like to declare in murano codebase"
17:36:37 <serg_melikyan> (c)
17:36:41 <serg_melikyan> ruhe_: +1
17:37:10 <serg_melikyan> We can assign this issue with j3, and katyafervent would update description
17:37:42 <katyafervent> Ok
17:37:52 <serg_melikyan> any objections? BP would be approved after description will be updated
17:37:58 <ruhe_> yep, definitely needs more work and unputs
17:38:26 <serg_melikyan> 4) https://blueprints.launchpad.net/murano/+spec/support-keystone-v3
17:38:39 <sjmc7> i think this was approved already
17:38:46 <sjmc7> i'm going to try to work on it in the next couple of weeks
17:39:22 <sjmc7> oh.. there was one other that i just remembered
17:39:29 <serg_melikyan> This one is a one of the major features in J3, Direction is Approved but Definition is Discussing.
17:39:31 <sjmc7> about more efficiently retrieving packages during deployment
17:39:46 <katyafervent> #action katyafervent Extend the description of https://blueprints.launchpad.net/murano/+spec/murano-api-exception-handling
17:40:07 <sjmc7> oops, sorry. regarding keystone - i haven't had a chance to look at it yet, but i think it's straightfoward
17:40:15 <sjmc7> most of the other openstack services support v3 already
17:40:50 <serg_melikyan> sjmc7: agree with you. I don't think that we need additional discussion on this
17:41:00 <serg_melikyan> any objections? ruhe_ ?
17:41:31 <ruhe_> approve it! :)
17:41:35 <serg_melikyan> done :)
17:41:56 <serg_melikyan> sjmc7: yeah, issue with package caching is very important...
17:42:02 * serg_melikyan searching for the link
17:43:05 <serg_melikyan> https://bugs.launchpad.net/murano/+bug/1334352
17:43:08 <uvirtbot> Launchpad bug 1334352 in murano "package loading makes repeat API calls" [High,Confirmed]
17:43:32 <ruhe_> thats actually the biggest one
17:43:35 <serg_melikyan> Assigned for j3 and raised priority
17:45:05 <serg_melikyan> sjmc7: you agree with this? :)
17:45:11 <sjmc7> yeah, i think it's pretty important
17:45:21 <serg_melikyan> Ok
17:46:33 <serg_melikyan> all, https://launchpad.net/murano/+milestone/juno-3 - please, take a look, do we miss some important BP that is not listed, but you do like to see it here?
17:46:54 <sjmc7> i took a quick look earlier
17:47:03 <sjmc7> nothing else caught my eye
17:47:52 <serg_melikyan> Than this is all for plans for Juno 3 :)
17:48:03 <serg_melikyan> #topic Open Discussion
17:49:17 <katyafervent> https://blueprints.launchpad.net/murano/+spec/dynamic-ui-specify-no-explicit-name-field
17:49:33 <katyafervent> What about this blueprint? will we continue to discuss it?
17:51:10 <serg_melikyan> This one is approved in direction, and I have no objections about implementation details.
17:52:29 <tsufiev> serg_melikyan, there were some concerns from sjmc7 IIRC
17:53:02 <sjmc7> not particularly. it just seems a bit unclean
17:53:15 <sjmc7> i don't understand the issue enough to complain one way or the other
17:54:11 <serg_melikyan> I am not sure that we should do this BP in J3, though
17:54:19 <tsufiev> sjmc7, could you please specify how the description should be extended to make it more clean?
17:54:48 <tsufiev> sjmc7, I mean, which part - dashboard/dynamic_ui/engine should be clarified?
17:55:03 <sjmc7> split it up into paragraphs; exlpain exactly why something fields are going directly from the ui to the engine
17:57:45 <tsufiev> sjmc7, have split it into paragraphs. I think stan_lagun could provide more exact info on the lifecycle of object model once it left muranodashboard and entered murano-api
17:57:48 <katyafervent> https://github.com/murano-project/murano-app-incubator/blob/master/io.murano.apps.linux.Telnet/UI/telnet.yaml#L13
17:57:54 <katyafervent> this part
17:58:43 <serg_melikyan> we are running out of the time, let's move discussion to #murano.
17:59:00 <serg_melikyan> #endmeeting