17:07:36 <tsufiev> #startmeeting murano
17:07:37 <openstack> Meeting started Tue Jul 22 17:07:36 2014 UTC and is due to finish in 60 minutes.  The chair is tsufiev. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:07:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:07:40 <openstack> The meeting name has been set to 'murano'
17:07:48 <tsufiev> hi all!
17:07:54 <ankurrr> hello
17:08:18 <slagun> hi
17:08:19 <dteselkin> Hi
17:08:25 <katyafervent2> hi
17:08:36 <tsufiev> seems all people that usually drive this meeting are flying on the plane (ruhe) or PTO (smelikyan)
17:09:19 <tsufiev> lets start with agenda https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:09:50 <tsufiev> #topic AI review
17:10:17 <tsufiev> [katyafervent & tsufiev] Provide an update on horizon/dashboard/selenium tests research
17:10:34 <katyafervent2> I have no update on that topic
17:10:34 <tsufiev> I didn't do it :(
17:10:56 <katyafervent2> I guess we should try to run our tests on devstack and it should work
17:11:12 <katyafervent2> and horizon guys will review our selenium tests :)
17:11:42 <tsufiev> katyafervent, I remember ruhe asked us to create an etherpad with results of our investigations about unit and integration tests in Horizon/Muranodashboard
17:12:19 <katyafervent2> we do have an etherpad, but there are no updates there
17:12:29 <tsufiev> katyafervent, could you provide a link?
17:13:20 <katyafervent2> it should be in the previous meeting history, sorry I can't provide it right now
17:14:00 <katyafervent2> I suggest to move on
17:14:01 <tsufiev> ok
17:14:39 <tsufiev> #action tsufiev/katyafervent2 update etherpad with results of our investigations about unit and integration tests in Horizon/Muranodashboard
17:14:51 <tsufiev> #topic Discuss approval of https://blueprints.launchpad.net/murano/+spec/support-keystone-v3
17:15:05 <sjmc7> that's me!
17:15:10 <tsufiev> sjmc7, yep :)
17:15:30 <sjmc7> i have not got much further with it, but our keystone team has agreed to help me with it
17:15:49 <sjmc7> so i'm hoping to get that done in our coming sprint (over the next two weeks)
17:16:26 <tsufiev> any objections?
17:17:15 <katyafervent2> no
17:17:23 <tsufiev> sjmc7, I suspect that BP's approval should be delayed until next time when ruhe appears online
17:17:30 <sjmc7> sure
17:17:53 <tsufiev> ok
17:18:01 <tsufiev> sjmc7, next one is also yours
17:18:09 <tsufiev> #topic Update on trusts
17:18:43 <sjmc7> i don't have much of an update. i think the approach i put in the BP should work, but i haven't had a chance to try to implement a proof of concept it yet
17:20:20 <tsufiev> sjmc7, I remember that Sahara guys and possibly Mistral had used trusts in their projects
17:20:34 <sjmc7> yep. heat too
17:20:59 <sjmc7> i'll take a look at those projects
17:22:49 <tsufiev> sjmc7, ok, if you have any difficulties, we could ask them directly
17:22:56 <sjmc7> sure
17:23:00 <tsufiev> let's move on
17:23:26 <tsufiev> #topic Discuss approval of https://blueprints.launchpad.net/murano/+spec/support-keystone-v3
17:23:43 <tsufiev> sorry
17:23:48 <tsufiev> #topic Discuss https://blueprints.launchpad.net/murano/+spec/application-license-tab
17:24:08 <sjmc7> let me get ryan
17:25:27 <sjmc7> drupalmonkey, this one's you
17:25:34 <sjmc7> application license tab
17:26:44 <slagun> It seems reasonable to have license as part of package manifest, not UI form
17:27:35 <drupalmonkey> slagun: if you want a checkbox for people to agree to the license terms though, would need to be in the UI yaml
17:27:43 <tsufiev> drupalmonkey, the problem with license embedded into Add Application wizard's description section (right side of the form) is that usually License is quite large
17:28:44 <tsufiev> It fits well into TextArea widget, otherwise form will be too tall
17:28:59 <slagun> drupalmonkey: If BP is about checkbox then why ut contains YAML definition?
17:29:26 <slagun> I think license details and tracking of license agreements is 2 separate BPs
17:29:36 <drupalmonkey> i added a couple lines for formatting here: https://review.openstack.org/#/c/108473/2/muranodashboard/templates/services/_wizard_create.html
17:29:49 <drupalmonkey> so if you have a lot of text you don't end up with a huge modal window
17:29:53 <drupalmonkey> becomes scrollable
17:30:42 <sjmc7> ultimately i think licensing needs a larger amount of work to do properly (allow licenses to be bought, or tracked per seat or something)
17:30:51 <tsufiev> gokrokve, we're still discussing License & Requirements tabs
17:31:01 <gokrokve> hi
17:31:05 <sjmc7> but for now we just need to be able to say that the user read a EULA
17:31:33 <gokrokve> sjmc7: I think this is enough for the current release. Just display the EULA and show a checkobox.
17:31:44 <sjmc7> ok. i agree that it's not the best longer term solution
17:32:17 <gokrokve> Do you need to track EULA agreement signatures?
17:32:24 <slagun> Is it urgent? If yes, lets make it a part of UI form. If not lets extend API with ability to request manifest info and have license text be stored in manifest + extra API to track user agreement
17:32:27 <tsufiev> drupalmonkey, I'll look at this BP's reviews in a short time
17:32:48 <gokrokve> slagun: I think we have license part in manifest.
17:32:52 <sjmc7> i don't think so, gokrokve. we just need to demonstrate that we've displayed it to the user
17:33:08 <gokrokve> sjmc7: Ok. It is pretty easy to implement.
17:33:23 <sjmc7> gokrokve - yeah, ryan's already submitted a patch
17:33:35 <slagun> gokrokve: even if we have we probably need to expand it. And most important make it accessible to dashboard
17:33:38 <sjmc7> slagun - it's urgent in the sense that we can't package some things without it
17:33:40 <gokrokve> sjmc7: Cool. Then lets review it and merge
17:34:04 <sjmc7> but ryan's work doesn't integrate with the license tab, just the deployment flow (since that's where we need to confirmation)
17:35:24 <slagun> I mean is it so urgent that we don't have time to implement it right way?
17:35:29 <gokrokve> sjmc7: I think we can do this on UI side. Just do not enable deploy button if EULA is not checked.
17:36:03 <tsufiev> sjmc7, gokrokve: if we have some further plans for those 2 tabs, perhaps we could leave them as is for now together with merging Ryan's work?
17:36:10 <sjmc7> ryan's patch just lets us add it as a UI input
17:36:13 <gokrokve> slagun: I think this is one of the requirement in HP. They should follow some legal reqirements if they expose soft to clients
17:36:51 <slagun> gokrokve: I understand. But maybe we can implement it better even if it takes some more time
17:36:59 <gokrokve> tsufiev: There is no anythinh urgent from our side for these tabs. So we can focus on HP requirements for them
17:37:02 <sjmc7> slagun - we can spend some time on doing it right, but deciding on 'right' and implementing it is not a quick process
17:37:11 <tsufiev> i mean, leave as is for J2, make constistent in J3
17:37:25 <sjmc7> i need to discuss it more with our product and legal people
17:37:29 <gokrokve> sjmc7: Agree. There is no specific requirements set form our side.
17:38:34 <gokrokve> EULA is mandatory for customer facing stuff. So I would rather merge Ryan's fix + add deploy button disable. We don't need to do anything on API and Engine part for that.
17:38:55 <slagun> It looks inconsistent that we can deploy anything from CLI/pythonclient without accepting EULA
17:39:16 <sjmc7> slagun - yes, i agree
17:39:38 <sjmc7> we will not be encouraging people to deploy from the CLI though, because it's really difficult
17:40:01 <sjmc7> ultimately we can't stop someone installing it themselves anyway since it's a glance image
17:40:08 <gokrokve> Agree. UI is 95% of all use cases for now.
17:40:18 <gokrokve> We can add this to CLI and API later.
17:40:26 <slagun> sjmc7: I accept is as a temporary solution. As soon as we all agree that it is temporary :)
17:41:10 <tsufiev> ok. seems like we more-or-less agreed
17:41:48 <slagun> because the intention was to freeze current UI forms format. It needs complete rework to supplement MuranoPL contracts, not to duplicate them
17:41:54 <gokrokve> +1. Lets do a quick fix to satisfy minimal legal requirements and lets file a new bug or BP to track activities with further fix in this area.
17:42:00 <tsufiev> sjmc7, I'll add an action for you to get more details from product and legal people
17:43:54 <tsufiev> #action [sjmc7] Get more details on Apps Licencing from HP side; others are encouraged to review Ryan's commits on https://blueprints.launchpad.net/murano/+spec/application-license-tab
17:44:32 <tsufiev> #topic J2 release
17:45:01 <tsufiev> https://launchpad.net/murano/+milestone/juno-2
17:45:50 <sjmc7> autho/supplier is done
17:46:09 <sjmc7> ah, sorry, already marked 'implemented
17:46:15 <tsufiev> katyafervent, speaking of https://blueprints.launchpad.net/murano/+spec/divide-upload-package-into-two-steps I've almost finished with the infrastructure you need: https://review.openstack.org/#/c/107769/
17:46:29 <katyafervent2> tsufiev:cool
17:46:42 <sjmc7> looks like we need some bug fixing
17:46:55 <katyafervent2> Most of this blueprint is done
17:47:08 <katyafervent2> sjmc7:right
17:47:37 <tsufiev> katyafervent, it still requires one more patchset, but you can already base your work on current state
17:49:54 <tsufiev> 1 Critical confirmed, 3 High in progress
17:52:18 <tsufiev> bug scrub/bug squash?
17:53:24 <tsufiev> here is a bug list prioritized: https://bugs.launchpad.net/murano/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&fiel
17:53:24 <tsufiev> d.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
17:54:10 <tsufiev> ok, we all agree that bugfixing is important and will do it ASAP :)
17:54:20 <tsufiev> moving on...
17:54:31 <tsufiev> #topic https://bugs.launchpad.net/murano/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&field.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.h
17:54:31 <tsufiev> as_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
17:54:44 <tsufiev> #topic [sjmc7] - Image tagging (http://lists.openstack.org/pipermail/openstack-dev/2014-July/040673.html) - whether there's anything we can do short term to make this more flexible
17:55:43 <tsufiev> sorry again for wrong link, hard to forget Linux shortcuts in Windows
17:55:43 <sjmc7> yeah.. there are obviously lots of things that could be handled in the contract stuff
17:56:10 <sjmc7> but i think just in the short term, having a list of tags defined in the UI code leads to problems
17:56:54 <sjmc7> i don't really have a big problem with using glance metadata to tag images, just that a static list like that is difficult. it almost seems better just to allow freeform tags
17:58:05 <slagun> the purpose of current tagging is to filter images. If app requires Linux it should not have an option to select Windows
17:58:19 <slagun> sjmc7: have you read my response in ML?
17:58:24 <sjmc7> yeah
17:58:50 <slagun> I think ML is a good place to discuss it
17:59:21 <sjmc7> ok. but as things are, we will need to tag things with the glance CLI
17:59:32 <tsufiev> agree on ML, especially we're running out of time here
17:59:47 <gokrokve> +1 for good and flexible image tags
17:59:48 <slagun> I agree on free-form tagging as long as this consistent with filtering and future plans
18:00:19 <slagun> there are tagging for the machine and tagging for the user
18:00:29 <sjmc7> yeah. i'll reply in the ML, you're right
18:00:42 <tsufiev> #topic Open Discussion
18:00:49 <sjmc7> we're out of time
18:00:55 <tsufiev> setting this only to copy-paste ruhe words
18:00:57 <tsufiev> [ruhe] reviewers, please make sure linked blueprints are approved and have all the required fields filled before you set +1/+2/approved on a patch. I found multiple instances of almost empty blueprints with merged patches. That doesn't help to track changes we have in the project.
18:01:07 <tsufiev> so, please keep that in mind :)
18:01:14 <sjmc7> yeah, we need to keep on top of that better
18:01:31 <tsufiev> #endmeeting