17:02:31 <ruhe> #startmeeting murano
17:02:32 <openstack> Meeting started Tue Jun 10 17:02:31 2014 UTC and is due to finish in 60 minutes.  The chair is ruhe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:33 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:35 <openstack> The meeting name has been set to 'murano'
17:02:42 <ativelkov_mobile> Will join you in ~ 5 mins
17:03:04 <ruhe> sorry, i didn't update the agenda
17:03:08 <tsufiev> hi there
17:03:12 <dteselkin> Hi
17:03:36 <ruhe> we definetely need to discuss status of J1
17:03:45 <ruhe> what other topics we should discuss today?
17:04:01 <slagun> hi
17:04:27 <katyafervent> hi What the blueprints have the most priority
17:04:42 <sjmc7> we have a number of open bugs we should try to reduce
17:05:29 <ruhe> ok. let's start with topic "status of J1" and cover blueprints, and pending reviews, and open bugs
17:05:40 <ruhe> #topic status of juno-1
17:05:52 <btully> I'd like to discuss the app catalog index, specifically the "Latest Apps" section and get some clarification on what that section is supposed to do. Possibly renaming it, etx
17:05:55 <btully> etc
17:05:57 <ruhe> #link https://launchpad.net/murano/+milestone/juno-1
17:06:15 <ruhe> btully: ok. will trigger this topic also
17:06:38 <ruhe> it's just two days before we cut the development milestone j1
17:06:52 <ruhe> there are several BPs which aren't even started
17:07:05 <tsufiev> seems that they should be moved to j2
17:07:31 <ruhe> tsufiev: yep
17:07:35 <btully> there is one of mine that is set to "Not started" but it's actually not the case
17:07:39 <ativelkov> o/
17:07:50 <ruhe> let's just make sure that these BPs are really "not started"
17:07:51 <btully> if you recall I was asked to split up my original blueprint into several
17:07:54 <ruhe> ativelkov: hey
17:07:59 <serg_melikyan> o/
17:08:12 <btully> however in doing my dev work, it really doesn't make sense to split them up since they are dependent
17:08:17 <ativelkov> sorry for being late folk: Moscow traffic becomes twice as slow when it starts rainign
17:08:30 <ruhe> btully: can you give us a link? i'll clear the milestone from it
17:08:38 <tsufiev> ativelkov, lifehack = subway ;)
17:08:41 <ruhe> is Ryan here?
17:08:59 <ruhe> sjmc7: should i move https://blueprints.launchpad.net/murano/+spec/additional-author-information to J2?
17:09:28 <btully> https://blueprints.launchpad.net/murano/+spec/murano-ui-horizon-patterns
17:09:28 <sjmc7> ruhe - we're trying to finish it
17:09:34 <sjmc7> it's in progress
17:09:43 <ankurrr> yeah, in progress
17:10:03 <ruhe> sjmc7: ok, can you please update the status? or should i do that?
17:10:08 <sjmc7> i'll do it
17:10:15 <ruhe> sjmc7: thanks
17:10:27 <btully> is the original blueprint with the dependencies. however the dependencies I feel should not be broken up as separate blueprints and instead should be committed on the same bp branch
17:11:26 <ruhe> btully: i don't have any problem with that. if you feel that it would be the right approach, then just do so
17:11:33 <btully> super. thanks!
17:11:53 <btully> so i'll set the above link milestone to j1
17:12:09 <ruhe> btully: does that mean, that we can clear all its child BPs?
17:12:41 <tsufiev> btully, do you mean it'll be ready on June 12, which is a cut for J1?
17:12:57 <tsufiev> it is pretty soon
17:13:01 <btully> i'd have to look at each one and make sure the info is contained in the parent BP
17:13:14 <btully> that was the other q we had
17:13:28 <btully> given the deadline of 6/12 and our time differences
17:13:41 <btully> do we have a cutoff time for commits?
17:14:23 <btully> could use some clarification on that
17:15:14 <tsufiev> we have 2 days as an average approve time for UI commits (don't ask me how I calculate it)
17:15:35 <btully> ok, good to know
17:15:36 <tsufiev> so it means that all blueprints not yet committed won't make it for J1
17:15:38 <ruhe> if we were an integrated project we would already block all the changes. and we definetely should do so. but in J1 it seems that we'll have just one day June12. also, i can do the release on June13 (by my local time) which will be late evening of June12 in US
17:15:53 <btully> so if I have something to commit in a few hours will it make it in?
17:16:03 <tsufiev> ruhe, agree, no need to be paranoid :)
17:16:09 <ativelkov> Should be fine, yes
17:16:20 <tsufiev> btully, absolutely
17:16:22 <ruhe> btully: yes it will. also you'll have all day tomorrow
17:16:26 <sjmc7> we can try and review stuff more aggressively today and tomorrow
17:16:40 <btully> but there's a 2 day approve time, no?
17:16:52 <btully> so for a release on the 12th, commits should be in by the 10th?
17:16:54 <sjmc7> btully - only by tradition
17:16:58 <sjmc7> it's not a rule
17:16:59 <ativelkov> it is an average, there is not rule %)
17:17:13 <ativelkov> we just have a large backlog of commits waiting for approval
17:17:15 <tsufiev> btully, that is true for complicated changes, but for simple changes it can be less
17:17:19 <ativelkov> and we may use some help here
17:17:19 <btully> k
17:17:47 <sjmc7> ativelkov - let's talk about reviews later and go through the remaining BPs
17:17:51 <ruhe> let's move on
17:18:04 <ruhe> slagun: what about https://blueprints.launchpad.net/murano/+spec/throw-correct-exception ?
17:18:28 <ruhe> ah, again and again i ask you about this superseded BP :)
17:18:36 <sjmc7> :)
17:18:52 <ruhe> i've just cleared milestone target
17:18:58 <slagun> ruhe, I don't know why it is marked ad complete. It is not
17:19:05 <tsufiev> ruhe, how do you order BPs?
17:19:16 <ruhe> tsufiev: i just opened https://launchpad.net/murano/+milestone/juno-1
17:19:19 <slagun> I'd like to move it to j2 actually
17:19:33 <ruhe> tsufiev: and i check those which look scary
17:19:55 <tsufiev> ruhe, got it
17:19:58 <ruhe> slagun: please update the BP
17:20:08 <gokrokve_> I just want to make sure that we have actions in j1
17:20:26 <gokrokve_> there are customers who want this feature for autoscaling
17:20:31 <tsufiev> gokrokve_, it will be hard for the UI part
17:20:45 <ruhe> UI will not make it into j1
17:20:53 <gokrokve_> tsufiev: what are the problems? How can I help?
17:21:01 <ruhe> gokrokve_: we'll get back to the action a little bit ealier
17:21:03 <ruhe> * later
17:21:13 <gokrokve_> what is the minimal functionality we can expose in UI?
17:21:14 <gokrokve_> ok
17:21:20 <slagun> ruhe, it is superseded by bug. But launchpad can mark BP as being superseded only by another BP
17:21:35 <ruhe> ativelkov: https://blueprints.launchpad.net/murano/+spec/murano-cli-client can you move this one to J2?
17:21:46 <sjmc7> i can help with that one ruhe/ativlekov
17:22:04 <ativelkov> ruhe: done
17:22:12 <ativelkov> I am sure katyafervent is working on it right now
17:22:16 <sjmc7> ah, ok
17:22:22 <sjmc7> i'll leave it alone then :)
17:22:28 <katyafervent> yeap, almost ready
17:22:49 <ativelkov> We need a proper manifest generation for MuranoPL-based packages - that is the trickier part
17:23:05 <ativelkov> But I am sure Kate will do it the right way
17:23:11 <ruhe> the next big one is https://blueprints.launchpad.net/murano/+spec/online-app-repository by iyozhikov
17:23:12 <ativelkov> I've moved the BP to j2 just in case
17:23:33 <gokrokve_> +1 to move it to j2
17:23:39 <gokrokve_> it is not urgent
17:23:55 <ruhe> i've updated status of https://blueprints.launchpad.net/murano/+spec/online-app-repository to "Needs code review"
17:24:19 <ativelkov> gokrokve_: its kinda urgent, as we've announced hot auto importing as a feature, and it requires package-create command
17:24:33 <gokrokve_> ok
17:24:44 <ativelkov> But it's ok to be a little late with it, rather then do it wrong
17:24:46 <ruhe> also, i've just updated status of https://blueprints.launchpad.net/murano/+spec/filter-flavor-for-each-service to "Implemented"
17:24:57 <ativelkov> I wanted to discuss this a little
17:25:15 <ruhe> ativelkov: which one do you want to discuss?
17:25:25 <ativelkov> filter-flavor-for-each-service
17:25:42 <ativelkov> I've written an email to ML about it, but havn't got any response
17:26:29 <ruhe> ativelkov: you can bug those who filed and worked on this BP in person and make sure they respond in ML :)
17:26:52 <ativelkov> Well, it is more general question actually
17:26:59 <sjmc7> ativelkov, we did discuss this before a bit
17:27:07 <sjmc7> that it should be at the API level
17:27:16 <sjmc7> or rather, the constraint level
17:27:28 <sjmc7> but that that was going to be a much bigger piece of work
17:27:50 <ativelkov> Right
17:28:03 <sjmc7> apologies for not replying, i meant to yesterday
17:28:08 <ativelkov> So, I just want to make sure that we are on a common ground here
17:28:13 <sjmc7> but i agree there's more needs doing there
17:28:27 <ativelkov> Great
17:29:07 <ruhe> ativelkov: sjmc7: can we move to the next BP?
17:29:17 <sjmc7> yep
17:29:33 <ruhe> the next one is https://blueprints.launchpad.net/murano/+spec/improve-engine-logging by sjmc7
17:29:42 <ruhe> it's in "Started" state
17:29:58 <sjmc7> yeah.. this is still sort of an ongoing one
17:30:10 <sjmc7> related to the exception BP you mentioned a few minutes ago, and some others
17:30:27 <sjmc7> i think we should probably close this BP in favor of more specific ones
17:30:50 <sjmc7> i still think improving error reporting is very important
17:31:10 <ruhe> so, just mark this one as "Implemented" with a note that remaining work will be tracked in separate BPs?
17:31:16 <sjmc7> yeah - i can do that
17:31:22 <ruhe> thank you
17:31:33 <ativelkov> I would prefer a set of logging functions to be added to the Core MuranoPL lib
17:31:57 <ativelkov> (as an example of separate BP)
17:32:00 <ruhe> i suggest everyone to refresh page with https://launchpad.net/murano/+milestone/juno-1
17:32:14 <ruhe> now it looks much better
17:32:17 <sjmc7> :)
17:32:21 <slagun> engine logging will be greatly improved after we merge https://review.openstack.org/#/c/98984/
17:32:26 <sjmc7> you shou;d've been an accountant
17:32:51 <ruhe> sjmc7: i'd prefer to be an astronaut instead of accountant
17:33:04 <sjmc7> :)
17:33:09 <ruhe> and now we have a clear list of things which we should review first
17:33:51 <ruhe> i suggest to move to the next topic "Bugs"
17:33:53 <tsufiev> ruhe, speaking of https://blueprints.launchpad.net/murano/+spec/normalize-dashboard-pagination ...
17:34:01 <ruhe> tsufiev: yes...
17:34:32 <tsufiev> it was originally in Implemented state, but then an idea has come to provide 'Previous' button
17:34:55 <tsufiev> I'd like to implement that idea in scope of that blueprint
17:35:09 <tsufiev> (to not create 3 blueprints for one topic)
17:35:26 <tsufiev> hope I'll do it tomorrow
17:35:49 <ruhe> tsufiev: ok, good
17:36:09 <ruhe> #topic bugs
17:36:25 <ruhe> now the list of BPs look good at https://launchpad.net/murano/+milestone/juno-1
17:36:30 <ruhe> but the list of bugs looks scary
17:36:55 <ruhe> sjmc7 started mini-triage day just an hour ago
17:37:11 <sjmc7> :)
17:37:16 <sjmc7> a meeting got cancelled
17:37:17 <christopheraedo> see if you can get it from here: https://drive.google.com/file/d/0B2hdAztV6b1IdE9GX21tbDhoX0U/edit?usp=sharing
17:37:22 <sjmc7> went bug-hunting instead
17:38:03 <ruhe> let's go through the list briefly
17:38:16 <ruhe> serg_melikyan: https://bugs.launchpad.net/murano/+bug/1326382 will you fix this one?
17:38:17 <uvirtbot> Launchpad bug 1326382 in murano "[python-muranoclient] Get method doen't return information about specific app" [Critical,Confirmed]
17:39:29 <ruhe> ok, let's hope serge will get back to us soon
17:39:37 <serg_melikyan> ruhe, probably not :(
17:39:51 <serg_melikyan> sorry, baby-sitting a little bit
17:39:53 <sjmc7> serg, i might be able to help, you have a load of bugs assigned to you
17:40:10 <katyafervent> I guess this bug need more verification - dashboard is working, so it's not critical
17:40:12 <serg_melikyan> sjmc7: not so many actually, but it will be great :)
17:40:25 <ruhe> sjmc7: great! please re-assign this bug to yourself
17:40:32 <sjmc7> curses! :)
17:40:36 <ruhe> my patch with alembic should fix the next one -  https://bugs.launchpad.net/bugs/1327132
17:40:37 <uvirtbot> Launchpad bug 1327132 in murano "Data base exception" [Critical,Confirmed]
17:40:45 <serg_melikyan> sjmc7: I can fill-in you with details after this meeting
17:40:55 <sjmc7> ok
17:41:03 <ruhe> slagun: will you fix https://bugs.launchpad.net/murano/+bug/1311755 in j1?
17:41:04 <uvirtbot> Launchpad bug 1311755 in murano "[api] API doesn't detect deployment failure" [High,Confirmed]
17:41:59 <sjmc7> this is related to environment deletion
17:42:12 <sjmc7> environment state transitions
17:42:51 <slagun> ruhe, lets move it to j2
17:43:04 <ruhe> slagun: ok. please do so
17:43:07 <serg_melikyan> it is actually directly related to actions
17:43:31 <ruhe> next one is https://bugs.launchpad.net/murano/+bug/1318095 sjmc7, this one is yours
17:43:32 <uvirtbot> Launchpad bug 1318095 in murano "[api] when deploying environment, failed package validation error results in misleading exception" [High,Confirmed]
17:43:47 <sjmc7> ah, yeah. i'll do that today
17:45:12 <ruhe> katyafervent: you filed https://bugs.launchpad.net/murano/+bug/1319677 . maybe you can fix it? how complex would be the fix? and do we really need it in j1?
17:45:13 <uvirtbot> Launchpad bug 1319677 in murano "Obsolete  API calls, which interacts with deployment status reports" [High,Confirmed]
17:45:37 <katyafervent> let me think
17:46:05 <katyafervent> we definitely need to fix it. 1 day would be enough
17:46:36 <katyafervent> well, may be it can be postponed to j2 - since it doesn't break anything
17:46:47 <katyafervent> assign it for me please
17:47:13 <ruhe> katyafervent: you can do it. and if it doesn't brake anything, you can make it "medium priority"
17:47:35 <katyafervent> I have no rights for that)
17:47:52 <ruhe> tsufiev: can you help with that?
17:48:05 <ruhe> the last one with high priority is https://bugs.launchpad.net/murano/+bug/1325101
17:48:06 <uvirtbot> Launchpad bug 1325101 in murano "[api] marks environments deleted regardless of actual state" [High,Confirmed]
17:48:11 <tsufiev> ruhe, sure
17:48:13 <ruhe> slagun: this one is also yours
17:48:43 <slagun> ruhe, this should be implemented after actions. So probably also in J2
17:49:02 <ruhe> slagun: ok. please update the bug accordingly
17:49:11 <ruhe> that's all about bugs i guess
17:49:34 <ruhe> we don't have much time and we have 2 more pending topics
17:50:08 <ruhe> #topic  app catalog index
17:50:12 <ruhe> btully: please go ahead
17:50:17 <btully> sure
17:50:33 <btully> so currently at the top of the page there is a section called "Latest Apps"
17:50:38 <btully> which I think is confusing
17:50:58 <btully> it appears to be something of a "Recent Activity" section
17:51:16 <btully> i.e., if an app has been deployed or added to an env it will show there
17:51:25 <ativelkov> btully: agree
17:51:27 <btully> so i am suggesting 2 things
17:51:39 <btully> rename section to reflect true purpose
17:51:46 <btully> and if we show apps there
17:52:06 <btully> they should not have action buttons in their "tile"
17:52:23 <btully> so some modified tile design
17:52:36 <tsufiev> btully, why remove the action buttons?
17:52:44 <sjmc7> yeah - my 2c on this is that if it's 'recently deployed stuff' you hsould instead get a link to the deployment
17:52:56 <sjmc7> and if it's "recently added applications" it makes sense to have the deployment buttons
17:52:56 <btully> if they are showing there, they already will have been acted on, no?
17:53:20 <ativelkov> Well, you may want to add another instance of this app to your environment
17:53:21 <sjmc7> but maybe this can be discussed after this meeting
17:53:22 <btully> ahh i see what you mean
17:53:24 <ativelkov> or to different env
17:53:28 <btully> yup
17:53:31 <btully> good point
17:53:46 <btully> ok at the very least we should reconsider the title of that section
17:54:01 <sjmc7> yes, agree
17:54:03 <btully> Latest Activity or Recent Activity, something like that
17:54:05 <tsufiev> the Lates Apps section should be redone even more
17:54:24 <tsufiev> e.g., all these Apps are stored now in user's web session which is not very good
17:54:30 <tsufiev> they must be stored in db
17:54:46 <btully> right, so for a large percentage of users, that section will be empty
17:54:47 <tsufiev> I agree to change the name for the section
17:54:47 <gokrokve_> btully: As we consider to support different formats like APS, TOSCA, would it make sense to add type to a title.
17:55:11 <btully> so also, do we even show that section if there are no items
17:55:12 <gokrokve_> btully: Like small icon like text "APS" or TOSCA"
17:55:27 <sjmc7> gokrokve_ - i think it would def make sense to mention the format in the details somewhere, yes
17:55:43 <tsufiev> btully, so I agree that thing needs to be changed, but frankly speaking, we don't have enough time to change it the _right_ way at J1
17:55:51 <gokrokve_> sjmc7: By the way did you add BP for APS format?
17:55:54 <sjmc7> let's agree to a) change the title of that section and b) discuss its use and whether we want to change how it works
17:55:58 <slagun> gokrokve_ this would be useful when we do begin support any of those. At least design such support
17:56:02 <sjmc7> gokrokve_ - not yet, planning to today
17:56:10 <btully> indeed, fir J1 was just  considering the title
17:56:13 <btully> for j1
17:56:15 <gokrokve_> sjmc7: Cool
17:56:24 <tsufiev> sjmc7, +1
17:56:33 <ruhe> also, +1 from me
17:56:42 <btully> +!
17:56:46 <btully> +1
17:57:07 <gokrokve_> +1
17:57:10 <ruhe> #agreed to a) change the title of that section and b) discuss its use and whether we want to change how it works
17:57:29 <tsufiev> ruhe, what's left?
17:57:35 <ruhe> gokrokve_: should we discuss actions?
17:57:44 <gokrokve_> ruhe: Sure
17:57:53 <ruhe> #topic murano actions
17:57:57 <gokrokve_> We need to have minimal support of actions.
17:58:09 <ruhe> gokrokve_: define minimal support please
17:58:14 <sjmc7> in 30 seconds or less, what are 'actions' in this context?
17:58:16 <gokrokve_> As I know there is API for that but we need to expose this functionality in UI
17:58:34 <gokrokve_> sjmc7: public methods in APP definitions
17:58:44 <gokrokve_> action like doBackup or ScaleUP
17:59:08 <tsufiev> gokrokve_, parameterized actions?
17:59:14 <gokrokve_> this is a workflow to do something as ALM
17:59:22 <gokrokve_> tsufiev: Without params for j1
17:59:25 <serg_melikyan> gokrokve_: to have UI we need to change specification of package, change how DynamicUI process definitions and many other bits :(
17:59:36 <gokrokve_> just URL with a hook to call an action
17:59:37 <ruhe> gokrokve_: there was no work done on designing the UI part. i doubt it'll make it into j1
17:59:52 <serg_melikyan> ruhe: design was actually done
18:00:12 <serg_melikyan> ruhe, gokrokve_ has done some WireFrames on this
18:00:32 <gokrokve_> not sure how dinamic UI is related to that
18:00:33 <serg_melikyan> if we are talking about actions without arfs
18:00:42 <tsufiev> gokrokve_, , I could expose a list of links in each Environment (or Application?)
18:00:42 <gokrokve_> I need just a list of actions available
18:00:46 <ruhe> serg_melikyan: i haven't seen any discussions about those wireframes
18:00:50 <gokrokve_> App
18:00:58 <tsufiev> gokrokve_, ok
18:01:02 <serg_melikyan> ruhe: it was before you have joined to us :)
18:01:02 <gokrokve_> we are out of time
18:01:11 <ruhe> folks, let's move to #murano
18:01:14 <ruhe> we're out of time
18:01:19 <ruhe> thanks everyone
18:01:22 <ruhe> #endmeeting