17:01:47 <ruhe> #startmeeting murano
17:01:48 <openstack> Meeting started Tue Apr  1 17:01:47 2014 UTC and is due to finish in 60 minutes.  The chair is ruhe. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:50 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:53 <openstack> The meeting name has been set to 'murano'
17:02:01 <Katyafervent2> hi guys
17:02:22 <ruhe> guys, if you're here, please let us know
17:02:41 <stanlagun> hi
17:02:42 <dmitryme> me here :-)
17:02:45 <dmitryme> hello
17:02:50 <sjmc7> hi. i'll be lurking
17:03:01 <gokrokve> hi
17:03:05 <ruhe> oh, great, new people :)
17:03:15 <ruhe> ok. here is our agenda:
17:03:20 <joel_c> .
17:03:23 <ruhe> #link https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Agenda
17:03:34 <ruhe> #topic AI review
17:04:01 <ruhe> there was only one AI on me - to create BP for cloud-init deployable agent. and i did it 5 minutes before the meeting
17:04:10 <ruhe> #link https://blueprints.launchpad.net/murano/+spec/cloud-init-deployable-agent
17:04:25 <ruhe> let's move to the next topic
17:04:35 <ruhe> #topic API status
17:04:43 <ruhe> Katyafervent2: your turn
17:04:53 <gokrokve> Does it mean that we don't need to have a prebacked image for Murano?
17:04:59 <Katyafervent2> ok
17:05:13 <ruhe> gokrokve: let's stick to the agenda and discuss agents later. ok?
17:05:19 <gokrokve> ok
17:05:25 <Katyafervent2> 1/2 of API is implemended
17:05:26 <tsufiev_> hi
17:05:40 <ruhe> Katyafervent2: what's left?
17:05:45 <dteselkin> Hi
17:05:58 <Katyafervent2> now update and get method are conmited and upliad on review
17:06:07 <Katyafervent2> *upload
17:06:47 <Katyafervent2> delete method and all other get method such ad downloading file package or ui definition
17:07:07 <Katyafervent2> it' s easy just need to set correct cobtent types
17:07:32 <Katyafervent2> witch is not so easy as in flask :)
17:07:41 <ruhe> Katyafervent2: do you need any help from someone else? Maybe you can outsource some easy parts to gokrokve? :)
17:08:08 <Katyafervent2> I hope to the end of the week we will have all calls in master
17:08:42 <tsufiev_> ruhe: you could review those commits, it would very helpful :)
17:08:45 <Katyafervent2> I have everything in stash already so I'll finish it
17:09:09 <ruhe> cool
17:09:10 <Katyafervent2> I'll let yoy know if I have questions
17:09:19 <ruhe> anything else?
17:09:25 <ruhe> to discuss
17:09:44 <Katyafervent2> did I make that topic clear?)
17:09:53 <ruhe> Katyafervent2: you did
17:10:09 <Katyafervent2> ok, move on then
17:10:18 <ruhe> #info API implementation status is 50%. Expected to be finished by the end of this week. Reviews are very welcome
17:10:32 <ruhe> #topic Engine status
17:10:46 <tsufiev_> ruhe: i missed the beginning, have you already discussed new package import?
17:10:57 <tsufiev_> as part of db initialization
17:10:59 <ruhe> tsufiev_: not yet
17:11:11 <ruhe> let's do it as part of this topic
17:11:30 <tsufiev_> ok :)
17:11:35 <sergmelikyan> ruhe we have almost finished work on Engine, I have small changeset on review with improvements in serialization, and now working on testing framework for MuranoPL
17:12:15 <ruhe> great
17:12:36 <ruhe> do you have an agreement with stanlagun on testing framework?
17:12:49 <sergmelikyan> But we have one important feature missing: Advanced Networking, without it we will have regression in list of features in comparison with previous release. I expect to finish till friday with Advanced Networking
17:13:04 <sergmelikyan> ruhe, yep
17:13:40 <ruhe> sergmelikyan: can you give us some overview of proposed testing framework for MuranoPL. that's an intersting topic
17:14:20 <sergmelikyan> ruhe we plan to have ability to cover MuranoPL with tests written on MuranoPL itself
17:15:01 <sergmelikyan> Main idea behind it simular to tests in different languages that can help to verify language functionality and compatibility of different implementations
17:16:32 <ruhe> any more questions or updates about MuranoPL and Murano engine status?
17:16:47 <ruhe> if not, let's discuss package import
17:17:14 <sergmelikyan> This will help us control implementation of MuranoPL, helping to prevent regressions. In previous language (XML Based) that was undoable
17:18:57 <sergmelikyan> ruhe can you update us on packages import topic?
17:19:03 <ruhe> sergmelikyan: me thinks that testing DSL by writing tests in DSL language is awesome :)
17:19:10 <ruhe> sergmelikyan: ok. packages
17:19:29 <tsufiev_> considering package import: we have already package parser implemented in murano-api, what's left to do is add manage command for that and make packages themselves
17:19:40 <ruhe> right
17:19:50 <tsufiev_> i think, that second is the harder part
17:19:57 <ruhe> we have package object in DB, we have package parser, which reads packages from disk
17:20:38 <ruhe> now, as part of Murano installation, we need to push base library classes to the DB within a single library package
17:20:56 <ruhe> we discussed that with sergmelikyan and stanlagun a little bit
17:21:01 <ruhe> and here is the idea:
17:21:17 <igormarnat_> ruhe: speaking of testing DSL by means of DSL, it's fine. There are C compilers written in C, right? :)
17:21:32 <ruhe> 1. ship base MuranoPL classes with murano-api tarball
17:21:43 <tsufiev_> could someone clarify for me: will the base (library) classes reside in the filesystem or in the db?
17:21:51 <stanlagun> db
17:21:52 <ruhe> 2. Initialize DB with tables using murano-manage dbsync
17:22:10 <ruhe> tsufiev_: i'm doing it right now :)
17:22:39 <ruhe> 3. pack base library classes in a Murano package
17:22:59 <tsufiev_> ruhe: oh, i see
17:23:00 <ruhe> 4. call murano-mange import-package $PATH_TO_PACKAGE
17:23:54 <ruhe> 5. murano-manage import-package will read the package and import it into the database
17:24:14 <ruhe> that's all
17:24:52 <ruhe> it doesn't look very nice, but we didn't find any other path to push base classes into DB
17:25:13 <sergmelikyan> As Engine status topic we have another area that we not yet covered - new class loader for Engine that works with Repository and packages
17:25:25 <ruhe> tsufiev_: what do you think?
17:25:27 <sergmelikyan> ruhe did you have time to play with ideas?
17:25:47 <tsufiev_> ruhe: ok, now it's almost clear
17:26:20 <ruhe> sergmelikyan: no i din't yet. but i understand that i have to have something working this week. otherwise go for your help :)
17:26:29 <tsufiev_> almost = afair, there are 2 types of packages: Applications and Library - are they treated the same way during import?
17:27:07 <ruhe> tsufiev_: i don't see any difference. Katyafervent2, sergmelikyan, stanlagun do you see any difference?
17:27:10 <sergmelikyan> tsufiev_, should be so
17:27:30 <Katyafervent2> yes
17:27:54 <sergmelikyan> ruhe, there is no difference from import point of view, AFAIK
17:28:33 <ruhe> Katyafervent2: tell us then. where do you see the difference?
17:29:02 <tsufiev_> the only difference between these 2 types known to me is that Library don't have related UI definitions
17:29:21 <tsufiev_> and Logo
17:29:28 <Katyafervent2> yes was for "no difference"
17:29:37 <ruhe> Katyafervent2: ok :)
17:29:57 <sergmelikyan> tsufiev_, but this does not matter for importing )
17:30:10 <ruhe> should we continue discussion on "package imports" or continue to the next topic?
17:30:10 <tsufiev_> sergmelikyan: ok, it seems so
17:30:12 <Katyafervent2> tsufiev_, you are right
17:30:15 <stanlagun> difference is that one has application inside and other doesn't have
17:30:46 <stanlagun> like exe and dll in Windows
17:31:29 <ruhe> stanlagun: should we run anti-virus software to make sure that our packages aren't infected? ;)
17:32:01 <sergmelikyan> :D There is no executable code in our packages ))
17:32:02 <stanlagun> :) packages are going to be signed to prevent this btw
17:32:11 <ruhe> ok
17:32:16 <ruhe> let's move to the next topic
17:32:18 <stanlagun> MuranoPL is executable
17:32:31 <ruhe> let me just put a fancy status item
17:32:39 <ruhe> #agreed to import packages the way ruhe said
17:32:47 <sergmelikyan> :)
17:32:52 <ruhe> #topic Release status
17:32:53 <Katyafervent2> :)
17:33:05 <ruhe> we already covered most of the server side parts
17:33:27 <ruhe> but we didn't cover the most important user-facing one - dashboard
17:33:38 <ruhe> tsufiev_: your turn
17:34:37 <tsufiev_> UI <-> murano-api integration is going on
17:35:02 <tsufiev_> I hope to finish it till this Friday
17:35:42 <gokrokve> Steve will finish the CSS part this week.
17:36:02 <ruhe> tsufiev_: we also need to update python-muranoclient. are you working on that, do you plan to?
17:36:19 <tsufiev_> ruhe: yes, I do
17:36:41 <ruhe> tsufiev_: great
17:36:52 <tsufiev_> also we had to implement Stats&Billing page
17:37:13 <Katyafervent2> do we have blueprint for that?
17:37:41 <ruhe> Katyafervent2: there is generic BP - https://blueprints.launchpad.net/murano/+spec/app-catalog-billing
17:38:17 <tsufiev_> as stanlagun said, UI for that feature should be very simple
17:38:29 <tsufiev_> so I've estimated it in 1 day of work
17:38:42 <ruhe> we also have 2 high-priority BPs in "Not Started" state:
17:38:45 <ruhe> #link https://blueprints.launchpad.net/murano/+spec/app-total-uptime
17:39:01 <sergmelikyan> tsufiev_, roughly another field on service details pacge
17:39:05 <sergmelikyan> *page
17:39:07 <ruhe> stanlagun: do you have any updates on this BP? do you think it can be finished in this release cycle?
17:39:37 <stanlagun> yes. I'm going to submit implementation for review today
17:39:57 <stanlagun> it is not very difficult but requires some support from workflows
17:39:57 <ruhe> stanlagun: you have about 2 hours :)
17:40:18 <ruhe> anyway, that sound promising
17:40:25 <ruhe> #link https://blueprints.launchpad.net/murano/+spec/service-defitions-migrate-to-apps-ui
17:40:37 <ruhe> tsufiev_: what about this one? ^
17:41:08 <tsufiev_> this should be also simple - it is mostly about removing some existing buttons & Actions from 'Service Definitins' panel and renaming it
17:41:20 <Katyafervent2> I quess it is working on prototype
17:41:31 <tsufiev_> + adding several wrappers to python-muranoclient
17:41:51 <tsufiev_> Katyafervent2: what prototype do you mean?
17:42:15 <Katyafervent2> fake applications
17:42:24 <Katyafervent2> It's already commited
17:42:59 <Katyafervent2> I mean you can browse it snd add new)
17:43:17 <tsufiev_> imho, the last blueprint is about the Admin part of AppCatalog, it currently employs murano-repository & murano-metadataclient
17:43:20 <Katyafervent2> so its app-ui
17:44:13 <ruhe> great. so it seems like we still can fit all the planned BPs in this release (0.5)
17:44:13 <Katyafervent2> ok, naming does not say so)
17:44:25 <tsufiev_> once I rewrite it to use murano-api & python-muranoclient, the obsolete dependencies can be safely thrown away from dashboard's requirements
17:44:57 <Katyafervent2> what about class loader? will Alex finish it?
17:45:15 <sergmelikyan> Katyafervent2, ruhe is working on class loader
17:46:08 <sergmelikyan> And I am backing him up :D Alex is on vacation almost till the end of the april
17:46:15 <Katyafervent2> sergmelikyan, ok. I missed it
17:46:18 * ruhe finally has some real work to do :)
17:46:46 <ruhe> ok. let's move to the next topic then
17:46:49 * sergmelikyan remembered clip from Britny about work :D
17:47:17 <ruhe> #topic Community work group status
17:47:56 <ruhe> so the idea was to create a dedicated focused group to think on how we can describe applications in the OpenStack cloud
17:48:11 <ruhe> from Murano we have two volunteers: me and stanlagun
17:48:14 <Katyafervent2> we should start our day by saying Hi in IRC
17:48:21 <ruhe> from Solum we have Adrian Otto
17:48:48 <sergmelikyan> Katyafervent2, definitely :)
17:48:56 <ruhe> Katyafervent2: i couldn't disagree with you :)
17:49:02 <sergmelikyan> ruhe, did you talked with Zane?
17:49:13 <ruhe> now we need to find "volunteers" from the Heat team
17:49:34 <ruhe> i didn't yet speak with them in IRC. i wanted to give them time to respond on my email
17:49:59 <ruhe> but i think it's time to go to #heat and speak with the Heat core team
17:50:04 <ruhe> i'll do it today
17:50:38 <ruhe> gokrokve: you're in both Solum and Murano, i guess you should participate in that group too
17:51:01 <gokrokve> Ok. I will if it is necessary
17:51:08 <Katyafervent2> Should sonebody join you there?)
17:51:16 <sergmelikyan> We should consider opportunity to meet in Atlanta (members of the group)
17:51:27 <Katyafervent2> *somebody
17:51:52 <ruhe> for those not familiar with the topic:
17:51:54 <ruhe> #link http://www.mail-archive.com/openstack-dev@lists.openstack.org/msg20522.html
17:52:05 <sergmelikyan> Ruhe are you going to the summit?
17:52:15 <ruhe> sergmelikyan: i guess so
17:52:44 * sergmelikyan almost sure that Adrian and Zane definitely will be there
17:53:07 <sergmelikyan> ruhe, cool! We should consider in what format we can meet with them
17:53:31 <ruhe> sergmelikyan: yes. i guess the will. but i'd like to have a healthy and focused discussion before the simmit
17:53:42 <ruhe> since people are very busy during the summit time
17:54:30 <ruhe> regarding format - i offered all the available communication tools: google hangouts, IRC meetings, ML
17:54:49 <ruhe> and if somebody is willing to join that group please let us know in that ML thread
17:54:56 <Katyafervent2> will in summit final dicision be made?
17:55:07 <ruhe> Katyafervent2: no one can tell
17:55:24 <Katyafervent2> We need to discuss everything before, right?
17:55:48 <ruhe> we need to have common understanding of things before the summit
17:57:03 <sergmelikyan> Let's move to the next topic?
17:57:17 <ruhe> sergmelikyan: yes
17:57:25 <ruhe> gokrokve: had questions about guest agent
17:57:34 <ruhe> #topic guest agent installable from cloud-init
17:58:04 <ruhe> gokrokve: answering your question - we will not need to build images if we install guest agent from cloud-init
17:58:39 <gokrokve> cool
17:58:53 <sergmelikyan> ruhe and we can support installing guest-agent even on windows with cloud-init, so no prebuilt images at all
17:59:04 <gokrokve> But still we will nee to tag them to distinguish windows and linux.
17:59:08 <sergmelikyan> sjmc7, this question may be interesting for you to
17:59:10 <dmitryme> ruhe: but installing an agent takes some time, right?
17:59:17 <sergmelikyan> gokrokve, yes
17:59:28 <sjmc7> sergmelikyan - yep, am making a note
17:59:29 <dmitryme> I mean you pay time for simplicity
17:59:48 <ruhe> dmitryme: it does. one of the possible solutions is to keep package mirror close to provisioned VMs
17:59:57 <gokrokve> Will this feature require internet access?
18:00:20 <gokrokve> Or you are going to embed agent directly to the user data?
18:00:20 <ruhe> gokrokve: in case if we have local mirrors - no, it will not require internet access
18:00:40 <ruhe> gokrokve: we'll need to desing this feature
18:00:44 <gokrokve> It should be documented.
18:00:47 <ruhe> at this moment it's just an idea
18:00:49 <sergmelikyan> we plan to have image-builder job for linux images, in case of someone need image with agent baked in, but also will have opportunity to work with any image with cloud-init installed
18:01:07 <ruhe> folks, we ran out of time
18:01:07 <gokrokve> How agent will be distributed? RPM\deb package?
18:01:11 <ruhe> let's move to #murano
18:01:13 <ruhe> #endmeeting