17:00:20 <ativelkov> #startmeeting murano
17:00:21 <openstack> Meeting started Tue Feb 25 17:00:20 2014 UTC and is due to finish in 60 minutes.  The chair is ativelkov. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:00:24 <openstack> The meeting name has been set to 'murano'
17:00:46 <ativelkov> Hi folks
17:01:14 <ativelkov> Any muranoers here? :)
17:01:14 <gokrokve> Hi!
17:01:39 <sergmelikyan> o/
17:02:05 <sergmelikyan> Hi, ativelkov
17:02:26 <ativelkov> not so many, but let's start anyway
17:02:37 <ativelkov> #topic AI review
17:03:19 <ativelkov> Before we actually go into the AIs, I want to mention that we've got lots of extra activities related to incubation request preparation, and this took quite a lot of time
17:03:41 <ativelkov> So, I expect some of the AIs to slip
17:04:05 <ativelkov> number 1: gokrokve to finalize MVP document
17:04:19 <gokrokve> I updated it.
17:04:31 <ativelkov> Is it on google docs?
17:04:31 <tsufiev> hi!
17:04:31 <gokrokve> Pelase review
17:04:35 <gokrokve> Yes.
17:04:41 <ativelkov> Good.
17:04:50 <ativelkov> #info MVP updated, is on google docs.
17:04:59 <ruhe> gokrokve: can you share the link?
17:05:48 <ativelkov> I think we should transfer it to Wiki as a feature spec for 0.5
17:05:52 <gokrokve> https://docs.google.com/a/mirantis.com/document/d/11C-_StJzseeFnqIL1hGJ0cfoB0vBaKaBKQOiaJSlXpg/edit?usp=sharing
17:06:36 <ativelkov> actually, the second ai - "ativelkov to complete roadmap planning according to it" is exactly about that
17:06:51 <ruhe> gokrokve: it's protected, could you please change to more permissive mode?
17:07:19 <ativelkov> We had a meeting discussing the roadmap, but could complete only DSL-related part
17:07:47 <ativelkov> the remaining requires some extra BPs to be created. I'll do it this week
17:08:07 <ativelkov> #action ativelkov to create the remaining blueprints targeting 0.5
17:08:16 <gokrokve> ruhe: Try it now. I changed the access right.
17:08:32 <ativelkov> next ai, ativelkov publish the abstract on wiki.
17:08:48 <ativelkov> We've chosen to initiate a broader discussion with community first
17:08:54 <ruhe> gokrokve: thank you. i can see it now
17:08:59 <ativelkov> So, the abstract was published in ML instead of wiki
17:09:24 <ativelkov> #link http://lists.openstack.org/pipermail/openstack-dev/2014-February/027202.html
17:09:30 <ativelkov> and the second part
17:09:42 <ativelkov> #link http://lists.openstack.org/pipermail/openstack-dev/2014-February/027938.html
17:09:53 <ativelkov> More to follow
17:10:12 <ativelkov> When we complete the discussion and get all the possible feedback we'll summarize it on the wiki
17:10:47 <ativelkov> We want to bring the idea to the widest possible audience, as our DSL approaches may be useful for other projects as well (solum is an example)
17:11:13 <ativelkov> next ai, ativelkov, stanlagun move spec to wiki and reference in blueprints
17:11:29 <ativelkov> spec is transferred
17:11:42 <ativelkov> #link https://wiki.openstack.org/wiki/Murano/DSL/Blueprint
17:11:57 <ativelkov> More BPs to come, as I already said
17:12:49 <ativelkov> next (me again!): ativelkov research potential Marconi integration for Agent communications
17:12:56 <ativelkov> no progress yet
17:13:22 <tsufiev> isn't that too much for one man :)?
17:13:37 <ativelkov> Just got some feedback from Savanna team that this think does not support lots of needed features - but I don't have any details yet
17:13:55 <ativelkov> tsufiev: well, you can volunteer to take some AIs from me ))
17:14:32 <ativelkov> and the last one: to schedule a meeting with Dmitry Mescheryakov to discuss agent messaging.
17:15:09 <_dim> Hi
17:15:13 <ativelkov> My fault: I didn't do that. We had some discussions in general chat on this topic though
17:15:19 <ativelkov> _dim: hi
17:15:47 <tsufiev> ativelkov: I could look into Marconi before main UI development is on pause
17:16:11 <tsufiev> i mean, before it is fully started
17:16:31 <ativelkov> tsufiev: thanks. Don't invest too much time though, we jsut need to have an overall understanding if it is suitable for us in long-term perspective
17:16:41 <tsufiev> ok
17:16:51 <ativelkov> #action tsufiev to look at Marconi (low priority task)
17:17:18 <ativelkov> Seems we are out of AIs )
17:17:25 <ativelkov> Moving to the next item
17:17:40 <ativelkov> BTW, the agenda is here https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:17:51 <ativelkov> I think I forgot to link it at the meeting start
17:18:10 <ativelkov> #topic DSL status
17:18:42 <ativelkov> stanlagun, who is one of the main drivers for the new DSL, is absent today
17:19:09 <ativelkov> so it seems like I'll give a quick update and will try to answer some questions if they are asked
17:19:32 <ativelkov> Stan will give more details when he returns
17:19:41 <ativelkov> So, we've finailized the proposal
17:20:00 <ativelkov> The links have already been given
17:20:09 <ativelkov> But just in case I'll repeat them
17:20:30 <ativelkov> #link https://wiki.openstack.org/wiki/Murano/DSL/Blueprint - general DSL description
17:20:45 <ativelkov> #link http://lists.openstack.org/pipermail/openstack-dev/2014-February/027202.html - DSL abstract
17:20:57 <ativelkov> #link http://lists.openstack.org/pipermail/openstack-dev/2014-February/027938.html - object oriented concept
17:21:24 <ativelkov> If anybody have any questions on this concepts - it may be a good time to ask them here and now :)
17:22:20 <ativelkov> No questions I think )
17:22:39 <ativelkov> Well, then we'll continue in the ML, but that will be much slower
17:22:50 <ativelkov> next topic
17:22:53 <ativelkov> #topic Oslo.messaging status
17:23:05 <ativelkov> sergmelikyan: can you give an update?
17:25:26 <sergmelikyan> I have completed patches related to migration to oslo.messaging - all communications between API and Conductor are now going through oslo.messaging
17:25:40 <gokrokve> Cool!!!
17:25:46 <sergmelikyan> Changes are not merged yet - some issues with tests in conductor
17:26:35 <ativelkov> sergmelikyan: will oslo.messaging-based communications use default openstack's messaging infrustructure service?
17:26:51 <sergmelikyan> ativelkov, mmm&
17:27:15 <sergmelikyan> Please, could you explain what do you mean?
17:27:27 * sergmelikyan didn't get question
17:27:54 <ativelkov> I mean, by default openstack uses rabbit for inter-service communications, right?
17:28:07 <ativelkov> willl we use the same instance of rabbit in this case?
17:28:26 <sergmelikyan> ativelkov, it is solely related how Murano is deployed
17:28:48 <ativelkov> Well, what is the suggested way then?
17:29:03 <sergmelikyan> ativelkov, as you said, actually.
17:29:21 <sergmelikyan> We need to integrate approach mentioned by you in MOST 5
17:29:41 <ativelkov> Well, that's up to the MOST team. We should collaborate with them
17:30:11 <ativelkov> BTW, can you provide a link to your changeset?
17:30:34 <sergmelikyan> https://review.openstack.org/#/q/status:open+branch:master+topic:migrate/oslo.messaging,n,z
17:30:45 <ativelkov> #link https://review.openstack.org/#/q/status:open+branch:master+topic:migrate/oslo.messaging,n,z
17:30:48 <ativelkov> Good, thanks
17:30:59 * ativelkov just wanted for the link to get into the meeting minutes
17:31:25 <ativelkov> One more question: what about conductor<->agent communications?
17:33:06 <sergmelikyan> We will migrate from Puka library to Kombu, but leave them as is for now.
17:33:35 <ativelkov> So, this will be rabbit-only (no other messaging providers)?
17:33:37 <sergmelikyan> Investigation about Marconi is one of the future plans in Murano components communication redesign
17:33:45 <sergmelikyan> ativelkov, yes
17:34:15 <ativelkov> I see. Well, anyway that is already a very good progress towards unification and openstack-compliance
17:34:25 <sergmelikyan> But since it is may be private RabbitMq instance, not related to one that used by OpenStack, it is not so bad
17:34:53 <ativelkov> I would even say that it SHOULD be private rabbit instance
17:35:03 <ativelkov> otherwise it may compromise the security
17:35:23 <ativelkov> So, the next one
17:35:28 <ativelkov> #topic Incubation Request status
17:35:50 <ativelkov> gokrokve: this one is on you. Could you please provide an update?
17:38:32 <gokrokve> We sent the incubation request. Right now there is a discussion time in the community.
17:39:13 <gokrokve> Probably next week Murano will be reviewed on TC meeting
17:39:32 <ativelkov> Could you link the ML thread?
17:41:48 <ativelkov> Meanwhile, this the etherpad where we track the status of our complieance with formal requuirements
17:41:51 <ativelkov> #link http://etherpad.openstack.org/p/murano-incubation-status
17:41:59 <ativelkov> We'll need to update it
17:42:09 <gokrokve> http://lists.openstack.org/pipermail/openstack-dev/2014-February/027736.html
17:42:20 <ativelkov> #action ativelkov to update the incubation statuspad
17:42:26 <ativelkov> thanks gokrokve
17:42:38 <ativelkov> #link http://lists.openstack.org/pipermail/openstack-dev/2014-February/027736.html - incubation request
17:42:42 <ativelkov> (just for MM)
17:43:03 <ativelkov> So, is that all related to our incubation request for now?
17:44:06 <ativelkov> that, it is time for open discussion
17:44:13 <ativelkov> #topic open discussion
17:44:19 <ativelkov> Any topics to discuss?
17:46:03 <ativelkov> If no, then let's wrap up for today
17:46:40 <gokrokve> There will be a TC meeting at 12AM
17:46:52 <ativelkov> Today?
17:47:03 <gokrokve> not for Murano but it will be greate it someone participate
17:47:05 <gokrokve> yes today
17:47:40 <ativelkov> I will not make it today
17:48:25 <ativelkov> gokrokve: will you have a timeslot for this? Its in your timezone
17:48:41 <gokrokve> I will be here for sure.
17:50:16 <ativelkov> We'll, I'll try to join, but it would be hard: have to wake up very early tomorrow
17:50:42 <ativelkov> Anything else?
17:51:24 <ativelkov> Then thanks everyone for joining
17:51:29 <ativelkov> #endmeeting