17:02:12 <ativelkov> #startmeeting murano
17:02:13 <openstack> Meeting started Tue Feb 11 17:02:12 2014 UTC and is due to finish in 60 minutes.  The chair is ativelkov. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:02:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:16 <openstack> The meeting name has been set to 'murano'
17:02:26 <ativelkov> Hi folks
17:02:34 <dteselkin> Hi
17:03:35 <ativelkov> #link This is our agenda for today: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
17:04:22 <ativelkov> #topic AI review
17:04:39 <ativelkov> So, let's start
17:05:33 <ativelkov> ativelkov and gokrokve to submit more BPs to Glance
17:05:49 <ativelkov> We've started doing that and submitted several BPs
17:05:55 <ativelkov> more remain to be done
17:06:40 <ativelkov> The main work which is still in progress is to create a draft for the API
17:06:45 <ativelkov> it is on me currently
17:07:34 <ativelkov> ativelkov to update project roadmap to reflect the metadata
17:07:34 <ativelkov> repository req's
17:08:07 <ativelkov> Not done yet: I had too much presentation activities last week, didn't get to that
17:08:25 <ativelkov> #action ativelkov to update project roadmap to reflect the metadata repository req's
17:08:33 <ativelkov> So this remains to be done
17:08:53 <ativelkov> And the last one on me create more MVP-releated blueprints
17:09:14 <ativelkov> This one was actually done by katyafervent, thanks to her :)
17:10:02 <ativelkov> katyafervent to comment the blueprint on dynamic service description
17:10:20 <ativelkov> Any comments here?
17:10:36 <sergmelikyan> ativelkov, not done yet,  katyafervent planned to work on this item tomorrow
17:11:11 <katyafervent2> Yes, I have no time due to release postponed
17:11:34 <ativelkov> ok, let's have it for the next week as well
17:11:50 <ativelkov> #action katyafervent to comment the blueprint on dynamic service descriptions
17:12:01 <katyafervent2> Ok
17:12:14 <ativelkov> next one: stanlagun to update the DSL description according to the implemented POC
17:13:03 <sergmelikyan> ativelkov, AFAIK it is done: http://bit.ly/1bJ7jjh
17:13:22 <stanlagun> I've written DSL description. It is on googledocs now. I'm going to publish it on wiki after initial feedback and approval
17:14:17 <ativelkov> Yes, let's publish it and get the feedback from the community.
17:14:33 <ativelkov> we'll also need some abstract and quick examples
17:15:22 <ativelkov> last ai: tnurlygayanov to help stanlagun with DSL Engine & YAML workflow unit tests
17:15:31 <ativelkov> any prohress on testing?
17:16:22 <tnurlygayanov___> no, we just read the code
17:16:27 <katyafervent2> We decide to choose anybody else to help with this action item
17:16:41 <katyafervent2> No?
17:16:44 <stanlagun> I just starting with testing. The first thing that need to be done is make it testable. Need to throw correct exceptions, to pass exception call stack across green threads etc
17:17:39 <stanlagun> Also need to write some simple testing framework that would contain all needed mocks and class injection mechanics
17:18:01 <sergmelikyan> I would like to mention that improving unit-tests coverage may be much proficient during actual development, not on PoC
17:18:12 <ativelkov> yes, sure
17:18:58 <ativelkov> So, let's agree that the testing framework is needed indeed, but actual tests should be done only hen adding this functionality to Murano itself
17:19:06 <ativelkov> Any objections?
17:19:53 <sergmelikyan> testing framework should also be developed during development phase ) What reason behind framework without tests?
17:20:09 <stanlagun> Tests already needed so that i wouldn't brake one part of DSL while adding features to another
17:20:10 <ativelkov> because it is the part of the engine
17:20:22 <sergmelikyan> I think mentioned framework will be efficiently written when will be needed by actual tests
17:21:17 <ativelkov> Ok
17:21:32 <sergmelikyan> stanlagun, I think there is no reason to invest time on PoC development. We need feedback and integration in main project
17:22:17 <ativelkov> it turns out we are already on our next agenda topic :)
17:22:22 <ativelkov> #topic New DSL status
17:23:05 <ativelkov> We've already received some feedback on the new language
17:23:56 <ativelkov> the general idea is that we need to simplify it as much as possible, to reduce the adoption time for the new developers
17:24:48 <sergmelikyan> ativelkov, I think we need to publish docs written by Stan as soon as possible, and discuss feature by feature features
17:25:19 <ativelkov> Yes, but first we need a short abstract
17:25:45 <sergmelikyan> ativelkov, sure
17:27:22 <ativelkov> Some draft of this abstract may be seen here: https://etherpad.openstack.org/p/v5rce77Rpt
17:27:31 <ativelkov> #link https://etherpad.openstack.org/p/v5rce77Rpt
17:27:46 <ativelkov> But it has to be finalized first
17:28:30 <ativelkov> #action tivelkov, stanlagun to complete the short abstract for the new DSL and then publish a complete description of Wiki
17:28:55 <ativelkov> meawhile, it is suggested not to use the term "DSL" at all
17:29:45 <ativelkov> This thing may have features and power of a full-fledged programming language but it should not look like it- unless absolutely needed
17:30:10 <ativelkov> Our users/develeopers should think of them as about the configuration files
17:31:49 <ativelkov> Herman Narkaytis has even proposed an analogue with the make-file
17:32:14 <ativelkov> But it may also look overcomplicated
17:33:33 <ativelkov> Anything else on this topic
17:33:34 <ativelkov> ?
17:34:16 <ativelkov> then, let's move on
17:34:20 <ativelkov> #topic Oslo.messaging status
17:34:53 <ativelkov> sergmelikyan: could you please share an update here?
17:38:07 <sergmelikyan> I had published email to the mailing list with results of my research. In short - we can migrate to oslo.messaging
17:40:00 <sergmelikyan> ETA: around a week
17:40:33 <ativelkov> OK, is it doable as part of 0.5?
17:40:43 <sergmelikyan> Sure
17:40:51 <ativelkov> good
17:41:06 <ativelkov> #info migration to oslo.messaging to be done as part of 0.5
17:42:21 <ativelkov> #link the ML thread here: http://lists.openstack.org/pipermail/openstack-dev/2014-February/026843.html
17:42:56 <ativelkov> ok, the last item in agenda
17:43:01 <ativelkov> #topic Repository Reorganization
17:43:25 <ativelkov> That's what we didn't complete discussiong last time
17:44:11 <ativelkov> There was a message to ML from sergmelikyan
17:44:15 <ativelkov> #link http://lists.openstack.org/pipermail/openstack-dev/2014-February/026526.html
17:44:44 <ativelkov> I wanted other Muranoers to express some opinions as well
17:44:52 <ativelkov> Either here or in a mailing list
17:45:10 <ativelkov> We have to make decisions on that before we start the actual coding of 0.5
17:46:53 <ativelkov> No opinions? :)
17:47:18 <sergmelikyan> :)
17:48:43 <ativelkov> oh, well. Guys, this needs to be done. Let's schedule the discussion on some other time then, when everybody are ready
17:49:27 <ativelkov> #topic Open Discussion
17:49:43 <ativelkov> Anything else to discuss?
17:50:46 <ativelkov> Well, lets wrap up then
17:51:01 <ativelkov> Thanks for joining
17:51:07 <ativelkov> #endmeeting