#openstack-meeting-alt: murano

Meeting started by ativelkov at 17:03:15 UTC (full logs).

Meeting summary

  1. AI review (ativelkov, 17:05:44)
    1. No docs on DSL yet, expect to have them this week (ativelkov, 17:07:17)
    2. ACTION: stanlagun to update the DSL description according to the implemented PoC (ativelkov, 17:07:34)
    3. ACTION: tnurlygayanov to help stanlagun with DSL Engine & YAML workflow unit tests (ativelkov, 17:17:11)

  2. Status for release 0.4.1 (ativelkov, 17:17:29)
    1. 0.4.1 is on track, release planned for Feb, 6 (ativelkov, 17:19:53)
    2. ACTION: all test 0.4.1 like hell (ativelkov, 17:22:55)
    3. http://bofh.ntk.net/BOFH/ (sergmelikyan, 17:25:24)

  3. Glance activities review (ativelkov, 17:25:45)
    1. It was decided that Glance will move towards being an "Artifact repository" usable by other projects - and Murano will store its Application packages there (ativelkov, 17:26:45)
    2. The changes will be made to Glance's V2 API - appropriate additional will be made (ativelkov, 17:27:22)
    3. the artifact repository will be implemented as pluggable addition to the core glance, so different projects will be have their artifact repository logic implemented as plugins (ativelkov, 17:29:56)
    4. ACTION: ativelkov and gokrokve_ to submit more BPs to Glance (ativelkov, 17:30:18)
    5. Simplified Metadata Repository to be imporved to support 0.5 and AppCatalog MVP (ativelkov, 17:33:02)
    6. ACTION: ativelkov to update project roadmap to reflect the metadata repository req's (ativelkov, 17:33:50)
    7. ACTION: ativelkov - create more MVP-releated blueprints (ativelkov, 17:35:59)

  4. New DSL status (ativelkov, 17:36:26)
    1. DSL is almost ready. We have working/deploying ActiveDirectory service written on new DSL (ativelkov, 17:40:32)
    2. https://github.com/istalker2/MuranoDsl (ativelkov, 17:41:28)
    3. https://github.com/istalker2/MuranoDsl/blob/master/meta/com.mirantis.murano.services.windows.activeDirectory.ActiveDirectory/manifest.yaml (stanlagun, 17:41:36)
    4. Heat is not going to introduce new Autoscaling in Icehouse, need to make a homebrew solution (ativelkov, 17:43:45)

  5. Dynamic UI to display Service descriptions (ativelkov, 17:45:01)
    1. http://blueprints.launchpad.net/murano/+spec/dynamic-fields-on-service-details (ativelkov, 17:45:37)
    2. ACTION: katyafervent to comment the blueprint on dynamic service descriptions (ativelkov, 17:50:52)

  6. open discussion (ativelkov, 17:51:03)
    1. AGREED: continue to discuss repo reorganization in ML (ativelkov, 17:59:20)
    2. http://www.meetup.com/openstack/ (ativelkov, 18:00:35)


Meeting ended at 18:00:47 UTC (full logs).

Action items

  1. stanlagun to update the DSL description according to the implemented PoC
  2. tnurlygayanov to help stanlagun with DSL Engine & YAML workflow unit tests
  3. all test 0.4.1 like hell
  4. ativelkov and gokrokve_ to submit more BPs to Glance
  5. ativelkov to update project roadmap to reflect the metadata repository req's
  6. ativelkov - create more MVP-releated blueprints
  7. katyafervent to comment the blueprint on dynamic service descriptions


Action items, by person

  1. ativelkov
    1. ativelkov and gokrokve_ to submit more BPs to Glance
    2. ativelkov to update project roadmap to reflect the metadata repository req's
    3. ativelkov - create more MVP-releated blueprints
  2. gokrokve_
    1. ativelkov and gokrokve_ to submit more BPs to Glance
  3. katyafervent
    1. katyafervent to comment the blueprint on dynamic service descriptions
  4. stanlagun
    1. stanlagun to update the DSL description according to the implemented PoC
    2. tnurlygayanov to help stanlagun with DSL Engine & YAML workflow unit tests


People present (lines said)

  1. ativelkov (123)
  2. stanlagun (18)
  3. gokrokve_ (17)
  4. igormarnat_ (16)
  5. katyafervent (15)
  6. sergmelikyan (11)
  7. openstack (3)


Generated by MeetBot 0.1.4.