17:04:20 <ativelkov> #startmeeting murano
17:04:21 <openstack> Meeting started Tue Nov 19 17:04:20 2013 UTC and is due to finish in 60 minutes.  The chair is ativelkov. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:04:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:24 <openstack> The meeting name has been set to 'murano'
17:04:32 <ativelkov> So, let's begin
17:04:40 <ativelkov> Our agenda is here: https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Agenda
17:05:14 <ativelkov> let's start with the #topic Summit summary
17:05:23 <ativelkov> #topic Summit Summary
17:05:57 <ativelkov> So, we have officially presented the changing of Murano mission from "Windows DataCenter as a service" to "Application Catalog"
17:06:10 <ativelkov> Received some positiv
17:06:19 <ativelkov> received some positive feedback from the community
17:07:05 <ativelkov> Seems like lot's of people were working on the similar topics on their own, looks like we may get some synergy while working together
17:07:44 <ativelkov> Also, it is #agreed to extract reusable functionality from Murano and contribute it to other projects
17:08:47 <ativelkov> E.g. Murano Workflows will be contributed to Mistral, Murano Agent may become Unified Agent, and some of our software post install configuration may get its way into Heat Software Configuration
17:09:11 <ativelkov> Discussions on Mistral and Unified Agent are already in progress
17:09:48 <katyafervent> Good news!
17:09:48 <ativelkov> That's all for summit, I think. Any questions?
17:10:25 <katyafervent> Is there is a special project name for a Unified Agent?
17:11:31 <ativelkov> Not yet. We just call it "unified agent", and "unified" means "adopted by more then one project"
17:12:20 <ativelkov> So, next topic
17:12:24 <ativelkov> #topic AI review
17:12:51 <ativelkov> We actually have 4 AIs
17:13:20 <ativelkov> gokrokve was supposed to "Put together and distribute over the mailing list AIs and agreements achieved in HK"
17:14:34 <ativelkov> gokrokve is on the Solum workshop today, so he probably cannot answer. In fact, we have sent an email into the distribution, summarising all the agreements and inviting the community to participate
17:15:08 <ativelkov> sergmelikyan was supposed to "Find new available timeslot for Murano meeting that is later then current one."
17:15:23 <ativelkov> As we are chatting right now it seems like this is done :)
17:15:30 <sergmelikyan> ativelkov, we moved meeting to Tuesday, 17:00 UTC :)
17:15:42 <ativelkov> yup
17:15:44 <sergmelikyan> And today is a first meeting with new schedule :)
17:16:10 <ativelkov> There is an AI to "fix Jenkins configuration to full eng"
17:16:16 <ativelkov> It was not assigned
17:16:23 <ativelkov> any news on this?
17:17:35 <sergmelikyan> It was assigned to Timur and AFAIK was done at the same day as assigned
17:17:36 <ativelkov> Probably it is up to tnurlygayanov, but he is not present
17:17:44 <ativelkov> ah, good
17:18:07 <ativelkov> last AI was to  start discussing with Solum devs API specs and env. descriptions format
17:18:17 <ativelkov> sergmelikyan: any progress on that?
17:19:46 <katyafervent> May by Gosha is doing it right now)
17:20:24 <ativelkov> I hope so
17:20:24 <sergmelikyan> ativelkov, from my side I had not enough time to do that :(
17:20:37 <sergmelikyan> And Georgy on the Solum Design Workshop now
17:21:03 <ativelkov> OK. So, let's hope gokrokve will do this on their workshop
17:21:16 <ativelkov> ok, we are done with AIs
17:21:28 <ativelkov> #topic Release 0.3 status
17:21:44 <ativelkov> sergmelikyan, can you give us an update on the release status?
17:22:41 <sergmelikyan> We fixing last issues in Release 0.3 and finishing with documentations
17:23:16 <ativelkov> Any estimates on when it will be ready?
17:23:24 <sergmelikyan> Current ETA for the release - 2 days, we planning to release 0.3 on Thursday
17:23:38 <ativelkov> #info Realease 0.3 is expected on Thursday
17:24:34 <ativelkov> #topic Release 0.4
17:25:01 <ativelkov> tsufiev: can you give an update for r.04?
17:25:38 <tsufiev> we're finishing admin UI for metadata today almost as planned
17:26:15 <tsufiev> i mean, last commit implementing its functionality should be approved tomorrow
17:26:44 <tsufiev> also there is advanced networking still to be merged...
17:27:12 <katyafervent> I thought it have already merged
17:27:18 <ativelkov> yes, I am working on this today
17:27:35 <ativelkov> #info metadata repository admin part is almost done
17:27:48 <ativelkov> #info advanced networking is being finished
17:28:22 <ativelkov> katyafervent: adv networking part of Conductor has been merged indeed, however some workflows still has to be modified
17:28:43 <katyafervent> ativelkov, Ok, thanks
17:29:06 <ativelkov> so, next topic)
17:29:27 <ativelkov> #topic Load Balancer Issue
17:29:46 <ativelkov> AFAIK, there was an email by sergmelikyan describing the problem
17:30:33 <ativelkov> Serge, can you briefly describe it here as well?
17:30:36 <igormarnat_> I remember there was some feedback about the subj
17:30:48 <sergmelikyan> Yes, but not so many responses. Maybe we need to forward this email to the Fuel Team to get they thoughts on Neutron LBaaS support.
17:31:27 <ativelkov> The feedback from Heat team was that we should't use AWS::-based templates if we can use OS::-based
17:32:14 <ativelkov> so, let's ale an AI )
17:32:18 <ativelkov> make*
17:32:37 <igormarnat_> Yep, I think we can modify the subj, adding there [Neutron] and [Fuel], and may be to ping folks personally to get some feedback
17:32:54 <ativelkov> #action forward the LoadBalancer email to Neutron and Fuel team, asking for feedback
17:33:38 <ativelkov> Anything else on this topic?
17:34:02 <ativelkov> If no, then the next one
17:34:07 <ativelkov> #topic Solum Integration
17:34:32 <ativelkov> I guess we don't have much here for now - not until gokrokve has some news from the workshop
17:35:27 <igormarnat_> He's there in #murano channel, let me ping him
17:35:45 <ativelkov> #action gokrokve to summarise the decisions of Solum design workshop for further discussion of integration paths
17:37:12 <ativelkov> Ok, probably he is busy. May be they have a lot to discuss, this may be promising :)
17:37:26 <igormarnat_> What else is in the agenda? What about scope of 0.5? Is it there?
17:37:40 <ativelkov> it is not in the agenda )
17:37:45 <ativelkov> #topic Open Discussion
17:37:56 <ativelkov> but let's discuss it now then
17:38:21 <ativelkov> So, we are going towards Application Catalog, obviously
17:38:55 <ativelkov> The core concept of the App Catalog will be the Metadata, describing the Cloud Applications
17:39:02 <katyafervent> Do we need to implement more applications?
17:39:10 <ativelkov> Nope
17:39:15 <ativelkov> at least not for now
17:39:43 <ativelkov> We expect others to do that - and not as part of Murano project
17:40:06 <ativelkov> For release 0.5 we need to dramatically improve the concept of Metadata
17:40:26 <ativelkov> I think we will need to develop the specification
17:40:40 <ativelkov> Rich and detailed, formal and excessive
17:41:00 <ativelkov> Then, we will need to extract a subset of it - which will be easy to explain and implement
17:41:16 <ativelkov> and then - last but not least - actually implement it :)
17:41:42 <igormarnat_> rich and detailed, formal and excessive � sounds scaring:)
17:41:59 <ativelkov> igormarnat_: that's specification only
17:42:06 <ativelkov> we don't want to change it often
17:42:21 <ativelkov> but we do not need to implement it as the whole thing
17:42:30 <ativelkov> we'll need something simple to begin with
17:42:54 <ativelkov> but this simple implementation should comply to the global vision, so the vision should be detailed
17:43:48 <igormarnat_> Speaking of spec, I'd say it's enough to be integral and consistent, but still these are just words:)
17:44:05 <igormarnat_> What's the plan then? When do we plan to have the draft?
17:45:08 <igormarnat_> BTW, is Stan here?
17:45:36 <ativelkov> stanlagun: are you here?
17:46:25 <stanlagun> yep
17:47:48 <stanlagun> we are working on it
17:48:12 <stanlagun> I mean ideas for spec
17:49:00 <ativelkov> We'll try to have some formal draft as soon as I finish with adv.net.
17:49:12 <igormarnat_> Do we have an etherpad or something?
17:49:42 <ativelkov> not yet, just the ideas. As I said, we need to fomalize them
17:51:35 <igormarnat_> Suppose to have them formalized by the next meeting (in a week)?
17:51:41 <ativelkov> Yes
17:51:59 <ativelkov> #action ativelkov stanlagun to formalise the new metadata ideas in the etherpad
17:52:04 <stanlagun> sure
17:52:23 <ativelkov> Ok. Any other questions?
17:52:38 <igormarnat_> #action ativelkov stanlagun To elaborate and formalize the spec for Metadata
17:53:31 <ativelkov> So,  let's conclude the meeting
17:53:36 <ativelkov> thanks for joining
17:53:40 <ativelkov> #endmeeting