15:00:58 <dkoryavov> #startmeeting murano
15:00:59 <openstack> Meeting started Mon Aug 26 15:00:58 2013 UTC and is due to finish in 60 minutes.  The chair is dkoryavov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:00 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:02 <openstack> The meeting name has been set to 'murano'
15:01:09 <dkoryavov> Here is agenda Agenda https://wiki.openstack.org/wiki/Meetings/MuranoAgenda#Agenda
15:01:10 <tsufiev> hi
15:01:17 <ativelkov> hi
15:01:30 <dkoryavov> And summary from the previous meeting http://eavesdrop.openstack.org/meetings/murano/2013/murano.2013-08-19-15.04.html
15:02:07 <IgorYozhikov> hi
15:02:28 <dkoryavov> tnurlygayanov_: hi.
15:02:32 <tnurlygayanov_> Hi all ) lets to start Murano meeting
15:03:41 <dkoryavov> tnurlygayanov_: can you tell us about the current state of v0.2? Do we have time to release it on 5th september?
15:03:44 <tnurlygayanov_> it is our agenta for today https://wiki.openstack.org/wiki/Meetings/MuranoAgenda
15:04:46 <tnurlygayanov_> dkoryavov, yes. Now we finished work with new features and ready to feature freeze.
15:06:51 <dkoryavov> tnurlygayanov_: as far as I can recall ativelkov already wrote message about feature freeze on today morning.
15:07:02 <ativelkov> yes, I did
15:07:03 <tnurlygayanov_> all bugs that must be fixed for release 0.2 posted to lanchpad.net
15:07:34 <dkoryavov> IgorYozhikov: what about the screencast?
15:07:44 <tnurlygayanov_> and we plan to fix and verify all bug with tag 'release-0.2' to September, 5.
15:08:26 <ativelkov> Core reviewers will not approve any commit which does not target any open bug of release-0.2
15:08:58 <ativelkov> The bug should be properly opened at launchpad - and the commit message should contain a link to it
15:09:17 <tnurlygayanov_> also, we should prepare dovumentation - we have many changes in installation procedures and we should chage the documentation.
15:09:24 <dkoryavov> IgorYozhikov: ?
15:09:25 <IgorYozhikov> Screencast, describes MS SQL AlwaysOn Availability Groups cluster,  mastering in progress and almost done
15:10:13 <IgorYozhikov> it's on the review :)
15:10:20 <dkoryavov> When we can see a final version? I suggest to upload it to youtube.
15:10:38 <tnurlygayanov_> Also, screencast about deploy ASP.NET Application Server Farm - work in progress. I plan to finish them today or tomorow.
15:11:06 <akuznetsova> I updated installation guide, it needs to be checked and merged
15:11:13 <dkoryavov> Sounds good.
15:11:13 <IgorYozhikov> I believe it could be uploaded under mirantis account
15:11:19 <tnurlygayanov_> Yes, we have update presentation for scrrencast, which prepared by Igor
15:12:08 <tnurlygayanov_> Yes, akuznetsova, I will review the changes today and will provide my feedback.
15:12:28 <Igor__> Is there updated roadmap which contains up-to-date description of 0.2 features?
15:13:06 <dkoryavov> #info IgorYozhikov and tnurlygayanov_ will prepare 2 screencasts before the next week.
15:13:27 <akuznetsova> tnurlygayanov_, ok
15:13:45 <dmyznikov> I have tested installation, service creation and deploy on CentOS 6.4 - all work fine
15:15:01 <dkoryavov> Igor__: AFAIK, no. Our roadmap is - our blueprints. It is not very good.
15:15:28 <tnurlygayanov_> #info today we got RPM packages for all Murano components and we plan to test it before release-0.2 to have RPM packages with Murano Release-0.2
15:15:30 <dkoryavov> We should to update our roadmap on the wiki.
15:15:53 <dkoryavov> #action dkoryavov will update roadmap on the wiki.
15:16:26 <tnurlygayanov_> #action need to test RPM packages with Murano
15:17:47 <tsufiev> tnurlygayanov_, can be testing of dynamic ui regarded as completed, i mean, no new bugs?
15:18:34 <dkoryavov> Someone have any question to discuss?
15:18:43 <tnurlygayanov_> tsufiev, yes, we work on web UI testing and we plan to finish it tomorow.
15:19:08 <akuznetsova> tsufiev, i tested dinamnic ui and created new fields and new steps with different attributes and all was fine
15:19:11 <tnurlygayanov_> Looks like now we have several critical, user-visible bugs in UI
15:19:17 <tsufiev> ok, i have only 1 opened bug left, and plan to fix it today
15:19:54 <tnurlygayanov_> Not in Dinamic UI, but just in UI, like instances count in ASP.NET Farms...
15:20:35 <dkoryavov> tnurlygayanov_: what bugs?
15:21:16 <tsufiev> tnurlygayanov_: instances count - you mean that bug, when there is only 1 instance by default when should be 2?
15:21:38 <tnurlygayanov_> Now we have hidden field 'instances count' on ASP.NET farm configuration form in UI
15:22:09 <tnurlygayanov_> tsufiev - and this is too )
15:22:29 <tsufiev> ok, i'll unhide it, no problem
15:22:39 <tnurlygayanov_> ok, thank you )
15:23:49 <akuznetsova> tsufiev https://bugs.launchpad.net/murano/+bug/1216975
15:24:22 <tnurlygayanov_> I just edited the description of forms in order to record a screencast - it is very easy to edit WebUI with Dinamic UI - we can controll all fields and parameters.
15:25:22 <tsufiev> yes, anybody can do it - just as intended by design
15:25:36 <tnurlygayanov_> #action create bug descriptions for all webUI bugs on launchpad.net/murano
15:26:22 <dkoryavov_> tnurlygayanov_ who will do this? :)
15:26:43 <dkoryavov_> tnurlygayanov_ add severall people to do this work
15:26:53 <tnurlygayanov_> all QA engineers )
15:27:55 <tnurlygayanov_> #action: akuznetsova, dmyznikov, tnurlygayanov: create bug descriptions for all webUI bugs on launchpad.net/murano
15:28:07 <dkoryavov_> OK
15:28:27 <dkoryavov_> Folks, we have no time. Let's move on.
15:28:28 <tnurlygayanov_> also, today we have fixed several problems with dependencies for Murano API Service
15:28:54 <tnurlygayanov_> Sergey, what the status of it?
15:29:32 <stanlagun> We've fixed issues with dependencies today
15:31:20 <dkoryavov_> I suggest to discuss an idea: to syncronize Murano releases with OpenStack releases.
15:31:53 <dkoryavov_> The next OpenStack release will be on 17th Oct. https://wiki.openstack.org/wiki/Havana_Release_Schedule
15:32:25 <ativelkov> We can try to implement some small features till that day, but nothing big
15:32:38 <ativelkov> it will be 0.25 or something
15:32:58 <stanlagun> 0.2.5
15:33:16 <Igor__> Do you mean we can release something like v2.1 by this date?
15:33:20 <dmyznikov> 0.2.1 ?
15:33:29 <dkoryavov_> Yes.
15:33:42 <dkoryavov_> We will have 1.5 months to do this.
15:34:39 <dkoryavov_> We can add win 2008 support, for example.
15:35:27 <dkoryavov_> Also we have several issues for perfomance of REST API and WebUI which can be implemented too.
15:35:42 <dkoryavov_> Let's vote?
15:35:53 <ativelkov> I think that Metadata repository and RBAC are more important
15:37:15 <dkoryavov_> ativelkov we can start work on Metadata repository, but I doubt that we will do it so soon.
15:37:45 <ativelkov> then let's speak to Gosha first
15:37:56 <ativelkov> as far as I understood he wanted this feature
15:38:10 <dkoryavov_> Georgy is here?
15:38:32 <ativelkov> And I don't think he likes if we postpone it due to shifted release schedule
15:39:06 <ativelkov> I don't see him
15:40:46 <dkoryavov_> We are opensource folks, right? :)
15:41:19 <ativelkov> Presumably :)
15:42:17 <dkoryavov_> stanlagun do we have any estimates for Metadata Repository?
15:43:10 <stanlagun> AFAIK we haven't estimated it
15:44:03 <dkoryavov_> Then I suppose to create a blueprint first and estimate it. Then we can discuss it.
15:44:05 <stanlagun> There are no requirements for what is required from such repository in short term
15:44:17 <ativelkov> I think we need to gather the exact requirements from Georgy (he spoke tu Customers and knows what do they want from RBAC)
15:46:01 <dkoryavov_> Yes. And I believe that this will be not very soon. Anyway, we can create an internal version before the next public release if we will need so.
15:46:16 <dkoryavov_> OK. I vote for the idea.
15:46:30 <dkoryavov_> What about you, folks?
15:47:14 <dkoryavov_> (hurry up! - we have only 10 minutes)
15:48:26 <dkoryavov_> ativelkov tnurlygayanov_ tsufiev stanlagun dteselkin IgorYozhikov dmyznikov akuznetsova ?
15:48:47 <ativelkov> At least we can create a detailed blueprint with our vision
15:48:50 <ativelkov> and estimate it
15:49:23 <tsufiev> i don't mind
15:49:34 <tnurlygayanov_> ok )
15:49:36 <dkoryavov_> No, no, I am about this idea: to syncronize Murano releases with OpenStack releases.
15:49:38 <dkoryavov_> :)
15:49:53 <ativelkov> Ah
15:50:14 <ativelkov> Well, I don't have any objections
15:50:27 <dkoryavov_> Ok, +1 from ativelkov
15:50:48 <dkoryavov_> tnurlygayanov_ tsufiev stanlagun dteselkin IgorYozhikov dmyznikov akuznetsova ?
15:50:49 <ativelkov> that was not a real +1, more like +0 ;)
15:51:10 <tsufiev> dkoryavov_: i don't mind
15:51:11 <akuznetsova> I agree, I think it is logical
15:51:11 <dkoryavov_> OK, 0+ :)
15:51:18 <stanlagun> +0 from me - don't have objections but also don't see rational for that
15:52:14 <tsufiev> stanlagun: it could be stated as: 'i'm not prepared well enough to formulate any objections' :)
15:53:14 <stanlagun> tsufiev: :)
15:53:30 <dkoryavov_> Our customers and community will know which version of Murano works with a new version of OpenStack.
15:53:46 <dkoryavov_> This is good for support teams too.
15:55:39 <dkoryavov_> This is good for our development process - we will work with OpenStack more closely (we will fix bugs :))
15:56:09 <dkoryavov_> dteselkin IgorYozhikov ?
15:56:56 <dkoryavov_> OK. As far as I can see, we are agreeed that my idea is more or less good.
15:57:00 <dkoryavov_> We have no time. Let's wait our meeting.
15:57:05 <tnurlygayanov_> yes, I belive that is good idea, but we should know what the date for each new OpenStack releases and rewrite our roadmap to map Murano releases with OpenStack releases
15:58:02 <dkoryavov_> #info Good idea: to syncronize Murano releases with OpenStack releases. Let's try to do so.
15:58:10 <dkoryavov_> #endmeeting murano
15:58:15 <dkoryavov_> That is all folks.
15:58:22 <dkoryavov_> #stopmeeting murano
15:58:33 <dkoryavov_> Unfortunately we have no time.
15:59:02 <dkoryavov> #endmeeting murano