08:09:43 <ricolin> #startmeeting multi_arch
08:09:44 <openstack> Meeting started Tue Mar 31 08:09:43 2020 UTC and is due to finish in 60 minutes.  The chair is ricolin. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:09:45 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
08:09:47 <openstack> The meeting name has been set to 'multi_arch'
08:09:50 <tonyb> hey ricolin !
08:10:21 <ricolin> hope everyone is fine
08:10:27 <ianw> tonyb: yeah, kids facetime and minecraft and whatnot ... they're very adaptable which is good
08:10:32 <ricolin> it's a crazy week
08:11:24 <ricolin> tonyb, assume you didn't need to adjust much since you already WFH:)
08:12:10 <tonyb> ricolin: Not too bad really but I reliased how much I have come to appreicate a quiet house ... now that it isn't ;P
08:12:23 <ricolin> lol
08:12:32 <tonyb> ricolin: how're things for you?
08:12:49 <tonyb> ACtually we should chat after the meeting :)
08:13:17 <ricolin> haha
08:13:20 <ricolin> fine!
08:13:37 <ricolin> :)
08:13:45 <ricolin> I put in two topic today
08:13:50 <ricolin> CI (as usual)
08:13:54 <ricolin> and Virtual PTG
08:14:02 <ricolin> anything else we should discuss today?
08:14:21 <ianw> no from me
08:14:35 <ricolin> s/topic/topics/
08:14:55 <tonyb> not from me
08:15:01 <ricolin> okay!
08:15:03 <ricolin> #topic VPTG planning
08:15:16 <ricolin> so what's plan!
08:15:33 <ricolin> *the plan
08:16:06 <ianw> fyi infra has been working on jitsi i think
08:16:16 <tonyb> How much time do people want to dedicate to it?
08:16:46 <tonyb> If we could commit to say 4 hours we could do a jitsi call and hack on some aspect of the CI
08:17:02 <ricolin> for current status, I assume 1/4-1/2 day?
08:17:06 <tonyb> peobably couldn't merge much in that window but who knows?
08:17:21 <ricolin> 4 hours sounds reasonable
08:17:24 <ianw> true i think it's just about "i'm doing this and nothing else for a set period"
08:17:41 <tonyb> what about 2 hour sessions?
08:17:45 <tonyb> with a gap day?
08:17:59 <tonyb> It'd mean we had a few days to merge stuff ?
08:19:03 <ricolin> you mean like 2 hours in first day, and 2 for the third day?
08:19:13 <tonyb> ricolin: Yeah soemthing like that
08:19:21 <tonyb> ricolin: as a "hackfest" thing
08:19:27 <ricolin> works for me
08:19:37 <tonyb> we could also do status/education stuff
08:19:41 <ricolin> will it make sense if we also host BOF this time?
08:19:51 <tonyb> Sure
08:20:02 <ricolin> tonyb, good idea, but what to educate about?
08:20:54 <tonyb> ricolin: I don't know exactly .. the SIG mission, "sponsors" consumers?
08:21:05 <ianw> it woudl be good if devstack was working, and people could maybe try their plugins
08:21:31 <tonyb> ianw: Yeah that's be good
08:22:18 <ianw> https://zuul.opendev.org/t/openstack/build/efdb93a189194b6b9df912d07c59e726/logs is a run i did this afternoon, it looks like a lot of it passed
08:22:29 <ricolin> ianw, we still got about two months so it might work that time:)
08:22:32 <ianw> anyway, picking bits of that would be good for group discussion
08:24:04 <ricolin> we can also have SIG status report for sure
08:25:19 <ricolin> VPTG discussion will host online this week (4/2)
08:25:30 <ricolin> will have more detail from there
08:26:01 <tonyb> Cool
08:26:44 <ricolin> Wonder if users/ops will join too:)
08:26:57 <tonyb> I don't know
08:27:36 <tonyb> I can tell my friends that use Multiarch OpenStack once we know when it'll be
08:27:46 <tonyb> they're $my TZ
08:28:23 <ricolin> thanks tonyb! Some broadcast is also what we need:)
08:29:46 <tonyb> ricolin: Well we can spamm the twittreverse and I can ask the osops moderators to help out
08:30:03 <tonyb> ricolin: there were a couple of multi-arch consumers at the last meetup
08:30:41 <ricolin> tonyb, local meetup?
08:31:07 <tonyb> ricolin: It was the London one in January
08:31:32 <ricolin> cool
08:31:54 <ricolin> so we should also host user/ops feedback!!
08:31:58 <tonyb> https://etherpad.openstack.org/p/LON-2020-OPS-AGENDA
08:32:16 <ricolin> #link https://etherpad.openstack.org/p/LON-2020-OPS-AGENDA
08:32:27 <tonyb> ricolin: That may be a little be of a stretch at this stage ... but sure
08:32:47 <tonyb> ricolin: if only we could somehow provide real beer and a virtual meetup
08:33:38 <ricolin> we can list beer in most have item to join this vPTG!!
08:34:27 <tonyb> hehe
08:35:08 <ricolin> guess that's all we need to discuss about VPTG in this meeting
08:35:23 <ricolin> #topic Follow on CI Resources
08:36:26 * tonyb is strangely silent
08:37:00 <ricolin> ianw, any more update on devstack patch?
08:37:10 <ianw> no, i haven't been looking at that, sorry
08:37:21 <ianw> kevinz and i spent some time looking at node failures in the linaro us cloud
08:37:32 <ianw> turned out to be a lack of floating ips
08:37:38 <ianw> so we switched it to be ipv6 only
08:37:56 <ianw> that went in today, and seems to be working
08:38:07 <ianw> #link https://review.opendev.org/716112
08:38:10 <tonyb> ianw: ooo another IPv6 only cloud that's kinda cool
08:38:26 <ricolin> you means that cause failure in earlier patch set of https://review.opendev.org/#/c/708317/ ?
08:39:06 <ianw> ricolin: quite a few arm64 jobs, even in dib and kolla were returning NODE_FAILURE; they couldn't get a node to run on
08:39:14 <ianw> now we should be able to run at capacity
08:39:37 <ianw> we also discussed the linaro-london cloud, which is currently disabled, because the us cloud is better so we don't want to run jobs there
08:40:03 <ricolin> ianw, okay, I did saw some error message regarding that issue days ago, so just make sure it's the same thing
08:40:05 <ianw> we decided to leave it for a while; if us capacity gets exceeded we can turn it back on, but while us is not at capacity it doesn't make sense
08:41:31 <ianw> that's about all i have to report :)
08:42:15 <tonyb> If I wanted to play with tox -e py on arm64 .... which repos is zuul "watching"
08:42:15 <ricolin> ianw, I didn't see the wheels story in https://storyboard.openstack.org/#!/project/openstack/multi-arch-sig
08:42:27 <tonyb> ricolin: That's on me
08:42:39 <ricolin> oh! sorry ianw!
08:43:38 <ricolin> tonyb, just a reminder here:)
08:43:41 <ianw> tonyb: umm, not sure, you could probably just add a arm64 nodeset to a tox job and it ... might ... just work
08:44:19 <tonyb> ianw: okay I was kinda hoping you'd say that
08:44:45 <tonyb> #action tonyb write up the "wheels story" (and no they don't go round and round)
08:44:50 <ianw> it may run a some setup roles that may or may not be ready for that ... i'd be interested in fixing anything
08:45:06 <tonyb> #action tonyb try a basic tox job in a repo
08:45:27 <ricolin> thanks tonyb
08:47:46 <ricolin> from my part, the multi-arch image support for kubernetes/cloud-provider-openstack is ready, I'm working on multi-arch support for other OpenStack container images
08:48:04 <ricolin> like all the agent images we have
08:49:01 <ricolin> which will be something I plan to talk to teams in VPTG(or before)
08:49:57 <ricolin> For the CI resource pool, I didn't get any other company to take action to donate arm resources to CI as they once promised
08:50:10 <ricolin> but will keep tracking with them
08:50:48 <ricolin> ianw, tonyb anything happen recently regarding CI?
08:51:05 <tonyb> ricolin: Not for me
08:51:07 <ricolin> *any other things
08:51:16 <tonyb> the limited container images we had died
08:51:32 <tonyb> So thinking outside the box
08:52:31 <ricolin> sorry, not fully understand `the limited container images we had died`
08:52:38 <ricolin> try me again!
08:53:03 <tonyb> Hmm I need to think how we'd phrase this .... could we get the arm64 zuul to run jobs on a non opendev.org repo?
08:53:26 <ianw> as in run something against github?
08:53:42 <tonyb> ricolin: Sorry I've been working to get ppc64le conatiners and diskimages built to so that tripleo can work with upstream sources in multiarch
08:54:04 <tonyb> ricolin: they were building just fine and we were abouit the publish them but then the builders failed
08:54:15 <tonyb> ianw: I was thinking rdoproject
08:54:23 <ricolin> tonyb, got it:)
08:54:48 <tonyb> ianw: *possibly* against a couple of opendev.org/openstack/*tripleo* repos longer term
08:55:28 <ianw> tonyb: i mean, anything zuul is monitoring, could run an arm64 job; it's just a node type to choose from
08:56:36 <tonyb> ianw: sure for the opendev.org/openstack/*tripleo* ones yeah but zuul isnot monitoring anything in rdoproject
08:57:09 <tonyb> ianw: and I really don't know if one zull can monitor 2 places like that 'nor if that's something *everyone* would support/agree to
08:57:18 <tonyb> hence the "oustide the box" statement
08:59:26 <ricolin> #action ricolin update multi-arch container image support story task to storyboard
08:59:56 <ianw> tonyb: it could be added; although as you say, the technical may be the least of it
09:00:14 <tonyb> ianw: Something to think about down the road
09:00:49 <ianw> i think that because zuul is still setup by puppet mostly, https://opendev.org/opendev/system-config/src/branch/master/hiera/group/zuul-scheduler.yaml might be the place
09:02:06 <ricolin> Okay, shall we move the discussion back to multi-arch-sig channel?:)
09:02:39 <ianw> yep
09:02:46 <ricolin> thanks ianw tonyb for join this meeting!:)
09:02:48 <ricolin> #endmeeting