15:00:40 <witek> #startmeeting monasca
15:00:41 <openstack> Meeting started Wed Jan 30 15:00:40 2019 UTC and is due to finish in 60 minutes.  The chair is witek. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:44 <openstack> The meeting name has been set to 'monasca'
15:00:53 <witek> hello everyone
15:00:58 <joadavis> hello
15:01:03 <witek> hi joadavis
15:01:41 <witek> the agenda for today:
15:01:47 <witek> https://etherpad.openstack.org/p/monasca-team-meeting-agenda
15:02:17 <witek> #topic hacking version in monasca-agent
15:02:23 <witek> https://review.openstack.org/#/c/628767/
15:03:00 <joadavis> I think there were a few commits in different repos to try to update the hacking version.
15:03:26 <joadavis> Unfortunately, it looked like there are a number of places where new checks are not working with the existing code
15:04:17 <joadavis> Do we want to prioritize changing the monasca code to work with the new checks, or do we live with the old version of hacking?
15:04:28 <witek> indeed https://review.openstack.org/#/q/(projects:openstack/monasca+OR+project:openstack/python-monascaclient)+is:open+owner:melissaml
15:04:30 <joadavis> or disable the checks we don't like. :P
15:06:42 <witek> we could add this as a story with `low-hanging-fruit` tag
15:06:48 <witek> and add it to the board
15:07:04 <witek> what do you think?
15:07:09 <sc> \o/
15:07:26 <joadavis> yeah, that might be a good idea
15:07:31 <witek> hi sc
15:08:03 <witek> hacking is not listed in g-r or upper-constraints
15:08:57 <joadavis> I tend to not want to change code without a good reason.  But the changes shouldn't be too bad.
15:09:19 <joadavis> I wondered what the motivation for moving to the new hacking was. I didn't see a community goal for it
15:09:58 <witek> some places with low coverage might be tricky
15:10:47 <witek> ok, I'll create a story and add to the board
15:11:13 <witek> #action add story for updating hacking version
15:11:34 <witek> #topic Kafka upgrade
15:11:45 <witek> https://review.openstack.org/629876
15:11:52 <joadavis> cool. we can have a task for monasca-agent and one for monasca-transform (and any other repos)
15:12:10 <joadavis> yes, kafka.  Sorry to bring it up again
15:12:43 <witek> Doug has left the comments
15:12:56 <joadavis> the comments were good
15:13:10 <witek> I actually agree with both toabctl and Doug :)
15:13:29 <witek> we should test new versions in CI
15:13:30 <joadavis> are there some additional testing we can define to get confidence and move forward?
15:13:52 <joadavis> CI testing is good/necessary
15:14:12 <joadavis> but maybe something at a larger scale to test the new performance?
15:14:55 <joadavis> I suggest that, but don't know who could do that
15:15:17 <witek> when I was testing I've adapted the tests Matthias has published
15:15:47 <witek> https://github.com/monasca/monasca-perf/tree/master/kafka_python_client_perf
15:16:07 <witek> I remember I had to change couple things
15:17:16 <witek> at Fujitsu we also did endurance testing, running Monasca under mid heavy load for week or two
15:19:22 <witek> I haven't noticed any deprecation warnings in logs of new Kafka
15:19:55 <joadavis> That might be good. The perf tests I expect would be ok, and toabctl has tested enough that any deprecation warnings should have popped up
15:20:26 <joadavis> I think the area of risk is in overall Monasca behavior, which something like an endurance test should find
15:21:10 <witek> I'd suggest to keep the change in review to get some more confidence that the new version works well for us
15:21:23 <witek> and also give a chance for everyone to test in their env
15:23:06 <witek> is that OK?
15:23:52 <witek> #topic notification engine clean-up
15:24:01 <witek> https://review.openstack.org/603154
15:24:23 <witek> this one hangs for a longer time already
15:25:56 <witek> I should actually update the board and put this one on it
15:26:52 <witek> it would be also good to merge this one first https://review.openstack.org/622361
15:27:09 <witek> to get DB schema properly installed in DevStack
15:27:11 <joadavis> yes, I'd glanced at that 603154 but hadn't done a review yet
15:28:01 <joadavis> the devstack update is definitely good.
15:28:20 <joadavis> should we merge it?  or I can try doing a fresh devstack with the change to verify
15:28:22 <witek> right now notification types enumeration is still initialized by sql script
15:29:06 <witek> I've tested my change locally both with Python 2 and 3 and it worked
15:29:40 <joadavis> works for me.  Should I workflow the devstack change?
15:30:41 <witek> fine with me, it's my change :)
15:31:17 <joadavis> done :)
15:31:21 <witek> thanks
15:31:41 <witek> I'll update the board with current reviews
15:32:07 <witek> just for reference, here's our board:
15:32:15 <witek> https://storyboard.openstack.org/#!/board/111
15:32:28 <witek> #topic open stage
15:33:12 <witek> no other topics?
15:33:43 <joadavis> none from me. just juggling a bunch of internal bugs
15:34:55 <witek> sc: will you attend the summit?
15:34:59 <joadavis> unfortunately that does mean I haven't thought about the vitrage integration in a while either
15:35:59 <witek> OK, if there are no other topics I'll close now
15:36:13 <witek> thanks for joining
15:36:16 <witek> bye
15:36:29 <witek> #endmeeting