15:00:50 <witek> #startmeeting monasca
15:00:51 <openstack> Meeting started Wed Mar 14 15:00:50 2018 UTC and is due to finish in 60 minutes.  The chair is witek. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:55 <openstack> The meeting name has been set to 'monasca'
15:01:03 <jgr> Hello
15:01:05 <sc> witek: yo
15:01:05 <witek> hi
15:01:07 <dougsz> hey there
15:01:09 <amofakhar> Hello
15:01:19 <witek> nice to see you all
15:01:34 <witek> we've got some topics in the agenda
15:01:37 <witek> let's start
15:01:45 <witek> #topic Rocky priorities
15:01:54 <sc> surprise surprise! I have an hour for the meeting!
15:01:55 <witek> https://review.openstack.org/552896
15:01:58 <witek> :)
15:02:21 <witek> I have sorted the topics according to accumulated points
15:02:30 <amofakhar> I did it already
15:02:39 <amofakhar> looks good
15:02:57 <witek> the rendered output is here http://logs.openstack.org/96/552896/1/check/build-openstack-sphinx-docs/180a924/html/priorities/rocky-priorities.html
15:03:21 <witek> I have left left-over community goals as well
15:03:55 <witek> also merged logs related topics to one `Query logs pipeline`
15:04:47 <witek> again, it's not ultimate list, it's just a summary of topics which most of us find important
15:04:50 <witek> as orientation
15:05:25 <witek> as next step, it would be nice to have owners for each topic, at least from the first group
15:05:47 <witek> volunteers very welcome :)
15:05:51 <jgr> You can put my name next to the Alembic topic
15:06:11 <witek> thanks, will do
15:06:27 <amofakhar> I like to help in Alembic too
15:06:32 <witek> great
15:06:37 <sc> for the time I can dedicate to monasca "Support Python 3.5" it's enough for me, I cannot get more
15:06:49 <witek> it's fine too
15:07:25 <jgu_> you can put my name to the retention policy, and Scott Grasley and my name to the persister python performance/java deprecation
15:07:45 <witek> nice, thank you
15:08:05 <witek> for the retention policy, we could split it for Influx and Cassandra
15:08:34 <jgu_> yes once we get down to the db plugin level
15:09:20 <aagate> you can put me and jodavis next to monasca transform refresh
15:09:24 <witek> I'll add the names to the list
15:09:33 <witek> for the rest we can fill in later
15:10:00 <witek> I have also started adding tasks which we already have to the Board
15:10:07 <witek> https://storyboard.openstack.org/#!/board/60
15:10:12 <sc> we can update as work is done and we have time, can't we?
15:10:56 <witek> sc: you mean update prio owners?
15:11:07 <sc> witek: yes
15:11:42 <witek> yes, so if someone has time and would like to lead one of the topics, we can put him/her in the list
15:11:51 <witek> anytime
15:12:38 <witek> for the Board, I still haven't checked if we can automatize it
15:12:57 <witek> #action witek checks StoryBoard automation
15:13:49 <jgr> Automation is good :-)
15:14:23 <witek> I guess, I'm done for the fist point
15:14:42 <witek> #topic DB migration spec
15:14:54 <witek> https://review.openstack.org/552030
15:15:23 <witek> we already have first review from nseyvet_ and amofakhar
15:15:30 <witek> thanks for the spec jgr
15:15:39 <jgr> No worries :-)
15:16:05 <witek> I'll review as well in the next days
15:16:40 * sc going to review COB
15:17:15 <witek> any comments on this?
15:18:03 <witek> #topic service domain for agent users
15:18:21 <witek> jgr: you seem to have an update from Keystone front
15:18:49 <jgr> witek: Indeed
15:19:27 <jgr> So the Keystone folks appear to be pretty happy with https://review.openstack.org/#/c/396331/ so far
15:19:58 <jgr> Even Adam Young likes it (he had some reservations about it initially)
15:20:38 <witek> sounds good, should we keep our prio topics though?
15:20:46 <jgr> It is looking good enough that I'm toying with the idea of giving https://review.openstack.org/#/c/507110/ an early overhaul to switch it to application credentials
15:21:17 <jgr> There is a risk with that: I don't know whether the Keystone side of this will be ready in time.
15:21:46 <jgr> But on the bright side we wouldn't need to build this elaborate hack with the service user domain only to tear it down again in the next release.
15:21:49 <jgr> Thoughts?
15:23:15 <witek> why not wait few weeks and see which progress Keystone implementation makes
15:23:28 <jgu_> yeah, I would lean towards to go for the final goal :-)
15:25:05 <jgr> Ok, good to hear that. That's pretty much my plan :-)
15:25:28 <jgr> (I don't want to rush into a domain based implementation early on)
15:26:00 <jgr> Meanwhile I'll have enough on my plate with the Alembic stuff anyway...
15:26:17 <witek> OK, please keep us updated on the whitelist progress
15:27:27 <witek> #topic spec for oslo.policy
15:27:46 <jgr> Will do
15:27:57 <amofakhar> comments are addressed and ready for review
15:28:05 <witek> thanks amofakhar
15:28:28 <witek> that's the second or third round of reviews
15:28:38 <amofakhar> yes it is
15:28:49 <amofakhar> third i think
15:29:54 <amofakhar> nothing more i just wanted to ask you to review it
15:29:57 <witek> adding for my list for this week
15:29:59 <witek> thanks
15:30:20 <amofakhar> thanks
15:30:34 <witek> change with implementation is also there
15:30:39 <sc> witek: amofakhar: could you share the URL for the review?
15:30:56 <amofakhar> https://review.openstack.org/#/c/511245/
15:30:59 <witek> spec https://review.openstack.org/#/c/511245/
15:31:01 <sc> thanks
15:31:01 <witek> :)
15:31:20 <witek> change with implementation is also there
15:31:28 <witek> https://review.openstack.org/#/c/546956/
15:31:47 <amofakhar> yes and it is waiting for review since before the PTG
15:32:00 <amofakhar> of course it is a big patch
15:32:34 <amofakhar> i am waiting for it to be reviewed and then start to work on monasca-log-api
15:33:22 <witek> reviews very welcome
15:33:36 * sc added himself
15:34:04 <amofakhar> thanks
15:34:05 <witek> thanks amofakhar for driving this
15:34:21 <amofakhar> ur welcome
15:34:42 <witek> #topic unit tests in monasca-ui
15:35:06 <amofakhar> I have seen in monasca-ui unit tests are not in /tests directory
15:35:22 <amofakhar> do you have any idea why it is not obey the role ?
15:35:45 <witek> no :(
15:35:54 <amofakhar> do you think it is ok?
15:36:10 <amofakhar> is it ok to do a clean up and move all tests into /tests ?
15:36:32 <amofakhar> because i have seen most of them has no unit test
15:36:55 <sc> amofakhar: for yes, the cleaner the better
15:37:09 <amofakhar> and it is better and recommended to have all tests in a place
15:37:28 <amofakhar> good, then i will do that in spare times
15:37:39 <witek> please compare with other horizon plugins
15:37:50 <amofakhar> sure
15:38:17 <witek> I've just looked at magnum-ui
15:38:23 <witek> they have similar structure
15:38:29 <witek> https://github.com/openstack/magnum-ui/blob/master/magnum_ui/content/clusters/tests.py
15:40:07 <amofakhar> I will check more plugins and search if there is any role about it or it's just a bad structure which is copied
15:40:18 <witek> good idea
15:42:00 <witek> thanks amofakhar
15:42:11 <witek> some more comments on this?
15:42:28 <amofakhar> thank u too
15:43:01 <witek> do we have other topics to discuss?
15:43:31 <witek> if not, thank you all
15:43:42 <witek> and see you next week
15:43:53 <witek> same place, same time :)
15:43:55 <amofakhar> good bye
15:44:00 <witek> bye bye
15:44:04 <dougsz> thanks
15:44:05 <sc> bye
15:44:07 <jgr> Bye
15:44:17 <witek> #endmeeting