15:00:02 <rhochmuth> #startmeeting monasca
15:00:03 <openstack> Meeting started Wed May  4 15:00:02 2016 UTC and is due to finish in 60 minutes.  The chair is rhochmuth. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:07 <openstack> The meeting name has been set to 'monasca'
15:00:08 <rhochmuth> o/
15:00:11 <bklei> o/
15:00:14 <fabiog> o/
15:00:18 <rhochmuth> https://etherpad.openstack.org/p/monasca-team-meeting-agenda
15:00:31 <rhochmuth> hi everyone
15:00:37 <mhoppal> hello
15:00:52 <bklei> hi
15:00:56 <rhochmuth> it looks like we have a full agenda
15:00:57 <jayahn> hi
15:01:09 <rbak> o/
15:01:10 <rhochmuth> hi jayahn
15:01:14 <witek> hello
15:01:40 <jayahn> good to see you here :)
15:01:48 <rhochmuth> is everyone recovered from last week
15:01:53 <rhochmuth> i'm not
15:01:56 <witek> :)
15:02:13 <rhochmuth> so, there is an agenda that i posted the link for up above
15:02:22 <rhochmuth> the first topic is mic-cycle planning
15:02:27 <rhochmuth> #topic mid-cycle
15:02:56 <witek> we would be interested in hosting mid-cycle in Munich
15:03:05 <witek> at the end of July
15:03:15 <rhochmuth> i put in a travel request with my mgmt
15:03:26 <rhochmuth> but, haven't heard back yet
15:03:32 <rhochmuth> i only asked last night
15:03:49 <fabiog> I can do it in Munich only 07/27-29
15:03:57 <bklei> i still need to get permission
15:04:06 <rhochmuth> hopefully, i'll know more in a couple of days
15:04:23 <rhochmuth> so, July 27, 28 and 29
15:04:25 <bklei> will others be able to travel to munich?
15:04:35 <rhochmuth> who cares
15:04:44 <bklei> :)
15:04:47 <fabiog> rhochmuth: don't be mean
15:04:58 <jayahn> i will not be able to travel to there.. almost for sure.
15:05:02 <rhochmuth> sorry, sometimes my fingers type on there own
15:05:18 <fabiog> alternatively Cisco could host it in SJC July 19 to 21
15:05:26 <rhochmuth> so, we'll need to get a head-count on who can travel
15:05:30 <rhochmuth> and see if this makes sense
15:05:45 <witek> we can set a doodle for that
15:05:48 <rhochmuth> let's try to get travel requests done by next week
15:06:00 <rhochmuth> ok, that sounds good too
15:06:18 <rhochmuth> jayahn, i don't recognoize your irc
15:06:40 <rhochmuth> can you introduce yourself
15:06:56 <jayahn> ah. yeap.
15:06:59 <jayahn> this is Jaesuk Ahn from skt.
15:07:11 <jayahn> from Korea, and it is midnight here. :)
15:07:12 <rhochmuth> ohh, got it
15:07:31 <rhochmuth> thanks for attending
15:07:39 <jayahn> no problem.
15:07:54 <rhochmuth> we are also talking about a new time slot for meetings
15:08:06 <rhochmuth> so, witek, you are going to create a doodle
15:08:11 <rhochmuth> that will be great
15:08:19 <witek> yes, for mid-cycle
15:08:20 <rhochmuth> i think i'm available for travel anytime
15:08:26 <rhochmuth> just don't know about travel budget
15:08:29 <witek> #action Witek sets doodle for mid-cycle
15:09:12 <rhochmuth> ok, let's sync-up next week on this topic and see if we can do a mid-cycle
15:09:13 <jayahn> for meeting time, midnight is not that bad for me. we can keep the current time.
15:10:08 <fabiog> I got the doodle up
15:10:13 <witek> :)
15:10:26 <fabiog> witek: sorry I was doing it without paying attention to the chat
15:10:28 <fabiog> http://doodle.com/poll/x6bf8ev6wvenfkdy
15:10:31 <rhochmuth> fabiog is a doodle master
15:10:32 <witek> np
15:10:54 <fabiog> rhochmuth: I should change my biz title into that :-)
15:11:30 <rhochmuth> Fabiog, Doodle Master Extrodianaire
15:11:34 <rhochmuth> at your service
15:11:47 <rhochmuth> Let's move on
15:11:57 <rhochmuth> #topic stable branch
15:12:06 <rhochmuth> https://review.openstack.org/#/c/306303/
15:12:23 <witek> yes, we have that obvious bug in monasca-ui
15:12:49 <witek> in my opinion we should mergre into stable
15:13:12 <bklei> i'm not sure about that -- i think we use /static at twc
15:14:17 <witek> hm
15:14:44 <bklei> will confirm and add a comment to review
15:14:50 <witek> OK, thanks
15:15:35 <rhochmuth> thanks bklei
15:15:49 <bklei> could you set STATIC_URL to / and have it work witek?
15:15:49 <rhochmuth> #topic reviews
15:16:26 <witek> but this would change the location of other static resources, right?
15:16:47 <bklei> yeah -- i guess so
15:17:28 <bklei> we can move on - will confirm if this patch would work for us
15:17:58 <rhochmuth> so there is revice https://review.openstack.org/#/c/307963/
15:18:10 <rhochmuth> fix metric-list limits
15:18:14 <bklei> twc REALLY wants this
15:18:29 <bklei> looks like it's in good shape?
15:18:43 <rhochmuth> ok, i'll review today, and probably end up merging
15:19:04 <bklei> awesome
15:19:15 <rhochmuth> witek, are you ok with this one
15:19:41 <witek> I haven't reviewed :(
15:19:57 <rhochmuth> it is basically a bug fix on metrics list
15:20:17 <rhochmuth> So, there is, https://review.openstack.org/#/c/289675/
15:20:29 <rhochmuth> i started reviewing this yesterday
15:20:57 <rhochmuth> bklei, it looks like you've +1'd that one
15:21:08 <rhochmuth> have you done any performance testing at twc
15:21:26 <bklei> just functional testing, no perf tests yet
15:21:28 <rhochmuth> also, to see the benefits of this change, you'll need to modify grafana 2
15:21:39 <rhochmuth> or rbak will
15:21:39 <bklei> yeah -- rbak is eager to do that :)
15:22:03 <rhochmuth> ok, assuming i get time today, i'll do a review and merge
15:22:13 <rhochmuth> this shouldn't impact anyone
15:22:29 <bklei> great -- yeah, shouldn't break any existing code path
15:22:32 <rhochmuth> the new capability is only enable if the group_by is specify as a qwuery param
15:22:49 <rhochmuth> so, this is low-risk
15:23:07 <rhochmuth> i'm assuming it will be merged today
15:23:21 <rhochmuth> https://review.openstack.org/#/c/306621/
15:23:35 <bklei> that's me
15:23:48 <bklei> i think i've rolled in feedback to date
15:24:04 <rhochmuth> well, you didn't get my feedback
15:24:10 <rhochmuth> :-)
15:24:10 <bklei> any objection to this given the larger conversation with the neutron ptl?
15:24:13 <bklei> :)
15:24:28 <rhochmuth> i'll start reviewing this one too
15:24:45 <rhochmuth> we didnt' discuss this with armando
15:24:51 <rhochmuth> but, we could add him to the review
15:25:02 <bklei> cool.  i'm guessing if we get neutron to start pushing data to monasca, it will give us more than this.  but this is the bare minimum our customers are asking for
15:25:10 <bklei> sure, will add him
15:25:28 <bklei> but i'm guessing, based on the conversations with him -- real code is years away :)
15:25:59 <bklei> is it armando dominguez?
15:26:45 <rhochmuth> Armando Migliaccio
15:26:50 <bklei> thx
15:27:04 <rhochmuth> he was at the 4th session last Wednesday
15:27:06 <bklei> added him
15:27:11 <rhochmuth> did you meet him
15:27:25 <bklei> i was in that session, but didn't talk with him directly
15:27:52 <bklei> i did talk with maryam tahhan -- she was thinking about doing something similar to my patch, so i added her
15:27:52 <rhochmuth> i'll add some folks from the hpe neutron team as well
15:27:59 <bklei> cool
15:28:00 <rhochmuth> like ed bak, ryan's dad
15:28:05 <bklei> +1
15:28:17 <slogan_> small world
15:28:25 <rhochmuth> hi syd
15:28:31 <slogan_> morning
15:28:45 <slogan_> sick as a dog, caught something on the flight back
15:28:50 <rhochmuth> yes, ed and ryan might be the first father son team in openstack
15:28:59 <slogan_> that's awesome
15:29:12 <rhochmuth> we might have an entire generation of openstackers
15:29:15 <rhochmuth> next
15:29:41 <rhochmuth> https://review.openstack.org/#/c/286281/
15:29:49 <rhochmuth> the infamous vertica hint
15:29:56 <rhochmuth> ok, will review
15:29:57 <bklei> :) that's me too
15:30:08 <bklei> thx. turned out to be pretty small change
15:30:19 <bklei> and keeps existing behavior, unless the cfg setting is there
15:30:45 <rhochmuth> btw, what happened with removing the temp tables
15:30:59 <rhochmuth> isn't there code that needs to be submitted for that one too
15:31:31 <bklei> yes, i'm on the hook for that
15:31:38 <bklei> hope to get to that next week
15:31:41 <rhochmuth> ok, sounds good
15:31:49 <rhochmuth> are you using that change in prodiuction already?
15:31:50 <bklei> i'd tested it, but needed cleanup.  it works though
15:32:15 <bklei> no -- not using the change yet
15:32:27 <rhochmuth> ok, will wait for your review
15:32:29 <bklei> so far, we haven't carried anything local
15:32:32 <bklei> cool
15:32:37 <rhochmuth> we're going to be picking up some of these changes too
15:32:50 <bklei> yeah -- that one in particular should really help vertica
15:32:58 <bklei> KV -- we'll see
15:33:11 <rhochmuth> https://review.openstack.org/#/c/251674/
15:33:24 <rhochmuth> https://review.openstack.org/#/c/285000
15:33:26 <bklei> that one and the next go together
15:33:39 <rhochmuth> Joe Keen is working on that
15:33:54 <bklei> yeah -- until this gets fixed, the rally tests we're trying to push for monasca are on hold
15:34:06 <rhochmuth> Ahhh, I see
15:34:09 <bklei> python client needs to be in global reqs for rally tests to work with monasca
15:34:24 <rhochmuth> So, I'm assumign Joe will try and get this resolved fairly soon
15:34:33 <bklei> awesome
15:34:45 <jkeen> bklei, do you know how much of Monasca needs to be in the projects.txt for your tests to work?
15:34:48 <rhochmuth> shoudl probably reach out to him if it starts getting delayed again
15:35:31 <bklei> jkeen -- not sure, i can connect you with yan, who knows more than me (via email)
15:35:54 <jkeen> That would be great.
15:36:12 <bklei> thx
15:36:52 <rhochmuth> so while we have joe and michael i wanted to let folks know about periodic notifications
15:37:00 <rhochmuth> #topic periodic notifications
15:37:51 <rhochmuth> joe, can you post link to blueprint?
15:39:03 <mhoppal> https://blueprints.launchpad.net/monasca/+spec/heat-integration
15:39:52 <rhochmuth> https://review.openstack.org/#/c/296813/
15:40:01 <mhoppal> basically we are adding in the ability to send a notfiication over and over at a given period until the state of the alarm it is associated with changes
15:40:07 <rhochmuth> https://review.openstack.org/#/c/310534/
15:40:20 <rhochmuth> https://review.openstack.org/#/c/308502/
15:40:23 <mhoppal> we are only allowing this on webhooks, we are doing this for heat autoscaling
15:40:26 <bklei> so we're saying 0 or 1 -- but should it be 0 or n?
15:40:34 <mhoppal> for now 0 or 1
15:40:39 <jkeen> 0 or 1 makes the problem much easier for now.
15:40:44 <mhoppal> but going forward we left it open to add more intervals
15:40:49 <jkeen> We can expand that later to a larger predefined set of intervals.
15:40:53 <mhoppal> pretty easy to add more intervals
15:40:57 <bklei> ok, and heat works with 1 minute re-alarms?
15:41:07 <rhochmuth> do we want units in minutes or seconds
15:41:23 <bklei> like -- is that what ceilometer does?
15:41:30 <jkeen> Yes, heat requested that timing.
15:41:35 <bklei> perfect
15:42:07 <rhochmuth> so, i have a couple of comments i'll add to the reviews
15:42:18 <rhochmuth> this does involve a schema change to mysql
15:42:24 <rhochmuth> postres, …
15:42:30 <rhochmuth> right?
15:42:41 <mhoppal> yes and also adding another kafka topic
15:43:13 <bklei> oooh, we'll need to track that in our puppet module
15:43:20 <rhochmuth> yup
15:43:37 <bklei> could you add the topic details to the blueprint?
15:43:48 <bklei> or is it in the docs in one of your reviews
15:44:04 <jkeen> I can add more information to the blueprint
15:44:17 <bklei> gracias
15:44:29 <rhochmuth> basically schema changes for databases and kafka changes
15:45:04 <bklei> ok, hopefully we'll have an upgrade path?
15:45:16 <rhochmuth> what's an upgrade path?
15:45:43 <witek> bklei: schema update script?
15:45:45 <bklei> upgrading the mysql schema
15:45:47 <bklei> yeah
15:46:10 <bklei> (we can't drop the db and start over)
15:46:10 <rhochmuth> we don't do db migrations, if that is what you mean
15:46:16 <bklei> yup
15:46:27 <rhochmuth> i think it is just the addition of a column
15:46:37 <bklei> ok, so an alter table command
15:46:39 <rhochmuth> https://review.openstack.org/#/c/308502/13/devstack/files/schema/mon_mysql.sql
15:46:57 <rhochmuth> currently called periodic_interval at the link above
15:47:02 <bklei> not too bad, we can migrate that ourselves
15:47:08 <rhochmuth> yes, just alter table
15:47:32 <rhochmuth> possible name change on the column based on feedback
15:48:02 <bklei> ok, we'll just need to remember to add the column when we pull that in
15:48:03 <bklei> thx
15:48:41 <rhochmuth> ok, will close on that topic then and look for feedback on reviews
15:48:59 <rhochmuth> i'm guessing this is a week or two from merging
15:49:53 <rhochmuth> on a side-note, we are looking into dropping the mysql from the api, and just have sqla
15:50:13 <rhochmuth> also, looking into the notification engine
15:51:00 <rhochmuth> #topic vitrage
15:51:17 <rhochmuth> so we had some interesting discussions with vitrage at the summit
15:51:24 <rhochmuth> they would like to integrate with monasca
15:51:34 <rhochmuth> i posted some requirements that they listed
15:51:51 <slogan_> where?
15:51:59 <rhochmuth> https://etherpad.openstack.org/p/monasca-team-meeting-agenda
15:52:07 <slogan_> ah, ok
15:52:17 <rhochmuth> i don;'t think we'll have time to discuss today unfortunately
15:52:25 <rhochmuth> but, i wanted to tee that one up
15:53:06 <slogan_> the alarm CRUD operations seems like good things to have
15:53:54 <rhochmuth> yeah, i think that makes sense, but i think it is more complicated than oru early discussions led us to believe
15:54:10 <rhochmuth> so, we'll need to have some design sessions on this one
15:54:21 <rhochmuth> on this topic
15:54:54 <rhochmuth> witek: does everythign make sense for the sproadic metrics and the latched alarms
15:55:32 <witek> yes, Tomasz rewrites his change in monasca-thresh
15:55:51 <rhochmuth> ok, hopefully we got it this time around
15:56:38 <witek> he has put what he's done sofar to gerrit
15:56:47 <witek> comments are wellcome :)
15:57:02 <rhochmuth> ok, i'll start taking a look
15:57:08 <rhochmuth> and i'll ping craig
15:57:34 <rhochmuth> so, we are down to two minutes
15:57:46 <rhochmuth> and we didnt' cover everything
15:58:05 <rhochmuth> also, next week the transform engine will be avaialble for review
15:58:14 <witek> cool
15:58:16 <rhochmuth> maybe we need two meetings
15:58:21 <rhochmuth> a week
15:58:22 <jayahn> cool
15:58:35 <bklei> :(
15:58:43 <rhochmuth> there is a blueprint on the transform engine
15:59:04 <rhochmuth> but, the actual design is still in progress of getting posted to the monasca wiki at
15:59:31 <rhochmuth> https://wiki.openstack.org/wiki/Monasca#Transform_and_Aggregation_Engine
15:59:38 <rhochmuth> Actually, it looks like it is all there
15:59:44 <rhochmuth> so, please start taking a look
15:59:52 <rhochmuth> they just published that last night
16:00:12 <rhochmuth> we've run out of time again
16:00:29 <witek> thank you Roland
16:00:30 <rhochmuth> i need to close the meeting
16:00:34 <jayahn> thanks
16:00:37 <slogan_> thanks Roland
16:00:37 <rhochmuth> bye everyone
16:00:38 <bklei> cya
16:00:52 <rhochmuth> #endmeeting