15:03:21 <d0ugal> #startmeeting mistral
15:03:21 <openstack> Meeting started Mon Oct 16 15:03:21 2017 UTC and is due to finish in 60 minutes.  The chair is d0ugal. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:24 <openstack> The meeting name has been set to 'mistral'
15:03:28 <d0ugal> Hey all
15:03:32 <bobh> o/
15:03:34 <d0ugal> Who is around for the Mistral meeting today?
15:03:35 <thrash> o/
15:04:34 <d0ugal> Renat can't join us today
15:04:42 <d0ugal> So I suspect this will be a fairly short meeting :)
15:04:59 <d0ugal> #topic Current status
15:05:25 <d0ugal> oops, I forgot the agenda and we had one action item
15:05:34 <d0ugal> but we can do that after the status updates
15:05:37 <d0ugal> Please share any updates
15:06:10 <d0ugal> bobh: Do you have anything to share?
15:06:29 <bobh> I sent email to the oslo team about adding a new project - Dough suggested treating it the same as a client library
15:06:37 <d0ugal> I have been mostly trying (but failing) to make progress on the action context bug. https://launchpad.net/bugs/1718353 - planning to work on it with Renat tomorrow morning (my time)
15:06:37 <openstack> Launchpad bug 1718353 in Mistral "The "context" parameter of Action.run() isn't filled properly for asynchronous actions" [High,In progress] - Assigned to Dougal Matthews (d0ugal)
15:06:45 <bobh> s/Dough/Dough/
15:06:50 <d0ugal> :)
15:06:57 <bobh> argh
15:07:07 <bobh> dhellman
15:07:38 <bobh> Anyway - probably need to discuss if we want to take that step, name for the project, etc
15:07:54 <d0ugal> bobh: I think it sounds like a good plan, I had read the emails.
15:07:56 <bobh> I'm happy to take the lead since I'm the instigator
15:08:20 <toure> still working through a few things, hope to finalize 506652 / 506653 today
15:08:51 <d0ugal> toure: cool, they are gerrit ID's right?
15:09:02 <toure> yes sir
15:10:05 <d0ugal> thrash, rbrady, apetrich - anything you'd like to share?
15:10:36 <rbrady> I unfortunately don't have any mistral status to share.  working on tripleo tasks for the previous week.
15:10:42 <thrash> d0ugal: checking on zuul v3 for the client repo. Will need to work more on moving the legacy jobs to use new zuulv3 interfaces.
15:11:00 <thrash> d0ugal: and the yamlparse and jsonparse patch landed, so I'm good there.
15:11:10 <d0ugal> thrash: did you see the request for tests?
15:11:23 <thrash> d0ugal: for... the parse?
15:11:30 <d0ugal> thrash: Yeah
15:11:35 <d0ugal> thrash: "<rakhmerov> thrash|g0ne: hi Brad, can you please add the tests for https://review.openstack.org/#/c/511616 ? I approved it by mistake but it's ok, we can add tests separately"
15:11:38 <thrash> d0ugal: I did not. I can work on that.
15:11:48 <thrash> d0ugal: ack
15:12:07 <d0ugal> #topic Open Discussion
15:12:34 <d0ugal> So I think we covered the agenda item there, last time we had an action for bobh to mail the list - that happened and it just needs to take the next step
15:12:39 <d0ugal> so now we can go into open discussion
15:12:47 <d0ugal> So, does anyone have anything they would like to chat about?
15:12:58 <bobh> any suggestions for project name for expressions package?
15:13:02 <d0ugal> If not, we can all spend 48 minutes doing bug triage ;)
15:13:20 <bobh> expressions is taken - mistral-expressions would work but implies a dependency that isn't really there
15:13:44 <d0ugal> bobh: taken where?
15:13:52 <bobh> pypi
15:13:57 <d0ugal> ah
15:14:32 <bobh> maybe something like evalexpr since that's what it does
15:14:36 <d0ugal> oslo.expressions could be an option - I am not sure if anyone can use the oslo prefix?
15:14:57 <bobh> That's a possibility - I can check with dhellman
15:15:07 <d0ugal> I think it will be something that is hard to explain in a name :)
15:15:13 <bobh> definitely
15:15:22 <d0ugal> It is a very abstract concept
15:15:50 <bobh> I need to find some abstract Greek or Roman reference
15:15:57 <d0ugal> hah :)
15:16:40 <bobh> I'll check on the oslo.expressions and go from there
15:17:01 <d0ugal> sounds good.
15:18:48 <d0ugal> Anything else?
15:19:03 <d0ugal> I'll wait a few mins and then end the meeting otherwise
15:19:29 <bobh> One other thing I'm looking for naming help with
15:19:41 <bobh> I'd like to have a join option that allows for "roads not taken"
15:20:14 <d0ugal> What does that mean?
15:20:44 <bobh> https://blueprints.launchpad.net/mistral/+spec/allow-join-success-on-partial-tree
15:21:13 <bobh> So there are times when there may be optional paths in a flow that may or may not happen depending on inputs
15:21:38 <bobh> join: all assumes that all paths are taken
15:21:54 <bobh> and any path not possible to take is considered an error
15:22:11 <d0ugal> Do you have an example?
15:22:33 <d0ugal> I think I understand but an example would be useful
15:22:38 <bobh> Say I'm deploying a service with a workflow and there are several different options for the service, that could run in parallel
15:23:07 <bobh> if one of the services is not needed (due to input values) then that path would not execute and the join: all would fail
15:23:15 <d0ugal> Right
15:23:47 <d0ugal> I wonder how Mistral could detect a failure vs "not-possible"
15:24:18 <bobh> there is a method that determines if a path is possible
15:24:31 <bobh> and if it's not possible it assumes error status
15:24:38 <d0ugal> Right
15:25:01 <bobh> I'd like an option to "ignore" the not possible paths
15:25:03 <d0ugal> join: started?
15:25:12 <bobh> that would work
15:25:34 <bobh> join: possible
15:25:39 <d0ugal> lol
15:25:44 <bobh> :-)
15:25:55 <d0ugal> If we have that I also want a join: impossible :P
15:26:06 <bobh> lol - that would be a cool feature
15:27:26 <d0ugal> Maybe you could have something like "join-paths: a, b, c
15:27:43 <d0ugal> and then you have to actually list the paths that need to join and we somehow name the paths in the workflow
15:27:49 <bobh> As long as we could eval the paths at runtime
15:28:04 <d0ugal> yeah, it could be an expression I guess
15:28:33 <bobh> I'll start the spec with "join: started" and we can discuss in the review
15:28:38 <d0ugal> Sounds like an interesting feature :) We only use join in a couple of simple places at the moment
15:28:43 <d0ugal> Sounds good!
15:29:03 <d0ugal> #action bobh to write a spec for "join: started"
15:29:20 <bobh> Thanks - we use it pretty extensively
15:30:03 <d0ugal> Anything else to discuss?
15:32:11 <d0ugal> Okay, I guess that is everything for today
15:32:16 <d0ugal> Thanks everyone for coming!
15:32:24 <d0ugal> #endmeeting