15:01:19 <rakhmerov> #startmeeting Mistral
15:01:20 <openstack> Meeting started Mon May 22 15:01:19 2017 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:24 <openstack> The meeting name has been set to 'mistral'
15:02:12 <rakhmerov> hi, anybody here from Mistral team?
15:02:12 <mgershen> o/
15:02:20 <rakhmerov> hi )
15:02:20 <bobh> o/
15:02:24 <toure> hello
15:02:38 <rakhmerov> let's wait 1 more minute
15:03:05 <rbrady> o/
15:03:08 <thrash> o/
15:04:01 <rakhmerov> ok, it's just been a week after the summit and the last meeting was devoted to the demo of Mistral GUI
15:04:34 <rakhmerov> so today I just would like to sync up on the current activities and further plans
15:04:59 <rakhmerov> #topic Current status (current tasks, plans, roadblocks)
15:05:10 <rakhmerov> if you have any updates, pls share them
15:05:39 <rakhmerov> my status: sent several patches with API layer optimizations, they were already merged
15:06:10 <rakhmerov> working on "Tracking previous tasks", need some more work to make "Join" case work, other than that it's done
15:06:18 <rakhmerov> also reviews as usually
15:06:41 <bobh> I'm working on some minor documentation improvements, should be pushed this week
15:07:05 <rakhmerov> bobh: thanks, and btw, also thanks for your patch for ad-hoc actions
15:07:45 <bobh> rakhmerov: np - it will be useful in our application and hopefully to others
15:07:57 <thrash> still working on the securing secrets impl
15:08:25 <d0ugal> Hey
15:08:32 <rakhmerov> bobh: indeed
15:08:36 <rakhmerov> d0ugal: hey )
15:08:41 <d0ugal> Looks like my connection dropped - I missed the start of the meeting
15:08:48 <rakhmerov> thrash: any roadblocks where we could help?
15:09:06 <thrash> rakhmerov: not at the moment.
15:09:06 <rakhmerov> d0ugal: no problem, we've just started
15:09:09 <rakhmerov> sharing updates
15:09:12 <rakhmerov> thrash: ok
15:09:27 <d0ugal> As for my status - I have been busy working on some TripleO workflows - but I am mostly done with that now, so as of today I am back working on the mistral-extra work. So I am going to be getting it ready for the openstack actions.
15:09:43 <d0ugal> I am just trying to remember where I was with it and what I need to do next :)
15:09:45 <rakhmerov> please go over the items you're assigned to for the current milestone (pike 2)
15:09:51 <rbrady> I'm working with thrash a little on the securing secrets, planning to add some more actions to tripleo
15:09:53 <rakhmerov> it ends on June 8, as far as I remember
15:09:53 <toure> status: working on closing errors in workflow error analysis, mainly around the mistralclient, after which I plan on improving the sqlalchemy query to be bit more flexible
15:10:43 <rakhmerov> d0ugal: the last thing I saw (and merged) was apetrich_ 's patch to switch all our actions to the class from mistral-lib
15:10:57 <rakhmerov> it's a pretty much all we need, as far as I understand
15:11:09 <rakhmerov> the next step can be just moving them over to mistral-lib, IMO
15:11:22 <rakhmerov> rbrady: ok, good
15:11:42 <rakhmerov> toure: any roadblocks?
15:11:53 <toure> pecan.py :)
15:11:57 <d0ugal> rakhmerov: yeah, I agree - there are a few extra things, like a config for enabling/disabling actions for projects etc.
15:12:20 <d0ugal> toure: lol, I've used it in anger a few times in the past if I can help.
15:12:34 <toure> d0ugal thanks
15:12:44 <rakhmerov> ok
15:13:01 <toure> I am slowly working through it, I will ping you if I hit a brick wall
15:13:18 <rakhmerov> rbrady, d0ugal: what I'm also thinking about is start writing docs for mistral-lib users
15:13:22 <d0ugal> rakhmerov: Are we ready to merge the error analysis spec? https://review.openstack.org/443217
15:13:27 <rakhmerov> toure: ok
15:13:41 <rakhmerov> d0ugal: I need to look at it again
15:13:48 <rakhmerov> I thought we had some questions there
15:14:08 <rakhmerov> but again, I'm for more agile approach at this point
15:14:17 <d0ugal> rakhmerov: k, thanks - I just voted, the last change just removed the WIP I think.
15:14:40 <rakhmerov> ok
15:14:42 <d0ugal> rakhmerov: +1, I think the spec covers the problem well and general solution - it will be hard to work out more details without trying out patches and giving feedback.
15:15:02 <rakhmerov> #action rakhmerov: review https://review.openstack.org/443217 again
15:15:20 <d0ugal> rakhmerov: good idea, I actually have a draft blog post about mistral-lib, I just need to finish it. Maybe after I post it I can use some of it for documentation
15:15:28 <d0ugal> or use it as a start for documentation.
15:15:39 <rakhmerov> d0ugal: that would be great, yep
15:16:00 <rakhmerov> later (probably this summer) I'd like to spend a week or two for restructuring the entire docs
15:16:14 <d0ugal> +1
15:16:28 <d0ugal> I've often thought about doing that too :)
15:16:49 <rakhmerov> I'm not saying I will be doing the whole thing myself. But I'd like to start with it and maybe we'll split it into different workstreams
15:16:53 <rakhmerov> :)
15:16:59 <rakhmerov> awesome, we'll do it
15:17:14 <rakhmerov> and this is one of our goals for this year )
15:17:36 <d0ugal> Yeah, I think first we should define a new documentation structure and then we can split it up and move the new docs to match it and fill in the gaps.
15:17:47 <rakhmerov> mgershen: Michal, do you know when you can get back to Mistral tasks?
15:18:22 <rakhmerov> d0ugal: yeah, what I also want to do is to somehow describe common principles on how we write docs
15:18:25 <rbrady> +1 for defining a structure and making it easier for mulitple contributors
15:18:28 <mgershen> I hope this week
15:18:28 <rakhmerov> don't know how, honestly :)
15:18:30 <rakhmerov> but I'd like to
15:18:34 <rakhmerov> mgershen: ok )
15:18:41 <rakhmerov> yep
15:19:23 <rakhmerov> this week when I finish my current task I'll move to HA work
15:19:42 <rakhmerov> I'm planning to start writing more tests targeted to test Mistral in HA
15:19:59 <rakhmerov> so that will be for another goal set for this year )
15:20:22 <rakhmerov> that work is pretty much endless but I'll try to participate in other things as much as I can
15:20:22 <d0ugal> great
15:20:41 <rakhmerov> ok
15:21:04 <rakhmerov> rbrady, thrash, bobh: I think I forgot to ask you last time, how was the summit in general?
15:21:22 <rakhmerov> I mean, this was a little new format and I wonder how it worked out
15:22:01 <bobh> rakhmerov: I think it works but I did miss the ore technical discussions that were held at the PTG - I'll need to get to Denver
15:22:21 <rbrady> rakhmerov: I thought the summit was okay.  there were a few talks I couldn't make it to because of scheduling conflicts
15:22:37 <bobh> rakhmerov: it's still an overwhelming number of sessions and I always find out on Thursday that there was a session on Tuesday that I should have attended
15:22:54 <rakhmerov> bobh: ok
15:23:05 <rakhmerov> ooh, btw, I asked for the room in Denver for Mistral
15:23:09 <rakhmerov> for two days
15:23:20 <rakhmerov> so please plan to join
15:23:26 <rbrady> cool.
15:23:33 <rakhmerov> 3 days I think was a little to much last time
15:23:41 <rakhmerov> 2 sounds sufficient
15:23:44 <rbrady> I have to drop.  I will see you all on IRC.
15:24:04 <rakhmerov> sure
15:24:18 <rakhmerov> so, I'm actually out of topics for today, just wanted to sync up
15:24:19 <toure> rakhmerov will it have video conferencing ability :)
15:24:25 <rakhmerov> as far as I can tell, things are going ok
15:24:43 <rakhmerov> toure: PTG?
15:24:47 <toure> yeah
15:25:00 <rakhmerov> hm.. I think it's doable if we ask it in advance
15:25:06 <toure> just for folks who may not be able to make it
15:25:10 <rakhmerov> I can try to organize that
15:25:14 <toure> cool
15:25:15 <rakhmerov> yes, I see
15:25:36 <rakhmerov> any other topics from you guys?
15:25:53 <d0ugal> Nope, nothing else from me
15:25:57 <toure> nope I am good
15:26:16 <rakhmerov> ok, let's finish earlier then
15:26:25 <rakhmerov> thanks for joining, have a good week!
15:26:30 <rakhmerov> bye
15:26:34 <rakhmerov> #endmeeting