15:00:30 <d0ugal> #startmeeting Mistral
15:00:31 <openstack> Meeting started Mon Apr 17 15:00:30 2017 UTC and is due to finish in 60 minutes.  The chair is d0ugal. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:35 <openstack> The meeting name has been set to 'mistral'
15:00:47 <d0ugal> Hey all, who is here for the Mistral meeting?
15:01:14 <d0ugal> rakhmerov was unable to make it today, so you are stuck with me ;)
15:02:46 <sharat> hi
15:02:55 <thrash> o/
15:02:55 <rbrady> hello!
15:02:58 <apetrich> o/
15:03:49 <d0ugal> yay :)
15:03:59 <d0ugal> okay
15:04:04 <d0ugal> #topic Review Action Items
15:04:28 <d0ugal> 1. mgershen: create a BP about "on-error" semantics
15:04:50 <d0ugal> That is the only action item, and since mgershen isn't here - I'll just re-add it for next week to make sure it isn't forgotten.
15:05:22 <d0ugal> #action mgershen: create a BP about "on-error" semantics
15:05:33 <d0ugal> I see that was actually copied from the previous week last time too
15:05:59 <d0ugal> so I'll try and ping people this week so that doesn't happen again - we can probably drop it if it comes up again next week.
15:06:09 <d0ugal> #topic Current Status (by team members)
15:06:23 <d0ugal> Please share your statuses.
15:07:26 <d0ugal> I am working towards moving the OpenStack actions to mistral-extra. Now we have a mistral-lib release that is making things much easier - it is progressing slowly.
15:08:21 <rbrady> mostly working on other stuff last week.  this week looking at prepping for boston and working on a bug for openstack-actions (will likely coordinate with d0ugal)
15:08:28 <thrash> I am almost done writing up an email outlining the changes I've proposed to the gate jobs. Planning to begin some work on the secure secrets feature.
15:08:40 <d0ugal> rbrady: oh, which bug is that? :)
15:08:49 <sharat> i am working on dashboard improvements and keystoneclient migration
15:09:44 <d0ugal> thrash: great, thanks for writing up - hopefully I'll be able to understand it more!
15:10:28 <rbrady> d0ugal: https://bugs.launchpad.net/mistral/+bug/1640394
15:10:30 <openstack> Launchpad bug 1640394 in Mistral "Can't pass kwargs to openstack clients" [High,New] - Assigned to Ryan Brady (rbrady)
15:10:58 <d0ugal> sharat: do you have some dashboard patches that need reviews?
15:11:30 <sharat> https://review.openstack.org/#/c/446945/
15:11:40 <apetrich> I'm removing the mistral dependency from tripleo-common was able to do a successful deploy with and using a patched mistral-lib and mistral
15:11:46 <d0ugal> rbrady: oh yeah, I remember that one. I think it could be quite tricky.
15:11:51 <sharat> https://review.openstack.org/#/c/454156/
15:11:54 <d0ugal> or, at least, I don't know how to solve it :)
15:12:03 <rbrady> d0ugal: +1.  sounds fun :)
15:12:09 <sharat> https://review.openstack.org/#/c/455275/
15:12:26 <sharat> https://review.openstack.org/#/c/453656/
15:12:34 <d0ugal> sharat: cool, thanks - we really need more reviews on the dashboard code. Unfortunately I have never even used it :/
15:12:41 <d0ugal> apetrich: great.
15:12:51 <sharat> https://review.openstack.org/#/c/452066/
15:13:10 <sharat> https://review.openstack.org/#/c/453573/
15:13:18 <sharat> d0ugal, this is it for now
15:15:07 <d0ugal> sharat: lots of patches :) I'll try and take a look, but I'm not sure I'll have time this week.
15:15:14 <d0ugal> Okay, moving on...
15:15:24 <sharat> d0ugal, sure.. take ur time :)
15:15:59 <d0ugal> #topic Pike 2
15:16:10 <d0ugal> I just want to touch on this quickly.
15:16:52 <d0ugal> Pike 1 was released last week \o/ - so we are now working towards Pike 2, which is released June 5th - 9th. So we have just under 2 months.
15:17:09 <d0ugal> I know that rakhmerov has been doing some planning to see what we should target for Pike 2
15:17:38 <d0ugal> This is what we have so far - https://launchpad.net/mistral/+milestone/pike-2
15:17:50 <d0ugal> It looks like Renat is going to be very busy :)
15:18:15 <d0ugal> Can everyone take a look at that and see if what they are working on is missing? and check anything that is assigned to them?
15:18:21 <d0ugal> thrash: we need to add your spec at least.
15:18:29 <d0ugal> (assuming you are targetting p-2)
15:18:34 <thrash> d0ugal: ack
15:19:10 <d0ugal> Actually, it is there.
15:19:23 <d0ugal> It just has no Assignee, I searched for your name.
15:19:39 <d0ugal> I don't have permissions to edit this - so if you spot anything, ask rakhmerov to update it :)
15:20:05 <d0ugal> #action Team to review pike-2 bugs and blueprints - checking everything is there and looks correct
15:21:08 <d0ugal> Moving on...
15:21:29 <d0ugal> #topic Open Discussion
15:21:39 <d0ugal> That is most of what I have today.
15:21:48 <d0ugal> Does anyone have anything they would like to discuss?
15:23:14 <sharat> nothing from my side :)
15:23:30 <rbrady> how about Boston?
15:23:30 <d0ugal> One idea I'd like to share, when I was chatting earlier I came up with this idea: https://blueprints.launchpad.net/mistral/+spec/mistral-tasks-branch
15:23:50 <d0ugal> rbrady: sure, we can talk about that - I don't know much about it.
15:24:01 <d0ugal> Who is planning on going to the Boston summit?
15:24:59 <thrash> I will be there.
15:25:00 <sharat> my lightning talk has been accepted on meteos
15:25:10 <rbrady> There is supposed to be a Mistral Onboarding event there and I was wondering if the mistral community had any ideas on how that should be executed
15:25:20 <sharat> not sure if I will make it or somebody else is presenting
15:26:06 <d0ugal> rbrady: https://www.openstack.org/summit/boston-2017/summit-schedule/events/18708/mistral-project-onboarding?BackURL=https%3A%2F%2Fwww.openstack.org%2Fsummit%2Fboston-2017%2Fsummit-schedule%2Fglobal-search%3Ft%3Dmistral%23eventid%3D18708
15:26:15 <rbrady> sharat: meteos on its own or integration with mistral?
15:26:16 <d0ugal> woah, that is quite a link.
15:26:38 <d0ugal> sharat: congrats on being accepted!
15:26:43 <sharat> rbrady, meteos architecture and overview
15:26:57 <d0ugal> rbrady, thrash - do we know anyone else that is going? is toure?
15:27:06 <rbrady> d0ugal: read the overview, thought it might be a good idea to organize a bit more
15:27:33 <rbrady> d0ugal: I don't think toure is going, but I will ask
15:27:40 <sharat> d0ugal, thanks.. session was proposed but only lightning talk was accepted
15:27:54 <d0ugal> rbrady: it sounds like maybe you and thrash could run the onboarding ;)
15:28:27 <d0ugal> but yeah, it isn't very clear how it will work - maybe you can just hang out in the room and help people go through the tutorial and/or answer questions?
15:28:38 <d0ugal> I can always try and be available on IRC if that helps at all
15:28:46 <rbrady> d0ugal: thanks
15:29:08 <thrash> d0ugal: we are. :) Anyone else that will be there is welcome to join us.
15:29:20 <d0ugal> rbrady, thrash - shall I add an action for you to both to look into what is needed? :)
15:29:27 <thrash> d0ugal: sure.
15:29:33 <rbrady> d0ugal: ack
15:29:59 <d0ugal> #action rbrady and thrash to find out what is needed for running the mistral onboarding session in Boston
15:31:09 <d0ugal> Okay, anyone got anything else?
15:31:55 <d0ugal> if not, I'll wait a minute or two and then we can all be released
15:32:19 <rbrady> nothing else from me
15:33:24 <d0ugal> Okay, thanks everyone for coming!
15:33:41 <sharat> thank u :)
15:33:44 <d0ugal> I wont be around next week, but hopefully rakhmerov will be around.
15:34:25 <d0ugal> o/
15:34:27 <d0ugal> #endmeeting