15:00:30 <d0ugal> #startmeeting mistral
15:00:30 <openstack> Meeting started Mon Mar 20 15:00:30 2017 UTC and is due to finish in 60 minutes.  The chair is d0ugal. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:34 <openstack> The meeting name has been set to 'mistral'
15:00:53 <d0ugal> Hey all, who is around for the Mistral meeting?
15:01:04 <d0ugal> Renat is ill this week and asked me to run it.
15:01:07 <mgershen> o/
15:01:17 <toure> hi d0ugal
15:01:59 <apetrich> o/
15:02:08 * d0ugal looks for the action items from last time
15:02:11 <rbrady> o/
15:03:28 <d0ugal> #topic Review action items
15:03:35 <d0ugal> Okay, so there are a couple...
15:04:01 <d0ugal> rakhmerov: send an invitation to team members to a weekly meeting
15:04:16 <d0ugal> ^ that was completed. I got it anyway and you are all here \o/
15:04:27 <d0ugal> - d0ugal: file a bug about finding tests changing coverage randomly
15:04:34 <d0ugal> Also completed, let me find the bug link...
15:04:53 <d0ugal> #link https://bugs.launchpad.net/mistral/+bug/1672443
15:04:53 <openstack> Launchpad bug 1672443 in Mistral "The Mistral coverage report isn't consistent" [Medium,Confirmed]
15:04:59 <d0ugal> Nothing much else to say about that.
15:05:20 <d0ugal> (we can come back to it later if people want, but I've not looked at it since)
15:05:31 <d0ugal> - ACTION: d0ugal: check availability of rooms for team meeting at 15.00 UTC and send an announcement
15:05:40 <d0ugal> and that was the final action item, which was also done.
15:05:49 <d0ugal> so that's good, 3/3 done.
15:06:04 <mgershen> nice :)
15:06:16 <d0ugal> #topic Current status (what was done last week, roadblocks, plans)
15:06:33 <d0ugal> Please share anything you have for this week.
15:07:49 <d0ugal> I wrote a spec about moving the OpenStack actions to mistral-extra (and allowing other actions, like ansible, to be added too). Feedback would be appreciated: https://review.openstack.org/446996
15:08:08 <d0ugal> #link https://review.openstack.org/446996
15:08:10 <rbrady> custom actions api patch landed this week, working on porting keystone_utrils to mistral-extra this week.
15:08:19 <rbrady> s/this/last/
15:08:34 <d0ugal> rbrady: woo!
15:08:50 <toure> status -- working on poc for the workflow error analysis https://review.openstack.org/#/c/443217/
15:09:09 <toure> also picked up a new bug https://bugs.launchpad.net/mistral/+bug/1586987
15:09:09 <openstack> Launchpad bug 1586987 in Mistral "Keystone projects_create does not allow id parameter" [Medium,In progress] - Assigned to Toure Dunnon (toure)
15:09:24 <mgershen> status: I did code reviews in all the time I had allocated for mistral this week, and I think I won't have time to do actual work this week as well.
15:09:26 <toure> rbrady +1
15:09:41 <d0ugal> toure: oh, cool - that spec has updated quite a bit since I last looked. I'll review it again.
15:10:18 <toure> d0ugal yeah worked on it Friday
15:10:33 * ddeja waves to all :)
15:10:36 <toure> Renat and I discussed some of the changes he liked
15:10:58 <d0ugal> toure: so that sounds like the id parameter isn't used when it is passed in?
15:11:02 * toure waves back to ddeja :)
15:11:11 <toure> right
15:11:18 <d0ugal> mgershen: thanks, the reviews are much appreciated
15:11:37 <d0ugal> ddeja: hey ddeja, thanks for stopping by. Renat isn't around this week, we are currently doing status if you have anything to share.
15:12:02 <d0ugal> toure: how would we fix it? it almost sounds like a keystone bug?
15:12:24 <mgershen> d0ugal: happy to hear. ping me if you want something reviewed.
15:12:26 <toure> d0ugal I think it is, that is what I am working on tracing the input
15:12:56 <d0ugal> toure: okay, cool - I assume we allow users to pass anything if the python-*client accepts **kwargs
15:13:06 <d0ugal> since we can't tell what they want exactly.
15:13:35 <toure> right, the problem I think is keystone is dropping the kwarg
15:13:49 <toure> which is what I am working on proving
15:14:03 <ddeja> d0ugal: unfortunatelly nothing from my side last week
15:14:27 <d0ugal> toure: sounds good, thanks.
15:14:56 <toure> sure thing..
15:15:30 <d0ugal> I know that Renat wanted to do some bug triage this week
15:15:43 <d0ugal> but I think given he can't make it, it is probably best to postpone it until next week.
15:16:30 <d0ugal> However, I'd ask that everyone look at a couple of bugs and try and triage them :)
15:17:03 <d0ugal> #action Team to do some initial bug triage
15:17:33 <d0ugal> #topic Pike 1 planning
15:18:01 <d0ugal> This is on the agenda, but I don't have anything specific for it
15:18:33 <d0ugal> Does anyone have anything they want to raise related to Pike 1? Any issues etc. that we are not targetting for it already?
15:18:57 <d0ugal> It might actually be that this is still on the agenda from last time :)
15:19:10 <d0ugal> Okay, I guess we can move onto open discussion
15:19:17 <d0ugal> #topic Open discussion
15:19:20 <mgershen> I would like us to fix this issue/bp: https://bugs.launchpad.net/mistral/+bug/1672379
15:19:20 <openstack> Launchpad bug 1672379 in Mistral "default task on error not running when task fail to evaluate input" [Undecided,Invalid]
15:19:37 <d0ugal> mgershen: whoops, sorry, I went a bit quick - but we can talk about that now anyway
15:20:57 <d0ugal> mgershen: right, so on-error is called when an action errors but not when there is a problem with the task itself - like an expression problem error.
15:21:25 <d0ugal> mgershen: do you think you will be able to work on it?
15:21:31 <mgershen> yes, Renat said the same thing. it is a feature in his eyes.
15:21:46 <d0ugal> Interesting :) /me reads the comments
15:22:11 <mgershen> in pike I should have time, not sure if it will be ready in pike-1
15:22:56 <d0ugal> right, I understand Renats comment but I do think we want to make sure users have a way to catch these errors
15:23:13 <d0ugal> mgershen: Does the tag-defaults on-error get called?
15:23:16 <d0ugal> task-defaults*
15:23:42 <d0ugal> I guess no as it should be the same logic
15:23:43 <mgershen> no
15:24:13 <d0ugal> mgershen: shall I reopen the bug so we don't forget it?
15:24:46 <d0ugal> I guess maybe the fix isn't to make it call on-error, maybe we need a new way to handle these situations.
15:24:47 <mgershen> whatever is best for you, I don't mind.
15:25:03 <d0ugal> on-task-error but a better name :)
15:25:04 <mgershen> we can also put an action item to talk more on this when Renat is back.
15:25:25 <d0ugal> Good idea.
15:25:50 <d0ugal> #action mgershen/team to talk with Renat about bug https://bugs.launchpad.net/mistral/+bug/1672379
15:25:50 <openstack> Launchpad bug 1672379 in Mistral "default task on error not running when task fail to evaluate input" [Undecided,Invalid]
15:27:07 <d0ugal> Anyone got any other ideas, bugs etc. they would like to discuss?
15:28:49 <d0ugal> If anyone is familiar with Keystone sessions I'd appreciate their input on https://review.openstack.org/#/c/447380/ and https://review.openstack.org/#/c/447046/
15:29:36 <d0ugal> Otherwise I think I'll wait a minute or so and close the meeting if there isn't anything else
15:29:37 <toure> d0ugal I have started looking at that a few mins ago
15:29:50 <d0ugal> toure: cool
15:29:58 <toure> nothing jumped out yet, still looking
15:30:08 <d0ugal> I think we should update how Mistral creates clients to use Keystone sessions
15:30:25 <toure> agreed...
15:30:32 <mgershen> +1
15:31:10 <mgershen> possible in python-mistralclient too
15:31:16 <d0ugal> Aparently Heat is already doing this with most clients, Mistral is one of the few that don't allow it yet
15:31:32 <mgershen> *possibly
15:31:54 <d0ugal> mgershen: yeah, the two patches I linked ^ make it possible in mistralclient
15:32:11 <mgershen> oops :)
15:32:37 <d0ugal> #action d0ugal to make a bug about using KeyStone sessions when we create OpenStack clients
15:32:48 <d0ugal> I'll make a bug after the meeting for this, I don't think there is one.
15:33:13 <d0ugal> Right, anyone got anything else or should we all take 27 minutes to go and triage bugs? ;)
15:34:40 <d0ugal> 5
15:34:41 <d0ugal> 4
15:34:43 <d0ugal> 3
15:34:45 <d0ugal> 2
15:34:47 <d0ugal> 1
15:34:49 <d0ugal> #endmeeting