16:00:07 <ddeja> #startmeeting mistral
16:00:09 <openstack> Meeting started Mon Jul 25 16:00:07 2016 UTC and is due to finish in 60 minutes.  The chair is ddeja. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:12 <openstack> The meeting name has been set to 'mistral'
16:00:17 <ddeja> hello all
16:00:25 <mgershen> o/
16:00:26 <jpeeler> hello
16:00:26 <rbrady> hey!
16:01:15 <ddeja> Renat can't attend the meeting and asked me to chair. Let's start with first topic
16:01:29 <ddeja> #topic Review action items
16:02:15 <ddeja> there were 2 action items on Renat and one on hparekh, but they are not there
16:02:37 <ddeja> sore there is one left -> rbrady, jpeeler: start with initial proposal on security module for Actions API
16:02:54 <ddeja> so, how's the work going? :)
16:02:58 <rbrady> jpeeler and I have been discussing it
16:03:12 <rbrady> I have a question about the context info
16:03:39 <ddeja> hm?
16:03:48 <rbrady> reading the requirement of the context, it seems the mistral.context solves that and could be ported over to mistral-lib
16:04:27 <ddeja> I guess that would be possible
16:04:30 <rbrady> OR a separate security context could be created and mistral.context could have a property (security_context)
16:05:07 <d0ugal> Hey
16:05:08 <rbrady> I've been looking through the code base a bit to see if there is a reason to use one approach over the other
16:05:33 <rbrady> does anyone have any thoughts about this?
16:05:33 <d0ugal> Sorry I am late
16:05:43 <ddeja> d0ugal: no problem :)
16:06:01 <ddeja> rbrady: I'm not an expert in this part unfortunately
16:06:11 <ddeja> IMO both approaches are OK
16:06:15 <jpeeler> i would think that external actions are going to have all the same authentication requirements as a native mistral action would
16:06:43 <ddeja> jpeeler: as af as I remember yes
16:06:48 <d0ugal> +1
16:07:16 <jpeeler> so porting sounds to be reasonable if for no reason other than consistency
16:07:36 <rbrady> to me the question is about exposing other details from the mistral context to the custom actions and not just the security attributes listed in the spec
16:07:49 <ddeja> rbrady, jpeeler, are you US based?
16:07:55 <jpeeler> yes, east coast
16:08:08 <rbrady> is there any reason not to share the full mistral context to a custom action?
16:08:25 <ddeja> rbrady: let me look on the code...
16:09:48 <ddeja> rbrady: IMO there is no reason, but I may not think about something
16:10:13 <d0ugal> Maybe this should be discussed on openstack-dev to get more input?
16:10:25 <ddeja> I can ask Renat about this tommorow on IRC
16:10:30 <rbrady> ddeja: ack.  thanks.  I think we'll port the context over then and see how the review comments play out
16:11:02 <ddeja> #action ddeja to ask Renat about proting context
16:11:29 <ddeja> ok, thanks guys for the update on this update
16:11:48 <mgershen> even if the context won't be passed now, it can be added later.
16:11:52 <ddeja> #topic Current status (progress, issues, roadblocks, further plans)
16:12:58 <ddeja> My status: Finishing work on alternative RPC layer. One patch still waiting for merge and some small bugs to fix
16:13:03 <mgershen> my status: have some time to start working on this bug https://bugs.launchpad.net/mistral/+bug/1603941
16:13:03 <openstack> Launchpad bug 1603941 in Mistral "create workflow fails on data too long for column definition" [High,Confirmed] - Assigned to Michal Gershenzon (michal-gershenzon)
16:13:41 <rbrady> I'm working on the actions api utils and execution modules
16:15:33 <jpeeler> i'm working on client caching and i appreciate the reviews i received. will incorporate those changes soon
16:16:17 <ddeja> Anyone else wish to share their status? :)
16:17:41 <ddeja> #topic Open discussion
16:17:56 <d0ugal> I have been at EuroPython and travelling for work, so not had time for Mistral.
16:18:24 <ddeja> d0ugal: OK, no problem
16:18:27 <d0ugal> This week is also a bit crazy for me, hopefully back to normal next week. I really want to figure out how to finish this bug: https://bugs.launchpad.net/mistral/+bug/1597640
16:18:27 <openstack> Launchpad bug 1597640 in Mistral "with-items does not process ad-hoc action default values" [High,In progress] - Assigned to Dougal Matthews (d0ugal)
16:18:45 <d0ugal> If anyone has any ideas where I should go next with it, that would be great. So far I just have a failing test case
16:19:09 <ddeja> d0ugal: you mean some unit test?
16:19:14 <d0ugal> or if anyone wants to finish it because I am being slow, I am happy for them to take it on :) - I don't want to block anyone
16:19:30 <d0ugal> ddeja: Yup, a failing unit test; https://review.openstack.org/337696
16:19:42 * ddeja is looking
16:20:30 <ddeja> d0ugal: I can look at it (hopefully tommorow) and leave a comment in the review
16:21:33 <d0ugal> ddeja: Great, that would be very useful :)
16:21:48 <ddeja> Any other opens? If not, we can end the meeting erlier.
16:22:34 <ddeja> counting to 10... 1
16:22:38 <ddeja> 2
16:22:42 <ddeja> 3
16:22:45 <ddeja> 4
16:22:48 <ddeja> 5
16:22:51 <ddeja> 6
16:22:54 <ddeja> 7
16:22:57 <ddeja> 8
16:23:00 <ddeja> 9
16:23:06 <ddeja> 10. sold!
16:23:19 <ddeja> thank you all very much and see you next week :)
16:23:21 <d0ugal> Thanks ddeja!
16:23:30 <mgershen> Thanks bey!
16:23:41 <ddeja> #endmeeting