16:01:01 <rakhmerov> #startmeeting Mistral
16:01:01 <openstack> Meeting started Mon Apr  4 16:01:01 2016 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:05 <openstack> The meeting name has been set to 'mistral'
16:01:59 <akuznetsova> hi there
16:02:02 <hparekh_> hi
16:02:03 <rakhmerov> hi!
16:02:12 <rakhmerov> how are you guys?
16:02:16 <toddjohn> hi
16:02:25 <rakhmerov> toddjohn: hi
16:02:39 <hparekh_> Great ! How are you rakhmerov ?
16:02:56 <NikolayM> hi everyone!
16:02:59 <rakhmerov> I'm ok
16:02:59 <rakhmerov> still alive )
16:03:05 <rakhmerov> hey
16:03:44 <rakhmerov> ok, let's start
16:03:53 <rakhmerov> #topic Review Action Items
16:04:40 <rakhmerov> one action item was on me
16:04:42 <rakhmerov> 1. akhmerov: propose time slots for 2 different meetings (for 2 groups of people from completely different time zones)
16:04:49 <rakhmerov> it's done
16:05:06 <rakhmerov> I sent out an email today with proposed time slots
16:05:26 <rakhmerov> most likely we'll make it bi-weekly
16:05:46 <rakhmerov> so please reply to that email with your thoughts and ideas
16:05:53 <akuznetsova> ok
16:06:12 <rakhmerov> the topic is [openstack-dev] [mistral] Bi-weekly team meetings
16:06:21 <rakhmerov> next topic
16:06:33 <rakhmerov> #topic Current Status (by team members)
16:06:59 <rakhmerov> my status: sent a number of patches to fix various problems related to transactions and locks
16:07:32 <rakhmerov> specifically, https://bugs.launchpad.net/mistral/+bug/1524477
16:07:33 <openstack> Launchpad bug 1524477 in Mistral "After-task logic runs multiple times if tasks run in parallel" [High,Fix released] - Assigned to Renat Akhmerov (rakhmerov)
16:07:47 <hparekh_> my status: I will resume my work on mistral-items-filtering blueprint.
16:07:54 <rakhmerov> I fully investigated it, reproduced locally and fixed
16:08:11 <rakhmerov> hparekh_: ok, are there any roadblocks with that?
16:08:41 <hparekh_> rakhmerov, No
16:09:01 <rakhmerov> ok
16:09:15 <hparekh_> rakhmerov, I was busy with some other stuff. :)
16:09:29 <rakhmerov> ok, understood
16:10:16 <akuznetsova> my status: just track new commits and review them
16:10:35 <rakhmerov> ok
16:10:56 <rakhmerov> akuznetsova: could you please remind what has been done on HA gate so far?
16:11:22 <rakhmerov> as far as I remember you created scripts for managing individual Mistral processes
16:11:30 <rakhmerov> is this part completed?
16:12:22 <akuznetsova> rakhmerov, I've just added an ability to run mistral services in a separate processes and I was working on base for HA tests, I did't send it on review yet
16:13:09 <rakhmerov> akuznetsova: ok
16:13:13 <rakhmerov> thanks
16:14:17 <akuznetsova> now api/engine/executor can be run in separate processes or all-in-one, user can manage this
16:15:21 <rakhmerov> I see
16:15:24 <rakhmerov> ok
16:15:41 <rakhmerov> let's keep in touch on this
16:17:00 <rakhmerov> btw, Mitaka RC2 has been made
16:17:36 <rakhmerov> Today or tomorrow the final Mitaka version should be released
16:17:47 <rakhmerov> ok, anything else on this part?
16:18:11 <rakhmerov> NikolayM: Nikolay, had a chance to work on something?
16:18:45 <NikolayM> no, I just reviewed a few commits
16:18:48 <rakhmerov> щл
16:18:49 <rakhmerov> ok
16:19:16 <rakhmerov> #topic Open discussion
16:19:30 <toddjohn> Hi...i have one small item to bring up
16:19:38 <rakhmerov> toddjohn: go ahead
16:20:09 <toddjohn> Just wanted to let you all know we have a summit presentation that's been accepted: https://www.openstack.org/summit/austin-2016/summit-schedule/events/7102?goback=1
16:20:17 <toddjohn> on Mistral
16:20:51 <rakhmerov> yeah, I saw
16:20:53 <toddjohn> No action to be taken, just wanted to make you aware of it
16:20:56 <rakhmerov> that's cool
16:21:00 <toddjohn> cool
16:21:01 <akuznetsova> nice!
16:21:05 <rakhmerov> yep, thank you
16:21:16 <toddjohn> yeah, it's working really well
16:21:23 <toddjohn> thanks
16:21:23 <rakhmerov> I'm currently trying very hard to get my US visa
16:21:33 <rakhmerov> if that's successfull, I'll be there
16:21:38 <toddjohn> cool
16:21:41 <rakhmerov> yep
16:22:01 <toddjohn> that's all i had
16:22:05 <rakhmerov> there's also another presentation that's just called "Mistral - Task Management Service"
16:22:19 <rakhmerov> hparekh_ is a presenter and I'm a co-speaker
16:22:28 <toddjohn> cool!
16:22:31 <rakhmerov> as far as I understand hparekh_ can't go
16:22:40 <hparekh_> rakhmerov, YEAH :(
16:22:41 <rakhmerov> but I may go
16:23:00 <rakhmerov> hopefully I'll be able to make it )
16:23:09 <rakhmerov> if that happens please welcome to that talk too
16:23:18 <toddjohn> Unfortunately i can't go either but a colleague of mine will be going to give the talk
16:23:29 <rakhmerov> I see
16:23:49 <rakhmerov> btw, toddjohn, do you have anything shared on your topic publicly?
16:24:00 <rakhmerov> github or any other source
16:24:30 <toddjohn> Not at the moment.
16:24:32 <rakhmerov> I mean your vision on how to handle those notifications and run Mistral workflows
16:24:35 <rakhmerov> ooh, ok
16:24:43 <toddjohn> we have the blueprint of course
16:24:48 <rakhmerov> I'd love to see what you guys think on that
16:24:55 <rakhmerov> hm... which one?
16:25:09 <rakhmerov> can you give a link? I may have missed it
16:25:15 <toddjohn> and i'll be pushing up a spec hopefully by the end of the week
16:25:18 <toddjohn> let me get it
16:25:19 <toddjohn> one min
16:25:22 <rakhmerov> sure
16:25:57 <rakhmerov> we discussed back in Tokyo the approximate design for similar thing but never got to implementing it
16:26:14 <toddjohn> https://blueprints.launchpad.net/mistral/+spec/event-notification-trigger
16:26:15 <rakhmerov> so I'm wondering if we're on the same page
16:26:39 <toddjohn> i'll try to get the spec up there later this week
16:26:45 <rakhmerov> ok, cool
16:26:49 <toddjohn> so you can see in more detail
16:26:55 <toddjohn> what we have in mind
16:26:58 <rakhmerov> I'll have a look at the BP and leave my comments
16:27:03 <toddjohn> Sure, cool
16:27:16 <rakhmerov> #action look at https://blueprints.launchpad.net/mistral/+spec/event-notification-trigger and leave comments
16:27:24 <rakhmerov> #action rakhmerov: look at https://blueprints.launchpad.net/mistral/+spec/event-notification-trigger and leave comments
16:28:30 <rakhmerov> ok, I don't have anything else for now
16:29:16 <rakhmerov> just a small announcement: I just joined a new company where I'm supposed to be focusing on Mistral 90% of my time
16:29:30 <toddjohn> cool! Congrats!
16:29:46 <rakhmerov> it should help move project further
16:29:49 <rakhmerov> yeah, thanks )
16:29:51 <hparekh_> Congratulations !!!!
16:29:56 <rakhmerov> :)
16:30:23 <rakhmerov> ok, and hopefully we'll be having more people on our meetings once we adjust time slots
16:30:25 <rakhmerov> :)
16:31:00 <rakhmerov> alright, if that's all we have we can shut down the meeting
16:31:09 <rakhmerov> counting to 10
16:31:11 <rakhmerov> 1
16:31:12 <rakhmerov> 2
16:31:13 <rakhmerov> 3
16:31:13 <rakhmerov> 4
16:31:15 <rakhmerov> 5
16:31:17 <rakhmerov> 6
16:31:20 <rakhmerov> 7
16:31:21 <rakhmerov> 8
16:31:23 <rakhmerov> 9
16:31:26 <rakhmerov> 10
16:31:28 <rakhmerov> thanks guys! Bye
16:31:40 <hparekh_> bye ! Thanks
16:31:58 <rakhmerov> #endmeeting