16:01:05 <nikolaym> #startmeeting Mistral
16:01:07 <openstack> Meeting started Mon Nov 30 16:01:05 2015 UTC and is due to finish in 60 minutes.  The chair is nikolaym. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:10 <openstack> The meeting name has been set to 'mistral'
16:01:20 <nikolaym> hi everyone!
16:01:29 <akuznetsova> hi there!
16:01:49 <nikolaym> Let's wait a couple of minutes for others
16:03:15 <akuznetsova> we forgot to send an email with remainder
16:04:18 <nikolaym> #topic Review action items
16:04:20 <dzimine> hello
16:04:35 <nikolaym> hi dzimine!
16:04:38 <akuznetsova> hi
16:05:45 <nikolaym> Who is with us today? :)
16:06:50 <nikolaym> 1. rakhmerov, melisha: design "Mistral HA" and "Multi-region support" during M-1
16:07:27 <nikolaym> melisha, rakhmerov, are you here now?
16:07:37 <aspiers> I am lurking, since I am interested in the HA work
16:08:00 <nikolaym> M-1 is over on dec 3
16:08:46 <nikolaym> I move this item to m-2
16:08:58 <nikolaym> #action rakhmerov, melisha: design "Mistral HA" and "Multi-region support" during M-2
16:10:02 <akuznetsova> yes, seems that this one wasn't done
16:10:22 <nikolaym> Next topic
16:10:35 <nikolaym> #topic Current status
16:10:55 <nikolaym> So, let's share your status
16:11:11 <^Gal^> I started working on execution refresh when there's new data. this week I'll probably have some internal company tasks.
16:12:15 <dzimine> Gal, is this coming also with the change of API, like a longpoll or event endpoint?
16:12:33 <^Gal^> dzimine: no, just UI
16:13:03 <ddeja> I fixed bug 'task stuck in running state', but have problems with running tests. I'll be fixing tests this week
16:13:13 <nikolaym> My status: did a lot of review, helped with backporting process
16:13:58 <nikolaym> ddeja, good, I'll take a look on your patch tomorrow
16:15:10 <akuznetsova> my status: I am ready to make our gates voting, all needed patches were merged
16:15:24 <akuznetsova> will make it after mitaka-1
16:17:08 <nikolaym> xylan_kong, are you with us?
16:17:17 <dzimine> for m4dcoder: the time of the meeting is unfortunately the one he can't make, from next time on I'll be getting his status and sharing; he's full time on Mistral this week but I didn't sync on what exactly he is fixing.
16:17:48 <nikolaym> xylan_kong: I've seen many patches from you
16:19:30 <nikolaym> dzimine, thanks for the update
16:20:49 <nikolaym> #topic M-1 status
16:20:59 <akuznetsova> https://launchpad.net/mistral/+milestone/mitaka-1
16:21:53 <akuznetsova> we have 9 bps
16:22:06 <akuznetsova> 2 of them have 'not started' status
16:22:20 <akuznetsova> but I guess that it is incorrect
16:22:30 <akuznetsova> so I propose to update them
16:22:30 <nikolaym> Guys, all bps which are not finished during m-1 should be moved to m-2
16:22:42 <akuznetsova> let's update them first
16:22:58 <akuznetsova> to understand the actual status
16:23:06 <nikolaym> #action nikolaym: move incomplete bps to m-2
16:23:28 <nikolaym> Yes, you're right
16:23:44 <nikolaym> Let's update them
16:24:02 <akuznetsova> nikolaym, let's do it now
16:24:37 <dzimine> I'd like to discuss this blueprint https://blueprints.launchpad.net/heat/+spec/mistral-wf-signal-json-format. Short is I am not sure it's a right thing; putting it for the record here and will follow up by email on the list, or ping me on IRC.
16:26:51 <akuznetsova> seems that Noa is not here now
16:27:24 <nikolaym> dzimine, there a patch in heat for that bp
16:27:51 <akuznetsova> https://review.openstack.org/#/c/243087/
16:27:54 <dzimine> yes I saw that and this triggered the thinking. I can leave the comments in the patch.
16:28:40 <nikolaym> yes, I think it is the right way
16:30:53 <akuznetsova> let's return to mitaka-1 bps overview
16:31:15 <nikolaym> yes
16:31:24 <akuznetsova> 1. https://blueprints.launchpad.net/mistral/+spec/mistral-ceilometer-actions
16:31:37 <akuznetsova> I saw commits on the review
16:31:41 <nikolaym> This is done
16:32:10 <nikolaym> We already have ceilometer actions in our list
16:32:15 <akuznetsova> #action mark https://blueprints.launchpad.net/mistral/+spec/mistral-ceilometer-actions as 'implemented'
16:32:24 <nikolaym> As well as trove
16:32:35 <akuznetsova> 2. https://blueprints.launchpad.net/mistral/+spec/mistral-async-actions-doc
16:32:48 <akuznetsova> wasn't started at all
16:32:58 <nikolaym> It seems it is not started yet
16:33:08 <nikolaym> correct
16:33:26 <akuznetsova> will be moved to mitaka-2
16:33:35 <akuznetsova> 3. https://blueprints.launchpad.net/mistral/+spec/mistral-osc-plugin
16:33:54 <akuznetsova> this is done
16:34:04 <nikolaym> yes
16:34:13 <akuznetsova> #action mark https://blueprints.launchpad.net/mistral/+spec/mistral-osc-plugin as 'implemented'
16:34:33 <akuznetsova> 4. https://blueprints.launchpad.net/mistral/+spec/mistral-alternative-rpc
16:34:44 <akuznetsova> nikolaym, this one yours
16:34:47 <nikolaym> but before the release we should mark them as "beta available", not implemented
16:35:09 <nikolaym> it should be moved to m-2
16:35:15 <akuznetsova> ok
16:35:19 <nikolaym> It is in progress
16:35:35 <akuznetsova> #action move https://blueprints.launchpad.net/mistral/+spec/mistral-alternative-rpc to m-2
16:35:46 <akuznetsova> 5. https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-executions-screen
16:36:06 <akuznetsova> ^Gal^, did you finish this one ?
16:36:22 <nikolaym> Gal, could you comment on this?
16:36:22 <akuznetsova> can we mark is as 'beta available' ?
16:38:28 <akuznetsova> ok, another bps are done
16:38:34 <nikolaym> it seems ^Gal^ is not here
16:39:08 <akuznetsova> so, 2 bps will be moved to m-2
16:40:19 <akuznetsova> and we have 7 bugs in 'in progress' status, we need to try to merge fixes for them in m-1
16:41:20 <nikolaym> yep
16:41:27 <akuznetsova> I guess that overall status of m-1 is pretty good
16:41:55 <nikolaym> cool
16:42:23 <nikolaym> Let's see how backporting is going
16:42:42 <nikolaym> #topic liberty backporting status
16:43:17 <akuznetsova> do we have a list of commits which should be backported ?
16:43:57 <nikolaym> I don't have such list
16:44:09 <akuznetsova> https://review.openstack.org/#/q/mistral+branch:stable/liberty+status:open,n,z
16:44:25 <akuznetsova> we have 2 commit which aren't merged
16:44:31 <nikolaym> I should ask Renat about that
16:44:40 <akuznetsova> ok
16:46:08 <nikolaym> Anyway, a lot of patches are merged in stable/liberty for now
16:46:24 <akuznetsova> yes
16:46:49 <nikolaym> And I treat its status as "green"
16:47:45 <nikolaym> #topic Open discussion
16:48:01 <akuznetsova> I have nothing from my side
16:48:10 <nikolaym> Guys, what is needed to discuss?
16:48:24 <nikolaym> Any issues, roadblocks?
16:48:41 <ddeja> I have one question: are test on master branch working?
16:49:01 <akuznetsova> ddeja, which test ?
16:49:05 <ddeja> Because I have a lot of problem running it today
16:49:25 <ddeja> akuznetsova: unit tests run using tox
16:49:46 <akuznetsova> yes
16:49:46 <nikolaym> which one of tests?
16:50:03 <akuznetsova> here https://review.openstack.org/#/c/251043/ all python27 and python34 are green
16:50:16 <akuznetsova> need to check what is wrong in your commit
16:50:21 <nikolaym> All tests are working now
16:50:55 <ddeja> akuznetsova: OK, thanks. I have problem with tests on pure master, but it means i have something wrong in my configuration
16:51:03 <nikolaym> But a couple of tests are failong from time to time
16:52:22 <nikolaym> need to investigate the problem
16:53:02 <akuznetsova> yes, looks like problem can be in the made changes
16:54:49 <ddeja> OK, thanks. I'll investigate tommorow
16:54:51 <nikolaym> Let's wrap up the meeting
16:55:19 <akuznetsova> bye all
16:55:31 <nikolaym> yes, I'll also try to run the tests with your changes
16:55:33 <^Gal^> hi
16:55:38 <^Gal^> https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-executions-screen isn't finished
16:55:43 <^Gal^> what's left is the refresh
16:55:59 <^Gal^> sry, had my eyes on another screen
16:56:09 <nikolaym> Gal, ok
16:56:21 <nikolaym> Thanks for updating
16:56:30 <^Gal^> sure
16:56:35 <^Gal^> you could mark that as beta
16:56:39 <nikolaym> You are on time :)
16:56:51 <^Gal^> :D
16:57:11 <nikolaym> bye!
16:57:24 <^Gal^> chao!
16:57:24 <nikolaym> #endmeeting