16:00:41 <rakhmerov> #startmeeting Mistral
16:00:41 <openstack> Meeting started Mon Nov 16 16:00:41 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:46 <openstack> The meeting name has been set to 'mistral'
16:00:51 <nmakhotkin_> hi everyone!
16:00:55 <rakhmerov> hi, please name yourself! )
16:00:57 <rakhmerov> hi
16:00:58 <akuznetsova> hi there
16:01:00 <xylan_kong> hi
16:01:11 <akuznetsova> I am Nastya
16:01:51 <LimorStotland> Hi all
16:01:52 <akuznetsova> oops, you meant different
16:01:53 <rakhmerov> akuznetsova: we know that! :)
16:01:56 <rakhmerov> hi Limor
16:02:24 <rakhmerov> 1 min...
16:03:38 <rakhmerov> ok, I'm here
16:04:04 <rakhmerov> ^Gal^: hi, I approved https://review.openstack.org/#/c/245773/ but please fix a couple minor style issues with your next patches
16:04:10 <rakhmerov> ok
16:04:19 <rakhmerov> there's no special agenda for today actually
16:04:24 <rakhmerov> #topic Review Action items
16:05:01 <rakhmerov> 1. rakhmerov: create Mitaka series and milestone in python-mistralclient LP
16:05:08 <rakhmerov> #action rakhmerov: create Mitaka series and milestone in python-mistralclient LP
16:05:09 <rakhmerov> :)
16:05:25 <rakhmerov> 2. melisha: Write docs about https://blueprints.launchpad.net/mistral/+spec/mistral-async-actions-doc in M-1
16:05:27 <nmakhotkin_> :)
16:05:45 <rakhmerov> this should not be evaluated now, we'll be tracking it in LP
16:05:56 <rakhmerov> 3. rakhmerov, melisha: design "Mistral HA" and "Multi-region sport" during M-1
16:06:13 <rakhmerov> not done, I'll keep it for records
16:06:21 <rakhmerov> #action rakhmerov, melisha: design "Mistral HA" and "Multi-region support" during M-1
16:06:34 <rakhmerov> 4. rakhmerov: ping melisha and look at the bugs together
16:06:35 <rakhmerov> done
16:06:49 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:06:58 <rakhmerov> let's share our statuses quickly
16:07:14 <xylan_kong> one by one
16:07:22 <rakhmerov> specifically, I'm interested if you have any roadblocks preventing you fro moving forward
16:07:34 <rakhmerov> xylan_kong: go ahead
16:07:36 <xylan_kong> 1. [ready for review] complete the implementation of 'mistral workflow sharing as a reference implementation of resource sharing feature', https://review.openstack.org/244155
16:07:43 <xylan_kong> 2. [ready for review] complete integration of mistral client and openstack client, https://review.openstack.org/245034
16:07:51 <xylan_kong> 3. [merged] a good news! The mistral-spec repo has been merged in mistral namespace, please see https://github.com/openstack/mistral-specs
16:07:57 <xylan_kong> 4. [in progress] add reno support in mistral, which I'm also trying to understand its mechanism
16:08:02 <xylan_kong> 5. [always] review work
16:08:10 <rakhmerov> awesome!
16:08:20 <akuznetsova> my status: review, made a couple of minor patches, thinking about what do next
16:08:20 <rakhmerov> xylan_kong: I'll review your patches tomorrow
16:08:35 <xylan_kong> for mistral-specs, I'll make some initial changes and write a detailed introduction about the new process later on.
16:08:39 <rakhmerov> xylan_kong: let's talk about this new process today later
16:08:47 <xylan_kong> rakhmerov: oik
16:08:51 <LimorStotland> my status : working on internal alcatel issues  and we need to start testing mistral this week
16:09:01 <_gryf> Today was a first meeting for openstack-ha. Here is the link for the minutes: http://eavesdrop.openstack.org/meetings/ha__automated_recovery_from_hypervisor_failure/2015/ha__automated_recovery_from_hypervisor_failure.2015-11-16-09.00.html
16:09:05 <nmakhotkin_> my status: fixed work mistralclient with unverified keystone cert (SSL/TLS), fixing async actions to send callback url for sending result back to Mistral
16:09:21 <nmakhotkin_> also a lot of review today
16:09:34 <_gryf> the reason I'm rising it on mistral miting is the fact, that people are very interested in proposed mistral solution for evac task
16:09:49 <xylan_kong> _gryf: glad to hear that
16:09:53 <rakhmerov> my status: mostly doing reviews and bug review
16:10:23 <akuznetsova> _gryf, very interesting...
16:10:25 <xylan_kong> _gryf: i'll take a look to see how we can help for that
16:10:30 <_gryf> cool!
16:10:35 <rakhmerov> _gryf: I know that, I talked to a bunch of people about that at the summit (5-6)
16:11:05 <rakhmerov> #action rakhmerov: review http://eavesdrop.openstack.org/meetings/ha__automated_recovery_from_hypervisor_failure/2015/ha__automated_recovery_from_hypervisor_failure.2015-11-16-09.00.html
16:11:19 <rakhmerov> ok, we'll see what they discussed
16:11:54 <rakhmerov> ok, thanks
16:12:02 <rakhmerov> any serious roadblocks?
16:12:15 <rakhmerov> xylan_kong: can we already start using spec repo?
16:12:26 <rakhmerov> for our new big BPs
16:12:47 <xylan_kong> rakhmerov: not for now, need to put a template file and some directories
16:13:05 <rakhmerov> ok, let us know when it's done
16:13:10 <xylan_kong> but i think it will not be very late
16:13:11 <rakhmerov> ok
16:13:16 <rakhmerov> sure
16:13:22 <rakhmerov> #topic Open Discussion
16:13:36 <rakhmerov> xylan_kong: can you briefly tell us about this reno thing?
16:13:46 <rakhmerov> and changes to maintaining stable branches
16:14:07 <xylan_kong> rakhmerov: hehe, i 'm also trying to understand well about reno
16:14:08 <rakhmerov> these are 2 things I'm interested in (since you are a liason now)
16:14:24 <rakhmerov> what were you able to understand so far? :))
16:14:26 <rakhmerov> not much?
16:14:33 <xylan_kong> for now, i just copy something from the examples Doug have given
16:14:46 <xylan_kong> to make sure we are far behind it
16:14:51 <xylan_kong> not
16:15:08 <rakhmerov> any details?
16:15:34 <rakhmerov> ok, then let's talk about that offline once you get enough details
16:15:42 <LimorStotland> sorry for the dumb question but what is reno?
16:16:03 <rakhmerov> I saw that there was a bunch of info on that but I didn't have a chance to get familiar with it
16:16:05 <xylan_kong> in my undersdanding, reno will track the features or bugs made to mistral automatically
16:16:15 <rakhmerov> LimorStotland: yes, that's what I'm asking too
16:16:18 <xylan_kong> but you need add patches for the feature and bug description
16:16:31 <rakhmerov> ok
16:16:45 <dhellmann> xylan_kong : right, reno will organize the notes you add, but you have to write them yourself
16:16:45 <xylan_kong> LimorStotland: http://lists.openstack.org/pipermail/openstack-dev/2015-November/078301.html
16:17:02 <xylan_kong> dhellmann: ooh, you're here
16:17:07 <LimorStotland> Thanks xylan_kong
16:18:02 <rakhmerov> dhellmann: ok, we'll pick that up
16:18:02 <xylan_kong> rakhmerov, nmakhotkin_ , you can ask dhellmann for your questions, i think nobody understand reno better than him
16:18:03 <rakhmerov> thanks
16:18:09 <xylan_kong> dhellmann :-)
16:18:15 <nmakhotkin_> sure, thanks
16:18:39 <xylan_kong> and i will understand it by myself
16:19:13 <rakhmerov> ok, sure. I just don't want to ask dhellmann about that (knowing that he's extremely busy) until I read something (or ask you) that was sent out in ML
16:19:33 <dhellmann> sure, if you have deep questions please post as a follow-up to that mailing list thread so everyone can benefit from the answers
16:19:37 <xylan_kong> rakhmerov: ok, no problem
16:19:52 <rakhmerov> dhellmann: we will
16:20:05 <dhellmann> rakhmerov : thanks!
16:22:02 <xylan_kong> rakhmerov: you can add an action for me
16:22:05 <rakhmerov> so team, I don't have much else to discuss today. We're deeply in M-1 now
16:22:11 <xylan_kong> about reno
16:22:16 <rakhmerov> xylan_kong: you can add yourself :)
16:22:23 <rakhmerov> ok, let me do that
16:22:37 <rakhmerov> #action xylan_kong: learn about reno and share with the team
16:22:43 <xylan_kong> #action xylan_kong: understand better about reno
16:22:46 <rakhmerov> :)
16:22:51 <rakhmerov> double action!
16:22:52 <xylan_kong> :-)
16:22:58 <xylan_kong> that's fine
16:23:15 <rakhmerov> ok, so, I thank all of you, I see a lot of patches on review. I'll try to do a better job on reviewing them
16:23:21 <rakhmerov> and encourage everyone to do so
16:23:30 <rakhmerov> lots of good bugfixes
16:23:46 <xylan_kong> yes, i have put more efforts on code works these days
16:23:55 <rakhmerov> Moshe's patch about CT is about to get merged, I'm really looking forward to see it done
16:24:01 <rakhmerov> ok
16:24:13 <akuznetsova> I have a question
16:24:17 <rakhmerov> yep
16:24:21 <rakhmerov> go ahead
16:24:46 <LimorStotland> Moshe is working on functional tests
16:25:02 <akuznetsova> I want to start work on doing our dsvm gates voting
16:25:07 <rakhmerov> LimorStotland: IMO it should be a separate patch
16:25:31 <akuznetsova> before it I want to make some refactoring in mistral devstack scripts and functional tests
16:25:37 <LimorStotland> Ok i will let him know
16:25:46 <rakhmerov> akuznetsova: we can't technically do it before we figure out how to solve a cycle problem
16:25:52 <rakhmerov> betwee mistral and client
16:26:05 <rakhmerov> akuznetsova: yep
16:26:06 <rakhmerov> sure
16:26:17 <akuznetsova> I don't like your suggestion
16:26:21 <nmakhotkin_> agree with rakhmerov
16:26:48 <nmakhotkin_> how do we solve this cyclic dependency problem?
16:26:55 <akuznetsova> I think that it will be better to make all perfect and only after it make it voting :-)
16:27:00 <rakhmerov> don't know yet
16:27:15 <rakhmerov> akuznetsova: the problem is deeper than that :)
16:27:35 <rakhmerov> such situations will pop up anyway
16:27:44 <rakhmerov> when we have to break the gate
16:27:54 <akuznetsova> I remember about cycle problem, I am going to think about it too
16:28:10 <xylan_kong> rakhmerov, nmakhotkin_ what's the problem you mean? i am not sure i know that...
16:28:16 <rakhmerov> actually whenever we make incompatible API changes for example (e.g. if we're working on a new API and it's not ready yet)
16:28:23 <akuznetsova> need to investigate how other project live with it
16:28:33 <rakhmerov> akuznetsova: yes
16:28:43 <rakhmerov> xylan_kong: let me explain it tomorrow :)))
16:28:49 <xylan_kong> rakhmerov: fine
16:28:49 <rakhmerov> it's going to be a long conversation :))
16:28:52 <nmakhotkin_> I guess other projects don't launch client tests in main repo
16:28:52 <akuznetsova> xylan_kong, we run CLI tests on every commit to mistral
16:28:58 <xylan_kong> rakhmerov :-)
16:29:06 <xylan_kong> akuznetsova: yes
16:29:32 <xylan_kong> akuznetsova: are you sure you want to tell the story now?
16:29:34 <xylan_kong> :-)
16:29:54 <akuznetsova> xylan_kong, let me explain it later, I will send an email with our current situation and possible descision
16:30:06 <xylan_kong> akuznetsova: appreciate that
16:30:41 <rakhmerov> ok, let's save some time and end the meeting now
16:30:47 <rakhmerov> is that ok?
16:30:58 <rakhmerov> a lot of things to do :)
16:31:05 <xylan_kong> sure, nothing from my side
16:31:09 <rakhmerov> thanks! bye!
16:31:10 <nmakhotkin_> ok, sure
16:31:13 <xylan_kong> keep coding and reviewing
16:31:17 <akuznetsova> bye
16:31:18 <rakhmerov> alright!
16:31:18 <nmakhotkin_> bye!
16:31:20 <rakhmerov> #endmeeting