16:03:57 <akuznetsova> #startmeeting Mistral
16:03:57 <openstack> Meeting started Mon Aug 10 16:03:57 2015 UTC and is due to finish in 60 minutes.  The chair is akuznetsova. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:00 <openstack> The meeting name has been set to 'mistral'
16:04:10 <akuznetsova> hi there
16:04:19 <^Gal^> Hi all
16:04:20 <gpaz> Hi all
16:04:21 <m4dcoder> hi!
16:04:24 <LimorStotland> Hi all
16:05:09 <akuznetsova> Renat and Nikolay are ill today :-(
16:05:52 <akuznetsova> so I guess that we can start
16:05:59 <^Gal^> :(
16:06:24 <akuznetsova> #topic Action Items review
16:06:47 <akuznetsova> we have two action items from previous meeting
16:06:56 <akuznetsova> NikolayM provide a plan of what we are going to do in L-3 iteration
16:06:58 <akuznetsova> and
16:07:06 <akuznetsova> NikolayM, all: look through the blueprints and think about what do we need in L-3
16:07:44 <akuznetsova> I didn't have enough time for looking through bps :-(
16:07:55 <akuznetsova> as far as I know Renat and Nikolay too
16:07:57 <^Gal^> when is the l2 due date?
16:08:08 <LimorStotland> I have something i think we need to land to L3
16:08:14 <akuznetsova> ^Gal^, last week
16:08:28 <^Gal^> oh ok lol, had that strange feeling
16:08:47 <akuznetsova> ^Gal^, Renat was in the business trip last week
16:08:59 <^Gal^> yeah he was at our offices in Israel
16:09:00 <akuznetsova> LimorStotland, you can assign it to L-3
16:09:22 <gpaz> Actualy the bp that I was working on already done and wait for review
16:09:25 <LimorStotland> ok cool...
16:09:27 <gpaz> https://blueprints.launchpad.net/mistral/+spec/expiration-policies-for-executions
16:09:43 <akuznetsova> cause we don't have a strictly defined roadmap for l-3, we still need to discuss it
16:10:02 <gpaz> And already targeted to L-3
16:10:35 <akuznetsova> maybe we can create a meeting in irc in mistral channel and look through all bps together
16:10:46 <akuznetsova> what do you think about it&
16:10:48 <LimorStotland> what about kong pagging feature? we also need it in L3
16:10:59 <^Gal^> sounds good to me
16:11:33 <LimorStotland> akuznetsova : it's a good idea.
16:12:00 <LimorStotland> do you want to want to Renat or should we schedule it?
16:12:15 <akuznetsova> #action akuznetsova create meeting for l-3 roadmap discussion
16:12:24 <LimorStotland> *wait to Rent
16:12:34 <akuznetsova> LimorStotland, we need to find appropriate for all time
16:12:47 <LimorStotland> Ok
16:12:54 <akuznetsova> LimorStotland, firstly I will talk with Renat
16:13:06 <^Gal^> Mistral dashboard and UI-wise, think we should check Horizon progress with the Angular JS implementation for l-3
16:13:38 <^Gal^> Timur and Niu probably know best
16:13:51 <akuznetsova> please, prepare list of bps which you what to discuss and assign to l-3
16:14:12 <akuznetsova> *want
16:14:18 <^Gal^> I'll make us an Angular JS one
16:14:36 <LimorStotland> I think all BP that are marked as L3 no?
16:14:58 <akuznetsova> LimorStotland, yes) but maybe you will find something new)
16:15:22 <akuznetsova> we will send an email about meeting information
16:15:29 <LimorStotland> So make it as L3
16:15:51 <akuznetsova> ok, cool, let's go to the next topic
16:16:03 <akuznetsova> #topic Current status
16:16:13 <^Gal^> I'll take me an action item to create AngularJS blueprint and check the mistral-dashboard related blueprints
16:16:16 <LimorStotland> I think what we want to add to L3 we need to mark it as L3 and then in the meeting we can discuss on the list
16:16:25 <akuznetsova> LimorStotland, agreed
16:16:46 <LimorStotland> my status: renat and i discovered that the problem i have aren't connecting to qpid, it's happened because 2 Scheduler can't play with each other. So i changed the qpid bp to : https://blueprints.launchpad.net/mistral/+spec/scheduler-ha  and i am working on it
16:17:07 <gpaz> my status : Expiration Policy For Execution BP : As I said, All code in gerrit and waiting for your reviews.
16:17:11 <^Gal^> Current Status: Working on execution overview screen, finished all the wiring. Just need to use the horizon overview template and I'm done.
16:17:11 <^Gal^> Cores - please review my commits:
16:17:11 <^Gal^> https://review.openstack.org/#/c/211183/
16:17:12 <^Gal^> https://review.openstack.org/#/c/210817/
16:17:25 <gpaz> https://review.openstack.org/#/c/206483
16:17:40 <akuznetsova> my status: prepared fix for running unit tests on the new gate, stumbled upon a problem that our unit tests do not work with real db (there are different problems here)
16:18:44 <akuznetsova> ^Gal^, could you please add reviewers to your patch ?
16:19:01 <^Gal^> Sure, should I add all cores?
16:19:06 <m4dcoder> I'm done with the error-resume bp. The patches were already approved but there was some problem trying to get pass Jenkins. I fixed it and currently waiting for folks to re-approve.
16:19:07 <LimorStotland> akuznetsova should unit tests work with real DB?
16:19:34 <akuznetsova> ^Gal^, you can simple type "mistral-core" in the field
16:19:47 <akuznetsova> LimorStotland, we had such use case
16:19:56 <LimorStotland> m4dcoder  can you add link to your commit ?
16:20:12 <^Gal^> Thanks :) didn't want to bother them, but I'll add them
16:20:18 <akuznetsova> m4dcoder, am I correct that this initiative was from your side ?
16:20:59 <akuznetsova> ^Gal^, it is their work) you can add me too, but I am not a core reviewer)
16:21:25 <^Gal^> akuznetsova: lol OK :) just added them, and i'm adding you too :P
16:21:42 <akuznetsova> ^Gal^, thanks)
16:22:05 <m4dcoder> yes, the bp is started by my team here.
16:22:22 <m4dcoder> https://review.openstack.org/#/c/202342/
16:22:33 <m4dcoder> and https://review.openstack.org/#/c/202343/
16:22:41 <akuznetsova> as far as I know, Renat was on the business trip, Nikolay worked on documentation and review
16:23:16 <akuznetsova> nice
16:23:27 <akuznetsova> #topic Open discussion
16:24:07 <akuznetsova> are there any questions from you guys?
16:24:43 <LimorStotland> m4dcoder I raised a concern on https://review.openstack.org/#/c/202343/
16:24:56 <m4dcoder> I already answered them there. :D
16:25:39 <akuznetsova> m4dcoder, I have a question for you
16:25:44 <m4dcoder> sure
16:26:02 <akuznetsova> as I said we have a problem with running unit tests with real db
16:26:25 <m4dcoder> what's the problem?
16:26:44 <m4dcoder> on postgresql?
16:26:46 <akuznetsova> if we run all tests in a few threads, we got a lot of error because of incorrect cleanup mechanism
16:26:48 <akuznetsova> yes
16:27:48 <akuznetsova> test is in one thread it still working, but test from another one just has finished and kill all resources, including resources of first test
16:28:09 <m4dcoder> how can i reproduce?
16:29:09 <akuznetsova> getch on my last commit https://review.openstack.org/#/c/209926/ and run "./run_tests --dbtype postgresql --parallel true"
16:29:15 <akuznetsova> *fetch
16:29:47 <m4dcoder> ok. i'll give that a try. will your solution to set parallel false be sufficient?
16:30:04 <akuznetsova> the result of running all tests in one thread can be found here http://logs.openstack.org/26/209926/5/check/gate-mistral-tox-unit-postgresql/c68c602/console.html.gz
16:30:22 <akuznetsova> in this case we have another error
16:30:36 <akuznetsova> sqlalchemy.exc.OperationalError: (psycopg2.OperationalError) FATAL:  remaining connection slots are reserved for non-replication superuser connections
16:30:55 <m4dcoder> that looks like a random error
16:31:01 <akuznetsova> no
16:31:08 <m4dcoder> not the sqlalchemy error but the one in the console.html
16:31:34 <akuznetsova> please, can you take a look at it?
16:31:54 <m4dcoder> i will take a look at it. but what's the max connection setting for postgresql on the box?
16:32:19 <m4dcoder> i think you may need to increase that in the postgresql conf.
16:32:26 <akuznetsova> #action m4dcoder take a look at problem with postgresql unit tests running
16:32:35 <akuznetsova> m4dcoder, hm
16:33:39 <m4dcoder> i'm pretty sure the problem from the sqlalchemy error is that it reached the max concurrent connection to the postgresql DB.
16:33:55 <m4dcoder> i usually have to increase that to 500 on my devbox.
16:34:02 <akuznetsova> m4dcoder, need to investigate it, postgresql config is modifing in openstack-infra scripts
16:35:00 <m4dcoder> thanks!
16:35:26 <akuznetsova> it will be a long way (I mean to make a fix in infra)
16:35:53 <akuznetsova> maybe we can fix cleanup mechanism in our tests and run them in a few threads ?
16:37:15 <m4dcoder> i'll take another look at the unit test.  it's already trying to clean up connections in the pool.
16:37:26 <akuznetsova> ok, need to think about it and find a final decision
16:37:37 <akuznetsova> that's all from my side
16:38:37 <akuznetsova> guys, any other topics for discussion ?
16:39:17 <^Gal^> hm,
16:39:37 <^Gal^> we still have the meeting time block thingy to take a look at
16:39:44 <^Gal^> not the entire team is here
16:40:17 <akuznetsova> ^Gal^, yes (
16:41:07 <^Gal^> we could take that as another action item IMO
16:42:21 <akuznetsova> #action akuznetsova start a discussion in the ml about new community meeting time
16:42:59 <^Gal^> thanks :) appreciate
16:43:46 <akuznetsova> I will send an email about free slots , all of you can leave a comment about what time is the most appropriate and I hope, that we will solve this problem
16:44:04 <^Gal^> #action ^Gal^ look at mistral-dashboard blueprints regarding l-3, add an AngularJS migration blueprint
16:44:29 <^Gal^> akuznetsova: that would be great, thanks!
16:44:51 <akuznetsova> anything else?
16:45:23 <^Gal^> that's all from me
16:46:30 <m4dcoder> thanks for running the meeting!
16:46:43 <akuznetsova> thanks for coming)
16:46:44 <^Gal^> +1!
16:46:59 <m4dcoder> cya
16:47:01 <akuznetsova> let's wrap the meeting
16:47:10 <^Gal^> bye all, have a great week
16:47:23 <akuznetsova> bye-bye
16:47:46 <LimorStotland> bye
16:47:57 <akuznetsova> #endmeeting