16:00:50 <NikolayM> #startmeeting Mistral
16:00:50 <openstack> Meeting started Mon Jul 20 16:00:50 2015 UTC and is due to finish in 60 minutes.  The chair is NikolayM. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:53 <openstack> The meeting name has been set to 'mistral'
16:00:58 <^Gal^_> Hi all
16:00:59 <NikolayM> hi everyone!
16:01:04 <gpaz> hi
16:01:11 <melisha> Hi
16:01:18 <LimorStotland> hi *
16:01:34 <xylan_kong> hi, guys
16:01:45 <NikolayM> so, let's start
16:01:47 <akuznetsova> hi
16:01:55 <NikolayM> #topic Review action items
16:02:07 <NikolayM> 1. rakhmerov: completely review https://blueprints.launchpad.net/mistral/+spec/expiration-policies-for-executions
16:02:29 <NikolayM> done
16:02:48 <gpaz> is it really done or still things that we need to discuss ?
16:03:04 <gpaz> done mean we agree on everything ?
16:03:16 <NikolayM> I plan to discuss this on meeting today
16:03:23 <NikolayM> 2. rakhmerov: review and discuss Lingxian's proposal about removing wf_trace module
16:03:24 <gpaz> ok
16:03:57 <NikolayM> it seems this one is not done
16:04:04 <xylan_kong> NikolayM: yeah
16:04:13 <LimorStotland> do we have bp for wf_trace ?
16:04:18 <xylan_kong> still need to talk about that
16:04:22 <NikolayM> so, xylan_kong, can I review this proposal?
16:04:30 <NikolayM> can you give a link?
16:04:38 <xylan_kong> yes, sure, actually i sent it before to openstack-dev
16:04:54 <xylan_kong> ok, i'll get the link then send it to our irc channel
16:05:00 <LimorStotland> i would like it also...
16:05:01 <xylan_kong> please record an action for me
16:05:24 <NikolayM> ok
16:05:41 <NikolayM> I assign it on myself
16:05:53 <xylan_kong> NikolayM: ok, thanks
16:06:01 <NikolayM> #action NikolayM: review and discuss Lingxian's proposal about removing wf_trace module
16:06:32 <NikolayM> let's move on
16:06:36 <NikolayM> #topic Current status
16:07:05 <NikolayM> let's tell our status
16:07:14 <LimorStotland> my status : I am working on pushing the puppet-mistral to the community and today i started the qpis
16:07:31 <xylan_kong> my status: keep my review work; completed the code of service api feature and workflow query pagination support for mistral, waiting for review
16:08:21 <melisha> I will update for Liat - she published the BP for tasks screen (https://blueprints.launchpad.net/mistral/+spec/tasks-screen-improvments) - she will start once approved
16:08:27 <^Gal^_> I'm still on the executions ui, had some progress, though it was a hectic week and I didn't get to program as much as i wanted. we added 2 more blueprints today that I would love you all take a look https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-cron-trigger-screen https://blueprints.launchpad.net/mistral/+spec/tasks-screen-improvments
16:08:42 <NikolayM> my status: repaired functional tests, worked on API auth patch, did backports to stable/kilo and today I am fixing execution state_info bug
16:09:00 <gpaz> my status: started to work on ‘expiration policy for execution’, I have a very basic flow that works …
16:09:21 <xylan_kong> NikolayM: thanks for picking up state_info bug
16:09:26 <NikolayM> ^Gal^_, good blueprints!
16:09:40 <NikolayM> thanks!
16:09:50 <^Gal^_> thanks :) the whole team helped
16:09:52 <NikolayM> yes, I am trying to fix that
16:10:42 <akuznetsova> my status: just review the commits
16:11:32 <NikolayM> ok, next topic
16:11:58 <NikolayM> #topic Expiration policy for executions discussion
16:12:10 <NikolayM> etherpad link: https://etherpad.openstack.org/p/expiration-policies-for-executions
16:13:39 <NikolayM> so, almost all of us already saw this etherpad and reviewed
16:14:31 <xylan_kong> yes
16:14:38 <xylan_kong> i think the whole idea is good
16:14:51 <xylan_kong> we can continue with code work
16:14:59 <xylan_kong> and see more details
16:15:04 <NikolayM> yes
16:15:36 <xylan_kong> so, like what i said this afternoon, gpaz, please go ahead with implementation
16:15:48 <gpaz> I do, thanks
16:16:12 <xylan_kong> but i don't know we could land it to l-2
16:16:33 <akuznetsova> it is a good feature, we should not forget to prepare some documentation for this in future
16:16:39 <xylan_kong> NikolayM: when will l-2 release?
16:16:48 <NikolayM> IMO, it needs some API for configuration criterias per user, what do you think?
16:17:02 <gpaz> when is l-2 ?
16:17:22 <NikolayM> July 29
16:17:25 <xylan_kong> akuznetsova: right, doc is very, very poor for mistral now
16:17:34 <gpaz> well, not l-2
16:17:37 <akuznetsova> https://wiki.openstack.org/wiki/Liberty_Release_Schedule
16:17:53 <akuznetsova> gpaz, liberty-2 (Jul 28-30)
16:18:14 <akuznetsova> oh, Nikolay already answered)
16:18:28 <xylan_kong> guys, i propose we pay more attention to doc in l-3
16:19:05 <xylan_kong> it's so important for newbees coming to mistral contribution
16:19:14 <akuznetsova> xylan_kong, fully agree with you cause we have official docs, but it is in terrible status now
16:19:22 <NikolayM> xylan_kong, agree
16:19:32 <melisha> #container {
16:19:33 <melisha> display: table;
16:19:33 <melisha> }
16:19:33 <melisha> #row  {
16:19:33 <melisha> display: table-row;
16:19:33 <melisha> }
16:19:34 <melisha> #left, #right, #middle {
16:19:34 <melisha> display: table-cell;
16:19:35 <melisha> }
16:19:48 <melisha> Sorry working on UI on another window :-)
16:19:55 <^Gal^_> lol
16:19:57 <NikolayM> :)
16:19:59 <gpaz> I m not sure I understand, The concern is to add documentation for the ‘expiration policy’ ?
16:19:59 <xylan_kong> :)
16:20:08 <akuznetsova> :-)
16:20:09 <gpaz> or in general ?
16:20:16 <xylan_kong> gpaz: no, i mean, for mistral
16:20:17 <LimorStotland> in general ...
16:20:27 <xylan_kong> and a good doc will help to clarify something historically
16:20:39 <NikolayM> #topic Open discussion
16:21:08 <xylan_kong> akuznetsova: i remember you have concentrated on that before, right?
16:21:48 <akuznetsova> akuznetsova, concentrated on what ?)
16:21:56 <akuznetsova> oops
16:22:01 <akuznetsova> xylan_kong, ^
16:22:12 <NikolayM> akuznetsova, on docs?
16:22:14 <xylan_kong> akuznetsova: doc effort
16:22:54 <xylan_kong> do you?
16:23:26 <akuznetsova> I am worry about it, but I did not write it)
16:23:59 <xylan_kong> akuznetsova: ok, sorry, maybe i misremembered
16:24:32 <akuznetsova> I can start transferring some wiki articles to our official docs
16:24:38 <xylan_kong> but anyway, we need a plan for that
16:24:59 <xylan_kong> is there any English native speaker in our team?
16:25:25 <akuznetsova> or I can prepare plan for what we have and what we need to describe
16:25:41 <xylan_kong> akuznetsova: yes, we could start from transfering wiki docs
16:25:45 <xylan_kong> akuznetsova: sound good!
16:26:20 <melisha> xylan_kong: Nice job on the pagination API. Is someone already assigned for doing the same for executions and tasks so we could build the UI with it?
16:26:54 <xylan_kong> melisha: you mean the UI or the other resource pagination in server side?
16:27:32 <akuznetsova> xylan_kong, I think no, I mean there are no English native speakers in our team, or maybe I don't know about somebody)
16:27:33 <melisha> Server side support for other entities
16:28:01 <melisha> akuznetsova,  xylan_kong: We don't have native speakers in our team
16:28:22 <xylan_kong> i will continue pagination with other resources if most of us have no rejection about current implementation for workflows
16:28:35 <xylan_kong> melisha: ok, pity
16:28:52 <xylan_kong> but never mind, i think it's ok
16:29:02 <xylan_kong> we did good before
16:29:44 <xylan_kong> s/rejection/objection
16:30:13 <melisha> xylan_kong: I left some small comment in the review but it looks good to me
16:30:16 <xylan_kong> melisha: certainly, if there are some guys in the position for help
16:30:23 <xylan_kong> melisha: i'll appreciate
16:30:32 <xylan_kong> melisha: yes, thanks, i saw
16:30:45 <xylan_kong> will handle tomorrow when i'm in office
16:30:51 <NikolayM> xylan_kong, I left my comments there, on the review
16:31:19 <xylan_kong> NikolayM: yes, will check them tomorrow
16:31:21 <NikolayM> ok
16:31:22 <xylan_kong> thanks guys
16:32:17 <xylan_kong> NikolayM: for the doc, is it worth for an action?
16:33:34 <NikolayM> what do you mean exactly?
16:33:52 <xylan_kong> doc improvement
16:34:23 <akuznetsova> I will check for bp, if there is no one, I will create it
16:34:30 <NikolayM> yes, I can try
16:34:31 <xylan_kong> akuznetsova: yes, you got me
16:34:56 <LimorStotland> i think we do need to map what we have and what we don't have and next week at the meeting discussed plan for it
16:35:25 <xylan_kong> LimorStotland: good suggestion
16:35:27 <akuznetsova> LimorStotland, yes, that's what I proposed earlier
16:35:59 <gpaz> LimorStotland, great idea
16:36:05 <akuznetsova> NikolayM, could you please create action item for that for the next meeting ?
16:36:06 <LimorStotland> ok so i agree with akuznetsova :-)
16:36:24 <NikolayM> yes, sure
16:37:06 <NikolayM> #action NikolayM: map what we have and what we don't have in our docs and next week at the meeting discuss plan for it
16:37:28 <akuznetsova> oh, look what I've found https://blueprints.launchpad.net/mistral/+spec/mistral-documentation
16:37:55 <akuznetsova> it was created a year ago)
16:38:22 <xylan_kong> akuznetsova: yes, we can continue that
16:38:42 <akuznetsova> xylan_kong, we can _start_ it)
16:38:54 <xylan_kong> akuznetsova: hehe
16:40:35 <NikolayM> so if you have no more questions, we can wrap up the meeting
16:41:15 <akuznetsova> btw, as you may see there is a problem with rally-gate, I already talked with guys from rally team and they said that it is a problem in the installation script, so I will continue to communicate with them to finally find out where the root of this proiblem
16:41:54 <xylan_kong> akuznetsova: appreciate that
16:42:12 <melisha> Did you happen to see BP - https://blueprints.launchpad.net/mistral/+spec/support-large-datasets?
16:42:35 <NikolayM> melisha, yes, I saw this
16:42:47 <xylan_kong> melisha: yes, i also read that today
16:43:15 <melisha> I think it is important for real life use cases. Do you have any thoughts / comments about it? When I simply tried to increase column size - Mistral had a core dump with segmentation fault
16:43:51 <melisha> How much memory is allocated to the Python process?
16:44:08 <NikolayM> melisha, why should we use mediumtext? Can we use longtext?
16:44:42 <NikolayM> we already use it for input_context and output
16:44:44 <melisha> NikolayM: We can bug this means that the user will be able to place up to 4GB in every column
16:45:03 <melisha> NikolayM: I know - not sure that is good...
16:45:32 <LimorStotland> i am afraid that longtext will be too big..
16:45:41 <NikolayM> Yes, it will be a real big dataset
16:46:02 <akuznetsova> we don't have such a big objects
16:46:31 <NikolayM> we can support that
16:47:00 <NikolayM> what if we need to process more than 16 MB? say, 40 MB or more?
16:47:43 <melisha> NikolayM: I agree it might be a use case although it is a lot...
16:47:53 <akuznetsova> NikolayM, we need to choose between 16 mb and 4 gb ?
16:48:02 <melisha> We can use longtext and place an application validation before INSERT / UPDATE
16:48:26 <melisha> Make the limitation configurable
16:48:38 <NikolayM> sounds good
16:49:04 <melisha> That way the user will also get a good error message instead of "DBError Data too long"
16:50:37 <melisha> Do you have an idea why the segmentation fault occurred? just so we will start looking at the right direction
16:50:48 <LimorStotland> i like the configuration idea... +1 melisha  :-)
16:52:14 <xylan_kong> i suggest we explore how other projects do that, maybe there is already an existing solution (maybe not)
16:53:27 <xylan_kong> for example, nova has column for use data, etc., but i'm not sure it's the same thing with what we met in mistral
16:53:27 <melisha> xylan_kong: OK. I agree. I know that in Heat they truncate the data before insert / update (for example, with "status_reason")
16:54:03 <NikolayM> Sahara uses its own big type for binaries based on Longtext
16:55:13 <xylan_kong> or, for mysql itself. (i don't know, i'm not expert for that)
16:55:32 <xylan_kong> just a suggestion
16:55:57 <LimorStotland> nova on user_data use MediumText
16:57:12 <LimorStotland> it's looks like every project do something else
16:57:47 <xylan_kong> LimorStotland: yep, we just found a way fits mistral
16:58:43 <NikolayM> yes
16:58:48 <LimorStotland> yep
16:59:04 <xylan_kong> #link https://blueprints.launchpad.net/mistral/+spec/mistral-documentation
16:59:12 <NikolayM> I like idea with limitation in config
16:59:15 <akuznetsova> guys, we are out of our time
16:59:21 <NikolayM> so, let's shut down the meeting
16:59:22 <melisha> OK. I will update BP
16:59:30 <NikolayM> bye !
16:59:30 <melisha> Thanks
16:59:33 <melisha> Bye
16:59:35 <LimorStotland> bye
16:59:35 <xylan_kong> ok, bye
16:59:36 <akuznetsova> bye
16:59:37 <NikolayM> #endmeeting