16:01:36 <rakhmerov> #startmeeting Mistral
16:01:37 <openstack> Meeting started Mon Jul  6 16:01:36 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:40 <openstack> The meeting name has been set to 'mistral'
16:02:22 <^Gal^> Hi everyone
16:02:23 <rakhmerov> hi
16:02:47 <^Gal^> I've just uploaded the Executions Screen Blueprint https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-executions-screen
16:02:55 <rakhmerov> let's wait a little bit for others
16:03:01 <rakhmerov> ok, good
16:03:03 <rakhmerov> let me see
16:03:18 <^Gal^> :)
16:03:36 <m4dcoder> helo
16:03:38 <m4dcoder> hello
16:03:44 <LimorStotland> hi all
16:03:54 <rakhmerov> hi )
16:04:00 <[1]melisha> Hi
16:04:32 <rakhmerov> ok, let's start our meeting
16:04:41 <noa_koffman> Hi
16:04:49 <rakhmerov> hey
16:04:59 <NikolayM> hi everyone !
16:05:00 <rakhmerov> the agenda of the meeting is at https://wiki.openstack.org/wiki/Meetings/MistralAgenda
16:05:04 <rakhmerov> hi Nikolay
16:05:22 <rakhmerov> #topic Review action items
16:05:37 <rakhmerov> 1. NikolayM: talk to Stan Lagun about YAQL 1.0 inclusion into global requirements
16:06:08 <rakhmerov> this is one basically done, Stan is about to get it solved soon (1-2 weeks)
16:06:17 <rakhmerov> 2. xylan_kong: proposal to replace utils.wf_trace with oslo.log
16:06:50 <rakhmerov> xylan_kong: you're here?
16:06:55 <rakhmerov> just in case
16:07:35 <xylan_kong> hi, guys
16:07:37 <rakhmerov> anyway, I see this item is done. He sent out the email in ML with subject [openstack-dev] [Mistral] Proposing to remove mistral.utils.wf_trace module
16:07:39 <xylan_kong> sorry i'm late
16:07:40 <rakhmerov> hey
16:07:44 <rakhmerov> xylan_kong: no problem )
16:08:03 <xylan_kong> i wrote a spec for using oslo.log to substitude wf_trace module, but with no response, so i gave up the atempt to work on that.
16:08:18 <rakhmerov> xylan_kong: I saw your proposal but I personally didn't have a chance to look at it closer. Someone else might have
16:08:42 <xylan_kong> rakhmerov: myabe it's not so necessary
16:08:43 <rakhmerov> xylan_kong: don't give up ) We'll get it reviewed and answered
16:08:46 <xylan_kong> and not so urgent
16:08:55 <xylan_kong> rakhmerov: ok, i'm ok
16:09:06 <rakhmerov> at least we can discuss it, create a BP and prioritize, right?
16:09:18 <xylan_kong> yep, sure
16:09:45 <rakhmerov> #action rakhmerov, others: review and discuss Lingxian's proposal about removing wf_trace module
16:10:00 <rakhmerov> 3. rakhmerov: check Winson's info about deadlocks occurring in scheduler
16:10:03 <rakhmerov> checked
16:10:20 <rakhmerov> there's really a problem there, I'm about to start working on it
16:10:34 <rakhmerov> #action rakhmerov: start working on deadlock problem in scheduler
16:10:38 <dzimine> hi, sorry I'm late.
16:10:48 <rakhmerov> hi dzimine!
16:11:00 <LimorStotland> rakhmerov  : do you know what the problem already?
16:11:14 <rakhmerov> nope, I have only assumptions
16:11:26 <rakhmerov> they need to be checked
16:11:36 <rakhmerov> 4. m4dcoder: send conf files for Mistral and Postgres to investigate deadlocks in scheduler
16:11:38 <rakhmerov> done
16:11:50 <rakhmerov> 5. rakhmerov: create a BP to make Mistral work with qpid behind oslo.messaging
16:12:04 <rakhmerov> done
16:12:06 <rakhmerov> #info https://blueprints.launchpad.net/mistral/+spec/support-qpid
16:12:29 <rakhmerov> and 6. xylan_kong, m4dcoder, NikolayM, LimorStotland: send a list of desired BPs and bugs for Liberty-2 so that we could plan
16:12:30 <xylan_kong> sorry for chipping in, for yaql, you may take a look at http://logs.openstack.org/35/193435/4/check/gate-mistral-devstack-dsvm/39237fd/logs/devstacklog.txt.gz
16:12:35 <rakhmerov> basically done
16:12:51 <rakhmerov> xylan_kong: yes, it's being figured out
16:13:03 <xylan_kong> rakhmerov: ok
16:13:09 <rakhmerov> will be solved tomorrow
16:13:13 <rakhmerov> or today
16:13:17 <xylan_kong> rakhmerov: good to know that
16:13:24 <NikolayM> xylan_kong, yes, there a wrong yaql version is installed on devstack
16:13:24 <LimorStotland> Ok
16:13:34 <xylan_kong> NikolayM: yep, i saw
16:13:47 <rakhmerov> #action NikolayM, akuznetsova: finish fixing http://logs.openstack.org/35/193435/4/check/gate-mistral-devstack-dsvm/39237fd/logs/devstacklog.txt.gz
16:14:03 <rakhmerov> ok, let's move on
16:14:31 <rakhmerov> #topic Current status (done last week, roadblocks etc.)
16:14:49 <rakhmerov> let's quickly report our statuses
16:15:31 <xylan_kong> my status: except review work, i wrote a spec for using oslo.log to substitude wf_trace module in openstack-dev; continue to work on service api implementation, see the series of patches https://review.openstack.org/#/c/193435/
16:15:37 <rakhmerov> my status: last week was mostly doing reviews and helping other team member, was also doing liberty-2 planning and corresponding meetings
16:15:44 <LimorStotland> my status:  I am still on the puppet installation. i am having some issues with the db installation
16:15:58 <[1]melisha> I am working on BP and spec for cleaning DB scheduler
16:16:22 <m4dcoder> I'll continue with the error-resume bp continuing with current solution to transition ERROR->RUNNING. i'll fix the unit test and resubmit the postgresql patch. i found a bug with last task being repeated when transition declare a non-existent task. i will file that shortly.
16:16:29 <rakhmerov> [1]melisha: awesome, looking forward to see the spec
16:16:49 <^Gal^> I did some reviews and wrote a ui blueprint
16:17:08 <^Gal^> https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-executions-screen
16:17:16 <rakhmerov> cool
16:17:20 <NikolayM> my status: I am working on alternative RPC implementation (using kombu).
16:17:26 <noa_koffman> my status: working on bug 1467969, writing tests
16:17:26 <openstack> bug 1467969 in Mistral "Error in start_workflow call inside periodic modules" [High,In progress] https://launchpad.net/bugs/1467969 - Assigned to noa (noa-koffman)
16:17:47 <xylan_kong> noa_koffman: please see my comments
16:17:56 <xylan_kong> maybe helpful to you
16:18:13 <rakhmerov> ok, anyone else?
16:18:16 <noa_koffman> ok thanks
16:18:26 <rakhmerov> I think everyone did
16:18:34 <rakhmerov> thanks a lot
16:20:00 <rakhmerov> today I mostly wanted to talk about Mistral Dashboard because a number of people decided to help with it last week (more over, on the same day!)
16:20:06 <rakhmerov> #topic Mistral Dashboard plans and blueprints
16:20:15 <^Gal^> yey :) dashboard ftw!
16:20:24 <rakhmerov> yeah :)
16:20:46 <rakhmerov> so I'd like to outline quickly the plan on UI
16:21:12 <^Gal^> k
16:21:20 <rakhmerov> and discuss what we think are the most important things that we need to achieve in a short term for UI
16:21:49 <^Gal^> what are your views regarding AngularJS development?
16:22:09 <rakhmerov> what do you mean specifically?
16:22:29 <^Gal^> regarding dashboard implementation
16:23:14 <rakhmerov> you mean "Do we need to use AngularJS or not?"?
16:23:25 <[1]melisha> rakhmerov: Old Horizon code was written using Django framework. All new modules should be written in AngularJS
16:23:35 <^Gal^> yeah
16:23:38 <^Gal^> that is correct
16:23:58 <xylan_kong> yes, i heard from zhenguo
16:23:59 <rakhmerov> ok, looks like you know much more about it :)
16:24:18 <^Gal^> cool :)
16:24:27 <rakhmerov> I don't have any opinion on that except I saw AngularJS a little bit and it seems like a good stuff
16:24:38 <^Gal^> yeah it's a great framework
16:24:43 <rakhmerov> but it may be a matter of taste though..
16:24:49 <^Gal^> it'll be perfect for openstack
16:24:59 <rakhmerov> great )
16:25:09 <xylan_kong> it's a trend :-)
16:25:16 <^Gal^> it is :) but a good one
16:25:19 <rakhmerov> so then I guess it's not even what we need to discuss if it's already decided
16:25:20 <^Gal^> I use it daily
16:25:34 <rakhmerov> or there's something that's not clear there?
16:25:48 <^Gal^> nah, just wanted to get your view and approval
16:26:02 <rakhmerov> I see
16:26:30 <rakhmerov> just to be clear: I know very little about Horizon so don't have an expert opinion
16:26:50 <^Gal^> oh ok, np
16:26:51 <rakhmerov> and this is why I'm so glad you joined and are ready to help with it
16:26:56 <rakhmerov> :)
16:27:01 <rakhmerov> alright
16:27:01 <^Gal^> sure :) np
16:27:07 <rakhmerov> so specifically on Mistral
16:27:13 <rakhmerov> currently we have https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-crud-operations
16:27:31 <rakhmerov> to CRUDify all Mistral entities exposed via API
16:27:54 <rakhmerov> the current state is that we have not all of them CRUDified
16:28:28 <rakhmerov> only workflows, executions (wf executions), tasks (task executions), workbooks
16:28:51 <rakhmerov> we also need to add action executions, action definitions, cron triggers, environments
16:29:09 <rakhmerov> and even existing are pretty obsolete
16:29:21 <xylan_kong> rakhmerov: what's more, maybe services :-)
16:29:23 <[1]melisha> rakhmerov: We checked the executions screen and it does not work at all. Even listing existing executions is not working propertly. Gal's BP will fix it
16:29:37 <rakhmerov> one more BP is registered today by ^Gal^: https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-executions-screen
16:29:58 <rakhmerov> xylan_kong: yes, right. I was just talking about really short term
16:30:13 <rakhmerov> [1]melisha: yeah-yeah, you're right
16:30:41 <rakhmerov> so zhenguo from Huawei already started repairing UI but it's not repaired on 100% yet
16:31:12 <rakhmerov> so I see that our primary short term goal is to simply CRUDify everything
16:31:21 <rakhmerov> w/o any advanced features
16:31:38 <rakhmerov> just so that Mistral UI has feature parity with Mistral CLI
16:32:10 <[1]melisha> rakhmerov: I agree. We just need to split the work so we won't do duplicate work and won't mess up things to each other
16:32:21 <rakhmerov> for that to do we got a suggestion from Alcatel folks to register individual BPs for each entity
16:32:43 <rakhmerov> [1]melisha: yes, right
16:32:59 <[1]melisha> rakhmerov: We will be able to allocate 2 UI developers for this purpose
16:33:29 <rakhmerov> very cool
16:33:41 <rakhmerov> I couldn't even dream about it just a week ago )
16:33:52 <[1]melisha> :-)
16:33:56 <^Gal^> :D
16:34:04 <xylan_kong> so it's a pity zhenguo is not here now, he really devote himself to that work, and he has a lot of ideas about our UI. hope we could coorperate very well
16:34:14 <rakhmerov> [1]melisha: you mentioned that you can file all required BPs under https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-crud-operations
16:34:20 <rakhmerov> can you still do that?
16:34:27 <rakhmerov> or ^Gal^
16:35:03 <[1]melisha> rakhmerov: Yes. Just let's approve the Executions BP first so we will have a good reference for all others
16:35:28 <rakhmerov> btw, zhenguo is already working on "Workflows" view now so that we can reuse his code to complete others
16:35:45 <rakhmerov> [1]melisha: yes, ok, no problem
16:36:00 <xylan_kong> rakhmerov: for UI work, i suggest we use etherpad to sync with each other to avoid duplicate work
16:36:02 <^Gal^> I wonder if he uses AngularJS or django
16:36:23 <^Gal^> yeah, we sure should
16:36:23 <rakhmerov> #action rakhmerov, xylan_kong, NikolayM: review https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-executions-screen BP on Tue
16:36:55 <rakhmerov> xylan_kong: sure, I'll create an etherpad
16:37:05 <xylan_kong> good
16:37:35 <rakhmerov> done: https://etherpad.openstack.org/p/mistral-ui-work
16:37:39 <xylan_kong> rakhmerov: seems you're very busy :-)
16:37:45 <^Gal^> lol that was quick
16:37:47 <rakhmerov> let's use it to gather all our ideas there
16:37:50 <^Gal^> ;d
16:38:01 <rakhmerov> xylan_kong: everyone's busy I guess
16:38:21 <rakhmerov> ok, do you guys have to say anything else in addition?
16:39:09 <rakhmerov> for it looks pretty clear at the high level, I think we just need to get into the battle as soon as possible
16:39:23 <rakhmerov> and work with details
16:39:44 <^Gal^> +1
16:39:59 <xylan_kong> sounds exciting
16:40:23 <rakhmerov> ^Gal^: btw, please try to communicate with zhenguo directly at #openstack-mistral so that you know better each other's status
16:40:32 <^Gal^> will do, tnx
16:41:02 <rakhmerov> btw, [1]melisha: do you know who else is going to contribute into UI from your side except ^Gal^?
16:41:15 <^Gal^> yeah, Liat Fried
16:41:18 <^Gal^> a fellow developer
16:41:29 <rakhmerov> awesome
16:41:42 <[1]melisha> She is just now starting the process of registering and contirbuting
16:41:44 <rakhmerov> I just need to know the pool of UI developers now :)
16:42:01 <rakhmerov> because looks like we have a bunch of them all of a sudden )
16:42:17 <^Gal^> lol
16:42:21 <rakhmerov> [1]melisha: that's fine
16:43:08 <rakhmerov> well, to be serious: we seem to have 3 UI engineers and 1 more wants to join
16:43:13 <rakhmerov> ok
16:43:23 <rakhmerov> one more thing on UI
16:44:14 <rakhmerov> we also touched a topic related to Workbook Builder based on Merlin framework that's currently being built by Timur Sufief (tsufiev) and others
16:44:50 <rakhmerov> so just FYI: Workbook Builder is an advanced mechanism that allows to build new workflows easier
16:45:28 <rakhmerov> he provides web UI based "rails" for new workflows: validation, content assist etc.
16:46:10 <rakhmerov> WB builder is now in a POC state (was demonstrated in Vancouver first) and tsufiev is now working on integrating it into Mistral Dashboard
16:46:12 <rakhmerov> so
16:46:47 <rakhmerov> it makes sense for you to look at the existing materials on Merlin and Mistral WB Builder and:
16:47:20 <rakhmerov> 1. Leave your feedback on the idea itself (whether it's worth efforts or not, what can be improved etc.)
16:48:23 <rakhmerov> 2. See if you can help with it because the whole initiative is suffering from the lack of resources even though, IMO, the idea is very good, it just requires a good accurate implementation
16:49:30 <rakhmerov> from my side: I need to help with communication between you, tsufiev and whoever else needed
16:49:46 <rakhmerov> and provide all initial links
16:49:49 <xylan_kong> rakhmerov: ok, i'll forward to zhenguo
16:50:09 <rakhmerov> #action rakhmerov, tsufiev: provide all initial links on Merlin and Workbook Builder
16:50:22 <rakhmerov> xylan_kong: thanks, appreciate
16:50:28 <xylan_kong> np :-)
16:50:35 <rakhmerov> any question about that?
16:50:57 <rakhmerov> i guess there will be a lot when you look at it
16:51:31 <rakhmerov> so my plan was to start with WB builder actively in Liberty-3
16:51:47 <rakhmerov> in Liberty 2 we need to get CRUD stuff done at least
16:52:02 <rakhmerov> alright
16:52:08 <[1]melisha> rakhmerov: We will look at it and try to give our feedback on the workflow builder. It will be easier to work on it once it is part of mistral-dashboard
16:52:38 <[1]melisha> rakhmerov: We also hope to finish CRUD stuff in Liberty-2
16:52:45 <rakhmerov> yes, right, I actually forgot to mention that it's not a part of Mistral UI now, it's a separate stuff
16:52:51 <rakhmerov> yes
16:52:55 <rakhmerov> we will
16:53:21 <rakhmerov> so as far as WB builder that will the task #1 for it: to get it integrated into Mistral Dashboard
16:53:56 <rakhmerov> #action rakhmerov: make sure to create a BP about integrating WB Builder into Mistral Dashboard project
16:54:21 <rakhmerov> so and the last thing I wanted to mention is what I now call "Management console
16:54:24 <rakhmerov> "
16:54:38 <rakhmerov> xylan_kong already started working on it, right?
16:54:51 <xylan_kong> rakhmerov: yes
16:54:59 <xylan_kong> rakhmerov: code is on review
16:55:04 <rakhmerov> he initially wanted to have a UI in Mistral to manage/monitor executors' state in the system
16:55:07 <rakhmerov> yeah
16:55:28 <rakhmerov> but as far as I understand you are now working on more general idea, right?
16:55:46 <rakhmerov> including not only executors but also other components
16:55:58 <xylan_kong> rakhmerov:  yes, we get all the services info through api
16:55:59 <rakhmerov> (sorry, I didn't review your code yet)
16:56:05 <rakhmerov> perfect
16:56:27 <xylan_kong> although only serivce type and servic name for now
16:56:28 <[1]melisha> rakhmerov, xylan_kong: Sounds very cool
16:56:32 <rakhmerov> so [1]melisha: please also get involved in it and review Lingxian's patches
16:56:42 <rakhmerov> yeah
16:56:56 <[1]melisha> rakhmerov: Will do.
16:56:57 <rakhmerov> I think once we've done with it it'll be a very useful stuff
16:57:26 <[1]melisha> #action [1]melisha: review Lingxian's patches
16:57:36 <rakhmerov> for example, it would be cool if we could see usage statistics for executors
16:57:49 <rakhmerov> like average actions per unit of time
16:57:53 <rakhmerov> etc. etc.
16:58:15 <xylan_kong> rakhmerov:  good idear
16:58:36 <rakhmerov> we could even manage some configuration params on the fly and relaunch those components
16:58:44 <rakhmerov> so the whole lot of ideas
16:59:01 <rakhmerov> basically we could manage physical components of Mistral
16:59:46 <rakhmerov> yeah, ok. I'm glad that we're all now more aware of the plans and the current status
16:59:59 <rakhmerov> a lot of exciting work ahead :)
17:00:11 <rakhmerov> so it's time to shut down the meeting
17:00:24 <rakhmerov> many thanks to all you guys for coming today :)
17:00:36 <^Gal^> bye all - have a great week
17:00:41 <NikolayM> bye everyone!
17:00:43 <m4dcoder> bye
17:00:45 <LimorStotland> goodbye all
17:00:46 <xylan_kong> thanks rakhmerov for holding
17:00:50 <rakhmerov> please go to our channel #openstack-mistral, see you there tomorrow
17:00:56 <rakhmerov> bye
17:00:59 <xylan_kong> see you
17:01:00 <rakhmerov> #endmeeting