16:00:12 <rakhmerov> #startmeeting Mistral
16:00:13 <openstack> Meeting started Mon Jun 22 16:00:12 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:17 <rakhmerov> hi team
16:00:17 <openstack> The meeting name has been set to 'mistral'
16:00:25 <xylan_kong> hi, i'm here
16:00:33 <rakhmerov> good to see you here )
16:00:40 <xylan_kong> rakhmerov: how's your vacation
16:00:45 <LimorStotland> Hi all
16:00:48 <rakhmerov> as usually, let's wait a couple of minutes
16:01:09 <rakhmerov> ooh, it was ok thanks :) pretty lazy. Books and video games mostly
16:01:10 <xylan_kong> LimorStotland: glad to see you here
16:01:25 <rakhmerov> hi Limor )
16:01:27 <xylan_kong> rakhmerov: cool
16:01:43 <rakhmerov> next time I will go somewhere :)
16:02:05 <rakhmerov> ideally ocean coast or mountains
16:02:19 <xylan_kong> yeah, i like mountains
16:02:22 <LimorStotland> you 2 and congrats xylan_kong
16:02:45 <xylan_kong> LimorStotland: ?
16:02:55 <NikolayM> hi all!
16:03:06 <rakhmerov> congrats?
16:03:09 <rakhmerov> with what? :)
16:03:13 <rakhmerov> I am curious too
16:03:28 <LimorStotland> the mail on the core...
16:03:34 <rakhmerov> oooh, that thing :)
16:03:42 <rakhmerov> let's what others say )
16:03:44 <xylan_kong> you know i'm going to be a father
16:03:52 <xylan_kong> LimorStotland: :-)
16:04:01 <rakhmerov> oooh, that is a much more important thing actually!
16:04:09 <xylan_kong> rakhmerov: yes, exactly
16:04:22 <xylan_kong> i will have a baby next month
16:04:28 <rakhmerov> let me know when you have a baby, I'll have a drink for his/her health (russian tradition)
16:04:30 <rakhmerov> :)
16:04:40 <xylan_kong> rakhmerov: sure, thanks!
16:04:43 <rakhmerov> ok
16:04:48 <rakhmerov> then let's start
16:04:58 <LimorStotland> Ooooo as we see in hebrew mazel tov!!!
16:05:05 <rakhmerov> someone from StackStorm might come but I'm not 100% sure
16:05:09 <rakhmerov> :)
16:05:43 <rakhmerov> ok, usually we start with "Review action items" topic but we haven't had meetings for a while so let's skip it
16:06:03 <rakhmerov> the agenda is at: https://wiki.openstack.org/wiki/Meetings/MistralAgenda
16:06:27 <rakhmerov> btw, just a quick note about our team meetings in general
16:06:59 <rakhmerov> I'd like to ask you to visit them at least once in a while if you can
16:07:30 <rakhmerov> even though it may seem useless for someone I notice that meetings help to keep member active
16:07:40 <rakhmerov> I don't know how exactly but it really works
16:07:44 <rakhmerov> :)
16:08:08 <rakhmerov> and please let me know in advance what you'd like to bring up at a next meeting
16:08:32 <rakhmerov> you can just modify that page that I posted here or reply to a reminder email
16:08:49 <LimorStotland> Ok
16:08:49 <rakhmerov> ook, let's move on
16:09:07 <rakhmerov> #topic Current Status (issues, roadblocks, etc.)
16:09:27 <NikolayM> my status:
16:09:44 <rakhmerov> in this traditional topic we usually report what we worked on last week, what we are working on now and what problems we have
16:10:28 <NikolayM> my status: worked on blueprint 'run individual actions', researched and developed new RPC layer for mistral (alternative RPC)
16:10:41 <m4dcoder> I worked on running unit tests on postgresql/mysql. there's a blocker on mysql version, need folks to comment on https://review.openstack.org/#/c/192961/
16:10:55 <rakhmerov> m4dcoder, hey! I didn't notice you're here )
16:11:01 <rakhmerov> good to see you here
16:11:14 <xylan_kong> my status:
16:11:16 <m4dcoder> i also started the "resume" feature. if there're additional comments/inputs, please review the thread in the ML.
16:11:24 <m4dcoder> hey, Renat!
16:11:39 <xylan_kong> my status: * implement a poc for retrieving executor service (it's used in workflow 'target'), but we need to discuss if everyone feels cool with it, so i can continue to work on it.
16:11:45 <xylan_kong> * add description support for execution, the api part has been merged, the client part is on review
16:11:49 <xylan_kong> * test database initialization for mysql and sqlite, correct the documentation
16:11:51 <rakhmerov> m4dcoder, ok, I'll see and comment on your patch
16:12:07 <LimorStotland> My status:i am working on puppet installation
16:12:25 <rakhmerov> ok
16:12:40 <m4dcoder> @rakhmerov: thanks!
16:12:58 <rakhmerov> guys, I see that you have some issues, let's discuss them in a few mins
16:13:03 <rakhmerov> ok
16:13:15 <NikolayM> also I had to move some patches from master to stable/kilo because devstack was not working there
16:13:49 <LimorStotland> i am on my phone so i met disconnect and connect again
16:13:57 <rakhmerov> my status: I just came back from vacation and was digging in my inbox all day, also reviewed and approved several patches and made a quick change in mistral-dashboard/.gitreview file
16:14:06 <rakhmerov> alright
16:14:07 <rakhmerov> good
16:14:38 <NikolayM> rakhmerov, those patches also already on review for week or more
16:14:48 <rakhmerov> nope
16:15:05 <rakhmerov> there wasn't a patch for mistral-dashboard repo
16:15:07 <rakhmerov> I checked
16:15:11 <NikolayM> https://review.openstack.org/191273
16:15:20 <NikolayM> and https://review.openstack.org/191406
16:15:45 <xylan_kong> yes
16:15:56 <rakhmerov> ooh... how come I missed them?..
16:15:57 <rakhmerov> ok
16:15:58 <rakhmerov> sorry
16:16:01 <NikolayM> I think you saw that
16:16:27 <rakhmerov> no-no, I was checking it specifically but for some reason I didn't see them for mistral-dashboard
16:16:40 <rakhmerov> ok, thanks, my fault
16:17:30 <LimorStotland> about the bp on chrome trigger in sec i have an issue.the oslo scheduler is under oslo-incubator are we fine with it?
16:18:01 <rakhmerov> ok, let's open a topic
16:18:02 <NikolayM> yes, we use periodic tasks
16:18:25 <rakhmerov> yes, I think that's fine
16:18:35 <LimorStotland> Ok thanks
16:19:02 <rakhmerov> we're going to get rid of as many packages from openstack/common as possible but for now we can't avoid all of them
16:19:06 <rakhmerov> so it's fine
16:19:23 <rakhmerov> #topic Liberty-1 status
16:19:52 <rakhmerov> guys, we're supposed to release a dev milestone this week, Liberty-1
16:19:54 <rakhmerov> https://launchpad.net/mistral/+milestone/liberty-1
16:20:16 <rakhmerov> so I'd like to sync up with you on what you think is feasible and what's not
16:20:39 <NikolayM> so, we have just 2 days before the liberty-1..
16:20:52 <rakhmerov> let's go over all the BPs now quickly and update their status
16:21:05 <rakhmerov> well, it's basically till the end of week
16:21:15 <rakhmerov> so we can think 3-4 days
16:21:22 <rakhmerov> not too much though I agree
16:21:39 <xylan_kong> rakhmerov: it's fine with my bp
16:21:49 <rakhmerov> this milestone is not too strong though and I don't want you to feel in rush but anyway, let's sync up
16:22:03 <rakhmerov> ok, let's go over them
16:22:09 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/run-unit-tests-on-postgresql
16:22:26 <rakhmerov> m4dcoder, can you comment on this BP?
16:22:44 <rakhmerov> how much is left on it?
16:22:46 <m4dcoder> the bp is up on review basically
16:23:03 <rakhmerov> you said you had some blocker
16:23:19 <rakhmerov> or it was about mysql config?
16:23:19 <m4dcoder> dzimine wants to see mysql included. but there's a problem with gate test for mysql
16:23:37 <rakhmerov> what kind of problem?
16:24:00 <m4dcoder> support for usec in datetime is only in mysql 5.6.4 and greater.
16:24:04 <dzimine> Hi there
16:24:15 <m4dcoder> hey, dmitri!
16:24:19 <NikolayM> hi!
16:24:19 <rakhmerov> hi dzimine, good to see you here!
16:24:21 <xylan_kong> hi, dzimine
16:24:57 <dzimine> Sorry I'm late. Catching up.
16:25:03 <NikolayM> devstack gate installs mysql itself and there is no reason to point it also in requirements.txt, I think
16:25:08 <rakhmerov> ok, m4dcoder, I agree that we need to have mysql stuff also. I think we can keep working on it
16:25:11 <NikolayM> the same for postgres
16:26:03 <rakhmerov> I'm not sure I understand the full context but can't we install any mysql version that we need on a gate?
16:26:16 <NikolayM> after that we'll have new devstack-gate with postgres where it also will be installed by devstack scripts
16:26:18 <m4dcoder> NikolayM, yeah, i can move the py lib for mysql and postgresql to the test script. that's not a big deal. the problem i have is the mysql version that devstack gate installs.
16:26:58 <rakhmerov> where is this version specified?
16:27:00 <dzimine> Re requirements.txt technically you are right but in practice everyone who set up mistral stepped at the trap of oh I don't have Python lib.
16:27:04 <rakhmerov> in an installation script?
16:27:29 <m4dcoder> also, rakhmerov, in this patch, i'm just supporting the unit tests to run from script (run_tests.sh).  still haven't figure out how to run the postgresql tests in devstack gate.
16:27:42 <rakhmerov> ooh, I see
16:28:05 <rakhmerov> but basically the BP is considered to be done? except we still owe you a review, right?
16:28:23 <m4dcoder> yes. more like help with removing blocker.
16:28:35 <NikolayM> dzimine, agree with you but installing everything is not the answer, right?
16:29:03 <rakhmerov> great, then let's keep working on that problem offline (IRC, ML and meetings if needed)
16:29:21 <rakhmerov> next BP: https://blueprints.launchpad.net/mistral/+spec/mistral-alternative-rpc
16:29:31 <NikolayM> it's mine
16:29:50 <rakhmerov> NikolayM, it seems like you won't be able to finish it till the end of week, right?
16:30:00 <NikolayM> let's move it to liberty-2
16:30:00 <rakhmerov> even though I know you made a progress on it
16:30:03 <NikolayM> yes
16:30:06 <rakhmerov> ok, let's do it
16:30:56 <rakhmerov> ok
16:31:00 <rakhmerov> the next one: https://blueprints.launchpad.net/mistral/+spec/mistral-workflow-variables
16:31:18 <rakhmerov> LimorStotland, did you have a chance to look at it?
16:31:54 <xylan_kong> maybe he is not here for the moment
16:32:01 <rakhmerov> she
16:32:02 <rakhmerov> :)
16:32:05 <xylan_kong> she?
16:32:08 <rakhmerov> yes
16:32:11 <xylan_kong> a girl? ooh, sorry
16:32:26 <rakhmerov> yeah, a pretty girl I should say :)
16:32:45 <xylan_kong> ok, forgive me
16:32:57 <rakhmerov> ok, let's go on and figure out the status of this BP later
16:33:19 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/yaql-v1-0
16:33:27 <rakhmerov> NikolayM, any news on this one?
16:33:43 <rakhmerov> did you talk to Murano folks about it?
16:34:30 <LimorStotland_> I  am here not yet sorry
16:35:04 <rakhmerov> ok
16:35:10 <NikolayM> I ask them to ping me if it will any progress here
16:35:14 <rakhmerov> just sent you an email with the same question..
16:35:32 <rakhmerov> LimorStotland_, is there a chance you'll look at it this week?
16:35:52 <rakhmerov> NikolayM, ok, got it. Same situation basically
16:36:08 <NikolayM> so, I can ask them again and get the answer
16:36:30 <rakhmerov> #action NikolayM: discuss yaql 1.0 with Murano team
16:36:59 <rakhmerov> the next one: https://blueprints.launchpad.net/mistral/+spec/mistral-execution-description
16:37:07 <xylan_kong> oh, it's mine
16:37:12 <rakhmerov> xylan_kong, it's on review, yes
16:37:13 <rakhmerov> I see
16:37:21 <xylan_kong> as i mentioned for my status, the api side is done
16:37:26 <rakhmerov> I'm sure it will be merged tomorrow
16:37:30 <rakhmerov> yep
16:37:30 <xylan_kong> but with a bug, https://review.openstack.org/#/c/193811/
16:37:40 <rakhmerov> what bug?
16:37:48 <xylan_kong> then the client side could pass the jenkins
16:38:04 <xylan_kong> rakhmerov: please see the patch, it's for the bug
16:38:36 <xylan_kong> lack of tests when i submit the previous patches for the bp
16:38:50 <rakhmerov> ooh, you mean we have a bug and BP filed for the same thing?
16:38:56 <xylan_kong> yes
16:39:08 <rakhmerov> can you please remove one of them from LP?
16:39:13 <rakhmerov> it's confusing
16:39:24 <rakhmerov> at your choice
16:39:38 <xylan_kong> rakhmerov: no-no, i mean i filed a bug, and https://review.openstack.org/#/c/193811/ is for that
16:39:47 <rakhmerov> I actually see this rather a BP than a bug though so you might want to change a patch commit message
16:40:22 <rakhmerov> hm...
16:40:33 <rakhmerov> ok
16:41:08 <rakhmerov> anyway, do you think you'll be able to finish everything on that this week?
16:41:09 <xylan_kong> rakhmerov: https://blueprints.launchpad.net/mistral/+spec/mistral-execution-description
16:41:14 <xylan_kong> yes, sure
16:41:20 <rakhmerov> I mean client side etc.
16:41:27 <rakhmerov> ok, cool
16:41:30 <rakhmerov> nice job
16:41:35 <xylan_kong> rakhmerov: certainly yes
16:41:46 <rakhmerov> next one: https://blueprints.launchpad.net/mistral/+spec/bash-completion-script-optimization
16:41:50 <rakhmerov> is done
16:41:57 <rakhmerov> no questions here
16:41:57 <xylan_kong> yep
16:42:07 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/mistral-retry-continue-on
16:42:26 <rakhmerov> NikolayM, I know it's on review but are there still any issues on that?
16:42:35 <rakhmerov> I remember we discussed a lot about it
16:43:17 <xylan_kong> the code has been merged
16:43:29 <NikolayM> it was merged recently, about 5-6 hours ago :)
16:43:42 <rakhmerov> ooh, yes
16:43:42 <rakhmerov> right
16:43:42 <rakhmerov> then let me fix its status
16:44:11 <rakhmerov> yes
16:44:16 <rakhmerov> sorry, overlooked it
16:44:22 <rakhmerov> next one: https://blueprints.launchpad.net/mistral/+spec/mistral-run-individual-action
16:44:37 <rakhmerov> NikolayM, your estimation?
16:44:58 <NikolayM> so, I think I finish it for day or two
16:45:06 <rakhmerov> ok, cool
16:45:22 <rakhmerov> and the last one
16:45:34 <rakhmerov> #topic BP: https://blueprints.launchpad.net/mistral/+spec/mistral-explicit-task-parameters
16:46:03 <rakhmerov> this one is assigned to me but we still actually don't have any detailed description on what we want to do here
16:46:30 <rakhmerov> I was actually going to discuss it with you today but looks like we don't have enough time for that
16:46:40 <xylan_kong> yes, i read it, but can't make sure i understand
16:47:10 <rakhmerov> so I would suggest I come up with a better spec (tomorrow) and let you know so that you comment it
16:47:20 <xylan_kong> ok, sounds great
16:47:23 <m4dcoder> sounds good.
16:47:37 <rakhmerov> if it's ok then I might have a chance to implement it and squeeze into Liberty-1 (not too likely though)
16:47:49 <rakhmerov> ok
16:49:21 <rakhmerov> basically, the idea is simple: if we need to jump to some task from many tasks (like "notify" task in lots of our unit tests) then it's not convenient to pass an input for it always using "publish" keyword
16:49:26 <rakhmerov> just too verbose
16:49:48 <rakhmerov> so the idea is to be able to configure that input as a set of regular function parameters
16:50:32 <rakhmerov> but, of course, it leads to a number of questions: how exactly is it going to work, are those params going to replace same vars in the context etc. etc.
16:50:43 <rakhmerov> so I'll describe everything first clearly.
16:50:47 <rakhmerov> alright
16:50:50 <xylan_kong> ok, i see
16:50:56 <rakhmerov> #topic Open Discussion
16:51:04 <rakhmerov> anything else guys?
16:51:14 <xylan_kong> rakhmerov: can we talk about https://blueprints.launchpad.net/mistral/+spec/mistral-executor-membership
16:51:20 <rakhmerov> yes
16:51:32 <xylan_kong> i just submited the poc code
16:51:52 <xylan_kong> just to prove what i want to do, and how i want it to be implemented
16:52:14 <rakhmerov> ok
16:52:34 <rakhmerov> I am not familiar with Tooz though
16:52:56 <rakhmerov> is it only going to work for our executors?
16:53:20 <xylan_kong> process initialization: http://dpaste.com/39QSHHP
16:53:21 <xylan_kong> get executros api: http://dpaste.com/1HTNMHM
16:53:23 <rakhmerov> I mean I'm kind of trying to understand the concept: why do we need this lib for executors but not for other components?
16:53:50 <xylan_kong> yes, it can be used in other compoments
16:54:04 <xylan_kong> just see if we have the use case
16:54:08 <rakhmerov> and what does it bring to us?
16:54:15 <rakhmerov> briefly
16:54:19 <rakhmerov> if it's possible )
16:55:03 <xylan_kong> we want to know how many executors in our system, and who are they, so we can use them in workflow
16:55:45 <rakhmerov> is this info stored in a DB?
16:55:49 <xylan_kong> no
16:55:49 <m4dcoder> are we going to have specialized executors?
16:55:51 <rakhmerov> or works differently
16:56:13 <xylan_kong> rakhmerov: it can use zookeeper as backend
16:56:22 <rakhmerov> m4dcoder, no, it's just a service to manage and monitor currently running executors and their properties
16:56:26 <rakhmerov> ok
16:56:37 <rakhmerov> xylan_kong, I think we just need to review your patches
16:56:40 <rakhmerov> first
16:56:48 <xylan_kong> ok
16:56:57 <rakhmerov> do you have any specific questions you'd like to bring up right now?
16:56:58 <rakhmerov> about it
16:57:04 <m4dcoder> in general, having tooz to track components can be useful, say if there're no executor available, then the API or engine should schedule the execution request for later, etc.
16:57:27 <m4dcoder> i'm unsure how it can be used directly in the WF if it's not supporting specialized executor.  maybe an example
16:57:39 <rakhmerov> one thing that concerns me is that ideally we need this kind of management console for all the system components: engines, apis, executors (scheduler later)
16:57:40 <xylan_kong> m4dcoder: target
16:57:51 <rakhmerov> yeah
16:58:02 <xylan_kong> m4dcoder: i saw it when i start to learn mistral
16:58:10 <xylan_kong> but i don't know its history
16:58:10 <rakhmerov> it's not supposed to be used in WF language, it's just a runtime tool
16:58:13 <m4dcoder> also, if we are using tooz, we can also take advantage of it to refactor distributed locking in mistral.
16:58:30 <xylan_kong> m4dcoder: yes, exactly
16:58:34 <rakhmerov> yeah, good though
16:58:37 <rakhmerov> thought
16:58:52 <rakhmerov> well, so far it wasn't really needed though
16:59:09 <rakhmerov> different topic I think anyway
16:59:24 <xylan_kong> ok
16:59:35 <rakhmerov> so ok, I mean maybe we should think about more general management console, not only about executors
16:59:40 <rakhmerov> that was my concern
17:00:03 <m4dcoder> +1
17:00:05 <rakhmerov> or just implement it for executors for now with a goal in mind to extend it later for other components
17:00:18 <rakhmerov> xylan_kong, what do you think?
17:00:28 <xylan_kong> ok, i will write a more detailed spec for the future work
17:00:33 <rakhmerov> ok
17:00:36 <m4dcoder> thx
17:00:43 <xylan_kong> :-)
17:00:45 <rakhmerov> ooh, shoot... we're out of time
17:00:53 <rakhmerov> thanks guys! great meeting
17:01:00 <rakhmerov> looking forward to talk to you again
17:01:02 <rakhmerov> thanks
17:01:03 <rakhmerov> bye
17:01:04 <xylan_kong> thanks
17:01:08 <xylan_kong> bye
17:01:09 <rakhmerov> #endmeeting