16:22:15 <rakhmerov> #startmeeting Mistral
16:22:16 <openstack> Meeting started Mon Apr 20 16:22:15 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:22:17 <rakhmerov> hi
16:22:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:22:21 <openstack> The meeting name has been set to 'mistral'
16:22:23 <rakhmerov> sorry for starting the meeting a little later
16:23:41 <NikolayM> hi !
16:23:44 <rakhmerov> hey
16:23:46 <akuznetsova> hey
16:23:50 <rakhmerov> let's wait for others
16:23:56 <rakhmerov> dzimine, you here?
16:24:01 <rakhmerov> m4dcoder?
16:24:10 <rakhmerov> xylan?
16:24:32 <dzimine> Yes
16:25:16 <rakhmerov> ok
16:25:19 <rakhmerov> let's start
16:25:29 <rakhmerov> #topic Review Action items
16:25:53 <rakhmerov> 1. rakhmerov, dzimine: figure out a plan for adding complex workflows into integration tests
16:26:11 <rakhmerov> it's still in progress, tomorrow we will have a meeting about it with Dmitri and Winson
16:26:35 <rakhmerov> #action rakhmerov (get others involved): figure out a plan for adding complex workflows into integration tests
16:26:53 <rakhmerov> 2. NikolayM: start ML discussion on YAQL 1.0, all: participate in it
16:26:55 <rakhmerov> done
16:27:06 <rakhmerov> 3. schedule a meeting with Dmitri and Nastya about integration testing
16:27:12 <rakhmerov> not done
16:27:23 <rakhmerov> #action rakhmerov: schedule a meeting with Dmitri and Nastya about integration testing
16:27:39 <rakhmerov> 4. rakhmerov: talk to Winson about his ideas on how to run stress tests in Mistral
16:27:46 <rakhmerov> it actually duplicates #1
16:28:12 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:28:19 <rakhmerov> let's report our current statuses
16:29:39 <dzimine> Just reviews these weeks
16:29:41 <NikolayM> my status: fixed some bugs, did yaql rollback, 'with-items' ordering. Today fixed one small bug in client
16:30:02 <rakhmerov> my status: last week I finished removing v1 artefacts, fixed a number of bugs including mistakes in "join" tests (all partial join tests were not thread-safe), also was involved in some administrative activities related with moving to openstack/ space
16:30:12 <rakhmerov> ok
16:30:24 <rakhmerov> #topic What's left to do in Kilo? (critical bugs, docs etc.)
16:30:31 <rakhmerov> ooh, one more thing
16:30:36 <rakhmerov> R1 is released
16:31:09 <rakhmerov> just a reminder: keep in mind that RC releases are not supposed to be uploaded on pypi
16:31:20 <rakhmerov> only official releases
16:31:56 <rakhmerov> ok, the main topic I was going to discuss is what else we should do till the end of Kilo cycle
16:32:06 <rakhmerov> it's generally less than two weeks
16:32:46 <rakhmerov> so I think it's time to do the last proposal on most important bugs/improvements and maybe even blueprints
16:33:07 <rakhmerov> however my suggestion is to not start anything heavy
16:33:37 <rakhmerov> I also would like to spend 2 days to refresh our documentation
16:33:47 <rakhmerov> btw, any help would be appreciated :)
16:34:27 <rakhmerov> ok
16:34:34 <akuznetsova> rakhmerov, what do you mean by 'refresh' ?
16:34:47 <akuznetsova> update articles in wiki ?
16:35:03 <rakhmerov> I mean "update it", many sections are obsolete
16:35:08 <rakhmerov> yes
16:35:24 <rakhmerov> let's take a look at the Lauchpad and make our suggestions on bugs/bps
16:36:07 <rakhmerov> one thing that we need to finish is https://blueprints.launchpad.net/mistral/+spec/mistral-default-input-values
16:36:07 <akuznetsova> now we are part of OpenStack and out official docs http://mistral.readthedocs.org/en/master/ are not in a good shape
16:36:16 <rakhmerov> it's done for workflows, but not done for actions yet
16:36:26 <rakhmerov> Lingxian Kong is now working on it
16:36:39 <rakhmerov> akuznetsova, yes
16:37:17 <akuznetsova> rakhmerov, maybe it's time to migrate from wiki to readthedocs ?
16:37:19 <rakhmerov> at this point though nobody is pushing us to get everything into ideal shape but yes, we need to improve it sooner than later
16:37:29 <rakhmerov> akuznetsova, yes!
16:37:34 <rakhmerov> I agree
16:38:16 <rakhmerov> in Liberty it will be on docs.openstack.org actually
16:38:34 <rakhmerov> I don't know now how it's going to happen but we'll figure it out
16:38:52 <rakhmerov> the main thing is to get the doc into shape now
16:39:49 <rakhmerov> so another BP: https://blueprints.launchpad.net/mistral/+spec/on-condition-one-liner
16:40:01 <rakhmerov> it seems to have been done actually
16:40:30 <rakhmerov> because our task spec seems to be supporting both lists and strings in on-XXX clauses
16:40:47 <rakhmerov> but we need to verify it and write tests for that if needed
16:41:47 <rakhmerov> I would also suggest we finish https://bugs.launchpad.net/mistral/+bug/1428576
16:41:48 <openstack> Launchpad bug 1428576 in Mistral kilo "Retry policy break-on property does not work" [Medium,In progress] - Assigned to Nikolay Makhotkin (nmakhotkin)
16:42:42 <rakhmerov> looks like we came to some ideas on that with dzimine, so I think we need to renew the thread in ML, agree on the solution and get it done
16:43:01 <rakhmerov> guys, any suggestions from your side?
16:43:03 <rakhmerov> dzimine?
16:43:12 <rakhmerov> NikolayM?
16:44:02 <NikolayMM> rakhmerov, it seems that on-condition-one-liner blueprint still is not done: https://github.com/stackforge/mistral/blob/master/mistral/workbook/types.py#L114
16:44:16 <rakhmerov> ok
16:44:17 <NikolayMM> it allows only list
16:44:26 <rakhmerov> Hm.. interesting
16:44:36 <rakhmerov> I thought I saw it allowing a string
16:44:45 <rakhmerov> that's ok, then we need to complete it
16:45:06 <rakhmerov> so just from usability standpoint I would also like to see https://bugs.launchpad.net/mistral/+bug/1444390 done
16:45:07 <openstack> Launchpad bug 1444390 in Mistral kilo ""Task name" column is missing in CLI action-execution-[list|get] commands" [Undecided,New]
16:45:24 <rakhmerov> #link https://bugs.launchpad.net/mistral/+bug/1444390
16:45:42 <rakhmerov> #link https://bugs.launchpad.net/mistral/+bug/1428576
16:45:43 <openstack> Launchpad bug 1428576 in Mistral kilo "Retry policy break-on property does not work" [Medium,In progress] - Assigned to Nikolay Makhotkin (nmakhotkin)
16:46:01 <rakhmerov> #link https://blueprints.launchpad.net/mistral/+spec/on-condition-one-liner
16:46:15 <NikolayMM> hmm
16:46:37 <NikolayMM> let's decide what we want to see instead of 'break-on'
16:47:34 <rakhmerov> NikolayMM, I thin it makes sense to get back to ML, I'm afraid we just don't have enough time right now
16:47:50 <rakhmerov> sounds ok?
16:48:02 <NikolayMM> yes
16:48:04 <NikolayMM> ok
16:48:26 <rakhmerov> #action rakhmerov: renew ML discussion about "break-on"
16:49:44 <rakhmerov> so what else do you think is critical to fix?
16:50:12 <dzimine> My internet went down, sorry
16:50:33 <dzimine> Still down. I'll pick it up on ML
16:50:56 <rakhmerov> ok, no problem
16:51:18 <rakhmerov> dzimine, do you see anything critically important for you that we need to fix in Kilo?
16:51:26 <rakhmerov> that's not done yet
16:53:42 <rakhmerov> ok, looks like dzimine is still experiencing some connectivity issues..
16:54:42 <rakhmerov> ok, so I don't see any other critical things for now
16:54:58 <rakhmerov> and I don't have anything else to discuss for today
16:55:15 <rakhmerov> let's close the meeting unless you have something else
16:56:02 <rakhmerov> ok
16:56:09 <rakhmerov> thanks for joining
16:56:13 <rakhmerov> bye
16:56:15 <NikolayMM> bye
16:56:21 <rakhmerov> #endmeeting