16:20:07 <rakhmerov> #startmeeting Mistral
16:20:08 <openstack> Meeting started Mon Apr 13 16:20:07 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:20:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:20:11 <openstack> The meeting name has been set to 'mistral'
16:20:34 <rakhmerov> hi
16:20:47 <xylan> hi
16:20:54 <xylan> my first time here
16:21:02 <rakhmerov> heey
16:21:14 <rakhmerov> what time is it in your timezone? )
16:21:20 <xylan> 00:30
16:21:23 <rakhmerov> woow
16:21:28 <xylan> a little late
16:21:43 <rakhmerov> you're desparate :)) ha-ha
16:21:47 <rakhmerov> ok
16:22:00 <dzimine> hi
16:22:03 <rakhmerov> not sure though if we'll have a lot of people here today
16:22:05 <rakhmerov> let's wait
16:22:09 <rakhmerov> hi dzimine
16:22:14 <rakhmerov> how are you?
16:22:29 <dzimine> :20 is a strange time, easy to miss
16:22:43 <rakhmerov> it was going to be temporary
16:22:53 <rakhmerov> because scheduling issues
16:23:00 <rakhmerov> I hope to fix it soon
16:23:04 <rakhmerov> sorry for that
16:23:10 <dzimine> np at all.
16:23:17 <rakhmerov> ok, let's start discussing something
16:23:44 <rakhmerov> #topic Review Action Items
16:23:48 <dzimine> ok m4dcoder won't join today, he's on a plane fyling to PyCon, btw if any of you guys are in PyCon, you can hook around
16:24:08 <rakhmerov> :)
16:24:10 <rakhmerov> ok
16:24:16 <rakhmerov> 1. rakhmerov: file LP bugs for concurrent issues in data flow and join tests
16:24:26 <rakhmerov> #info https://bugs.launchpad.net/mistral/+bug/1443285
16:24:27 <openstack> Launchpad bug 1443285 in Mistral kilo "Periodic failures of data flow and join tests" [Undecided,New] - Assigned to Renat Akhmerov (rakhmerov)
16:24:44 <rakhmerov> 2. rakhmerov, dzimine: figure out a plan for adding complex workflows into integration tests
16:24:59 <rakhmerov> still need to do, I hope this week
16:25:05 <rakhmerov> #action rakhmerov, dzimine: figure out a plan for adding complex workflows into integration tests
16:25:15 <rakhmerov> it's not urgent though IMO
16:25:29 <rakhmerov> 3. dzimine, rakhmerov: create necessary BPs for changes described in https://docs.google.com/a/stackstorm.com/document/d/1Gy6V9YBt8W4llyErO_itHetkF1oNYv4ka-_5LdFKA18/edit#
16:25:52 <rakhmerov> they're created
16:25:54 <dzimine> done
16:25:57 <rakhmerov> yes
16:26:07 <rakhmerov> 4. rakhmerov: make sure to look at "Invent better condition" section in https://docs.google.com/a/stackstorm.com/document/d/1Gy6V9YBt8W4llyErO_itHetkF1oNYv4ka-_5LdFKA18/edit#heading=h.n1jc8i9qhikt
16:26:13 <rakhmerov> I did look at it
16:26:30 <rakhmerov> I think it doesn't make sense to discuss details right now
16:26:42 <rakhmerov> and we decided to move it to liberty right
16:27:03 <rakhmerov> let's move next
16:27:06 <rakhmerov> #topic Current Status (by team member)
16:28:07 <dzimine> haven't done any mistral work last week.
16:28:07 <rakhmerov> my status: last week I finished deleting all v1 stuff, finally it's done. I also started fixing another portion of concurrency problems occurring in Mistral engine once in a while
16:28:22 <rakhmerov> I'm still in progress
16:28:24 <rakhmerov> ok
16:28:53 <rakhmerov> I also see a bunch of patches from xylan and m4dcoder that I need to review today
16:29:11 <xylan> yes, i have finished this bp https://blueprints.launchpad.net/mistral/+spec/mistral-default-input-values today, still need to fix some issues Winson suggested
16:29:17 <dzimine> m4dcoder has his YAML validation patch ready but not in waiting for YAQL changes to merge
16:29:30 <rakhmerov> yeah
16:29:32 <dzimine> not it's rebased.
16:29:49 <dzimine> and ready to be reviewed (except we should discuss YAQL in a min).
16:29:57 <rakhmerov> xylan, ok, I'll review your patches (and I hope others too) tomorrow the first thing
16:30:07 <xylan> very appreciate
16:30:18 <rakhmerov> I have something to discuss on YAQL too
16:30:24 <rakhmerov> ok
16:30:35 <rakhmerov> let me quickly report on RC1 progress
16:30:43 <rakhmerov> #topic RC1 progress
16:30:56 <rakhmerov> so this week we'll release RC1
16:31:38 <rakhmerov> basically we just need to squeeze in a couple of things
16:31:47 <rakhmerov> DSL changes (like removing "policies")
16:32:15 <NikolayM> hi everyone
16:32:24 <NikolayM> I am late, sorry
16:32:29 <rakhmerov> and some additional things on "with-items"
16:32:35 <rakhmerov> hi NikolayM
16:32:44 <rakhmerov> can you please report your status?
16:33:11 <rakhmerov> so RC1 I think is on target, we have several things that we're going to finish this week
16:33:56 <rakhmerov> and btw, TC will be considering Mistral addition to OpenStack
16:34:02 <rakhmerov> cross your fingers )
16:34:18 <dzimine> nice
16:34:21 <xylan> :)
16:34:22 <NikolayM> my status: last week I fixed some bugs, especially bug with DB error in transport and issue with 500 error on API in case of rabbit transport
16:34:23 <rakhmerov> I already saw the corresponding item in their agenda for tomorrow
16:34:40 <NikolayM> also worked on moving to YAQL 1.0
16:34:52 <rakhmerov> NikolayM, good, I saw your patches but didn't have a chance to review
16:35:00 <rakhmerov> ok
16:35:29 <rakhmerov> ok, let's go straight to open discussion and talk about YAQL and whatever else that we need
16:35:35 <rakhmerov> #topic Open Discussion
16:35:46 <NikolayM> rakhmerov, I heard that murano has integration w/ mistral but they are still using old yaql (0.2.4)
16:35:55 <rakhmerov> ok, yes
16:36:06 <rakhmerov> that was my first item I wanted to discuss
16:36:19 <rakhmerov> so
16:36:25 <NikolayM> so they want us to revert yaql in Mistral to 0.2.4
16:36:27 <rakhmerov> it's kind of weird actually
16:36:32 <NikolayM> yes
16:36:37 <rakhmerov> is that a blocker for them?
16:36:47 <rakhmerov> the fact that we use YAQL 1.0 already
16:37:16 <dzimine> they talked us into using 1.0 :) and now it's a problem
16:37:22 <NikolayM> I think it is a good idea to have a discussion with murano guys
16:37:36 <NikolayM> dzimine, yes :)
16:37:58 <rakhmerov> NikolayM, can you please explain the root of the problem?
16:38:05 <dzimine> yeah if we begin to put changes on top of changes - like there are 2 patches on review to adjust to 1.0 YAQL...
16:38:17 <dzimine> may be it's a right thing for them to push forward :)
16:38:38 <dzimine> so, discuss on mail list?
16:39:05 <rakhmerov> so as far as I understand the only problem for them now is that integration piece made my HP folks? Murano calling Mistral workflows?
16:39:15 <NikolayM> rakhmerov, Mistral is not working w/ murano
16:39:18 <rakhmerov> dzimine, yes, I think it should be discussed in ML
16:39:34 <NikolayM> rakhmerov, yes
16:39:40 <rakhmerov> NikolayM, what does it mean "is not working ..."?
16:39:45 <rakhmerov> ok
16:39:51 <rakhmerov> so, integration...
16:40:00 <NikolayM> murano and mistral have different yaql versions
16:40:11 <rakhmerov> is it critical for them to make it work now by the end of Kilo?
16:40:16 <rakhmerov> I know
16:40:26 <NikolayM> ooh, I don't know exactly
16:40:34 <rakhmerov> I am just trying to understand the scale of the problem for Murano
16:40:39 <rakhmerov> ok
16:40:40 <rakhmerov> ML
16:41:14 <rakhmerov> #action NikolayM: start ML discussion on YAQL 1.0, all: participate in it
16:41:31 <dzimine> AFAIK it's not Murano problem: it's a problem for the Murano/Congress/Mistral integration initiative project.
16:41:45 <rakhmerov> may be
16:41:57 <dzimine> To which they run the gate tests just to be sure that the 3 install together in the same building.
16:42:12 <rakhmerov> it would be cool if we could somehow support both YAQL versions
16:42:34 <rakhmerov> but it may not be that easy to do
16:42:49 <rakhmerov> dzimine, yes
16:43:28 <rakhmerov> I saw that Stan was mentioning that there's a chance for Murano to transition to YAQL 1.0
16:43:38 <dzimine> so we need to check if this is a voting gate, how critical it is (e.g. can we make it fail till they upgrade), etc.
16:43:41 <rakhmerov> ok, let's try to figure the solution here
16:43:50 <rakhmerov> yes
16:43:51 <rakhmerov> right
16:43:58 <dzimine> ok, Mailing list than.
16:44:02 <rakhmerov> yep
16:44:14 <rakhmerov> dzimine, looks like you had a topic to discuss?
16:44:18 <rakhmerov> on yaql too
16:44:59 <dzimine> yaql we just discussed.
16:45:17 <rakhmerov> ooh, I thought you were going to discuss something else
16:45:19 <rakhmerov> ok
16:45:41 <dzimine> on more integration tests - we probably need Nastya to participate.
16:46:14 <rakhmerov> ok
16:46:18 <dzimine> We have some Mistral integation tests we use in StackStorm, which can be creatively ported to mistral functional tests. Some workflows
16:46:25 <rakhmerov> we can try to schedule a meeting with her
16:46:35 <dzimine> so no, nothing esle.
16:46:55 <rakhmerov> ok
16:47:24 <rakhmerov> #action rakhmerov: schedule a meeting with Dmitri and Nastya about integration testing
16:48:00 <rakhmerov> dzimine
16:48:03 <rakhmerov> quick question
16:48:21 <rakhmerov> did you already switch to using our latest code?
16:48:30 <rakhmerov> after that big refactoring
16:49:18 <dzimine> yes, to after big refactoring code.
16:49:29 <dzimine> but not to the latest bits.
16:49:39 <rakhmerov> ok
16:50:01 <rakhmerov> was just curious to know if it works ok for you
16:50:01 <dzimine> https://github.com/StackStorm/mistral/tree/st2-0.8.1
16:50:07 <rakhmerov> ok
16:50:26 <rakhmerov> we still keep finding some concurrent issues in our tests
16:50:32 <dzimine> you can always see what we are usign - the latest branch corresponds to what it is.
16:50:47 <rakhmerov> I'm now trying to polish everything to avoid them
16:50:56 <dzimine> the question there is what is 'tests', because of sqlite, and what is real.
16:50:59 <rakhmerov> ok, thanks, got it
16:51:16 <rakhmerov> yes, exactly, that's what I'm trying to figure out now
16:51:41 <dzimine> that's why I think if we do 1) functional test and 2) find ways to run them under stress we will be catching many of these concurrencty issues.
16:51:50 <rakhmerov> I fixed a number of things weeks ago but now I have only assumptions where and what may be wrong
16:52:04 <rakhmerov> 100% agree
16:52:12 <rakhmerov> so it's an important thing to do
16:52:40 <rakhmerov> let's discuss the plan on our regular meeting this week (or earlier if possible)
16:53:06 <dzimine> rakhmerov if you reach out to m4dcoder directly he had some ideas and script runs that stress tests mistral.
16:53:27 <dzimine> they are not directly applicable to mistral as they rely on st2 but may be can be ported.
16:53:32 <dzimine> I'll talk to him too.
16:54:02 <rakhmerov> sure
16:54:05 <rakhmerov> I'll do
16:54:41 <rakhmerov> #action rakhmerov: talk to Winson about his ideas on how to run stress tests in Mistral
16:55:00 <rakhmerov> ok, guys. Do you have anything else?
16:55:07 <dzimine> not on my side.
16:55:07 <rakhmerov> any blockers that you see?
16:55:20 <rakhmerov> ooh
16:55:48 <rakhmerov> NikolayM, did you already think how to implement ordering for 'with-items'?
16:56:05 <NikolayM> not yet
16:56:07 <rakhmerov> is going to be simple/hard?
16:56:10 <rakhmerov> ok, no problem
16:56:21 <rakhmerov> please spend some time and let us know
16:56:38 <NikolayM> I think it won't be so simple
16:56:43 <rakhmerov> :))
16:56:56 <rakhmerov> let's think about it
16:57:00 <NikolayM> ok
16:57:12 <rakhmerov> we need to implement it before Apr 30
16:57:27 <rakhmerov> it's kind of a critical bug in 'with-items' now
16:57:46 <rakhmerov> ok, I suggest that we close our meeting for today. 2 mins left
16:57:55 <rakhmerov> thanks guys for coming
16:58:02 <rakhmerov> appreciate that
16:58:11 <xylan> :)
16:58:36 <NikolayM> bye!
16:58:38 <rakhmerov> bye
16:58:40 <xylan> bye
16:58:42 <rakhmerov> #endmeeting