16:00:20 <rakhmerov> #startmeeting Mistral
16:00:29 <openstack> Meeting started Mon Feb  9 16:00:20 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:34 <openstack> The meeting name has been set to 'mistral'
16:00:37 <rakhmerov> hi
16:00:44 <akuznetsova> hi
16:00:54 <dzimine> hallo :)
16:01:21 <rakhmerov> :)
16:01:43 <rakhmerov> let's wait a couple of mins
16:03:08 <rakhmerov> hm.. looks like there're just two of us
16:03:43 <akuznetsova> i am here too :(
16:03:50 <rakhmerov> ook )
16:04:00 <rakhmerov> let's start
16:04:11 <rakhmerov> #topic Review Action Items
16:04:21 <rakhmerov> 1. dzimine, look at the bugs and assigned most critical ones to kilo-2
16:04:31 <rakhmerov> it's not relevant anymore and I guess it was done
16:04:33 <dzimine> oh… didn’t do it exactly
16:04:39 <dzimine> but no, irrelevant.
16:04:44 <rakhmerov> yeah, that's ok
16:04:50 <dzimine> did hte best effort anyways.
16:04:58 <rakhmerov> sure
16:05:01 <rakhmerov> 2. akuznetsova, file bugs for recently found usability issues
16:05:17 <akuznetsova> rakhmerov, done
16:05:21 <rakhmerov> ok
16:05:40 <rakhmerov> it means the bugs with environments, right?
16:05:50 <akuznetsova> correct
16:05:53 <rakhmerov> ok
16:06:06 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:06:27 <rakhmerov> my status: released kilo-2 on Friday and keep refactoring task result processing
16:06:48 <rakhmerov> there's some progress but I still need to spend I guess a few days on that
16:07:37 <dzimine> dzimine status: last week - flashed out how to handle YAML with rakhmerov, completed the “catch exeptions” bug fix;
16:07:54 <rakhmerov> well done, btw!
16:07:55 <dzimine> this week - small change to expose the “stop workflow” functionality
16:08:01 <rakhmerov> ok
16:08:03 <dzimine> in the API
16:08:04 <akuznetsova> my status: finished with first commit to Rally and now we almost have a special Rally gate in mistral repo, prepared cli tests for env, now I am working on instraction : how to run Rally Mistal scenarious
16:08:19 <rakhmerov> well done too :))
16:08:47 <rakhmerov> btw, http://logs.openstack.org/47/153647/2/check/gate-rally-dsvm-mistral-task/bf39010/
16:08:49 <dzimine> nice. Are we getting good load there?
16:09:00 <rakhmerov> click HTML report link
16:09:15 <rakhmerov> dzimine, it's rather a required piece of infrastructure
16:09:33 <dzimine> yes I know.
16:09:43 <rakhmerov> which gives us the mechanism to easily add new load tests
16:09:54 <rakhmerov> now it'll be easy to write them
16:10:11 <rakhmerov> as far as good load, not yet
16:10:33 <akuznetsova> yes, I just made initial commit with needed Mistral infrastructure and basic scenarios
16:10:50 <rakhmerov> ok
16:11:14 <rakhmerov> let's move to the next topic
16:11:17 <rakhmerov> #topic "Kilo-3" scope and blueprints
16:11:35 <rakhmerov> so we released kilo-2 and several BPs were moved to kilo-3
16:11:36 <dzimine> well kilo-3 is “a final release”, right?
16:12:05 <rakhmerov> not exactly
16:12:09 <rakhmerov> let me clarify
16:12:22 <rakhmerov> during kilo-3 we can add new functionality
16:12:30 <rakhmerov> after that no
16:12:36 <dzimine> clear.
16:12:39 <rakhmerov> only bugfixing, stability, docs
16:12:42 <dzimine> and when is kilo-3 again?
16:13:02 <rakhmerov> but this is only if we 100% follow OpenStack procedures
16:13:09 <rakhmerov> March 19
16:13:20 <rakhmerov> a month
16:13:33 <rakhmerov> just over
16:14:10 <dzimine> ok. we need to review the BP and bugs than and capture anything recent in them. Like YAQL clean-up.
16:14:22 <rakhmerov> and even if we do follow OpenStack rules then there's a mechanism called something like "feature request" to add new functionality even after 3rd dev milestone
16:14:31 <rakhmerov> yes
16:15:01 <dzimine> and when is the final Kilo release in OpenStack?
16:15:03 <nmakhotkin> Hi, sorry, I am late
16:15:18 <rakhmerov> today I actually just wanted to ask you to look at Kilo-3 and validate if 1) all you're interested in is included 2) suggest what could be removed
16:15:23 <rakhmerov> nmakhotkin, np
16:15:24 <rakhmerov> hi
16:15:31 <akuznetsova> dzimine, https://wiki.openstack.org/wiki/Kilo_Release_Schedule
16:15:37 <rakhmerov> yep
16:15:38 <dzimine> ^^ thanks
16:15:53 <rakhmerov> April 30
16:16:22 <rakhmerov> so during April we're supposed to be fixing lots and lots of bugs like crazy )
16:17:07 <rakhmerov> so as far as scope of kilo-3 we can do a planning poker again
16:17:13 <dzimine> oh, we’ll be fixing them now, too :)
16:17:25 <rakhmerov> yes )
16:17:43 <rakhmerov> I'll set up a meeting for planning poker later
16:18:01 <akuznetsova> rakhmerov, what with our scope ? do we have the final list of bps for kilo-3 ?
16:18:06 <dzimine> ok than the action is to capture all in the blueprints. and when we do the pocker, we shall 1) allocatie tme for bugs and 2) review existing bugs and assign them to the scope, too. #action
16:18:56 <rakhmerov> akuznetsova, no, we don't yet have all the BPs. I'm hereby asking to suggest (can do that offline) what you would like to see in Kilo-3
16:19:15 <rakhmerov> and after that we will estimate if it's feasible to do during kilo-3
16:19:50 <rakhmerov> #action rakhmerov, dzimine: capture everything in blueprints
16:20:17 <rakhmerov> #action rakhmerov, dzimine: review existing bugs and assign them to the scope
16:20:19 <rakhmerov> thanks
16:20:59 <rakhmerov> ok, that's basically all I wanted for this meeting
16:21:43 <dzimine> quick discussion on YAQL? just to put the thoughs:
16:21:45 <rakhmerov> Nikolay is fixing expressions now, looks like now we have a full picture
16:21:51 <rakhmerov> yes
16:21:55 <rakhmerov> go ahead
16:22:30 <dzimine> 1) rakhmerov pls share the details of what we came up with, the just of it is to always use “{yaql}”.
16:22:47 <dzimine> 2) the question is: if we do it, it breaks v1, too.
16:22:55 <dzimine> how do we deal with it?
16:23:10 <rakhmerov> well
16:23:26 <dzimine> from what I know it only can impact solum.
16:23:32 <dzimine> anyone else?
16:23:48 <rakhmerov> 1) yes. The details are captured in https://etherpad.openstack.org/p/mistral-DZ-RA (maybe not well structured) but I think we're all on the same page here
16:24:02 <rakhmerov> 2) do we still need to care about v1?
16:24:14 <rakhmerov> I was going to get rid of it completely
16:24:33 <rakhmerov> solum yes, but we effectively don't support v1 anyway
16:24:44 <akuznetsova> we already broke v1 )
16:24:49 <rakhmerov> so they can keep using one of the previous versions
16:25:20 <rakhmerov> but yes, expressions will break v1 if we don't split them into versions (I would hate to do that though)
16:25:38 <rakhmerov> akuznetsova, how did we break it?
16:25:49 <rakhmerov> you mean that failing test that we found today?
16:26:07 <akuznetsova> rakhmerov, yes, it fails on every commit now
16:26:20 <rakhmerov> I'm still hoping it was done by mistake
16:26:33 <rakhmerov> if not then yes, we already did
16:27:07 <dzimine> and solum likely pinned the version of mistral..
16:27:14 <rakhmerov> and if we still want to support v1 we will have to restore old expressions and let it leave in a v1 related module
16:27:23 <rakhmerov> dzimine, I think so
16:27:29 <rakhmerov> we can ask them anyway
16:27:41 <dzimine> no they didn’t https://github.com/stackforge/solum/blob/master/requirements.txt#L23
16:28:03 <dzimine> we can commit a fix for them once we move over.
16:28:11 <rakhmerov> yeah, but this is a client
16:28:26 <rakhmerov> not sure about server
16:28:58 <rakhmerov> #action rakhmerov: talk to solum folks (Roshan) and find out what version of Mistral they depend on
16:29:37 <rakhmerov> yes, we were going to help them this winter to transition to v2
16:29:44 <rakhmerov> but it didn't happen yet
16:29:50 <rakhmerov> and maybe to the better
16:30:02 <rakhmerov> given all those changes we're making now
16:30:36 <rakhmerov> so, again, let's think if we still need to leave v1 code base
16:31:06 <dzimine> afaik they use devstack.
16:31:13 <rakhmerov> the only reason I see for that is just to have a clear example of how system can evolve from one version to another
16:31:27 <dzimine> strongly recommend to keep them on v1 till we flash out v2 details.
16:31:42 <rakhmerov> yes, maybe
16:32:31 <rakhmerov> #action all: think if we need to keep v1 code base
16:32:34 <dzimine> as for the approach - Nikolay, Nastya, did you have a chance to see it? you’re ok with it?
16:32:58 <akuznetsova> dzimine, to see what ?
16:33:18 <rakhmerov> I'm not sure I followed the question..
16:33:20 <rakhmerov> yep
16:33:21 <dzimine> oh I thought Renat had shared it - the proposal to change yaql.
16:33:33 <rakhmerov> aah
16:33:37 <rakhmerov> yes I did
16:33:44 <akuznetsova> oh, yes, it was shared
16:34:09 <dzimine> that’s the best we managed to come up with, input very welcome.
16:34:19 <rakhmerov> right
16:34:21 <dzimine> if we go ahead tdo it, time is now.
16:34:42 <rakhmerov> to me it looks good now
16:34:44 <dzimine> else we are too close to kilo-3, and if we pass kilo-3 with these changes, it gets harder to chagne.
16:34:58 <rakhmerov> yes
16:35:15 <dzimine> The change is relatively big. we need a blueprint on it.
16:35:28 <rakhmerov> well, my general comment here: I insist we stabilize v2 api/dsl during kilo-3
16:35:47 <rakhmerov> after that it will be really bad of us
16:35:50 <rakhmerov> if we do
16:36:25 <rakhmerov> which means we should try pretty hard during till March 19
16:36:34 <dzimine> yes and once we stabilize it we can dump v1
16:36:50 <rakhmerov> I agree
16:36:51 <rakhmerov> yes
16:37:13 <dzimine> this YAQL thing is the biggest one so far.
16:37:20 <rakhmerov> yep
16:37:31 <dzimine> others we have already agreed on.
16:37:35 <rakhmerov> the second is task result thing
16:37:41 <dzimine> yes.
16:37:52 <dzimine> task result thing.
16:38:00 <rakhmerov> :))
16:38:02 <dzimine> which you Renat is already working towrads.
16:38:06 <rakhmerov> ok
16:38:13 <rakhmerov> do we need to discuss anything else now?
16:38:20 <rakhmerov> I am out of ideas :)
16:38:38 <dzimine> Quck update for Winson m4dcoder - he is implementing a bunch of production workflows now and filing/fixing bugs as he goes.
16:38:42 <dzimine> Including usability ones.
16:38:52 <rakhmerov> very good
16:39:00 <dzimine> Well I want to decide who is doing YAQL and when
16:39:02 <rakhmerov> we'll strive to fix them asap
16:39:15 <akuznetsova> will we implement crud operations in  UI ?
16:39:16 <rakhmerov> Nikolay has already started with it
16:39:34 <dzimine> and just to share with you that we deployed Mistral on multiple nodes with scaled out SQL and scaled out Rabbit underneath, and will be running shitload of workflows on it.
16:39:44 <dzimine> Now guess what I expect it to fail dramatically : )
16:39:45 <dzimine> hahaha
16:39:52 <dzimine> but than we fix it.
16:39:55 <rakhmerov> akuznetsova, I would like to but I think we first need to look at all more important things to do and estimate our efforts
16:40:18 <rakhmerov> :))
16:40:25 <dzimine> > Nikolay has already started with it
16:40:30 <dzimine> with GRUD in UI?
16:40:39 <rakhmerov> GRUD :)))))
16:40:42 <rakhmerov> CRUD
16:40:45 <akuznetsova> rakhmerov, yes, sure, YAQL and dsl stabilization are more important )
16:41:17 <rakhmerov> dzimine, yes, we wanted to adjust UI a little bit so we could do all the CRUD operations
16:41:25 <dzimine> lastly, what’s the story on deploying Javascript engine? Nikolay?
16:41:27 <rakhmerov> which we currently don't have
16:41:54 <rakhmerov> Nikolay, can you please give us a link to the doc where you described that?
16:42:28 <akuznetsova> nmakhotkin, ^
16:44:03 <rakhmerov> nmakhotkin, you're still with us? :)
16:44:49 <rakhmerov> I guess he's experiencing some connectivity problems
16:44:54 <rakhmerov> it happens to him sometimes
16:45:24 <rakhmerov> so dzimine we can ask him to share the details later
16:45:45 <rakhmerov> is that ok?
16:45:48 <dzimine> ?
16:45:58 <dzimine> ok.
16:46:01 <rakhmerov> if he tells us later
16:46:03 <dzimine> done for today?
16:46:06 <rakhmerov> looks like he's gone
16:46:08 <rakhmerov> yep
16:46:16 <rakhmerov> let's finish
16:46:25 <dzimine> we’re all done for today right?
16:46:31 <rakhmerov> yes
16:46:33 <rakhmerov> thanks and bye!
16:46:39 <akuznetsova> bye!
16:46:41 <rakhmerov> #endmeeting