16:00:35 <rakhmerov> #startmeeting Mistral
16:00:35 <openstack> Meeting started Mon Feb  2 16:00:35 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:39 <openstack> The meeting name has been set to 'mistral'
16:00:47 <nmakhotkin> hi!
16:01:43 <rakhmerov> hi Nikolay
16:01:48 <rakhmerov> 2 mins
16:02:47 <akuznetsova> hi, sorry, I am a bit late
16:03:48 <dzimine> hi all
16:04:29 <rakhmerov> no problem
16:04:42 <rakhmerov> guys, I apologize, pls give me 2 more mins
16:07:55 <rakhmerov> I'm here
16:07:58 <rakhmerov> ok
16:08:40 <rakhmerov> so we didn't actually have any action items
16:09:06 <rakhmerov> so let's discuss other topics
16:09:22 <rakhmerov> #topic Kilo-2 progress
16:09:52 <rakhmerov> release page: https://launchpad.net/mistral/+milestone/kilo-2
16:10:14 <rakhmerov> I moved a couple of low/medium priority BPs to Kilo-3
16:10:33 <rakhmerov> but overall it looks ok
16:10:57 <rakhmerov> so here I would like to discuss just one thing
16:11:27 <rakhmerov> I think we need to leave only bugs that are possible to fix till this Friday
16:12:09 <rakhmerov> dzimine, I'd like to ask you to take a look at the bugs and assign all that you're interested in to Kilo-2
16:12:38 <rakhmerov> it can be done offline to save time
16:12:52 <dzimine> ok. Bugs keep on coming.
16:13:16 <rakhmerov> yeah
16:13:23 <rakhmerov> it's bad and good at the same time
16:13:24 <rakhmerov> :)
16:13:25 <dzimine> but i’ll cast my opinion at existing ones.
16:13:31 <rakhmerov> ok
16:13:46 <dzimine> the bigger quesiton is are there any critical ones which we want to fix before we call it kilo-2.
16:13:46 <rakhmerov> and pls can you please take a look at https://bugs.launchpad.net/mistral/+bug/1415886 again
16:13:51 <rakhmerov> at our comments
16:14:00 <rakhmerov> I think it's invalid and can be closed
16:14:03 <akuznetsova> btw,  I have found a few usability bugs today (for environments cli)
16:14:22 <rakhmerov> can you pls file bugs?
16:14:25 <rakhmerov> for them
16:14:34 <akuznetsova> rakhmerov, you, tomorrow I will
16:14:48 <rakhmerov> #action dzimine, look at the bugs and assigned most critical ones to kilo-2
16:14:49 <akuznetsova> rakhmerov, *yes
16:15:08 <rakhmerov> #action akuznetsova, file bugs for recently found usability issues
16:15:11 <rakhmerov> ok
16:15:39 <rakhmerov> do you want us to discuss them now or take it offline?
16:15:58 <akuznetsova> me? no
16:16:06 <akuznetsova> I just have one question
16:16:22 <rakhmerov> sure, go ahead
16:16:22 <akuznetsova> I will ask it later in open discussion
16:16:25 <rakhmerov> ko
16:16:27 <rakhmerov> ok
16:16:46 <rakhmerov> so, dzimine, answering your question about critical bugs...
16:17:06 <rakhmerov> I would really like to fix whatever is related with expressions
16:17:23 <rakhmerov> and I'll strive to finish result/output refactoring
16:18:04 <dzimine> you guys brough up quite a lot of questions on YAQL.
16:18:10 <rakhmerov> I've mostly done with the overall picture
16:18:17 <rakhmerov> yes
16:18:48 <rakhmerov> I'm shocked why we didn't see all those issues before..
16:19:15 <rakhmerov> ok, I think that is pretty much it on this topic
16:19:37 <rakhmerov> and I actually forgot current status topic
16:20:30 <rakhmerov> so, on Kilo-2, I think there should be no rush or panic with releasing kilo-2
16:20:39 <rakhmerov> keep in mind that this is a development milestone
16:20:46 <rakhmerov> #topic Current Status (by team members)
16:21:13 <dzimine> do we release kilo-2 based on time or based on scope (when we fix this list of bugs/implement min list of BP?)
16:22:40 <dzimine> status: drafterd impl on handling errors to prevent zombie workflows, WIP for early feedback / criticism here https://review.openstack.org/#/c/151975
16:22:43 <rakhmerov> my status: last week I fixed "publish" functionality, reproduced a bug reported by Winson about parallel tasks (didn't fix it though yet since it turned out to be not so trivial), also keep working task output refactoring (made 1 patch so far) and hoping to get it done in ~2 days
16:22:57 <rakhmerov> dzimine, based on time
16:23:26 <rakhmerov> because we're trying to be synced with all core projects in terms of release dates
16:24:06 <rakhmerov> dzimine, thanks. That's a good patch, I will leave a few comments
16:24:24 <nmakhotkin> status: worked on std.javascript and fix one bug related to with-items and action_context
16:25:39 <rakhmerov> ok
16:26:00 <rakhmerov> akuznetsova, dzimine?
16:26:06 <akuznetsova> status: started to test environments
16:26:12 <rakhmerov> ok
16:26:46 <rakhmerov> ooh, dzimine, you already wrote you status
16:26:53 <rakhmerov> ok, so let's go to
16:27:00 <rakhmerov> #topic Open Discussion
16:27:27 <rakhmerov> akuznetsova, you were going to ask something
16:27:31 <akuznetsova> yes
16:27:33 <rakhmerov> pls do
16:28:09 <akuznetsova> how to use environments ? where should I pass env name? During execution creation ?
16:28:53 <rakhmerov> ok, we have that 'params' thing in start_workflow() method
16:29:15 <akuznetsova> execution-create cli command has 3 arguments only
16:29:26 <akuznetsova> wf_name, wf_inputs, params
16:29:27 <rakhmerov> so environment is either a string (env name) or a dictionary and is passed under 'env' key in 'params'
16:29:38 <rakhmerov> yes
16:29:41 <rakhmerov> in params
16:29:56 <akuznetsova> like {env: <name>} ?
16:30:04 <rakhmerov> params={'env': 'env_name'}
16:30:08 <rakhmerov> yep
16:30:35 <rakhmerov> but in CLI I guess it should be a json string as usually
16:31:19 <rakhmerov> ok
16:31:29 <rakhmerov> do you have any more questions?
16:31:40 <akuznetsova> no, just this one
16:31:47 <rakhmerov> alright )
16:32:06 <rakhmerov> I wanted to pay your attention to just one thing
16:32:25 <rakhmerov> I sent you an email about YAQL problems and suggestions how to solve them (not for all though)
16:32:45 <rakhmerov> so please read it carefully and provide your feedback
16:32:56 <dzimine> ok, will do.
16:33:15 <rakhmerov> we need to fix all this asap
16:34:20 <rakhmerov> anything else?
16:34:40 <rakhmerov> I don't have anything
16:35:02 <akuznetsova> me too
16:35:16 <rakhmerov> gentlemen?
16:35:47 <rakhmerov> ok, let's finish then
16:35:50 <nmakhotkin> from me too
16:35:54 <rakhmerov> thanks to all!
16:35:55 <rakhmerov> bye
16:35:57 <nmakhotkin> bye!
16:36:02 <rakhmerov> #endmeeting