16:00:50 <rakhmerov> #startmeeting Mistral
16:00:50 <openstack> Meeting started Mon Jan 19 16:00:50 2015 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:54 <openstack> The meeting name has been set to 'mistral'
16:00:55 <rakhmerov> hi
16:01:22 <akuznetsova> hi
16:02:09 <rakhmerov> how's it going?
16:02:18 <akuznetsova> not good
16:02:34 <NikolayM> hi !
16:03:07 <rakhmerov> hi
16:03:15 <rakhmerov> akuznetsova, what happened?
16:03:18 <rakhmerov> anything serious?
16:03:37 <akuznetsova> rakhmerov, I stuck with my commit to Rally
16:03:42 <NikolayM> akuznetsova, :(
16:03:49 <rakhmerov> ooh!!
16:04:29 <rakhmerov> that's ok, don't hurry with that
16:04:33 <dzimine> hi all
16:05:01 <rakhmerov> hi
16:05:04 <rakhmerov> let's start
16:05:12 <akuznetsova> rakhmerov, we discussed some ideas with Boris, today he founded another solution and I have to rewrite part of my code
16:05:27 <rakhmerov> ok, I see
16:05:52 <rakhmerov> let us know if you need help, don't struggle alone in the dark )
16:06:11 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:06:25 <rakhmerov> let's quickly let each other know our statuses
16:07:14 <akuznetsova> I am working on my commit to Rally, fix Boris's comments
16:07:57 <rakhmerov> my status: Last week we had several meetings with Dmitri on a number of problems they faced with Mistral, I completed a part of "Secure Access" BP (patches on review), today I was also trying to fix problems occurring in environment tests (still in progress)
16:09:14 <bhavenst> anybody here? :)
16:09:19 <akuznetsova> yes
16:09:20 <rakhmerov> yep
16:09:32 <rakhmerov> hi Bryan, nice to "see" you again here
16:09:34 <bhavenst> OK, just a little quiet
16:09:38 <bhavenst> Hi, yeah same
16:09:50 <dzimine> my status: last week I investigated ‘result->output->published data’ transformation and discovered some problems there, discussed with Renat; this week I target to begin fixing some of them.
16:10:01 <rakhmerov> everyone is still trying to wake up after New Year holidays :)
16:10:06 <rakhmerov> especially in Russia :)
16:10:33 <NikolayM> status: worked on with-items, especially on concurrency policy and its implementation for with-items, already worked fine but I still have few issues
16:10:49 <rakhmerov> ok
16:10:55 <bhavenst> So far have looked into webhooks and ceilometer triggering for heat a bit to see how they do it.  Haven't started yet though.  Will soon.
16:11:10 <rakhmerov> alright
16:11:20 <dzimine> Also, prototyped catching errors and reportign exceptions in engine (to solve the problem of tasks/workflows stuck in “RUNNING” state when some exceptios happen. Got stuck there because the desired behavior is not clear.
16:11:59 <rakhmerov> yeah, we probably need to talk about that separately
16:12:06 <dzimine> @m4dcoder: Winson are you here?
16:13:21 <dzimine> I know that Winson was building workflows and discoered / fixed bugs and problems there as he moved on.
16:13:41 <rakhmerov> ok
16:14:00 <rakhmerov> dzimine, do you know what his status is on environment BP?
16:14:05 <dzimine> he’ll be pushing his local fixes upstream hopefully this week - we didn’t have a chance to sync up
16:14:11 <rakhmerov> is there something left on that?
16:14:21 <rakhmerov> ok, I see
16:14:36 <dzimine> AFAIK environment BP first part is done, what’s left is ‘default variables’.
16:14:43 <dzimine> for tasks.
16:14:49 <rakhmerov> yes, ok
16:14:58 <rakhmerov> that was pretty much my understanding as well
16:15:15 <rakhmerov> guys, do you see any roadblocks in your work that you'd like to discuss right now?
16:16:16 <rakhmerov> #action dzimine, clarify Winson's status on "Environment" BP
16:16:55 <rakhmerov> ok, let's proceed
16:17:03 <rakhmerov> #topic "Kilo-2" scope and blueprints
16:17:25 <rakhmerov> I'd like to discuss Kilo-2 scope again a little bit
16:17:27 <dzimine> is nmakhotkin around?
16:17:31 <rakhmerov> yes
16:17:34 <rakhmerov> he's here
16:18:18 <dzimine> may be I missed nikolay’s status update?
16:18:31 <rakhmerov> he reported it
16:18:32 <dzimine> damn sorry here it is!
16:18:35 <dzimine> :)
16:18:38 <rakhmerov> :) np
16:19:02 <NikolayM> yes :)
16:19:25 <rakhmerov> ok, so the reason I'd like to pay a little bit of our attention to Kilo-2 scope again is that I talked to Dmitri last week :)
16:20:13 <rakhmerov> and after those conversations I came to conclusion that we should probably move some of the BPs to the next milestone
16:20:27 <rakhmerov> just because we now see much more important things
16:20:47 <dzimine> blocking bugs, mainly.
16:20:53 <rakhmerov> yes
16:21:27 <dzimine> this is what we have so far: https://launchpad.net/mistral/+milestone/kilo-2
16:21:31 <rakhmerov> unfortunately, we still need to work through that and build the full list of urgent bugs
16:21:50 <rakhmerov> yes
16:22:09 <rakhmerov> what we could do now is to take a look at this page and suggest what we can get rid of (for now)
16:23:15 <rakhmerov> one thing that I'd like to say over and over again is: we should forget about "half-done" solutions, quality is our highest priority now
16:24:03 <rakhmerov> ok, let's vote
16:24:23 <rakhmerov> I think https://blueprints.launchpad.net/mistral/+spec/mistral-non-distributable-actions could be moved away
16:24:32 <dzimine> +1 on “no half-done”. It really blows once we real-use it
16:24:46 <dzimine> agree on non-distributable-action
16:24:51 <akuznetsova> maybe we can postpone bps connected with mistral-dashboard?
16:24:58 <rakhmerov> although I already started working on it I realized it's not so trivial task and I don't want to spend time on it now
16:25:29 <rakhmerov> akuznetsova, yes, I think the same
16:26:10 <rakhmerov> objections?
16:26:15 <dzimine> I would move manage-db out, too.
16:26:29 <akuznetsova> https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-crud-operations , https://blueprints.launchpad.net/mistral/+spec/mistral-dashboard-tests , https://blueprints.launchpad.net/mistral/+spec/mistral-execution-visualization
16:27:06 <dzimine> This is maintanance task, no tech risk, just ‘do it once the thing works’.
16:27:07 <rakhmerov> I actually really want to implement those UI BPs but it's not a good time now. We can commit to that work in the next milestone
16:27:42 <dzimine> +1 on akuznetsova’s proposal
16:27:49 <rakhmerov> dzimine, yes. I included it just because Fuel folks asked about it
16:27:56 <rakhmerov> +1 on it too
16:29:20 <rakhmerov> Nikolay, what do you say about "manage-db" ?
16:29:45 <rakhmerov> I remember Igor asked us to add it but am not sure exactly how important it is for him now
16:30:03 <rakhmerov> he had some problems with packaging because of it as far as I remember
16:30:15 <rakhmerov> I mean Igor Yozhikov
16:30:29 <akuznetsova> rakhmerov, did you create more bps based on your meeting with dzimine ?
16:30:59 <rakhmerov> akuznetsova, not yet, it's in progress, we will soon
16:31:12 <dzimine> no we did not but we probably should (bug at least) to see the scope visible.
16:31:24 <rakhmerov> we're just making various notes that we still need to think over
16:31:38 <rakhmerov> sure, we need to do it
16:31:45 <akuznetsova> ok. it means that list of bps for kilo-2 will be bigger
16:32:05 <rakhmerov> NikolayM, you here?
16:32:13 <dzimine> and it may help to add a dedicated “DB_model refactoring” blueprint as other tasks depend on it (at least 2).
16:32:15 <rakhmerov> yep
16:32:23 <rakhmerov> and/or bugs
16:33:20 <rakhmerov> #action rakhmerov, dzimine, create necessary BPs/bugs for the upcoming "cleaning up" work
16:33:26 <dzimine> action: dzimine - add blueprints/bugs and add critical of them to kilo-2 scope, rakhmerov will remove the ones he thinks wrong..
16:33:27 <dzimine> haha
16:33:38 <rakhmerov> :)))
16:33:58 <rakhmerov> ok, moved away "manage-db" for now
16:34:14 <rakhmerov> we may ask folks from fuel to help with it
16:34:16 <akuznetsova> what about https://blueprints.launchpad.net/mistral/+spec/mistral-auth-middleware-option ? I guess it is quite 'big' feature, isn't it?
16:34:47 <rakhmerov> right, but it's now in low priority which means it's not
16:34:50 <rakhmerov> so it's ok
16:35:11 <rakhmerov> if it's not completed in 3 weeks we can easily move it
16:35:47 <akuznetsova> ok
16:36:13 <rakhmerov> dzimine, what do you think about "aciton providers"?
16:36:22 <dzimine> move out.
16:36:26 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/action-providers
16:36:48 <dzimine> I hoped to bring more developers to this but we lost some to sickness…
16:36:49 <rakhmerov> I know we still owe Winson a response to his letter but not sure how important it is for you
16:37:02 <rakhmerov> ooh, it's bad to hear
16:37:08 <dzimine> response is important - we want to be clear on design
16:37:16 <rakhmerov> tomorrow
16:37:26 <dzimine> but doing it - we won’t have time due to bugs / critical additions.
16:37:33 <rakhmerov> I'll do it tomorrow first thing
16:37:55 <rakhmerov> #action rakhmerov, NikolayM: reply to Winson on action providers design
16:38:03 <rakhmerov> ok, clear
16:38:43 <rakhmerov> done
16:38:47 <rakhmerov> anything else?
16:39:00 <rakhmerov> I'm personally still hoping to tackle Script Action
16:39:19 <rakhmerov> really would love to see that thing
16:39:40 <rakhmerov> so suggesting that we leave it
16:40:11 <rakhmerov> I think Nikolay is the best candidate to get it knocked out
16:41:10 <rakhmerov> dzimine, one more thing I'd like to ask you about is to clarify a BP definition with Winson: https://blueprints.launchpad.net/mistral/+spec/mistral-runtime-context
16:41:29 <rakhmerov> I asked him some questions about it via email but still didn't get a reply
16:42:14 <dzimine> ok.
16:42:16 <rakhmerov> the thing is that this BP doesn't make a lot of sense to me anymore
16:42:20 <rakhmerov> ok
16:42:33 <rakhmerov> #action dzimine, clarify https://blueprints.launchpad.net/mistral/+spec/mistral-runtime-context definition with Winson
16:43:26 <rakhmerov> ok, looks like we now have some room for new blueprints
16:43:56 <rakhmerov> anything else on that part?
16:44:08 <rakhmerov> some other thoughts?
16:44:56 <rakhmerov> #topic Open discussion
16:45:36 <rakhmerov> please go ahead if you have anything to discuss
16:45:55 <rakhmerov> ooh, btw
16:46:13 <rakhmerov> I already mentioned we now have some problems with environment tests
16:46:25 <rakhmerov> just for your information
16:46:50 <rakhmerov> they now basically are blocking the whole process of development
16:46:56 <akuznetsova> unit tests?
16:47:00 <rakhmerov> yes
16:47:14 <rakhmerov> we have about 5-6 patches that we can't merge in because these tests keep failing
16:47:28 <rakhmerov> even though non of these patches are related to environments
16:47:33 <rakhmerov> so
16:47:57 <rakhmerov> I think I'm close to fixing them and will try to do it asap, ideally tomorrow
16:48:02 <rakhmerov> just be aware of it
16:48:27 <rakhmerov> the bad news is that they seem to be not very easy to trace
16:48:40 <rakhmerov> because they occur not every time
16:48:56 <akuznetsova> talking about failing tests, rakhmerov what about update_action test in your commit ?
16:49:03 <rakhmerov> and actually never on my local machine )
16:49:18 <rakhmerov> that one is still on you :)
16:49:26 <rakhmerov> I was hoping you would take a look at it
16:49:47 <rakhmerov> I did spend a few mins on it but was unable to see the problem
16:49:49 <akuznetsova> won't you add a couple of unit tests that check update too?
16:50:00 <rakhmerov> so maybe something is wrong with the test itself, dunno
16:50:08 <rakhmerov> ooh, sure
16:50:11 <rakhmerov> I'll do
16:50:38 <akuznetsova> maybe it is some issue on cli side?
16:50:39 <rakhmerov> #action rakhmerov, add a couple of unit tests checking "updated_at population
16:50:57 <rakhmerov> yes, that's what I honestly think it is
16:51:05 <rakhmerov> very likely
16:51:42 <rakhmerov> so I think that's it from my side
16:51:48 <rakhmerov> anything else folks?
16:52:37 <akuznetsova> nothing from my side
16:52:37 <rakhmerov> ok, let's wrap up for today
16:52:47 <rakhmerov> ok, thanks to everyone!
16:52:51 <bhavenst> OK, thanks
16:52:56 <rakhmerov> have a good week )
16:53:03 <rakhmerov> bye-bye
16:53:05 <akuznetsova> bye
16:53:11 <rakhmerov> #endmeeting