16:00:34 <rakhmerov> #startmeeting Mistral
16:00:35 <openstack> Meeting started Mon Sep  1 16:00:34 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:37 <rakhmerov> hello
16:00:39 <openstack> The meeting name has been set to 'mistral'
16:01:13 <akuznetsova> hi
16:01:19 <enykeev> Hey
16:02:03 <nmakhotkin_> hi
16:02:24 <rakhmerov> Kirill, I know folks in the US celebrate labor day today, do you know by any chance if Dmitri was going to join us today?
16:03:24 <rakhmerov> enykeev?
16:03:29 <enykeev> No idea, haven't seen him today
16:03:56 <rakhmerov> ok
16:04:23 <rakhmerov> ok, let's quickly go through our agenda items today
16:04:34 <rakhmerov> #topic Review Action Items
16:04:37 <rakhmerov> 1. rakhmerov and others: discuss workflow other types
16:05:36 <rakhmerov> it's not a good time to discuss this thing now, it's a long term topic
16:05:46 <rakhmerov> #action rakhmerov and others: discuss workflow other types
16:06:10 <rakhmerov> rakhmerov, start a ML discussion about Glance integration
16:06:10 <rakhmerov> rakhmerov, talk to Angus about versioning CLI
16:06:10 <rakhmerov> rakhmerov, validate that we can release a minor version for the old client of the new one goes forward
16:06:23 <rakhmerov> these 3 items are not relevant anymore
16:06:43 <rakhmerov> it's all either decided or implemented
16:06:59 <rakhmerov> #topic Current status (progress, issues, roadblocks, further plans)
16:07:10 <rakhmerov> let's quickly report what you're up to
16:07:16 <enykeev> Spent the week by implementing v2 API and fixing nasty little bugs along the way.
16:07:35 <rakhmerov> ok, it is done, right?
16:07:50 <enykeev> as far as I can tell
16:07:55 <rakhmerov> ok
16:08:23 <nmakhotkin_> last week I worked on the implementation delayed calls and mistralclient v2 (client and CLI)
16:08:28 <enykeev> we are still missing action API, though
16:09:03 <rakhmerov> yes, that's fine
16:09:11 <rakhmerov> shouldn't be that hard to add them
16:09:14 <nmakhotkin_> enykeev, we can create actions endpoint
16:09:23 <rakhmerov> yes
16:09:24 <akuznetsova> I added two more tests and finish mistral-workflow-execution-tests blueprint
16:09:32 <rakhmerov> ok
16:09:54 <rakhmerov> my status: made a lot of changes in engine and execution infrastructure last week, discussed workflow policies with Dmitri and started working on them (kind of challenging thing), had lots of design discussions with all the team
16:10:27 <rakhmerov> guys, I know you found a bug in Bryan's commit (already merged), are you sure you know how to fix it?
16:10:33 <rakhmerov> if yes, please just do it
16:10:45 <rakhmerov> if know, we can discuss it here or tomorrow
16:10:46 <nmakhotkin_> https://review.openstack.org/#/c/118187/
16:10:58 <nmakhotkin_> I guess this can fix it
16:11:08 <rakhmerov> ooh, ok
16:11:13 <rakhmerov> I'll take a look
16:12:09 <akuznetsova> need to wait a gate and we will see
16:12:16 <enykeev> nmakhotkin_, we should probably also add unit test for that
16:12:47 <rakhmerov> yep )
16:13:11 <nmakhotkin_> yes
16:13:16 <rakhmerov> akuznetsova, any progress on that Pool size issue?
16:14:31 <akuznetsova> one issue will be fixed with nmakhotkin_  commit
16:15:04 <akuznetsova> but generally i didn't find the root of problem
16:15:09 <rakhmerov> ooh, ok
16:15:14 <rakhmerov> let's discuss tomorrow
16:15:16 <akuznetsova> will spend more time tomorrow
16:15:22 <rakhmerov> ok, thanks
16:15:32 <rakhmerov> #topic Release 0.1 progress
16:15:37 <rakhmerov> ook
16:16:16 <rakhmerov> you can take a look at the milestone at LP: https://launchpad.net/mistral/+milestone/0.1
16:16:53 <rakhmerov> we have three BPs that we didn't start working on
16:17:32 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/mistral-ui
16:17:40 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/mistral-workflow-wait-policy
16:17:46 <rakhmerov> https://blueprints.launchpad.net/mistral/+spec/mistral-terminal-states
16:18:14 <rakhmerov> and pretty heavy that I am now working on: https://blueprints.launchpad.net/mistral/+spec/mistral-workflow-policies
16:18:20 <nmakhotkin_> I plan to start wait policy in a few days
16:18:26 <rakhmerov> I'll probably spend at least 3-4 days on it
16:18:37 <rakhmerov> yes, I think it shouldn't be that hard
16:18:50 <rakhmerov> and it will be based on delayed calls services
16:19:06 <nmakhotkin_> yes :)
16:19:15 <rakhmerov> Kirill, Nikolay, how would you estimate adjusting mistral-ui?
16:19:36 <rakhmerov> so that it works with API V2
16:20:47 <rakhmerov> would 2-3 days be enough to fix it?
16:21:01 <rakhmerov> from your perspective
16:21:20 <enykeev> really hard to tell. Most of the things should take about a day or two, but there might be some nasty bugs and there were lots of changes in horizon lately
16:21:35 <rakhmerov> ooh, really?
16:21:41 <rakhmerov> what kind of changes?
16:22:06 <rakhmerov> or if you have, please share a link or something to find out about them
16:23:08 <enykeev> afaik, they are rewriting UI parts pretty badly and this was their main goal for this release, although I haven't paid too much attention
16:23:21 <rakhmerov> ok
16:23:46 <rakhmerov> I didn't think to include this BP at all into 0.1, and if we need we can still exclude it but I'm still hoping to get it done
16:23:47 <rakhmerov> ok
16:24:47 <rakhmerov> so I think finishing up all current activities (API, client, hanging patches) will take other 2-3 days so we'll have about 6-7 days left till the end of the cycle
16:24:57 <rakhmerov> for 3 BPs
16:25:02 <rakhmerov> seems ok to me
16:25:41 <rakhmerov> I'm just a little worried about having not really comprehensive testing for some of the new things
16:25:53 <rakhmerov> may be we need to look at it and see where we can improve it
16:26:17 <rakhmerov> first of all, I'm talking about engine, Data Flow etc. (my part actually :) )
16:26:35 <rakhmerov> even though I try to test main things we may want to add more tests
16:26:57 <rakhmerov> ok, do you guys want to discuss anything else?
16:27:13 <rakhmerov> #topic Open Discussion
16:27:45 <rakhmerov> if no, we can go to bed :)
16:28:35 <enykeev> nope, nothing
16:28:38 <rakhmerov> ok, let's finish
16:28:45 <rakhmerov> bye and thanks to everyone!
16:28:48 <enykeev> thanks
16:28:50 <nmakhotkin_> bye!
16:28:53 <rakhmerov> #endmeeting