16:00:10 <rakhmerov> #startmeeting Mistral
16:00:11 <openstack> Meeting started Mon Jul 28 16:00:10 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:12 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:14 <openstack> The meeting name has been set to 'mistral'
16:00:16 <rakhmerov> hi
16:00:28 <dzimine> hi
16:01:33 <rakhmerov> hi Dmitri
16:02:11 <rakhmerov> #topic Review Action Items
16:02:23 <rakhmerov> 1. dzimine (and optionally xazel): review commits related to integration testing from akuznetsova
16:02:34 <dzimine> done
16:02:37 <rakhmerov> dzimine, I think this is done, right?
16:02:38 <rakhmerov> ok
16:02:51 <rakhmerov> 2. rakhmerov, fully figure out the new engine architecture, data models, protocols between different components and implement reverse (or linear?) workflow and cover it with tests
16:03:35 <rakhmerov> I figured out all the major things. And I keep working on reverse workflow
16:03:58 <rakhmerov> so it's not done yet but close, 1-2 days
16:04:20 <rakhmerov> there's a couple of big patches, you can review them and give your feedback
16:04:32 <m4dcoder> hey
16:04:38 <rakhmerov> hi!
16:04:42 <dzimine> rakhmerov, I looked over it on Fri and will look again (had comments there but lost them, need to redo)
16:04:56 <rakhmerov> ok, thanks
16:05:21 <rakhmerov> #action rakhmerov, finish reverse workflow implementation
16:05:40 <rakhmerov> 3. akuznetsova, ping folks at #openstack-infra about https://review.openstack.org/#/c/107255/
16:05:51 <rakhmerov> akuznetsova, are you here today?
16:06:14 <rakhmerov> ooh, actually this patch is merged
16:06:17 <rakhmerov> so it's done
16:06:27 <rakhmerov> 4. akuznetsova, finish with mistralclient tests and work with tests for console client
16:06:52 <rakhmerov> I was unable to talk to her today, I'll try to find her tomorrow
16:07:12 <rakhmerov> #action rakhmerov, get update on integration testing
16:07:23 <rakhmerov> 5. rakhmerov, assign a couple of tasks to bhavenst
16:07:26 <rakhmerov> done
16:07:51 <rakhmerov> #topic Current status (progress, issues, roadblocks)
16:10:09 <dzimine> my plan is to catch up with Renat’s changes, understand and review them. if anything else needs review we’ll do it.
16:10:23 <rakhmerov> my status: I keep working on the new engine. I think most of the principal things are clear to me now. Last week I finished the general structure and all the main interfaces and protocols between components. I also spent almost 2 days to change our DB access layer (got rid of dicts) and fixed a huge number of tests. Now I'm working on workbook specification v2 (partial) in order to implement reverse workflow
16:10:33 <rakhmerov> ok
16:11:10 <dzimine> xazel is unfortunately off Mistral for this week, modular reviews and small changes/fixes.
16:11:20 <rakhmerov> yeah, ok
16:11:38 <rakhmerov> I asked him to review my commits
16:11:58 <rakhmerov> and he also rebased his commits that are ready to be merged
16:12:16 <rakhmerov> anyone else here with us?
16:12:32 <dzimine> I think xazel’s commits are all in, no?
16:12:45 <dzimine> waht about https://review.openstack.org/#/c/106618/
16:13:12 <rakhmerov> ooh, yes
16:13:14 <rakhmerov> you're right
16:13:42 <rakhmerov> I thought one commit about oslo.db is still hanging but it got merged because of a trivial rebase I think
16:13:47 <rakhmerov> ok, this is closed
16:14:13 <rakhmerov> btw, Nikolay got back from vacation today and started working
16:14:30 <rakhmerov> I don't see him in IRC though for some reason )
16:15:19 <rakhmerov> ok, not a huge crowd today )
16:15:30 <dzimine> There some CLI bugs reported by Angus, it would be good if Nikolay can look at them.
16:15:46 <rakhmerov> yes, that's what he started from
16:15:58 <rakhmerov> I believe he already proposed a couple of patchsets
16:16:21 <rakhmerov> https://review.openstack.org/#/c/110001/
16:16:34 <dzimine> another thing: gate-mistral-devstack-dsvm began to fail from some point, do we know when? Can we ask aKuznetsova to look at it?
16:17:09 <rakhmerov> #info today we created a separate Launchpad project for python-mistralclient
16:17:23 <rakhmerov> so please report client (and CLI) bugs in there
16:17:48 <rakhmerov> dzimine, what's your availability this week if we need to talk?
16:18:09 <rakhmerov> or you can let me know later when you're comfortable
16:18:22 <dzimine> any night; I have time for Mistral this week.
16:18:33 <rakhmerov> ok, good
16:18:48 <dzimine> just LMK a bit ahead of time
16:19:01 <rakhmerov> sure
16:19:34 <rakhmerov> as far as devstack gate yes, you're right
16:20:15 <rakhmerov> #action rakhmerov, let akuznetsova know that devstack gate keeps failing so that she can find the reason
16:20:39 <rakhmerov> if you guys don't have any other topics/questions we can wrap up
16:21:45 <rakhmerov> let's finish?
16:22:07 <rakhmerov> I personally know what to do, no questions for now to discuss
16:22:24 <dzimine> ok, Renat get busy with your big change :)
16:22:26 <dzimine> finish.
16:23:01 <rakhmerov> dzimine, I feel that it's now going much better, good chances we'll get something worthy soon )
16:23:15 <rakhmerov> you'll see :)
16:23:38 <dzimine> I have couple of questiosn to you, let’s jump into openstack-mistral...
16:23:39 <rakhmerov> ok, thank you guys for joining today
16:23:47 <rakhmerov> ok
16:23:47 <m4dcoder> thanks! bye.
16:23:48 <rakhmerov> bye
16:23:55 <rakhmerov> #endmeeting