16:01:13 <rakhmerov> #startmeeting Mistral
16:01:14 <openstack> Meeting started Mon Jun 30 16:01:13 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:01:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:18 <openstack> The meeting name has been set to 'mistral'
16:01:21 <rakhmerov> hi all
16:02:43 <rakhmerov> who has joined us? :)
16:02:49 <rakhmerov> raise your hands
16:02:57 <xazel> hey
16:03:04 <rakhmerov> hi Kirill
16:03:23 <rakhmerov> btw, while we're waiting for others let me show you something
16:03:31 <rakhmerov> you may be familiar with this
16:03:39 <akuznetsova> hey
16:03:45 <rakhmerov> hi!
16:04:00 <rakhmerov> Kirill, can you take a look pls at http://paste.openstack.org/show/85171/
16:04:24 <rakhmerov> Nastya gets it when she is trying to run Mistral API
16:04:31 <rakhmerov> I believe something is wrong with keystone
16:04:42 <rakhmerov> isn't it that problem with openssl?
16:05:38 <xazel> nope, it's not. I haven't seen anything like that before.
16:05:46 <rakhmerov> hm, ok
16:05:50 <akuznetsova> probable it is my local problems and i do something wrong
16:06:12 <akuznetsova> i will try again tomorrow in the new venv
16:06:14 <rakhmerov> akuznetsova, ok, let's go through the process of installation tomorrow together step by step
16:06:18 <rakhmerov> sure
16:06:32 <rakhmerov> you can share your screen and we'll try to figure the problem out
16:07:02 <rakhmerov> ok, not sure how many people are going to be here today, looks like there are just three of us for now
16:07:07 <rakhmerov> so let's make it quick
16:07:28 <rakhmerov> Kolya is on enforced vacation till July 26th, Timur is busy
16:07:46 <rakhmerov> Dmitri and Winson seem to be busy as well
16:07:50 <rakhmerov> so
16:08:00 <rakhmerov> #topic Previous Action Items
16:08:07 <rakhmerov> no previous action items!
16:08:09 <rakhmerov> :)
16:08:30 <rakhmerov> #topic Current status (quickly by team members)
16:08:39 <rakhmerov> let's start with Kirill
16:09:00 <rakhmerov> xazel, what are you up to?
16:09:23 <xazel> spent the week trying to merge stackstorm\mistral-demo into stackforge/mistral-extra (https://review.openstack.org/#/c/103015/)
16:09:34 <rakhmerov> ok
16:09:47 <rakhmerov> current status? Roadblocks?
16:09:53 <rakhmerov> what's left?
16:11:03 <xazel> basically, we need to rewrite some examples to reflect latest changes in DSL and then figure out how to make it as friendly to user as possible
16:11:16 <rakhmerov> ok
16:11:57 <rakhmerov> will you have some time tomorrow? We could try to work on this together and fix what's needed
16:12:27 <xazel> I think so. Skype me when you have time.
16:12:34 <rakhmerov> ok
16:12:45 <rakhmerov> akuznetsova, what's your status?
16:13:03 <akuznetsova> hm..not very optimistic, cause i am on the way to install the mistral
16:13:26 <rakhmerov> #action rakhmerov, skype Kirill on Tue and work with him on integrating mistral-demo examples into mistral-extra
16:13:48 <rakhmerov> akuznetsova, don't worry, that's totally fine
16:14:11 <rakhmerov> #action rakhmerov, get in touch with Nastya and figure out the problem with Mistral installation
16:14:25 <akuznetsova> plans : install mistral and update requirements and check that all is ok, then to start see into python-mistral client
16:14:44 <rakhmerov> afaik, you've done a good job on preparing a proposal for testing infrastructure
16:15:14 <akuznetsova> thanks, also i prepared some blueprints
16:15:58 <rakhmerov> ok, that's good, I still didn't look at them, will do tomorrow (or may be today later while watching World Cup :) )
16:16:39 <rakhmerov> My status: last Tue released Mistral version 0.0.4 and since then I have been researching a lot of Workflow related stuff (Petri nets, WFMSs, BPM/BPMN/BPEL, Ansible, yawl, workflow patterns)
16:16:55 <rakhmerov> I have read a lot of interesting things
16:17:07 <tnurlygayanov> Hi there!
16:17:11 <rakhmerov> that made me sure we haven't done anything really stupid so far
16:17:15 <rakhmerov> hey Timur!
16:17:24 <rakhmerov> glad you made it to join us
16:18:20 <rakhmerov> so my plan is to spend 2-3 days more on that because I think it's really useful to get on a distance from what we're doing and rethink our ideas
16:18:41 <rakhmerov> tnurlygayanov, do you have any updates?
16:19:32 <tnurlygayanov> rakhmerov, sorry, no updates for the last week, now I'm woring with many projects in parallel
16:19:47 <tnurlygayanov> *working
16:19:50 <rakhmerov> understandable, no problem
16:20:25 <rakhmerov> Timur, the only thing I'd ask you to help with (you and/or Sergey) is try to install Mistral on Nastya's machine
16:20:33 <rakhmerov> she keeps getting a problem
16:20:38 <tnurlygayanov> I know that we have some internal OpenStack lab for manual testing, rakhmerov, are you got it?
16:20:39 <rakhmerov> http://paste.openstack.org/show/85171/
16:21:12 <rakhmerov> I'll try to look at it myself tomorrow morning but just in case if we can't do it it would be nice if you could help her
16:21:19 <tnurlygayanov> ok, we will check. Do you have ideas what the root of these problems?
16:21:29 <tnurlygayanov> ok
16:21:48 <rakhmerov> Timur, no I am not aware of the dedicated OpenStack lab for Mistral
16:22:24 <rakhmerov> I think there's something wrong with keystone, may be even reinstallation of openssl is required
16:22:31 <rakhmerov> it's just a theory though
16:22:44 <rakhmerov> so, what is the status on Mistral lab?
16:24:33 <rakhmerov> ok, Timur, let's discuss Mistral Lab separately
16:24:43 <tnurlygayanov> yes
16:24:47 <rakhmerov> I see that the ticket in Jira is closed
16:24:54 <rakhmerov> but not sure why it's rejected :)
16:25:18 <rakhmerov> #topic Further plans
16:25:48 <rakhmerov> our further plans is to make a serious refactoring and add the functionality needed for version 0.1
16:26:12 <rakhmerov> I'm planning to finish needed research by the end of the week and start coding it
16:26:33 <rakhmerov> I wish Dmitri was here to discuss this topic more, maybe next time
16:26:39 <rakhmerov> #topic Open Discussion
16:27:01 <rakhmerov> guys, do you have anything else for today to discuss?
16:27:21 <akuznetsova> nothing from my side
16:28:00 <xazel> nope
16:28:18 <rakhmerov> ok
16:28:58 <rakhmerov> for this week I'd like to see those bugs fixed https://bugs.launchpad.net/~winson-c-chan
16:29:19 <rakhmerov> I'll ping Dmitri and ask him about this
16:29:32 <rakhmerov> ok, let's finish then
16:29:39 <rakhmerov> thanks everyone for joining in
16:29:52 <akuznetsova> buy
16:29:53 <xazel> thanks!
16:30:28 <rakhmerov> bye-bye
16:30:29 <rakhmerov> :)
16:30:33 <rakhmerov> #endmeeting