16:00:20 <rakhmerov> #startmeeting Mistral
16:00:21 <openstack> Meeting started Mon May 26 16:00:20 2014 UTC and is due to finish in 60 minutes.  The chair is rakhmerov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:24 <openstack> The meeting name has been set to 'mistral'
16:00:28 <rakhmerov> hi
16:00:52 <NikolayM> hi !
16:02:02 <rakhmerov> agenda: https://wiki.openstack.org/wiki/Meetings/MistralAgenda
16:03:12 <rakhmerov> #topic Review Action Items
16:03:29 <rakhmerov> 1. rakhmerov, NikolayM: adjust wiki (DSL spec, terminology, overall structure)
16:04:16 <rakhmerov> NikolayM, I know you created a page with ReST API spec
16:04:23 <NikolayM> I think it is done partially
16:04:29 <peoplemerge> hi
16:04:46 <rakhmerov> hey
16:04:52 <rakhmerov> here it is: https://wiki.openstack.org/wiki/Mistral/RestAPI
16:05:08 <rakhmerov> but I'm not sure that DSL page is up to date?
16:05:20 <rakhmerov> did you fix it too?
16:05:31 <NikolayM> yes
16:05:43 <NikolayM> I'll fix it on this week
16:05:47 <rakhmerov> ok
16:06:11 <rakhmerov> #action NikolayM, fix wiki DSL page (make it up to date)
16:06:23 <rakhmerov> besides that I fixed lots of other stuff
16:06:47 <rakhmerov> 2. rakhmerov, xazel: talk about small improvements in Mistral Dashboard
16:06:51 <rakhmerov> well
16:06:55 <rakhmerov> yes, we did :)
16:08:39 <rakhmerov> sorry, I'm back
16:08:57 <rakhmerov> 3. rakhmerov: make sure to test Mistral Dashboard in the local environment
16:09:03 <rakhmerov> that one is ok
16:09:17 <rakhmerov> I just had some problems with it but they're gone
16:09:21 <NikolayM> recently I created a new stackforge project for our dashboard
16:09:30 <NikolayM> mistral-dashboard
16:09:57 <rakhmerov> ok, yes
16:10:02 <NikolayM> I think we should move our code related to dashboard from client to it
16:10:07 <rakhmerov> xazel, you're here?
16:10:13 <rakhmerov> sure
16:10:26 <rakhmerov> we'll let Kirill know about it
16:10:35 <rakhmerov> 4. NikolayM: file a bug ticket for the bug in Data Flow related with non-recursive task publishing
16:10:53 <rakhmerov> this one is done and the but itself has been fixed
16:11:01 <rakhmerov> is it correct NikolayM?
16:11:48 <rakhmerov> let's skip other 3 AIs since they were purely related with summit preparations
16:11:55 <rakhmerov> they were all done
16:11:57 <NikolayM> yes, correct
16:12:06 <rakhmerov> ok
16:12:11 <rakhmerov> ok, next topic
16:12:29 <rakhmerov> #topic Current Status (by team members)
16:13:53 <rakhmerov> rakhmerov's status: just got back home on Friday after the summit, mostly adjusting BPs based on summit notes, doing reviews etc.
16:14:05 <rakhmerov> and planning
16:14:37 <NikolayM> created/modified page on wiki, fix some bugs with API, review, and finished error handling on our API controllers
16:14:50 <NikolayM> thanks to Angus :)
16:15:06 <rakhmerov> yes, and btw, I talked to Angus today
16:15:36 <rakhmerov> he kindly agreed to help us implement BP related to pluggable actions
16:15:50 <NikolayM> oh, cool
16:16:04 <rakhmerov> actually I think something was already committed
16:16:08 <rakhmerov> let me check
16:16:45 <rakhmerov> there you go: https://review.openstack.org/#/c/95502/
16:17:47 <rakhmerov> hey, is anybody else here at the meeting?
16:17:57 <rakhmerov> StackStorm folks?
16:18:05 <rakhmerov> Winson?
16:19:41 <rakhmerov> hm... NikolayM, looks like there's nobody else
16:20:17 <NikolayM> hm
16:22:34 <rakhmerov> ok, I hoped to have more people here but looks like people still didn't adjust their schedule after the summit
16:23:35 <rakhmerov> so then I would suggest to make topic "Summit Results" very short
16:23:45 <rakhmerov> #topic Summit Results
16:24:04 <rakhmerov> overall, I'm satisfied with the Summit regarding Mistral
16:25:01 <rakhmerov> the major achievements are:
16:25:26 <rakhmerov> * there are people who want see Mistral as one of the core OS projects (e.g. Zane Bitter)
16:26:01 <rakhmerov> * we attracted a lot of attention to Mistral (significant interest from 5-6 teams including Solum, Heat)
16:26:34 <rakhmerov> btw, Solum folks (and Angus particularly) started using Mistral, we are already working with Angus
16:27:16 <NikolayM> it is very good, I think
16:27:22 <rakhmerov> Angus filed several BPs that Solum team is interested in
16:28:09 <rakhmerov> we need to implement them soon, they all don't conflict with our plans
16:29:08 <rakhmerov> yes, and another significant achievement is that we came up with a high level design for TaskFlow so that everyone becomes happier with it
16:29:12 <rakhmerov> including Mistral
16:29:49 <rakhmerov> we have a general plan, the next step is to create a more detailed plan with all necessary design documents and reasoning
16:30:56 <rakhmerov> I talked to Joshua and Adrian Otto last week about Mistral incubation and we decided to proceed with a detailed plan with Joshua and then expose it to TC as a part of Mistral incubation process
16:31:55 <rakhmerov> besides that we got new contacts, I'm still planning to meet with some of them this week
16:32:51 <rakhmerov> and one more thing: we met with Dmitri at the summit and summed up all the most important technical items that we need to address during this cycle
16:33:15 <rakhmerov> based on summit results (including people opinions)
16:33:52 <rakhmerov> Nikolay, so I would suggest to save our time a little bit and finish for today
16:33:58 <rakhmerov> unless you have some questions/comments
16:34:35 <rakhmerov> I'm hoping next time it will be more crowded here and we can really discuss our plans for the next couple of months
16:35:01 <rakhmerov> NikolayM, what do you think?
16:35:09 <NikolayM> so, I have no questions
16:35:26 <rakhmerov> and btw, by that time I'll have all the BPs created so that we'll be able to discuss them
16:35:35 <rakhmerov> ok
16:35:40 <NikolayM> yes
16:36:02 <rakhmerov> just in case, is there anyone at the meeting who has questions/comments/topics?
16:37:18 <rakhmerov> ok, then let's wrap up for today
16:37:24 <rakhmerov> thanks
16:37:28 <rakhmerov> #endmeeting