16:07:21 <tnurlygayanov> #startmeeting Mistral
16:07:21 <openstack> Meeting started Mon Apr 21 16:07:21 2014 UTC and is due to finish in 60 minutes.  The chair is tnurlygayanov. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:07:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:07:24 <openstack> The meeting name has been set to 'mistral'
16:07:47 <manask> hi
16:08:01 <NikolayM> hi
16:08:04 <tnurlygayanov> #topic Mistral Weekly Meeting
16:08:31 <tnurlygayanov> #topic Review the AIs
16:08:32 <m4dcoder> o/
16:08:48 <tnurlygayanov> Hi Mistral team
16:09:14 <tnurlygayanov> today we again have meeting without Renat
16:09:46 <tnurlygayanov> so, let's discribe the status of action items from the previous meeting
16:10:05 <tnurlygayanov> we have several important questions for today's meeting
16:11:20 <tnurlygayanov> so, Renat plan to finish the presentation for Mistral demo to 04/23
16:11:29 <tnurlygayanov> and he works on it right now
16:11:51 <dzimine> demo scenario all works, correct?
16:12:06 <tnurlygayanov> also I know that Renat and Nikolay work on code for demo scenario
16:12:21 <tnurlygayanov> NikolayM, any updates for this?
16:12:42 <tnurlygayanov> dzimine, I think yes, Nikolay can shae tha detailed status
16:13:17 <NikolayM> dzimine, yes, all demo work fine now
16:14:49 <tnurlygayanov> ok, cool
16:15:03 <NikolayM> today I've finished pretty logging (also output to console) to watch the progress of any execution
16:15:41 <tnurlygayanov> dzimine, what about your progress for the last week?
16:16:13 <tnurlygayanov> on this week I just have reviewed several commits.
16:16:19 <NikolayM> and also I found small bug related to dataflow
16:16:53 <tnurlygayanov> NikolayM, can you please describe the progress for the lst week, not only for today :)
16:17:16 <tnurlygayanov> #info NikolayM has finished pretty logging (also output to console) to watch the progress of any execution
16:17:31 <tnurlygayanov> m4dcoder Hi :)
16:17:46 <tnurlygayanov> m4dcoder what about your progress for the last week?
16:17:47 <m4dcoder> hey!
16:18:06 <m4dcoder> completed coding for the engine standalone process bp
16:18:07 <tnurlygayanov> so, as I know Mistral PoC now is ready for demo
16:18:11 <m4dcoder> submitted it for review
16:18:23 <dzimine> I mainly did reviews and worked with Renat re presentatoin and planning next steps. Share what we've decided once we move to "next steps".
16:18:25 <tnurlygayanov> ok, cool
16:18:40 <dzimine> Most of the work is between manask and enykeev
16:18:45 <tnurlygayanov> #info has completed coding for the engine standalone process bp and submitted it for review
16:19:02 <tnurlygayanov> #info m4dcoder   has completed coding for the engine standalone process bp and submitted it for review
16:19:21 <tnurlygayanov> #info dzimine prgress - Most of the work is between manask and enykeev
16:19:26 <tnurlygayanov> ok
16:19:36 <NikolayM> Timur, last week I fixed some bugs with action design and demo scenario
16:19:43 <tnurlygayanov> manask, Hi :)
16:20:02 <tnurlygayanov> #info NikolayM -  last week I fixed some bugs with action design and demo scenario
16:20:20 <tnurlygayanov> manask, what about your progress for this week?
16:20:34 <manask> I sent out a review for broken tests.
16:20:58 <tnurlygayanov> #info manask sent out a review for broken tests.
16:20:59 <manask> It is still under review and since there are intermittent issues
16:21:01 <tnurlygayanov> ok
16:21:35 <tnurlygayanov> so. enykeev?
16:22:11 <tnurlygayanov> or enykeev == m4dcoder ? (sorry, I don't remember all nicks)
16:22:36 <m4dcoder> enykeev is different person
16:22:55 <tnurlygayanov> ok, sorry. He is on the meeting?
16:23:17 <tnurlygayanov> looks like no
16:23:26 <tnurlygayanov> ok, let's move on
16:23:49 <tnurlygayanov> #topic Demo Scenario and How We Will Show It
16:24:12 <dzimine> For enykeev - looked at cleaning up the Action interface, got a first draft ready (not sure if it's on a review, didn't see it)
16:27:29 <tnurlygayanov> ok, thank you, Dmitry.
16:27:36 <tnurlygayanov> #info enykeev - looked at cleaning up the Action interface, got a first draft ready (not sure if it's on a review, didn't see it)
16:28:22 <tnurlygayanov> so, about the POC screencast
16:28:31 <tnurlygayanov> #topic POC screencast
16:29:06 <tnurlygayanov> Renat suggest to not implement Dashboard and show the first screencast without the dashboard
16:29:46 <NikolayM> And it will be cool if dashboard will be implemented :)
16:30:09 <tnurlygayanov> so, looks like we will create the basic dashboad about 1-2 weeks also and we can make the screencast  without the dashboard
16:30:19 <tnurlygayanov> yes, of course
16:30:27 <tnurlygayanov> we want to have the dashboard too
16:30:57 <tnurlygayanov> but also we want to make the screencast asap :)
16:31:28 <tnurlygayanov> so, I suggest to show the first screencast without dashboard and after that make the another screencast with the dashboard
16:31:40 <dzimine> AFAIK the plan is: screencast now, dashboard by summt
16:31:42 <tnurlygayanov> we can name the release with dashboard Mistral 0.1
16:31:47 <tnurlygayanov> yes
16:31:56 <dzimine> and if we have time to re-do screencast with the dashboard we will.
16:32:12 <dzimine> enykeev will be working on it this week.
16:32:15 <dzimine> on dashboad.
16:32:47 <dzimine> Nikolay's pretty_log changes are sufficient for a techy screencast.
16:32:47 <tnurlygayanov> ok, cool
16:33:12 <tnurlygayanov> #info screencast  the plan is: screencast now, dashboard by summit
16:33:26 <tnurlygayanov> #info sceencast and if we have time to re-do screencast with the dashboard we will.
16:34:16 <tnurlygayanov> dzimine, yes, we have described this patch with Nikolay today.
16:34:42 <tnurlygayanov> now it looks good.
16:35:30 <tnurlygayanov> dzimine, ok, I see your comment.. :)
16:36:13 <tnurlygayanov> so, do we have the another AI to discuss on today's meeting?
16:36:29 <tnurlygayanov> let's to descuss the AIs for the next week
16:37:06 <tnurlygayanov> I plan to fix issues with pep8 and configure pep8 checks for each commit - now we have some problems with it
16:37:28 <tnurlygayanov> #action Timur: fix issues with pep8 and configure pep8 checks for each commit - now we have some problems with it
16:37:47 <tnurlygayanov> #action Timur: review commits
16:38:22 <tnurlygayanov> #action enykeev: working on Mistral Dashboard
16:38:57 <tnurlygayanov> dzimine, NikolayM, manask, what about you?
16:39:11 <tnurlygayanov> do we have some plans for the next week? :)
16:39:43 <m4dcoder> i plan to move the instantiation of ScalableEngine to use stevedore and renaming the current ScalableEngine to POC engine
16:40:51 <tnurlygayanov> #action: m4dcoder move the instantiation of ScalableEngine to use stevedore and renaming the current ScalableEngine to POC engine
16:41:47 <manask> No specific plans. Will pick up things if they come along my way.
16:42:23 <NikolayM> I plan to fix next bugs with dataflow
16:42:35 <tnurlygayanov> #action: manask will pick up things if they come along my way.
16:42:54 <tnurlygayanov> #action: NikolayM fix next bugs with dataflow
16:42:57 <tnurlygayanov> ok, cool
16:43:11 <tnurlygayanov> looks like a plan :)
16:43:41 <tnurlygayanov> so, I know that Renat will prepare the screencast
16:46:11 <tnurlygayanov> #action Renat prepare the screencast for Mistral
16:49:58 <manask> sounds like we are done?
16:50:55 <tnurlygayanov> yes
16:51:00 <tnurlygayanov> ok
16:51:17 <manask> perfect. Thanks!
16:52:16 <tnurlygayanov> thank you guys for this meeting
16:52:22 <tnurlygayanov> #endmeeting