09:02:29 <ryu25> #startmeeting midonet
09:02:30 <openstack> Meeting started Tue Dec  8 09:02:29 2015 UTC and is due to finish in 60 minutes.  The chair is ryu25. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:02:31 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:02:33 <openstack> The meeting name has been set to 'midonet'
09:03:10 <ryu25> #link https://wiki.openstack.org/wiki/Meetings/MidoNet agenda
09:03:40 <ryu25> #topic Announcements
09:04:23 <ryu25> The first announcement I have is that I have created a Launchpad page for midonet
09:04:25 <ryu25> #link https://launchpad.net/midonet
09:04:48 <ryu25> Still need to fill in the details, but with help rom red_trela, it's getting there
09:05:13 <ryu25> it's not done yet, so for now, we will continue to file bugs against JIRA
09:05:46 <red_trela> what's missing at this point?
09:05:51 <ryu25> but I am hoping that we can start migrating all the bugs from JIRA to LP in January...
09:06:14 <ryu25> red_trela: I think we just need to start moving the existing bugs around in one shot
09:06:21 <ryu25> to avoid having yet another place to look for bugs
09:06:27 <red_trela> got it
09:06:30 <yamamoto> are we going to do "mitaka", aligning with the rest of openstack?
09:06:55 <yamamoto> https://launchpad.net/midonet/mitaka
09:07:46 <ryu25> yamamoto: good question, I originally thought so but I was told by thierry that we don't necessary follow the OpenStack releases
09:08:01 <ryu25> I personally think it will be much easier to just follow it
09:08:33 <ryu25> I will ask in the ML
09:08:39 <ryu25> i think the discussion belongs there
09:08:49 <red_trela> I think we should still do "mitaka", but with our own schedule (which is allowed and pretty common ever since the big tent was introduced)
09:08:57 <red_trela> right, let's discuss it on the ml
09:09:41 <ryu25> red_trela: it seems pretty confusing to call it mitaka but yet release completely separately from the rest of the mitaka OpenStack projects
09:09:45 <ryu25> anyway, let's disscuss in ML
09:09:58 <jfjoly> We can do releases in between and decide which one is for Mitaka.
09:10:49 <ryu25> #action ryu25 ask in ML about the midonet release cycle and versioning
09:11:10 <ryu25> jfjoly: we can do milestones
09:11:56 <red_trela> other announcements? ;)
09:12:14 <ryu25> anyone?
09:12:30 <red_trela> so, #midonet is now an official OpenStack channel
09:13:10 <ryu25> red_trela: so no more #midonet-dev then?  Just #midonet, right?
09:13:31 <red_trela> and eavesdrop (OpenStack logging facility) should be added soon - pending +A from openstack infra
09:13:39 <red_trela> ryu25: right
09:14:11 <red_trela> we also got gerritbot, but as our repos are not yet on OpenStack infra, it only just notifies about networking-midonet yet.
09:14:29 <ryu25> #info midonet-dev irc chnanel is replaced by midonet
09:14:56 <red_trela> and we'll get statusbot, which is used by the openstack (infra) folks to share some important information, like "gate it broken, don't +A anything"
09:15:09 <ryu25> very cool!
09:15:24 <yamamoto> #link https://review.openstack.org/#/c/252172/
09:15:42 <red_trela> well, cool once we use the gate and other infra ;)
09:16:42 <ryu25> any other announcement?
09:16:54 <red_trela> not sure whether we also get meetbot, which would be cool for an irregular meeting, I guess...will try to have it added as well
09:17:36 <ryu25> one last announcement from me - v5.1 is scheduled to have an RC in the beginning of January.
09:17:53 <ryu25> jfjoly: please correct me if I'm wrong on that
09:18:44 <jfjoly> ryu25: That's correct 😃
09:19:05 <red_trela> don't forget to update the release schedule in the wiki, please
09:19:27 <jfjoly> red_trela: thanks good point
09:19:51 <yamamoto> which wiki?  i thought we are moving to launchpad :-)
09:20:11 <ryu25> #info midonet v5.1 RC scheduled the first half of Janurary
09:20:37 <red_trela> I guess that's one of the parts that's not ready yet...but right, release schedules go to launchpad as well I guess
09:21:02 <jfjoly> yamamoto: we can update both , that's a different audience.
09:21:04 <red_trela> but launchpad doesn't completely replace having a wiki ;)
09:21:16 <red_trela> we'll probably move to the OpenStack wiki, though
09:21:50 <ryu25> any more announcement?
09:22:19 <red_trela> guess that we moved to openstack-dev ml is old news by now :)
09:22:42 <ryu25> red_trela, still good to be reminded, thanks
09:23:30 <ryu25> #topic Bugs
09:24:21 <ryu25> it might be blasphemous to post a link to JIRA in this channel but that's all we have at this moment
09:24:29 <ryu25> #link #link https://midonet.atlassian.net/browse/MNA-1112?jql=project%20%3D%20MidoNet%20AND%20priority%20%3D%20Major%20and%20issuetype%20%3D%20Bug%20AND%20status%20in%20(Proposed%2C%20Reopened)%20ORDER%20BY%20createdDate%20Desc%2C%20priority%20Desc
09:25:00 <ryu25> sorry i double linked
09:25:03 <ryu25> #link https://midonet.atlassian.net/browse/MNA-1112?jql=project%20%3D%20MidoNet%20AND%20priority%20%3D%20Major%20and%20issuetype%20%3D%20Bug%20AND%20status%20in%20(Proposed%2C%20Reopened)%20ORDER%20BY%20createdDate%20Desc%2C%20priority%20Desc
09:25:32 <ryu25> this is the list of bugs marked as major that we have currently
09:25:36 <ryu25> no Critical bug
09:26:04 <red_trela> that links brings me to MNA-1112, not to a list
09:26:20 <red_trela> oh, wait
09:26:43 <ryu25> red_trela: supposed to search
09:26:45 <ryu25> filter the bugs
09:26:46 <red_trela> looks like my console doesn't like the link
09:26:52 <red_trela> too long :P
09:27:17 <red_trela> works now ;)
09:27:21 <ryu25> sorry i knew JIRA gets discriminated here
09:27:49 <ryu25> nothing urgent on this list except that I think most of these should be fixed for v5.1
09:28:20 <ryu25> anyone has any comment on these bugs?
09:29:00 <ryu25> I wanted to try out the Bug Deputy process of Neutron in midonet, so I volunteered myself last week to see how that goes
09:29:15 <ryu25> and the experience was quite good, and very educational
09:30:04 <ryu25> i got to clean up a lot too, by removing duplicates and invalid ones
09:31:14 <red_trela> the cleaner the better to move to launchpad ;)
09:31:38 <ryu25> i think it's a good idea to continue, and kitsuneninetails has already kindly volunteered to take on this role for this week
09:31:50 <ryu25> i will work with him on this process since we're all new to it
09:31:55 <red_trela> awesome
09:32:29 <ryu25> I will update the meeting wiki page with the deputy schedule
09:32:51 <ryu25> and a brief summary of the bugs reported last week
09:33:16 <ryu25> #info kitsuneninetails is the next bug deputy
09:33:37 <ryu25> #action ryu25 update meeting wiki with bug deputy sched and bug summary for last week
09:35:11 <ryu25> there is no bug that requires any special attention, so going to move on.  feel free to stop me if you want to discuss the bugs further
09:36:28 <ryu25> #topic Open Discussion
09:38:15 <ryu25> for feature proposal in midonet, i would like to follow the RFE process practiced in Neutron.  anyone has opinions on this?
09:39:35 <ryu25> I will ask in ml also
09:39:49 <yamamoto> ryu25: do you mean to have a separate drivers meeting or do it here?
09:40:12 <red_trela> I think sticking to Neutron's best practices is always a good idea :)
09:41:10 <ryu25> yamamoto: I don't know actually, I'm thinking a separate meeting
09:41:15 <ryu25> but that might be too heavy
09:41:37 <ryu25> but i guess the process is to simply create a bug reporing what you want to implement
09:41:54 <ryu25> and we can go over them here to start
09:42:14 <red_trela> not sure there's enough time, but can't hurt to try
09:42:36 <ryu25> right, we'll adjust as we go
09:43:26 <ryu25> #action ryu25 start a conversation about feature proposal in ML
09:44:03 <ryu25> red_trela, you might be the best preson to answer this, but I would like to know a bit more about migrating midonet to the OpenStack infra
09:44:29 <red_trela> big question
09:45:03 <red_trela> and not one I'm prepared to answer right now, so I might be forgetting things
09:45:06 <ryu25> i see a lot of value in doing that, but i also see a lot of unknowns...
09:45:22 <red_trela> anything specific?
09:45:43 <red_trela> maybe I know the answers, otherwise I need to find them :)
09:45:48 <ryu25> no, it's a big topic so let's discuss elsewhere
09:46:22 <red_trela> okay
09:47:05 <red_trela> feel free to ask me in #midonet or on openstack-dev ml with anything that is not clear in this regard :)
09:47:05 <yamamoto> red_trela: are there todos somewhere?
09:48:02 <red_trela> yamamoto: no, I should probably put them in the wiki or something - I did everything so far, but there's a few steps that I will certainly need help with
09:48:19 <red_trela> I already brought up one or two things on the mailing list
09:48:37 <ryu25> red_trela: organizing it in one place will be useful, i think
09:49:09 <ryu25> for everyone to start helping out in the process
09:49:09 <red_trela> sure
09:49:58 <red_trela> well, for now, I need people help with decisions (see ml) - and then to implement those :)
09:50:03 <red_trela> but yes, will do
09:51:02 <ryu25> #action red_trela create a doc (wiki, lp,...) to organize and share the process for the move to openstack infra
09:51:09 <ryu25> red_trela: sure, let's work together on it
09:51:55 <red_trela> the trickiest one will be the migration to Gerrit, as we can't migrate/import (unmerged) review requests
09:52:18 <red_trela> so people probably need to re-open them, i.e. we want to first merge as many as possible, I guess
09:53:09 <ryu25> right, we can't have them co-exist pointing to the same code base
09:53:33 <ryu25> ok interesting, that's something we can discuss in the community
09:53:58 <ryu25> red_trela also started a thread today about moving PMC out of midonet
09:54:01 <ryu25> #link http://lists.openstack.org/pipermail/openstack-dev/2015-December/081693.html
09:55:05 <ryu25> with the original discussion started by yamamoto
09:55:10 <ryu25> i'm +1 on this idea
09:55:30 <yamamoto> do you have any idea why it's put in the current structure?
09:55:44 <ryu25> for ease of maintenance
09:55:45 <red_trela> right, this might actually be required by OpenStack (release management) - and I'm sure downstream distributions would appreciate it as well, as the expect a 1:1 tarball to package mapping
09:56:06 <ryu25> managing releases together for example
09:56:53 <red_trela> and we might have to put the midonet-cli into yet another repo as it uses a different license (GPLv3)
09:57:13 <red_trela> I'll bring that up as a separate discussion, though
09:57:34 <red_trela> need to make sure it's really required first
09:57:56 <ryu25> as for PMC, let's see what others say on this.  I know we have differing opinions
09:58:04 <red_trela> indeed
09:58:21 <yamamoto> ryu25: so currently pmc is incompatible with different versions of midonet?
09:58:44 <red_trela> I wonder, if we want to put PMC on pypi, does it need to be a separate repo? Because pypi is another requirement by OpenStack.
09:59:01 <ryu25> yamamoto: not necessarily so, though I cannot say for sure to which version it is compatible with
09:59:13 <ryu25> now that it has been merged into midonet for a while
09:59:43 <red_trela> okay, I think we need to finish here as our reserved time slot is over :)
09:59:53 <ryu25> red_trela: afaik yes, which is why we mirror it to a different PMC repo (yuck)
10:00:02 <ryu25> ok ending the meeting, thanks everyone!
10:00:05 <yamamoto> bye
10:00:09 <ryu25> #endmeeting