04:00:21 <samP> #startmeeting masakari
04:00:22 <openstack> Meeting started Tue Jun 13 04:00:21 2017 UTC and is due to finish in 60 minutes.  The chair is samP. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:00:25 <openstack> The meeting name has been set to 'masakari'
04:00:25 <abhishek_k> o/
04:00:25 <samP> Dinesh_Bhor: hi
04:00:36 <sagara> Hi
04:00:37 <samP> Hi All..o/
04:00:56 <samP> lets start
04:01:08 <Dinesh_Bhor> yes
04:01:23 <samP> sorry for absent last week
04:01:38 <samP> #topic Critical Bugs
04:01:44 <samP> any bugs to discuss
04:02:26 <Dinesh_Bhor> Need opinions about this: https://review.openstack.org/#/c/468771/2/masakari/engine/drivers/taskflow/host_failure.py
04:02:40 <Dinesh_Bhor> comment by tushar san
04:03:27 <samP> about the number of threads?
04:03:37 <Dinesh_Bhor> yes
04:04:43 <samP> In config, its define as, number of cores can be used to run this job, right?
04:05:06 <Dinesh_Bhor> yes
04:06:04 <samP> In that case, IMO, 100 is way too high.
04:06:41 <Dinesh_Bhor> yes, agree
04:08:10 <samP> I preffer, lower single digit value, (quad core -1) = 3 which will hold for testing evns too
04:09:00 <samP> operator may tune this value upon the spec of the their node where (masakari-engine runs)
04:09:48 <Dinesh_Bhor> ok, sure. I will make it 3
04:10:26 <samP> After all this is an configurable value and default value should work for any possible env...(just my opinion)
04:10:41 <samP> Dinesh_Bhor: thanks, I will comment this..
04:11:14 <Dinesh_Bhor> samP: thanks
04:11:41 <samP> if no more bugs to discuss, lets jump in to Discussion points..
04:11:47 <samP> Dinesh_Bhor: NP
04:11:59 <samP> #topic Discussion Points
04:13:42 <abhishek_k> for recovery method customization, I have replied to comments from Renant #link https://review.openstack.org/#/c/458023/
04:13:43 <samP> About recovery method customization, we have to discuss about Renat's comment,
04:13:52 <samP> abhishek_k: thanks..
04:14:24 <samP> IMO, there are some misunderstandigs here..
04:15:40 <abhishek_k> samP: could you please help me to understand, IMO in masakari we have certain business rules which will not allow certain api's to be performed. For example in above case we are setting reserved_host to False while notification is in process, but if you try to update the reserved_host using REST API while notification is running then it will raise HTTP Forbidden error.
04:16:38 <samP> abhishek_k: correct..
04:17:58 <samP> IMO, we have to levels of tast executions, (1) process the business logics (2) simple recovery tasks
04:18:29 <samP> (2) can be offload to mistral, but not (1)
04:19:11 <samP> s/we have to levels/we have 2 levels/
04:19:26 <abhishek_k> samP: (1) is clearly dependent on (2)
04:21:01 <samP> abhishek_k: correct, however, if mistral can return values, we could use mistral to execute (2),
04:21:29 <tpatil> samP: need to check if mistral can run the workflow synchronously
04:21:51 <samP> tpatil: agree
04:24:10 <samP> tpatil: isn't that the resone why we prohibit reserved_host API to update while notification is running?
04:27:08 <tpatil> samP: we don't allow host to be updated while notiification is running otherwise nova scheduler will start using host for creating new servers
04:28:10 <samP> tpatil: got it.
04:29:01 <samP> nyway, IMO we sould discuss this in ML, where other people can also participate to the discussion. I will send this mail to [masakari] ML
04:29:44 <samP> #action samP Send mail to discuss about https://review.openstack.org/#/c/458023/
04:31:07 <samP> Other items, Honjo-san proposed spec for "Add event notification feature to masakari"
04:31:32 <samP> #link Add event notification feature to masakari https://review.openstack.org/#/c/473057/
04:31:46 <samP> please review ^^
04:32:18 <abhishek_k> ok
04:32:44 <abhishek_k> samP: I have seen your comments on documentation patch, I will fix them asap
04:32:44 <tpatil> samP: sure
04:32:51 <abhishek_k> samP: thank you for review
04:33:06 <samP> abhishek_k: "Add db purge support" this is from last week discussion, right?
04:33:14 <samP> abhishek_k: np, thanks
04:33:18 <samP> tpatil: thanks
04:33:28 <abhishek_k> samP: yes, I have submitted lite-specs for this
04:33:40 <abhishek_k> #link https://review.openstack.org/473379
04:33:48 <samP> abhishek_k: great, thanks, I will review this..
04:34:02 <abhishek_k> samP: thank you
04:35:05 <samP> And please review https://review.openstack.org/#/c/469070/ if you have spare time..
04:35:46 <samP> I think Owner: Greg is in OPNFV summit at China...
04:36:07 <tpatil> samP: Sure
04:36:49 <samP> So, we can't expect quick replies for Greg..
04:36:55 <samP> tpatil: thanks
04:38:07 <samP> I think no other updates for other pike work items...
04:38:20 <samP> lets move to AOB,
04:38:30 <samP> #topic AOB
04:39:07 <Dinesh_Bhor> samP: is RPM and debian packaging thing all done? need to submit patch in global-requirement to add python-masakariclient
04:39:59 <samP> rpm packaging is done, got some request from Adem for fix the versions and tags..
04:40:49 <Dinesh_Bhor> samP: ok
04:40:55 <Dinesh_Bhor> thanks for update
04:40:58 <samP> I am referring to openstack stack release team documents for how to fulfill those
04:41:31 <tpatil> samP so until that is not done, we should hold submitting patch in global-requirements, right?
04:41:44 <samP> tpatil: right..
04:41:51 <tpatil> samP: OK
04:42:35 <samP> please wait till I fix the versions...otherwise it will be a mess :)
04:42:55 <tpatil> samP: I got it
04:43:13 <Dinesh_Bhor> me too
04:45:15 <samP> Dinesh_Bhor: About the pacemaker config, sorry for the delay and thanks for the replay.. I wil give you more detilas on mail about this.
04:45:50 <Dinesh_Bhor> samP: OK
04:46:27 <samP> abhishek_k: About the testing envs, I saw you raised some issues, are those issues are still vaild?
04:46:36 <abhishek_k> samP: yes
04:46:52 <abhishek_k> samP: Please do the needful :)
04:48:22 <samP> abhishek_k: OK then, I will check them and come back to you. Can we have this discussion on #openstack-masakari, from 4:00pm JST today?
04:48:45 <abhishek_k> samP: sure, please ping me
04:49:02 <samP> abhishek_k: great...thanks
04:49:36 <samP> OK, then. AOBs to discuss?
04:50:39 <abhishek_k> samP: nothing from our side
04:50:53 <samP> abhishek_k: thanks..
04:51:17 <samP> If no other topis to discuss, lets finish the meeting...
04:51:24 <samP> Thank you all.....
04:51:46 <tpatil> Bye
04:51:48 <abhishek_k> thank you
04:51:49 <samP> #endmeeting