04:08:44 <tpatil> #startmeeting masakari
04:08:46 <openstack> Meeting started Tue Apr 18 04:08:44 2017 UTC and is due to finish in 60 minutes.  The chair is tpatil. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:08:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:08:49 <openstack> The meeting name has been set to 'masakari'
04:08:53 <rkmrHonjo> Oh, sorry...
04:09:02 <rkmrHonjo> #topic High priority items
04:09:27 <rkmrHonjo> Do you have high priority items?
04:09:36 <tpatil> https://bugs.launchpad.net/masakari/+bug/1663513
04:09:38 <openstack> Launchpad bug 1663513 in masakari "Masakari failed to rescue PAUSED instances" [High,In progress] - Assigned to Dinesh Bhor (dinesh-bhor)
04:09:56 <tpatil> There is one minor comment from you on patch https://review.openstack.org/#/c/454721/
04:10:38 <rkmrHonjo> tpatil: yes.
04:10:38 <tpatil> I don't see that's a big issue, I think Dinesh intention to put instance uuid in single quote is to highlight uuid in the log message which looks good to me
04:11:10 <rkmrHonjo> tpatil: hm...OK, I add +1 to that patch.
04:11:20 <tpatil> Thank you
04:11:22 <Dinesh_Bhor> rkmrHonjo: thanks
04:12:02 <rkmrHonjo> Can we go to next topic?
04:12:19 <tpatil> yes
04:12:24 <sagara> yes
04:12:28 <rkmrHonjo> thanks.
04:12:34 <rkmrHonjo> #topic Bugs (stuck/critical)
04:14:06 <rkmrHonjo> There are some patches that aren't reviewed. Please review if you can. https://review.openstack.org/#/q/project:openstack/masakari
04:14:39 <rkmrHonjo> e.g. Use DDT to reduce test code duplication https://review.openstack.org/#/c/424549/
04:14:48 <tpatil> Sure
04:15:04 <rkmrHonjo> tpatil: Thank you.
04:15:47 <rkmrHonjo> any other bugs?
04:16:34 <sagara> no
04:17:24 <rkmrHonjo> #topic Discussion points
04:17:36 <rkmrHonjo> "recovery method customization" and "Pike work Items" are written on wiki, but wiki was not updated sicne last week.
04:17:43 <rkmrHonjo> Do you want to discuss about those items?
04:18:07 <sagara> last week, Sampath-san created a draft version of it.
04:18:17 <sagara> #link https://etherpad.openstack.org/p/masakari-recovery-method-customization
04:18:46 <sagara> I will add it to masakari-spec repo later.
04:19:18 <tpatil> Abhishek has completed a POC to read YAML file in which actions will be added by Operator for each notification type
04:19:39 <tpatil> this YAML information will be used to create task workflow
04:19:48 <rkmrHonjo> #action sagara add masakari-recovery-method-customization spec to masakari-spec repo
04:20:30 <rkmrHonjo> tpatil: Great. Will Abhishek push it to gerrit?
04:20:33 <sagara> rkmrHonjo: thanks
04:20:46 <tpatil> rkmrHonjo: yes
04:21:22 <tpatil> He will cover the specs for the existing workflow in the master code.
04:21:42 <tpatil> There are several new action added in the above etherpad url which needs discussion
04:23:11 <tpatil> He will cover all actions added in "Current recovery action in Masakari" section
04:24:27 <tpatil> Some of the action added "Other possiable recovery actions" are self-explanatory, except last one "triggering crash dump in a server"
04:24:40 <rkmrHonjo> Is changing host aggregate unnecessary?
04:25:06 <abhishek_k> tpatil, rkmrhonjo: As this workflow is configurable, so when operator changes the workflow in configuration file then he needs to restart the engine servuce
04:25:29 <abhishek_k> s/servuce/service
04:26:37 <tpatil> That can be handled in SIGHUP signal, we can reload the config file by handing this signal
04:27:01 <abhishek_k> tptil: ok
04:27:48 <tpatil> rkmrHonjo: host Aggregate code will remain as it is
04:28:04 <rkmrHonjo> tpatil: Is it configurable?
04:28:14 <tpatil> yes using add_reserved_host_to_aggregate option
04:28:31 <rkmrHonjo> tpatil: ok. thank you for explaining.
04:29:57 <rkmrHonjo> any other discussions?
04:31:45 <tpatil> triggering crash dump in a server: does that mean we should take kernel crash dump of the specified server
04:33:25 <rkmrHonjo> tpatil: Sorry, what is that topic...?
04:33:53 <tpatil> https://etherpad.openstack.org/p/masakari-recovery-method-customization, Line #24
04:33:56 <rkmrHonjo> Ah, I find it in Other possiable recovery actions section.
04:34:07 <rkmrHonjo> tpatil: thanks.
04:34:27 <sagara> tpatil: I think so, but I think we had better confirming it Sampath-san
04:34:43 <tpatil> sagara: Ok
04:37:41 <rkmrHonjo> ok, let's go to next topic. Please talk in AOB if you have other topics.
04:37:45 <rkmrHonjo> #topic AOB
04:37:58 <rkmrHonjo> Do you want to finish this meeting? Or wait for samP until UTC 5:00(=JST 14:00)?
04:40:28 <tpatil> We will discuss with samP on openstack-masakari channel about recovery_method_customization topic
04:41:30 <rkmrHonjo> tpatil: OK. Then can we finish this meeting?
04:41:47 <sagara> yes
04:42:06 <Dinesh_Bhor> yes
04:42:21 <rkmrHonjo> Thanks. I finish this meeting after that. Let's go to openstack-masakari channel.
04:42:28 <Dinesh_Bhor> thank you all
04:42:42 <sagara> thanks
04:42:52 <tpatil> Thanks
04:42:56 <rkmrHonjo> thanks.
04:43:04 <rkmrHonjo> #endmeeting
04:44:37 <tpatil> I have to end this meeting as I had started it
04:44:42 <tpatil> #endmeeting