04:03:57 <rkmrHonjo> #startmeeting masakari
04:03:58 <openstack> Meeting started Tue Mar 14 04:03:57 2017 UTC and is due to finish in 60 minutes.  The chair is rkmrHonjo. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:03:59 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:04:01 <openstack> The meeting name has been set to 'masakari'
04:04:13 <rkmrHonjo> #topic bugs
04:04:30 <rkmrHonjo> Do you have any bugs to discuss?
04:05:48 <rkmrHonjo> nothing?
04:05:53 <tpatil> # link : https://bugs.launchpad.net/masakari/+bug/1670940
04:05:53 <openstack> Launchpad bug 1670940 in masakari "If failure host is the reserved host, the compute service of the failure host finally beccomes the enable status" [Undecided,In progress] - Assigned to takahara.kengo (takahara.kengo)
04:05:53 <sagara> do we need to talk https://bugs.launchpad.net/masakari/+bug/1670940 ?
04:06:10 <tpatil> There is already a patch up to fix this issue
04:06:25 <tpatil> I will review this patch soon
04:06:42 <rkmrHonjo> tpatil: Thank you. I'll review it, too.
04:06:53 <sagara> me too
04:07:13 <rkmrHonjo> any other items?
04:07:29 <sagara> no
04:08:28 <rkmrHonjo> ok. Let's go to next topic.
04:08:38 <rkmrHonjo> #topic Pike work items
04:08:43 <sagara> #link: https://etherpad.openstack.org/p/masakari-pike-workitems
04:09:19 <rkmrHonjo> Do you have objections about priorities written in etherpad?
04:09:39 <rkmrHonjo> s/objections/opinions/g
04:10:34 <sagara> I have read all items, I agree those priorities.
04:10:44 <tpatil> me too
04:11:05 <Dinesh_Bhor> yes, me too
04:11:20 <rkmrHonjo> me too.
04:12:08 <Dinesh_Bhor> About this: Python 3.x support
04:12:12 <tpatil> It will be nice to see specs for high priority items
04:12:39 <Dinesh_Bhor> I think most of the masakari code is already PY3 compatible
04:14:22 <tpatil> Dinesh_Bhor: Do we have any gate jobs that run on PY3?
04:14:41 <Dinesh_Bhor> tpatil: No, not yet
04:15:11 <tpatil> It's better to add this support before declaring it's py3 compatible
04:15:49 <Dinesh_Bhor> tpatil: Agree
04:16:42 <sagara> tpatil, Dinesh_Bhor: Do we need to change py3 priority?
04:18:22 <tpatil> Anyone want to run masakari on Py3?
04:18:40 <tpatil> If yes, we can make it high priority
04:19:14 <sagara> I haven't heard run masakari on Py3.
04:20:14 <sagara> So, I think we don't need to change that priority (remains Low)
04:20:15 <rkmrHonjo> I think that there are a few people running openstack on Py3.
04:22:44 <rkmrHonjo> sagara: I agree to your opinion.
04:23:12 <Dinesh_Bhor> sagara: I am ok with L
04:23:32 <tpatil> rkmrHonjo: Let's these people comment on the Py3 item on etherpad and we can change it's priority to high. What do you guys think?
04:24:04 <sagara> tpatil: I agree
04:24:13 <tpatil> Dinesh has added a new BP
04:24:16 <tpatil> # link: https://blueprints.launchpad.net/masakari/+spec/enable-openstack-proposal-bot
04:24:34 <rkmrHonjo> tpatil: I agree.
04:25:23 <tpatil> sagara, rkmrHonjo: Thanks
04:25:49 <tpatil> Add devstack plugin for masakari-monitors
04:26:09 <tpatil> For above item , I don't think there is a need for specs
04:26:44 <tpatil> presently, masakari doesn't install masakari-monitors on single node
04:27:02 <tpatil> we should add this support in masakari devstack plugin itself
04:28:34 <sagara> tpatil: I agree, I think it also need for destructive testing for masakari
04:29:01 <tpatil> sagara: correct
04:29:27 <tpatil> Recoverable libvirt events customization
04:29:41 <tpatil> Who will write specs for this item?
04:29:55 <rkmrHonjo> tpatil: me.
04:30:05 <rkmrHonjo> soryy,
04:30:11 <rkmrHonjo> sorry, not me.
04:30:27 <sagara> Is it sampath idea?
04:31:01 <tpatil> We need to understand which libvirt events to support and what action to take for each of them
04:31:02 <rkmrHonjo> sagara: the idea is written by me. but the person who writes specs is not decided.
04:31:57 <rkmrHonjo> tpatil: yes.
04:32:08 <rkmrHonjo> sagara, tpatil: OK, I try to write specs.
04:32:49 <tpatil> Add ssl support to Masakari API
04:33:15 <tpatil> We have worked on this item before. Will upload patch soon
04:33:31 <rkmrHonjo> #action rkrmHonjo write Recoverable libvirt events customization spec
04:33:50 <abhishekk> tpatil: for this no changes needed in masakari
04:34:16 <tpatil> abhishekk: need to confirm it again
04:34:24 <abhishekk> tpatil: we need to get this patch merged in devstack https://review.openstack.org/#/c/416009/
04:34:31 <sagara> "Add ssl support to Masakari API" have already implemented (but not merged)?
04:35:26 <sagara> I confirmed it. ok so I will review it.
04:36:52 <rkmrHonjo> abhishekk: Can we use HTTPS endpoint if we install current masakari by manual(not devstack)?
04:37:17 <sagara> sorry, I misunderstood about https://review.openstack.org/#/c/416009/
04:37:48 <abhishekk> rkmrHonjo: I have not tried mannualy, but IMO it will work
04:38:12 <rkmrHonjo> abhishekk: ok, thanks.
04:38:24 <abhishekk> you just need to create https endpoints
04:40:40 <rkmrHonjo> abhishekk: Really? Is specifying key files in masakari.conf unnecessary?
04:42:05 <abhishekk> rkmrHonjo: you need to specify ssl_key_file = /opt/stack/data/CA/int-ca/private/devstack-cert.key and
04:42:05 <abhishekk> ssl_cert_file = /opt/stack/data/CA/int-ca/devstack-cert.crt
04:42:15 <abhishekk> under wsgi section in masakari.conf
04:42:45 <rkmrHonjo> abhishekk: thanks!
04:43:24 <abhishekk> these key files you can found in devstack repo
04:43:36 <abhishekk> s/found/find
04:46:14 <sagara> Let's talk next item
04:46:56 <rkmrHonjo> OK. After all, should we need to change the priority? I think that it is not needed.
04:47:37 <rkmrHonjo> sagara: sorry, ok. let's go to next item.
04:48:36 <sagara> rkmrHonjo: don't need to change "add ssl support"'s priority. and it maybe already works well.
04:49:16 <rkmrHonjo> sagara: ok.
04:50:08 <sagara> Is there any comment for items below?
04:50:58 <rkmrHonjo> sagara: no.
04:52:08 <tpatil> can we proceed to the next topic?
04:52:45 <rkmrHonjo> tpati: Yeah. Next topic is AOB.
04:52:50 <sagara> tpatil: yes. I already agree
04:52:55 <rkmrHonjo> #topic AOB
04:53:01 <rkmrHonjo> Do you have any other topics?
04:54:14 <tpatil> No
04:54:26 <rkmrHonjo> OK, thank you all. this meeting is over.
04:55:05 <rkmrHonjo> (I'll write "endmeeting" after that.)
04:55:20 <rkmrHonjo> #endmeeting