04:01:00 <samP> #startmeeting masakari
04:01:01 <openstack> Meeting started Tue Dec 20 04:01:00 2016 UTC and is due to finish in 60 minutes.  The chair is samP. Information about MeetBot at http://wiki.debian.org/MeetBot.
04:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
04:01:04 <openstack> The meeting name has been set to 'masakari'
04:01:09 <samP> hi all
04:01:19 <abhishekk> o/
04:01:20 <Dinesh_Bhor> samP: hi
04:01:22 <abhishekk> hi
04:01:32 <rkmrhj> hi
04:01:46 <samP> #topic Critical bugs
04:01:57 <samP> any bus to discuss?
04:02:05 <samP> sorry, bugs
04:02:41 <samP> if no then, we can jump in to next topic
04:03:43 <samP> if you have any, then we can discuss them later in this meeting
04:03:48 <samP> #topic Discussion points
04:04:09 <samP> First, pypi packaging
04:04:48 <samP> when we create the repo, I didn't add pypi jobs. so, there are no pypi packages for masakari
04:05:05 <samP> Today I manually add v2.0.1 to pypi
04:05:42 <samP> #link https://pypi.python.org/pypi/masakari/2.0.1.dev19
04:06:08 <samP> I can do same for masakari-monitors and python-masakari-client
04:06:54 <rkmrhj> samP: Please do it.
04:06:56 <samP> I think we should add pypi jobs for gate to automatically update the pypi
04:07:10 <tpatil_> Hi
04:07:13 <samP> hi
04:07:33 <tpatil_> Having problem connecting from my mac, so connected from windows
04:08:04 <samP> tpatil_: ok, no problem. you are live now..
04:08:13 <tpatil_> Yes ,finally
04:08:53 <samP> we are discussing about adding pypi packages for masakari/monitors/client
04:09:06 <tpatil_> ok
04:09:49 <samP> I will update the project config for add pypi jobs for masakari/monitors/client.
04:10:05 <samP> however, monitors would be bit tricky.
04:10:47 <samP> rkmrhj: how are we doing with adding setup script for shell scripts in monitors?
04:12:31 <samP> anyway, I will work with masakari and client first.
04:12:52 <samP> #action samP add pypi jobs to project config of masakari and client and monitors
04:13:25 <rkmrhj_> samP: Thanks.
04:13:28 <samP> next, I would like to discuss about documentation
04:14:35 <samP> The reason is, some ppl are start to try masakari and Im flooded with emils
04:15:01 <tpatil_> what kind of documentation are you expecting to start with?
04:15:04 <tpatil_> apis?
04:15:39 <samP> In first step, how to install and then APIs
04:16:10 <samP> I think we do have japanese doc for how to install and configure
04:17:13 <tpatil_> please forward all Japanese documentation to us and we will try to translate in English.
04:17:20 <abhishekk> samP: https://github.com/openstack/masakari/tree/master/devstack, here it is mentioned how you can install masakari
04:18:01 <samP> abhishekk: thanks
04:19:02 <samP> abhishekk: we need to document this from how setup from the start, start with creating pacemaker cluster for compute nodes
04:19:32 <abhishekk> samP: ok, got it
04:20:15 <samP> tpatil_: I will try to translate this to some level. could you please brush it up?
04:20:26 <tpatil_> samP: Sure
04:20:38 <samP> and the next question is, where we can host this?
04:21:00 <samP> since we can not use openstack.doc, one option is to use http://pythonhosted.org/masakari
04:21:29 <samP> or we can host it in git with masakari source
04:22:03 <tpatil_> samP: I think git is fine to start with
04:23:19 <samP> tpatil_: sure, then I will push the initial draft
04:23:54 <rkmrhj> Does the document contains installing steps of masakari-monitors?
04:25:01 <samP> rkmrhj: good question, I am thinking to put them all in one document.
04:25:24 <tpatil_> In general, it should include all services needed to run masakari in multi node environment.
04:25:26 <samP> rkmrhj: any suggestions?
04:26:06 <samP> tpatil_: sure
04:26:53 <rkmrhj> sampP: Sorry, no suggestions. I planned to write installing steps of masakari-monitors after implementing blueprints. But my plan doesn't contain masakari.
04:26:57 <samP> abhishekk: thanks for the BP..
04:27:21 <abhishekk> samP: WC
04:28:07 <samP> rkmrhj: That would be fine. I will write the basic steps to install them. you can update it.
04:29:02 <rkmrhj> samP: OK, sure.
04:29:07 <samP> #action samP add "how to install masakari" docs
04:29:21 <samP> OK, I will add them soon
04:29:46 <samP> next topic is sepc repo
04:29:53 <samP> #link https://review.openstack.org/#/c/412376/
04:31:14 <samP> its under review now, hopefully we will get it soon. Then I will cookiecut it and will be ready to go.
04:31:18 <tpatil_> After this patch is merged, we will start pushing specs for all action items in last meeting
04:31:57 <tpatil_> all action items discussed in last meeting
04:31:58 <samP> tpatil_: user, but wait for cookicut.
04:32:24 <samP> tpatil_: not "user", sure
04:32:54 <tpatil_> you mean once this project is available in github, correct?
04:33:44 <samP> tpatil_: after it available in github, first patch would be the cookicut, which make the structure for the repo
04:34:06 <tpatil_> samP: Ok, I got it
04:35:03 <samP> tpatil_: I will puch this patch wright after repo available on github
04:35:49 <tpatil_> ok
04:36:15 <samP> OK then, that was all the items I added to agenda. Any thing else to discuss?
04:37:03 <tpatil_> Nothing from my side for now
04:37:17 <abhishekk> samP: Please check the blueprint, once it is approved we ill submit patches against it
04:37:18 <samP> tpatil_: thanks
04:37:37 <samP> abhishekk: sure, thank you
04:37:48 <abhishekk> thanks
04:38:10 <samP> #topic AOB
04:38:19 <rkmrhj> bye
04:38:23 <samP> wait
04:38:37 <rkmrhj> oh, sorry.
04:38:46 <samP> I am gonna take early vac from 12/26
04:39:50 <tpatil_> Ok, are you available for the next meeting?
04:40:05 <samP> so, not gonna be able to host next IRC till 1/10
04:40:44 <tpatil_> Ok
04:41:05 <rkmrhj> Sure.
04:41:08 <samP> because its new year, I think most of us are not available on 1/3
04:42:32 <tpatil_> Let's keep in touch for important matter on mailing list till then
04:42:32 <samP> any volunteer to host the meeting on 12/27? or we can skip 12/27 and 1/3
04:43:59 <samP> tpatil_: sure
04:44:48 <tpatil_> IMO, we can skip meeting on 12/27 and 1/3 and as said above we can use mailing list to discuss on important agenda
04:44:49 <rkmrhj> I agree to skip 12/27 and 1/3.
04:44:59 <samP> OK, lets skip the IRC for 12/27 and 1/3, however post to ML for any important matters.
04:45:21 <samP> tpatil_: rkmrhj thanks
04:45:45 <samP> Is there any other things to discuss?
04:46:14 <samP> if no then, lest finish... thank you all
04:46:27 <rkmrhj> Not discuss, but I have a request. Please review https://review.openstack.org/#/c/397064/
04:47:16 <tpatil_> rkmrhj: I will check this patch soon
04:47:25 <samP> #action Review https://review.openstack.org/#/c/397064
04:47:31 <rkmrhj> tpatil_: Thanks a lot!
04:47:36 <samP> rkmrhj: me too will check
04:48:40 <rkmrhj> samP: tanks, too.
04:48:49 <samP> ok then, bye all "Merry Christmas And Happy New Year"
04:48:57 <rkmrhj> NG: tanks Correct: thanks
04:49:13 <Dinesh_Bhor> samP: same to you, thanks to all
04:49:22 <tpatil_> Happy New year to everyone in advance
04:49:52 <samP> #endmeeting